News, Press & Events

07 Jun 2010

New Acrobat Vulnerability - PDF-XChange not affected.

Tracker Software Products Ltd are pleased to report that no versions of PDF-XChange Viewer (Version 1 or 2.x) or any other PDF-XChange product is affected by this issue and users need take no action in regards to our products to ensure the safe functioning of their PC's or in opening any PDF file with our products.

 

 

Back to all News, Press & Events