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1 PDF-XChange Editor/Editor Plus V6

 

 

PDF-XChange Editor/Editor Plus v6.x

User Manual

Designed for anyone from home users to large corporate environments that wish to View/

Edit/Modify and even OCR Image based PDF files on their Windows PC's. There is now a

FREE pdf reader alternative to the Adobe Reader that truly raises the bar! The PDF-XChange

Editor is smaller, faster and more feature rich than any other FREE PDF Reader/ PDF Viewer/ PDF

Editor available on the market. This free pdf editor download also allows users to try the

extended functionality offered by the licensed PDF-XChange Editor in evaluation mode - for free.

No PDF reader or Viewer offers more features than PDF-XChange - or does so without

compromising performance, quality or security. Checkout the feature list below and save $100's

in unnecessary expenditure on your PDF software solution today.

PDF-XChange Editor Plus is now available. The new version of the Editor includes all the

features of the standard Editor plus a newly designed Fillable Forms Designer/Editor. It also

provides the ability to Create Dynamic Stamps using the features of the new Forms designer.

   Section Topics

· Introduction

· Common Actions

· *Macros

· PDF Editor Overview

· Page Content Editing

· Main Menu

· Toolbars Area

· Shell Extensions

If you're unable to find

what you're looking for in

this help system, try these

alternative resources:

Our Website

Knowledgebase

Support Forums

or contact our support team support@tracker-software.com                

9
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http://www.tracker-software.com
http://www.tracker-software.com/knowledgebase
http://www.tracker-software.com/forum/
mailto:support@tracker-software.com
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2 Introduction

System Requirements

IMPORTANT! Evaluation mode vs. Licensed mode

Switches for EXE installers

Switches for MSI installers

Uninstalling the program

Command Line option

Keyboard Shortcuts

Tracker Software Products Ltd are the authors and publishers of a number of award winning software

applications and developer toolkits including the best-selling PDF-XChange and PDF-Tools products

for the creation, manipulation, viewing, editing and printing of ISO standard compatible PDF files. 

Our tools are used by millions of clients around the world to work with the now ubiquitous Portable

Document Format (PDF) created by Adobe Inc and released as an open standard to provide a common

means to present documents that would always look the same when viewed on a user’s PC - even if the

Viewing party did not have all the fonts and images present on their own PC - could be contained within

the PDF file to ensure common viewing. 

To accompany the standard format, Adobe created a free viewer to ensure that anybody could view

distributed PDF files freely without requiring the purchase of any additional software - the viewer was

made freely available. 

To create PDF files the user could purchase Adobe Acrobat from Adobe direct or as the specification of

PDF format was freely available to competing software authors - software applications from 3rd parties

quickly appeared and this healthy competition along with the stability of a freely available viewer at no

cost has ensured that the PDF format has now become 'the' preferred method to share documents

between Government agencies, departments privately and for companies large and small. 

Everybody was happy, Adobe was the philanthropic author of a world-wide standard available to anyone,

End users and Suppliers could share all manner of documents and information and there was a healthy

3rd party software community expanding the market and ensuring that inexpensive solutions for

creating and manipulating PDF files was available, for even the smallest business and private user - whilst

Adobe remained at the top of the heap, providing heavyweight commercial solutions for big business. 

And then ... for some reason only known to Adobe, they decided that some functionality would be

available to users of their free Adobe Reader only if they used a product officially 'certified' to offer this

functionality by Adobe - all competing software applications would now have to apply to Adobe for a

certificate or the new functionality would not be possible with files made by competing and 'non'

certified PDF creation and manipulation tools. 

To be clear - we are not talking here about the creation of PDF files - but the ability to see, modify and

use files already created and then to be viewed in Adobe's free PDF reader, most specifically

11

12

15

18

24

25

25

http://www.tracker-software.com/
http://www.tracker-software.com/buy-now
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commenting and annotation added to PDF files by non-Adobe creation tools - these could not be read

by the Free Adobe Reader! 

Suddenly the 'Open' PDF format was not so open and it was concern that Adobe would continue to

extend this in the future to regain some degree of control over who can create software with the ability

to offer advanced PDF creation and manipulation functionality - whereas in the past, the primary reason

for the success of this standard format has been the fact that any software company has been free to

create products for the purpose without interference from any party - including Adobe. 

And that is why 6 years ago we decided to create the 'Free' PDF-XChange Viewer to allow PDF files

created by any software (not just ours or Adobe's) that adheres to the open PDF format specification as

defined by Adobe - to take advantage of these extended features. 

However - we have not stopped there and we are now pleased to continue the legacy of the FREE

PDF-XChange Viewer with the all NEW PDF-XChange Editor! We have added a host of useful

features and functionality that users have told us they would find advantageous and usually only found

in paid for software - such us our new Text Editing functionality. Further will continue to do so over the

coming months and years - mostly free - but we have also added advanced functionality to Edit other

content, modify, manipulate and create new PDF files, and for these extended features we do make a

modest charge to allow us to continue in our endeavor's - however - feel free to restrict your use to the

free functionality should you not find the enhanced functionality of the paid for 'PRO' version of use to

you. 

We commit to not making any functions for viewing content a chargeable extra in the PDF-

XChange Editor and to treat all files in the PDF format as equal - no matter with which tool they have

been created - whether Adobe's, ours or any other 3rd party software publishers - if the file has been

created to conform and adhere to the PDF specification and uses functions supported by our Viewer and

Editor - it will be viewable - irrespective of the origin of the creation Tools author. 

A very important and significant change in the ongoing development of the PDF format is it is now

no longer controlled and set by Adobe - the PDF format is now officially controlled and determined by

the ISO (International Organization for Standardization) and its future wholly determined and

controlled independently of Adobe Inc for the benefit of all users and independent software developers,

making the PDF format a truly open document format in perpetuity. We hope you find this viewer robust

and reliable for your purposes - should you need help or support - please visit our free user support

forums. We welcome you ideas and suggestions on these forums as well. 

http://www.iso.org/iso/home.htm
http://www.tracker-software.com/forum3/index.php
http://www.tracker-software.com/forum3/index.php
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2.1 Notice

PDF-XChange Editor is a rapidly expanding product for Tracker Software Products, Ltd. 

Due to the timing difference between the release of new versions of this product and the subsequent

documentation, it is possible that certain functions may be active but not completely documented in the

download that you receive. 

Where we know that certain functions will be available but are not active at the time of documentation,

we have marked these items with a legend in red such as: 

Note: This function was not available at the time of writing of this documentation. 

Rest assured that we are aware of these and will be releasing new versions of the documentation as

rapidly as we can to stay abreast of the latest features of PDF-XChange Editor! 

This documentation is valid through version 5.5 Build 315.0  

2.2 System Requirements

PDF-XChange Editor supports all Windows (32/64 bit) operating systems from Windows XP** and later.

Version 5 (2012): Microsoft/Citrix Terminal Server compatible*.

Version 4: Microsoft/Citrix Terminal Server compatible*. 

Version 3: Still available for Windows 95/98

*Note: Though many users have virtualized some of our component products such as the PDF-

XChange Editor and PDF-Tools application using XenApp, we do not support this at this time. Particularly

the printer drivers are not designed to work in a virtualized environment.

** Limitations to product support for Windows XP

To experience the best performance of our products on all Windows operating systems, the onus

is on users to ensure that they have all the latest available Microsoft Windows Service Packs &

Updates installed.

http://www.tracker-software.com/knowledgebase/399-Limitations-to-Windows-XP-Home--Professional-Product-Support
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2.3 IMPORTANT! Evaluation mode vs. Licensed mode

Important Notes for the PDF-XChange Editor - Build 5.5 and later! 

All the features you have been used to for free - are still available as free functions and do not require a

payment for license to use without restriction - subject always to our License standard terms and

conditions. We are constantly also adding new features to both the FREE and paid for (Licensed) states of

the Editor - rest assured we have not simply used the offer of a FREE mode to capture users interest and

then removed the ability to use these features subsequently and required payment - any features

available freely now, will always be free to use - and we are committed to expanding both the FREE

features and those available in the Licensed/Paid for versions. 

Warning *** Warning *** Warning *** Warning!!!!! 

All features marked as 'PRO' can only be used in evaluation mode with the absence of a valid license key. 

If you save the file after having used these 'PROTECTED' features, it will be altered to include watermarks

making it obvious it has been modified with an evaluation copy. 

These watermarks CANNOT subsequently be removed without a valid license! 

Please ensure that you do not modify original documents using these evaluation features if they cannot be

recreated again and if it is important to you and cannot be reproduced! 

For further information, please Contact Us! 

2.3.1 In What Mode Am I Running?

If you are not sure whether your Editor is running in Evaluation or Licensed mode, simply open the Edit>

Preferences> Registration and make sure you see your license Key State Valid. As shown in the

screenshot below. 

      Key State Valid

http://www.tracker-software.com/contact
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If you see the following under the Registration Info section, you are running in the unregistered

Evaluation mode, and you must be careful not to save the PDF if you make certain kinds of changes to

it. 

     Edit>Preferences>Registration: No License keys
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Safety Feature

As a last resort, if you try to use a Licensed feature in Evaluation mode, the following dialog will appear:

     Protected Feature Warning Dialog

The Protected Feature dialog does not stop a user from accessing Licensed features, it only warns the user that

"Buy now" watermarks will be placed on the document. These cannot be removed without a valid license. By

choosing Yes, the feature can then be used with the understanding that the Evaluation mode limitations will be

applied once the document is saved. Click No to Cancel the command. 

Version History and Projected Features

See here for the history of features and fixes implemented for each Version and build.

http://www.tracker-software.com/PDFXE_history.html

http://www.tracker-software.com/PDFXE_history.html
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2.4 Switches for EXE installers

Command line Installation the PDF-XChange PDF Editor 

Our binary 'EXE' installers support both 32 and 64 bit versions of MS Windows, whereas the MSI

installers are separated into 32 or 64 Bit Windows installers as the Microsoft MSIN installer technology

does not lend itself to a unified 32/64 bit installer type. If you are not sure if you have a 32/64 bit

Windows operating system, please use either the EXE installer which will 'intelligently' make this choice

for you - or use the 32 bit MSI installer as this will function correctly in both 32 or 64 bit Windows -

albeit the 32 bit version will not take full advantage of your hardware/Windows capabilities and features

available in Shell Extensions. 

The latest downloads are available from our web site downloads page. 

The PDF-XChange binary 'EXE' install file is downloaded as a 'ZIP' file from which you must extract the

installer itself -: PDFXVE5.exe, whereas the MSI installers are offered without being 'wrapped' in ZIP

archives.

Here is an example of the full command line string available for the Binary 'EXE' type installers (see the MSI

section if that is the installer of choice!): 

Most items are optional unless otherwise stated 

C:\PDFXVE5.exe /quiet /norestart SET_AS_DEFAULT=1 KEYFILE="\\readable\path\to\licenseFile.xcvault" 

Please note - parameters names are case sensitive.

Broken down into sections - these are the switches and what each does: 

SWITCHES DESCRIPTION 

 MAIN install executable and path

This is the full path to the installation executable, note it is the

standard install executable - both silent and non silent installations

are available from the single executable. 

C:\PDFXVE5.exe 

 /install  <directory>
installs a complete local copy of the bundle in [directory]. Install is

the default. 

 /repair  <directory> repairs a complete local copy of the bundle in [directory].

 /uninstall  <directory> uninstalls a complete local copy of the bundle from [directory].

 /passive Displays minimal UI with no prompts during installation.

 /quiet Displays no UI and no prompts.

http://www.tracker-software.com/product/downloads
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 /norestart

Suppress any attempts to restart. Beware PDF-XChange may require

a reboot before updates will take effect.  By default UI will prompt

before restart.

 /log=<filename>

 Causes Setup to logs to a specific file. This can be a helpful

debugging aid.

The information contained in the log file is technical in nature and

therefore not intended to be understandable by end users. Nor is it

designed to be machine-parseable; the format of the file is subject

to change without notice.

/log "c:\logs\PDFXVE_INSTALL.txt"

 SET_AS_DEFAULT=0|1

If parameter is specified and has a value other that 1, the Editor will

not be set as default PDF application during installation. You can

always set the Editor as default application later from the Editor's

preferences.

 VIEW_IN_BROWSERS=0|1

If specified and has value 1, PDF files will be viewed in a browser. 

The view in browser option can also be turned on or off later via

Editor's preferences. 

 KEYDATA=<serial_key> 

Allows the Serial Key to be registered during silent installation - for

live use. Without this information PDF-XChange will function in

demo mode only

Example: PDFXVE5.exe /KEYDATA="PVP20-YDQsF/

+TlsfTU3HHtV...PAnfXcPnrZJFGhLFgbON4s+=" 

 KEYFILE=<xcvault file>

Allows the a license file (.xcvault) to be used for registration during

silent installation by - for live use. A valid UNC path is required. 

Without this information PDF-XChange will function in demo mode

only

Example: PDFXVE5.exe /KEYFILE:"\path\to\xcvault\file.xcvault"

 USERNAME=<name> 

Allows the registered username to be specified during silent

installation. 

Example: USERNAME="MY Name" 

 ORGANIZATION=<name> 

Allows the Company details to be specified during silent

installation. 

Example: ORGANIZATION="Tracker Software" 

 USEREMAIL=<email> 

Allows the users email address details to be specified during silent

installation. 

Example: USEREMAIL="my@email.com" 
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 EDITOR_LANGUAGE=<lang_id>

Sets a language lang_id as the default language for the User

Interface. 

none - installer will preserve current settings for UI language; it is a

default value

auto - Editor will choose localization language based on the user's

localization settings of the OS

builtin - Editor will be forced to do not use localization (use built in

strings)

<langID> - Language ID of the language as shown in the ISO Code

column in the list of available languages for the Editor (http://

tracker-software.com/editor_lang); for example, de-DE - for German,

uk-UA - for Ukrainian;

Examples

PDFXVE5.exe EDITOR_LANGUAGE="de-DE"

msiexec.exe /i PDFXVE5.x86.msi EDITOR_LANGUAGE="fr-FR"

msiexec.exe /i PDFXVE5.x64.msi EDITOR_LANGUAGE="it-IT"

 DESKTOP_SHORTCUTS=0|1
If specified with value 1, desktop icon(s) will be created during the

installation. 

 PROGRAMSMENU_SHORTCUTS=0|1 
If specified with value 1, instructs Setup create a group for the PDF-

XChange Editor in the Start menu. 

2.4.1 Installation Command-line Examples

· Install the application in silent mode (no user input) without re-boot system: 

PDFXVE5.exe /norestart /quiet

· Install the application in silent mode (no user input) with registration information: 

PDFXVE5.exe /quiet KEYDATA="PVP20-YDQsF/+TlsfTU3HHtV...PAnfXcPnrZJFGhLFgbON4s+="

USERNAME="My Name" ORGANIZATION="Tracker software" USEREMAIL="my@email.com" 

· Install the application for French, without any icons in Start Menu and desktop: 

PDFXVE5.exe DESKTOP_SHORTCUTS=0 PROGRAMSMENU_SHORTCUTS=0 EDITOR_LANGUAGE="fr-FR"

· Install the PDF-XChange Editor as default viewer for PDF-files and allow to view PDF-files in

browsers: 

PDFXVE5.exe SET_AS_DEFAULT=1 VIEW_IN_BROWSERS=1
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2.5 Switches for MSI installers

Windows ® Installer. V 5.0.7100.0

Command-line for installation is: 

msiexec /Option <Required Parameter> [Optional Parameter] [PROPERTY=PropertyValue]

Broken down into sections - these are the switches and what each does: 

OPTIONS PARAMETER DEFINITION

Install Options

/package or /

i  

<Product.msi

>
Installs or configures a product 

/a  
<Product.msi

>
Administrative install - Installs a product on the network 

/j<u|m>   
<Product.msi

>

Advertises a product - m to all users, u to current user. Additional

parameters can be used:

[/t <Transform List>] 

[/g <Language ID>]

/uninstall | /x 

 
<Product> Uninstall the product. Parameter can be .msi file or Product Code.

Display Options

/quiet   Quiet mode - Installs the application without user interaction 

/passive   Unattended mode - progress bar only 

/q[n|b|r|f]  

Sets user interface level: 

n - No UI 

b - Basic UI 

r - Reduced UI 

f - Full UI (default) 
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Restart Options

/norestart   Do not restart after the installation is complete 

/

promptrestart

 

  Prompts the user for restart if necessary 

/forcerestart   Always restart the computer after installation 

Logging Options

/l  <LogFile>

Defines logging level for installation. Possible modifiers are:

i - Status messages 

w - Nonfatal warnings 

e - All error messages 

a - Start up of actions 

r - Action-specific records 

u - User requests 

c - Initial UI parameters 

m - Out-of-memory or fatal exit information 

o - Out-of-disk-space messages 

p - Terminal properties 

v - Verbose output 

x - Extra debugging information 

+ - Append to existing log file 

! - Flush each line to the log 

* - Log all information, except for v and x options 

/log  <LogFile> Equivalent of /l* <LogFile> 
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Repair Options

/f  <Product>

Repairs a product. Parameter is an .msi file or Product Code. May have

the following modifiers: 

p - only if file is missing 

o - if file is missing or an older version is installed (default) 

e - if file is missing or an equal or older version is installed 

d - if file is missing or a different version is installed 

c - if file is missing or checksum does not match the calculated value 

a - forces all files to be reinstalled 

u - all required user-specific registry entries (default) 

m - all required computer-specific registry entries (default) 

s - all existing shortcuts (default) 

v - runs from source and recaches local package 

For additional options and more detailed description please refer to Microsoft's Web Site.
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Properties  Public properties defined by PDF-XChange installation may be specified as well as standard

MSI public properties.

For complete list of standard public properties please refer to: http://msdn.microsoft.com/en-gb/

library/aa370905(VS.85).aspx  

Most useful properties are:

 Standard Properties

ADDLOCAL
 <list of

features> 

The value of the ADDLOCAL property is a list of features that

are delimited by commas, and are to be installed locally. PDF-

XChange Editor & PDF-XChange PRO installers define the

following features: 

F_Viewer - PDF-XChange Editor and its components; 

F_Plugins - Plugins modules for the Editor (requires

F_Viewer). If F_Plugins is specified, the following

features can be used to install plugins:

F_Plugin_SP – to install SpellChecker plugin. Requires

F_Plugins

F_FileOpenPlugin – install plugin that provide support

for file secured by FileOpen. Requires F_Plugins

F_ReadOutLoudPlugin – install the plugin that

provides read out loud functionality. Requires

F_Plugins

F_OCRPlugin – install plugin that allow OCR image

based PDF files in the Editor. Requires F_Plugins.

F_Updater - Update for Tracker products

F_SPPlugin - for sharepoint

F_OptimizerPlugin - install plugin that allows to

optimize existing PDF files to reduce size. Requires

F_Plugins.

F_PDFAPlugin - install plugin that allows to convert

existing PDF files to PDF/A compatible files. Requires

F_Plugins.

F_SPPlugin - install plugin that allows the Editor to

works with files located on SharePoint/Office 365

servers. Requires F_Plugins.

F_GDPlugin - install plugin that allows the Editor to

work with files located on Google Driver cloud storage.

Requires F_Plugins.

F_OFCPlugin - install plugin that allows to open MS

Office documents directly in the Editor. Requires

http://msdn.microsoft.com/en-us/library/aa370905(VS.85).aspx
http://msdn.microsoft.com/en-us/library/aa370905(VS.85).aspx
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F_Plugins.

F_BookmarksPlugin - for bookmarks

F_PDFAPlugin - for PDF/A plugin

F_VLangs - Localization files for the Editor (requires F_Viewer).

F_BrowserPlugins - plug-ins for web browsers (MS Internet

explorer, Mozilla FireFox, Opera, Safari, and Chrome) which

allows to view PDF files inside these browsers. This feature

requires F_Viewer feature to be installed as well as F_IEPlugin

and/or F_NPPlugin. 

F_IEPlugin - IE plugin. Requires F_BrowserPlugins and

F_Viewer. 

F_NPPlugin - Firefox and Opera plugin. Requires

F_BrowserPlugins and F_Viewer. 

F_ShellExt - Extensions for Windows Explorer and Windows

shell. These extensions allow to view PDF thumbnails into

Windows Explorer, show properties of PDF files, handling

preview of PDF files into Windows Vista (and later) and Office

2007 (and later), provides IFilter component which allows

Windows Desktop Search engine to make search inside PDF

files;

INSTALLLOCATION   Specifies the folder where products will be installed. 

Product specific properties

SET_AS_DEFAULT  
If not specified or specified and has value of "1", PDF-

XChange Editor will be set as default application for PDF files. 

VIEW_IN_BROWSERS  

If not specified or specified and has value of "1", PDF-

XChange Editor will be configured to open PDF files inside

browsers..

DESKTOP_SHORTCUTS  
If not specified or specified and has value of "1", installer will

place shortcuts for installed application on Desktop.

PROGRAMSMENU

_SHORTCUTS
 

If not specified or specified and has value of "1", installer will

create program menu group for installed application and their

components.

USERNAME
 <username

>

Specifies the username for which applications will be

registered. 

ORGANIZATION  <oname>
Specifies the organization name for which applications will be

registered.

USERMAIL  <email> Specifies the user email. 
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KEYFILE
 <xcvault

file> 

Specifies the UNC location of the license vault file

<filename>.xcvault. 

KEYDATA  <regkey>  Specifies registration key in plain text. 

EDITOR_LANGUAGE=<i

d>*
 <id>*  Specifies a language for the Editor.  Requires F_Vlangs

NOUPDATER  

If not specified or specified and has value of "0" Updater will

be installed.  A value of "1" will prevent Updater from being

installed. 

SCHEDULEUPDATER  

If not specified or specified and has value of "1", installer will

add a task to the Task Scheduler that allows to periodically

check Tracker's products for available update.

<id> for your target language can be found here: http://msdn.microsoft.com/en-us/library/

ee825488(v=cs.20).aspx 

The “Language Culture Name” is used with EDITOR_LANGUAGE.  – E.g. for German use de-DE

Command-line Examples: 

· Install the application in quiet mode (no user input) to folder "C:\Program Files\Tracker":

msiexec /i PDFXVE5.x86.msi /quiet INSTALLLOCATION="C:\Program Files\Tracker"

· Install the application in quiet mode to default folder. Specify the user license info: 

msiexec /i PDFXVE5.x86.msi /quiet USERNAME="Dave" USERMAIL="abc@a.b.c"

KEYFILE="\UNC\path\to\xcvaultfile"

· Install PDF-XChange Editor with all features, German language and a 'basic' UI during install. 

Note that because ADDLOCAL is not being used here then all componants including F_VLangs

are installed.  

msiexec /i PDFXVE5.x86.msi /qb EDITOR_LANGUAGE="de-DE" 

· Install PDF-XChange Editor with specific features only. Editor with Spellcheck and OCR plugins but not

FileOpen or ReadAloud plugins, Browser plugins for only IE, German language and a 'basic' UI during

install.  Because ADDLOCAL is being called to install specific features then only those features explicitly

called will be installed, so in this case F_VLangs must be explicitly called :

msiexec/i PDFXVE5.x86.msi /qb

ADDLOCAL="F_Viewer,F_Plugins,F_Plugin_SP,F_OCRPlugin,F_VLangs,F_BrowserPlugins,F_IEPlugin"

EDITOR_LANGUAGE="de-DE"

· Install PDF-XChange Editor with specific features only. Editor with Spellcheck and OCR plugins but not

FileOpen or ReadAloud plugins, Browser plugins for only IE, German language and a 'basic' UI during

install.  Because ADDLOCAL is being called to install specific features then only those features explicitly

called will be installed, so in this case F_VLangs must be explicitly called :

msiexec /i PDFXVE5.x86.msi /qb

ADDLOCAL="F_Viewer,F_Plugins,F_Plugin_SP,F_OCRPlugin,F_VLangs,F_BrowserPlugins,F_IEPlugin"

EDITOR_LANGUAGE=de-DE 

http://msdn.microsoft.com/en-us/library/ee825488(v=cs.20).aspx
http://msdn.microsoft.com/en-us/library/ee825488(v=cs.20).aspx
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2.6 Uninstalling the program

-Uninstalling the Program-,

The PDF-XChange Editor may have been installed alone or as part of the PDF-XChange PRO package. 

Windows XP 

· In the Control Panel click Add/Remove Programs 

· Find All instances of PDF-XChange Editor, PDF Editor, or PDF-XChange PRO by Tracker Software

Products 

· Click the Remove button and follow the instructions in the accompanying dialog boxes 

· Restart your system 

Windows Vista/Windows 7/Windows 8/ Windows 8.1/ Windows 10 

· In the Control Panel click Programs and Features 

· Find All instances of PDF-XChange Editor, PDF Editor, or PDF-XChange PRO by Tracker Software

Products 

· Click the Program so it is highlighted 

· On the toolbar at the top, click Uninstall and follow the instructions in the accompanying dialog

boxes 

· Restart your system 

The Program has now been removed from your system. 
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2.7 Command Line option

Formal syntax

<anytext> - it means any text string.

<a>| <b> - means <a> or <b>

<filename> - full or relative path to file; when the path contains white spaces it should be enclosed in quotation marks. For

example:

c:\MyDocuments\MyTestDocument.pdf but "c:\My Documents\My Test Document.pdf"

<pagesrange> - specifies the range of pages to be processed. For example:

1,3,10-20 // to process 1,3,10,11,12,..20 pages

50- // to process 50,51,... <LastPageNumber> pages

-50 // to process first fifty pages

[expression] - means that expression is the optional part of command line. For example if syntax is:

/print[:[default[=yes|no]][&showui[=yes|no]]] <filename>

then will be correct:

/print "c:\example.pdf"

/print:default "c:\example.pdf"

/print:default&showui "c:\example.pdf"

/print:default=yes&showui=yes "c:\example.pdf"

/Print Command

Name:

/print

Description:

prints pages from specified document(s).

Syntax:

/print[:[default[=yes|no]][&showui[=yes|no]][&printer=<printername>][&pages=<pagesrange>]]

<filename1> [<filename2> ... <filenameN>]

Parameters:

· default - if specified then default parameters(options) will be used for printing; by default application uses

the last used print-parameters.

· showui - if specified then standard print dialogue will be displayed before printing; by default application

prints pages silently, without UI.

· printer - use it to specify necessary printer exactly, otherwise the default printer will be used.

· pages - specify the pages range(s) that should be printed, otherwise all pages will be printed.

Example:

PDFXEdit.exe /print:default=yes&showui=yes&printer="PDF-XChange Printer" "c:\example.pdf"
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/PrintTo Command

Name:

/printto

Description:

prints pages from specified document(s). The name of printer is required.

Syntax:

/printto[:[default[=yes|no]][&showui[=yes|no]][&pages=<pagesrange>]] <printername>

<filename1> [<filename2> ... <filenameN>]

Parameters:

· default - if specified then default parameters(options) will be used for printing; by default application uses

the last print-parameters.

· showui - if specified then standard print dialogue will be displayed before printing; by default application

prints pages silently, without UI.

· pages - specify the pages range(s) that should be printed, otherwise all pages will be printed.

Note: if <printername> contains the white spaces then it should be enclosed in quotation marks.

Example:

PDFXEdit.exe /printto:default=yes&showui=yes "PDF-XChange Printer" "c:\example.pdf"

/ExportSettings Command 

Name:

/exportsettings

Description:

exports settings of the application to a file on the disk; also you may use end-user's feature Menu/Edit/

Export Settings

Syntax:

/exportsettings[:<parameters>] <filename>

Parameters:

· settings – specify it to export all application's settings. Supported values: yes, no, 1, 0, true, false. Default

value is true.

· stamps – specify it to export all custom stamps collections. Supported values: yes, no, 1, 0, true, false.

Default value is false.

· history – specify it to export documents opening history(recents). Supported values: yes, no, 1, 0, true,

false. Default value is true. 

· pluginsdata - to export advanced plugins data (example: custom dictionaries for SpellChecker plugin).

Supported values: yes, no, 1, 0, true, false. Default value is false.
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Example: 

PDFXEdit.exe /exportsettings "c:\PDFXChangeEditorSettings.xcs"

PDFXEdit.exe /exportsettings:history=no "c:\PDFXChangeEditorSettings.xcs"

PDFXEdit.exe /exportsettings:history=no&stamps=yes&pluginsdata=yes "c:\PDFXChangeEditorSettings.xcs"

/ImportSettings Command 

Name:

/importsettings

Description:

imports all settings from a file on the disk that was created by /ExportSettings command or by end-user's

feature Menu/Edit/Export Settings; also you may use end-user's feature Menu/Edit/Import Settings 

Syntax:

/importsettings[:<parameters>] <filename>

Parameters:

· settings – specify it to import all application's settings. Supported values: yes, no, 1, 0, true, false. Default

value is true.

· stamps – specify it to import all custom stamps collections. Supported values: yes, no, 1, 0, true, false.

Default value is true.

· history – specify it to import documents opening history(recents). Supported values: yes, no, 1, 0, true,

false, merge. Default value is true. You may use merge value if you want to combine your existing history

items with new ones during import.

· pluginsdata - to import advanced plugins data (example: custom dictionaries for SpellChecker plugin).

Supported values: yes, no, 1, 0, true, false. Default value is true.

Example:

PDFXEdit.exe /importsettings "c:\PDFXChangeEditorSettings.xcs"

PDFXEdit.exe /importsettings:history=merge "c:\PDFXChangeEditorSettings.xcs"

PDFXEdit.exe /importsettings:history=merge&stamps=yes&settings=no "c:\PDFXChangeEditorSettings.xcs"
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/ImportP Command

Name:

/importp

Description:

launch the application, imports application’s settings from the specified file to current storage of settings:

system registry or special settings file (for portable application only). The input file must be in a special format

(see 

/ExportP).

Note: use new /ExportSettings and /ImportSettings command instead of old /ExportP and /

ImportP. 

Syntax:

/importp <filename>

Example:

PDFXEdit.exe /importp "c:\PXCEditor.MySettings.dat"

/ExportP Command

Name:

/exportp

Description:

exports all application’s settings to an specified file. It always creates a new file with special format and

contains all non-default application’s options.

Note: use new /ExportSettings and /ImportSettings command instead of old /ExportP and /

ImportP. 

Syntax:

/exportp <filename>

Example:

PDFXEdit.exe /exportp "c:\PXCEditor.MySettings.Backup.dat"

/UseP Command 

Name:

/usep

Description:

instructs the application to use the input file as source of all settings.

Syntax:

/usep[:readonly[=yes|no]] <filename>

Parameters:

· readonly – if specified then an input file with application’s settings will be used for read only and not be

changed on exit of application.

Example:

PDFXEdit.exe /usep:readonly "c:\PXCEditor.MySettings.dat"
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/A Command 

Name:

/A

Description:

opens document from an specified file and sets the custom view point, search words and highlight rectangles

if necessary.

Syntax:

/A <param1>=<value1>[&<param2>=<value2>[&...]][=OpenParameters] <filename>

Parameters:

· nameddest=<destName> - specifies a named destination in the PDF document.

· page=<pageNum> - specifies a numbered page in the document, using an integer value. The

document’s first page has a pageNum value of 1.

· comment=<commentID> - specifies a comment on a given page in the PDF document. Use the page

parameter before this command. For example:

page=1&comment=452fde0e-fd22-457c-84aa-2cf5bed5a349

· zoom=<scale>[,<left>,<top>] - sets the zoom and scroll factors, using float or integer values. For

example, a scale value of 100 indicates a zoom value of 100%. Scroll values left and top are in a coordinate

system where 0,0 represents the top left corner of the visible page, regardless of document rotation.

· view=Fit|FitH[,<top>]|FitV[,<left>]|FitB|FitBH[,<top>]|FitBV[,<left>] - set the view of the displayed

page, using the keyword values defined in the PDF language specification. For more information, see the

PDF Reference. Scroll values left and top are floats or integers in a coordinate system where 0,0 represents

the top left corner of the visible page, regardless of document rotation. Use the page parameter before

this command.

· viewrect=<left>,<top>,<width>,<height> - sets the view rectangle using float or integer values in a

coordinate system where 0,0 represents the top left corner of the visible page, regardless of document

rotation. Use the page parameter before this command.

· pagemode=<bookmarks|thumbs|none> - displays bookmarks or thumbnails (none by default).

· scrollbar=1|0 - turns scrollbars on or off.

· search=<wordList> - opens the Search panel and performs a search for any of the words in the specified

word list. All matching words are highlighted in the document. The words list must be enclosed in

quotation marks and separated by spaces. For example:

search="word1 word2"

You can search only for single words. You cannot search for a string of words.

· highlight=<left>,<right>,<top>,<bottom> - highlights a specified rectangle on the displayed page.

Use the page parameter before it. The rectangle values are integers in a coordinate system where 0,0

represents the top left corner of the visible page, regardless of document rotation.

· fullscreen[=yes|no] - when specified then document will be opened in Full Screen mode.

· password=<password> - specify password string to open silently an password-protected document.

· usept[=yes|no] - when specified then all values for positioning are absolute and measured in points(1/72

inch).
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Example:

PDFXEdit.exe /A zoom=1000 "c:\example.pdf"

PDFXEdit.exe /A page=255&zoom=200&pagemode=thumbs&search="lazy dog" "c:\example.pdf"

/Open Command

Name:

/open

Description:

opens document from an specified file and sets the custom view point, searches words and highlights

rectangles if necessary.

Syntax:

/open[:<param1>=<value1>[&<param2>=<value2>…]] <filename1> [<filename2> ... <filenameN>]

Note: to simple open document(s) you may not specify the /open keyword:

PDFXEdit.exe "c:\example1.pdf" "c:\example2.pdf"

Parameters:

See to parameters list of /A command.

/Close Command 

Name:

/close

Description:

closes already opened document by specified source file name

Syntax:

/close[:[mode=]save|discard|ask]

Parameters: 

· mode=ask - if document has changed then asks user about save changes before closing.

· mode=discard - close document silently, without asking about saving changes.

· mode=save - if document has been changed then it saves changes silently before closing.

Note: mode=ask - is by default.

Example:

PDFXEdit.exe /close "c:\example.pdf"

PDFXEdit.exe /close:mode=save "c:\example.pdf"

PDFXEdit.exe /close:discard "c:\example.pdf"
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/AddLang Command

Name:

/addlang

Description:

installs new UI-languages from special UI-languages pack. UI-languages pack is a zip-archive that contains

one or more *.xcl files.

Syntax:

/addlang[:[mode=]ask|user|all]] <filename>

Parameters:

· mode=ask - asks user about installing mode: “for this user only” or “for all users on this machine”. This is

default mode.

· mode=user - installs new UI-languages silently, for current user only.

· mode=all - installs new UI-languages silently, for all users on target machine.

/RunJS Command 

Name:

/runjs

Description:

launches the JavaScript.

Syntax:

/runjs[:log[=yes|no]] <scriptfilename> [<filename1> ... <filenameN>]

Parameters:

· log=yes|no - if specified without any value or value is yes then application creates log of executing of this

command. The log file _RunJSLog.txt will be placed to the our program folder in user's location.

· <scriptfilename> - full path to text file that containing the Adobe's JavaScript code.

Example:

       // to add 'Draft' stamp to all pages in document
PDFXEdit.exe /runjs "c:\AddDraftStampToAllPages.txt" "c:\example.pdf"

// the file "c:\AddDraftStampToAllPages.txt" may contain text:
var numPages = this.numPages;
for (i = 0; i < numPages; i++)
{
     this.addAnnot({
            page: i,
            type: "Stamp",
            author: "Editor",
            name: "myStamp",
            rect: [200, 400, 350, 500],
            contents: "This page is draft!",
            AP: "Draft"
        });
}
app.execMenuItem("Save", this);
this.closeDoc(true);
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2.8 Keyboard Shortcuts

The Editor supports a number of Keyboard Shortcuts, which are detailed in the table below: 

COMMAND* KEYBOARD SHORTCUT COMMAND* KEYBOARD SHORTCUT 

Actual Size 
Ctrl+0 

("zero" not letter "O") 
Show/Hide Menu Bar F9 

Bookmarks Ctrl+B Next Page Right 

Clear Delete Next View Alt+Right 

Clockwise (CW) Ctrl+Shift+Num + Open... 
Ctrl+O (letter "O" not

numeric "zero") 

Close Ctrl+W Page... Ctrl+Shift+N 

Comments Ctrl+M Pages Thumbnails Ctrl+T 

Contents F1 Paste Ctrl+V 

Copy Ctrl+C Preferences... Ctrl+K 

Counterclockwise

(CCW) 
Ctrl+Shift+Num - Previous Page Left 

Crop Pages... Ctrl+Shift+T Previous View Alt+Left 

Cut Ctrl+X Print... Ctrl+P 

Delete Delete Properties Toolbar Ctrl+E 

Delete Pages... Ctrl+Shift+D Redo Ctrl+Y 

Document

Properties... 
Ctrl+D Rotate Pages... Ctrl+Shift+R 

Fields Ctrl+I Save Ctrl+S 

Find Ctrl+F Save As Ctrl+Shift+S 

Find Next F3 Search Ctrl+Shift+F 

Find Previous Shift+F3 Select All Ctrl+A 

Search Selected

Text 
Ctrl+F+F Select Entire Page Ctrl+A 

Search Selected

Text 
Ctrl+Alt+F Full Screen F11 
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First Page Home 
Show/Hide Text

Formatting Toolbar 
Ctrl+E 

Fit Page Ctrl+1 Undo Ctrl+Z 

Fit Width Ctrl+2 Zoom In Ctrl+Num + 

Full Screen F12 Zoom Out Ctrl+Num - 

Last Page End Zoom To... Ctrl+Shift+M 

Layers Ctrl+L Show/Hide Toolbar F8 

Check Spelling F7    

*The underlined letter is the Alt hotkey for the command when opened in a menu. To create shortcut

keys in the Editor one should right-click at the Tool Bars area and choose Customize... When the

Customize dialog appears, shortcut keys can be created by changing Properties in the Commands field.

To customize keyboard shortcuts, please see the How to Customize Commands  section.620



34

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Introduction

3 Common Actions

In PDF, many objects utilize the same actions; Bookmarks, Links, Form fields, Buttons, etc. can all use the

same actions from the Edit Actions List window. Custom JavaScript actions are also supported. See the

JavaScript API reference for more details.  

Edit... Allows you to select an action. 

Moves the selected action up in the list of actions.

Moves the selected action down in the list of actions.

Remove removes the selected action. 

Add... opens a drop-down menu to allow you to choose an action. Click on the action name for

more information.

http://www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/js_api_reference.pdf
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 Run a JavaScript

Go To a Page in the Document

 Go To a Page in Another Document

 Go To a Page in Embedded Document

 Open a Web Link

 Open a File

 Execute a Command

 Reset a Form

 Submit a Form

 Play a Sound

 Show/Hide a Field

 Read an Article

 Run a JavaScript

Opens the Add Action: "Run a JavaScript" window where you can input your script. The PDF-XChange

Editor has been designed to be compatible with most Adobe JavaScript actions. See the JavaScript API

reference for more details.
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http://www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/js_api_reference.pdf
http://www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/js_api_reference.pdf
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 Go To a Page in the Document

Opens the Add Action: "Go To a Page in the Document" window. This allows you to set the

destination for the action that will go to a page in the current document. 

     Add Action: "Go to a Page in the Document window.

 Zoom in enlarges the preview.

 Zoom out shrinks the preview.

 Use Current View Will adjust the Destination Properties so that the destination matches the

current preview.
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Destination properties

These options allow for the specific configuration of the target destination. 

Use Page Number allows you to specify a page as well as coordinates on the page. 

Page define the page you wish the to go to. 

X: coordinates along the X axis in pt (point)

Y: coordinates along the Y axis in pt (point) 

Use Zoom Level set or select the zoom level you desire.

§ Inherit uses the current zoom level used to view the document. 

§ Actual Size sets the zoom level so that what is displayed on screen is 1:1 scale. Results

may vary depending on the screen resolution, size and DPI.

§ Fit Page adjusts the zoom level so that the full page is visible in the PDF display area. 

§ Fit Width fits the page width to to the PDF display area.

§ Fit Height fits the page height to the PDF display area.

§ Fit Visible is similar to fit page, but the document will be zoomed in to fit the contents of

the page to the visible area of the PDF display area. 

§ Fit Visible Width is similar to fit width, but the document will be zoomed in to fit the

widest content of the page to the visible width of the PDF display area. 

§ Fit Visible height is similar to fit height, but the document will be zoomed in to fit the

highest contents of the page to the visible height of the PDF display area. 

§ X% defines the percentage of the zoom level.

Use Rectangle creates a resizable rectangle. The dimensions of the rectangle in the preview is

determined by the Use Rectangle fields. The rectangles positions is determined by the values set in

the X and Y coordinate fields. 

Note: The Inherit options for the X and Y axis coordinates are deactivated when Use

Rectangle is selected. 

Use Named Destination will cause the "Go To a Page in the Document" action to go to a named

destination. Use the Add Current View  button to add a new named destination. 

Add current View Adds the current view in the preview to the left as a new named destination. 

Delete  removes the selected named destination. 
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 Go To a Page in Another Document

Creates an action that will open another document and navigate to a specified page within that

document. The Add Action "Go To a Page in Another Document" window opens when this action is

selected from the Edit Actions List. An Open Files window launches to allow for document selection. 

 Zoom in enlarges the preview.

 Zoom out shrinks the preview.

 Use Current View Will adjust the Destination Properties so that the destination matches the

current preview.
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Destination properties

These options allow for the specific configuration of the target destination. 

Use Page Number allows you to specify a page as well as coordinates on the page. 

Page define the page you wish the to go to. 

X: coordinates along the X axis in pt (point)

Y: coordinates along the Y axis in pt (point) 

Use Zoom Level set or select the zoom level you desire.

§ Inherit uses the current zoom level used to view the document. 

§ Actual Size sets the zoom level so that what is displayed on screen is 1:1 scale. Results

may vary depending on the screen resolution, size and DPI.

§ Fit Page adjusts the zoom level so that the full page is visible in the PDF display area. 

§ Fit Width fits the page width to to the PDF display area.

§ Fit Height fits the page height to the PDF display area.

§ Fit Visible is similar to fit page, but the document will be zoomed in to fit the contents of

the page to the visible area of the PDF display area. 

§ Fit Visible Width is similar to fit width, but the document will be zoomed in to fit the

widest content of the page to the visible width of the PDF display area. 

§ Fit Visible height is similar to fit height, but the document will be zoomed in to fit the

highest contents of the page to the visible height of the PDF display area. 

§ X% defines the percentage of the zoom level. 

Use Rectangle creates a resizable rectangle. The dimensions of the rectangle in the preview is

determined by the Use Rectangle fields. The rectangles positions is determined by the values

set in the X and Y coordinate fields. 

Note: The Inherit options for the X and Y axis coordinates are deactivated when Use

Rectangle is selected. 

Use Named Destination will cause the "Go To a Page in the Document" action to

go to a named destination.

Note: Because the document is only displayed rather than opened, it is not possible to add

or modify named destinations. 
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Target Document

Allows for the selection of the document to be opened by the action. 

File Name: This field lists the name and location of the target file. 

Open In: This field specifies the way the file is opened. 

§ Window set by user preference inherits the user's setting set in the Edit> Preferences>

Documents> Manage Tabs and Windows  section.

§ Existing Window opens the file within the existing window.

§ New Window opens the file in a new window. 

 Go To a Page in Embedded Document

Adds an action that will go to a page within a file that is embedded within the parent document. When

choosing this action, the Choose Root Document dialog is activated. 

A root document must be chosen to define where to look for the embedded document to be opened.  

This document will define the currently active document as the root document that contains the file to

be opened. 

Choose External Document defines an external document to be the root document. 

203
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Once the root document is selected, click OK to open the Add Action: "Go To a Page in Embeded

Document" window to define the destination within the Embedded document to open to.

 Zoom in enlarges the preview.

 Zoom out shrinks the preview.

 Use Current View Will adjust the Destination Properties so that the destination matches the

current preview.
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Destination properties

These options allow for the specific configuration of the target destination. 

Use Page Number allows you to specify a page as well as coordinates on the page. 

Page define the page you wish the to go to. 

X: coordinates along the X axis in pt (point)

Y: coordinates along the Y axis in pt (point) 

Use Zoom Level set or select the zoom level you desire.

· Inherit uses the current zoom level used to view the document. 

· Actual Size sets the zoom level so that what is displayed on screen is 1:1 scale. Results may vary

depending on the screen resolution, size and DPI.

· Fit Page adjusts the zoom level so that the full page is visible in the PDF display area. 

· Fit Width fits the page width to to the PDF display area.

· Fit Height fits the page height to the PDF display area.

· Fit Visible is similar to fit page, but the document will be zoomed in to fit the contents of the

page to the visible area of the PDF display area. 

· Fit Visible Width is similar to fit width, but the document will be zoomed in to fit the widest

content of the page to the visible width of the PDF display area. 

· Fit Visible height is similar to fit height, but the document will be zoomed in to fit the highest

contents of the page to the visible height of the PDF display area. 

· X% defines the percentage of the zoom level.

Use Rectangle creates a resizable rectangle. The dimensions of the rectangle in the preview is

determined by the Use Rectangle fields. The rectangles positions is determined by the values set in the

X and Y coordinate fields. 

Note: The Inherit options for the X and Y axis coordinates are deactivated when Use

Rectangle is selected. 

Use Named Destination will cause the "Go To a Page in the Document" action to go to a named

destination. Use the Add Current View  button to add a new named destination. 
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 Open a Web Link

This is the default action when the Link tool is used, though the Link Tool  supports all the actions

listed in this section. Selecting the Open a Web Link action launches the Add Action "Open a Web

Link" window.   

     Add Action Open a Web Link window

Type or Paste the link or URL into the field provided. 

Note: Creating a link to send an email may require the addition of the "mailto:" tag before

the email address. For example: mailto:support@tracker-software.com

 Open a File

Adds an action to open a file. When the option is selected, the Add Action: "Open a File"  window is

launched

     Add Action: "Open a File" window

566
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Destination

File Name: displays the name of the selected file. 

Browse... launches the File Open window to select the file to be opened. 

Options

Open In:

§ Window set by user preference inherits the user's setting set in the Edit> Preferences>

Documents> Manage Tabs and Windows  section.

§ Existing Window opens the file within the existing window.

§ New Window opens the file in a new window.

Operation: 

§ Open will open the file. 

§ Print will print the file.

Directory: Used when opening an application. The directory listed here should be the starting

directory of the program file. This is somewhat akin to creating a desktop shortcut for a program

or app. In the shortcut properties, the directory is listed and functions in the same respect here. 

Browse... opens the a File Open window to select a file or folder. 

Parameters: When opening a program, it is opened using command line parameters in the

background. Add program specific parameters depending on the syntax and available

parameters of the program or app being opened. 

Note: The Directory and Parameters fields apply only when opening a Program using the

Open File action. If there is data in these fields when opening a file (such as a .pdf)

the data in those aforementioned fields will be ignored. 

203
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 Execute a Command

A command within a PDF refers to an immediate action. A few example of  When this action is selected,

the Edit Actions "Execute a Command" window opens to allow the selection of the available

commands.  

     Edit Action: "Execute a Command" window

Command Name: Type the first few letters of the desired command into this auto-complete field, or

select the the command from the drop down menu. 

Available Commands

 AcroForm:FormData_ExportData exports the form data to a file.

 AcroForm:Forms_ImportData imports form data from a file. 

 AcroSendMail:SendMail sends a copy of the active document through email. 

 ActualSize Sets the zoom level to 100% showing the document in its actual size

 AddFileAttachment add a new attachment. 

 Annots:Tool:InkMenuItem activates the pencil tool to free-draw on the page.

 AutoScroll activates scrolling through pages without using keystrokes or the mouse.

 Clear delete the selection.

 Close closes the active document.

 COMP:AddBackground add a background to the document.

 COMP:AddHeadFoot add headers and footers to the document.
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 COMP:AddWatermarks add text or image based watermarks to the document.

 Copy copies the selection to the clipboard.

 CopyFileToClipboard copies the full file name to the clipboard.

 CropPages crops the pages of the document by opening the Crop Pages  window.

 Cut cuts the selection and places it on the clipboard. 

 DeletePages deletes pages from the active document. 

 DIGSIG:CertifyInvisible certify the document without placing a visible signature.

 DIGSIG:ClearAll clears all digital signatures on the document. 

 DIGSIG:NextSigPullRight get existing or create new unsigned signature field then sign it.

 DIGSIG:SaveAndAuthenticateTask certifies the document and adds a visible signature.

 DIGSIG:ValidateAll validates all signature in the active document. 

 Editor:New create a new document with black pages.

 ExtractPages opens the Extract Pages  window. 

 Find opens the Find Toolbar . 

 FindCurrentBookmark will locate and highlight the bookmark for the currently viewed page.

 FindSearch Open an advanced search pane.

 FirstPage Go to the first page in the document

 FitHeight The page zoom will be modified so that the full height of the page can be viewed.

 FitPage The page zoom will be modified so that the full page can be viewed.

 FitVisible The page zoom will be modified so that all visible content can be viewed, with a

small margin of white space around it.

 FitWidth Page is fitted into display area so page width is displayed. This usually results in

some of the page not being visible without scrolling.

415

406

189
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 FullScreen View document in full screen.

 GeneralInfo show the properties of the active document.

 GeneralPrefs show application preferences dialog.

 GoBack Navigate backwards.

 GoBackDoc Go to previous document.

GoForward Navigate forward.

 GoForwardDoc Go to the next document.

 GoToPage Go to a specific page in the document.

 HandMenuItem activates the Hand Tool . Click and pan around the document.

 Highlight from file to be used in conjunction with an XML data file which defines a character

count for character to be highlighted. This command is mostly for development purposes.

 InsertPages Insert pages from another document into the current one. Same as going to

Document> Insert Pages .

 LastPage Go to the last page of the document.

 LoupeMenuItem Activates the Loupe Tool  and shows the Loupe Window.

 NewBookmark Creates a new bookmark.

 NextPage Go to the next page in the document.

 OneColumn show page by page continuously. This command is the same as Continuous page

view.

Open Opens an existing PDF by launching an Open File window.

 PanAndZoomMenuItem Show/Hide the Pan and Zoom pane .

 Paste Add content from the clipboard to the document.
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 PrevPage go to the previous page in the document.

 Print print the active document.

 PropertyToolbar Show the properties of the selected object.

 Quit Closes the PDF-XChange Editor and prompts to save any changed documents.

 Redo Redo the previously undone action.

 ReplacePages Replace specified pages of the active document with pages from another

document.

 Revert Revert the active document to its original state since the previous save.

 RotateCCW Rotates the current view counterclockwise. This does not apply any changes to

the document.

 RotateCW Rotates the current view clockwise. This does not apply any changes to the

document.

 RotatePages rotates the pages of the active document.

 RotatePagesCCW rotates the selected page(s) 90 degrees counterclockwise.

RotatePagesCW rotates the selected page(s) 90 degrees counterclockwise.

 RotatePagesCW180 rotates the selected page(s) 180 degrees.

 Save saves the active document.

 SaveAs Save the active document with a new name.

 Scan create a new document using the custom scan options.

 Scan:Create insert new pages from the scanned image files to the document.

 SelectAll same as using the keyboard shortcut for select all (Ctrl+A). This command will select

every object in the active object or focus area.

ShowCoverPage Display the first page separately in two pages view.
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 ShowGaps show/hide a gap between pages.

 ShowGrid toggles grid in the background of the document for perfect object alignment.

 ShowGuides toggles the guides. See the Show Rulers  section for more details on guides.

 ShowHideAnnotManager toggles the Comments pane .

 ShowHideArticles toggles the Articles pane .

 ShowHideBookmarks toggles the Bookmarks pane .

 ShowHideContentPanel toggles the Contents pane .

 ShowHideDestinations toggles the Destination pane .

 ShowHideFileAttachment toggles the Attachments pane .

 ShowHideOptCont toggles optional content.

 ShowHideSignatures toggles the Signatures Pane .

 ShowHideThumbnails toggles the Thumbnails Pane .

 ShowRulers toggles the Rulers .

 SinglePage switches to single page view method.

 SnapToGrid enables snapping objects and annotations to grid. Visit the Snap  section for

more details.

 TwoColumns activates Two pages continuous View which shows two pages side by side

continuously.

 TwoPages activates Two Pages view which shows to pages side by side.
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 Undo undoes the most recent change.

 ZoomTo opens the Zoom To window allowing for specific zoom adjustments.

 ZoomViewIn increases the magnification of the document.

 ZoomViewOut decreases the magnification.

 Reset a Form

Resets all form fields to their default values. 
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 Submit a Form

Use this action to set up the parameters to submit a form. When the Submit a Form action is selected,

the Add Action: "Submit a Form" window is opened to allow setup. 

Enter a URL for this link: This field will allow submitting to an online entity, or as in the screenshot

above, a mailto address to submit the form through email.

Form Field Selection lists all the fields in the document. Select the desired fields to export.

Select All selects all fields.

Deselect all deselects all fields.

Invert Selection reverses the selection so that fields that were selected have been deselected, and fields

that were not selected will now be selected.    

Exclude Selected this option reverses the way the Form-Field selection area works. With the Exclude

selected option activated, the selected fields will not be submitted, but those that are not selected will. 

Include Empty fields by default, empty fields do not export any data.
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Export Format

Define the format in which the form will be exported.

Type: FDF Files (*.fdf) 

FDF files are used for text files exported from .PDF files. FDF files are smaller than .PDF files

because they only contain the form field data in text format, and not the entire form.

Convert dates to standard format all dates will be converted to D:YYYY/MM/DD format.

Field Data if selected, field data will be included. 

Comments if selected, comments data will be included. 

Incremental changes to the PDF if selected, incremental changes will be reported in the FDF

data. Note: This feature has not yet been implemented at time of documentation.

Type: XFDF Files (*xfdf) 

Exports as descriptions of page form elements and their values, such as the names and values for

text fields; used for saving form data that can be imported into a PDF document.

Convert Dates to standard format all dates will be converted to D:YYYY/MM/DD format.

Field Data if selected, field data will be included. 

Comments if selected, comments data will be included.
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Type: HTML Files (*html) 

Exports HTML instructions for reconstructing the form field data. 

Convert dates to standard format all dates will be converted to D:YYYY/MM/DD format.

Type: PDF Files (*pdf) 

The file format will not be converted. 

When exporting as a PDF, no changes are made to the file or its data.
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 Play a Sound

Sets an action that plays a sound. Use this action to set up the parameters to a sound. When the Play a

Sound action is selected, the Add Action: "Play a Sound" window is opened to allow recording and

setup. 

To use an existing sound file, use the  Browse button. Otherwise, record a new sound clip using the

 record button.

Use the  Play button to listen to the sound clip. 

Use the  Stop button to stop playing the sound clip. 
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 Show/Hide a Field

Depending on how this command is set, it will show or hide a field or set of fields. To set up this action,

choose it in the Edit Action list and click on Edit. This opens the Edit Action: "Show/Hide a Field

window.

Unfortunately this field does not currently function as a toggle, so it will either Show, or Hide a field, but

not both. Select the fields desired for this action, then choose Show or Hide. 

Select All selects all fields.

Deselect all deselects all fields.

Invert Selection reverses the selection so that fields that were selected have been deselected, and fields

that were not selected will now be selected.  

To confirm the action, click on OK.

 Read an Article

Note: This feature has not yet been implemented at time of documentation. 
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4 *Macros

Macros are Variables used to in place of static text for the purpose of saving a filename of a

document(s), such as the current time, path, page number etc. 

In PDF-XChange Editor, Macros can be used for creating names for Stamps, Watermarks and new

Documents.

To use a Macro, click the button on the dialog box and select the Macro name from the drop-down list

to place it in the field.

Document Title

Document Index

Document Info

Page Number

Number of Pages

File Name

Folder Name

Date

Year

Month

Day

Time

Hour

Minute

Seconds

Computer Name

User Name

Environment Variable

Application Version

Image Number

Auto Number

Using Macros with Editor operations
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A Macro is presented by its Name (see Macro names in the list above).

The Macro format is %[<Macro Name>] or, when it is customizable, %[<Macro Name>:<Parameter>].

<Parameter> is optional, it means, you can choose to use it or not.

Note: Be careful using Macros for creating File Names! 

Symbols      / \ : * ? " < > |                            are not allowed to be a part of a document name,

and, when they are added with Macro, they will be changed or removed:

                   " * "    and     " ? "                         will be removed;

                   " :"                                                 will be replaced with   "-";

                   "/ ", " \ " , " " ", " < ", " > ", " | "   will be replaced with "_"

Example: if you Extract pages from your document and put  "E:\" as Destination Folder and

the string %[Env:HOMEDRIVE]%[Env:HOMEPATH] as File Name, where HOMEDRIVE is "C:" and

HOMEPATH is " \User\Kevin", you will get a new document with a full name (path and name):

"E:\C-\User\Kevin.pdf".

To check if the Macro name includes these symbols, move a mouse cursor to that Macro name and,

in a pop-up window, check all text that might be added to a file name.
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An example of using a Macro:

1. As a simple example of using macros, run the Export to Image and specify the File Name for newly

generated image files with Macros File Name, Page Number, and Number of Pages from the drop-

down list by clicking on . Fill the the field File Name with: %[FileName]_Page%[ Page] of %[Pages]. 

  PDF document name is Example.pdf.

Export to Image window.

1. Choose File Name for image files with the Macro panel.  2. The field File Name. 

3. Option for viewing the resulting files in the Windows explorer window. 4. Preview window shows Page and Number of

Pages in the PDF Document.
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2. Press OK to perform the action Extract to Images and see the generated image files in the specified

Destination Folder F:\New Folder with File Name(s) "Example_Page1 of 2.jpg" and "Example_Page2 of

2.jpg".

The resulting image files.

Go to the top 56
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1. Document Title

Name

DocTitle

Description

DocTitle represents the current Document Title, which can be specified in the Document's

Initial View . This macro can be used only in operations with PDF documents. 

It has one of the following values:

- File Name without extension if you set the File Name in the field Show in Title (File

> Document Properties > Initial View);

- Document Title from the field Document Title in the Description Info  if it is set

in Show in Title in Initial View ;

- File Name without extension if the field Document Title in Description Info is

empty.

Syntax

%[DocTitle]

Example

The File name is "articles.pdf"; 

The Document Title is "ACDSee PDF Image." (with a period ".").

In the Document's Initial View, in the field Show in Title,  set:

1) Document Title; 2) File Name.

  For creating a Watermark choose the macro DocTitle and you will get:

1) "ACDSee PDF Image."; 2) "articles".

Go to the top
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2. Document Index

Name

DocNumber

Description

DocNumber presents the Document Index and has the value of an index (the sequence

number) of a file in a list of input files (e.g. in adding several files to a single PDF document)

or output files (e.g. in extracting pages from a PDF document). Document Index starts from

"1".

Syntax

%[DocNumber:<Parameter>]

Parameters

For the  <parameter> you can enter an integer number: that number indicates minimum

amount of digits for formatting the page number (e.g., the <parameter> is 4, and indexes

are: "0001", "0002", etc.). 

Example 

If you are adding three pages from three image files to your active PDF document, and you

want to put labels on the new pages using the macro Document Index.
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In the resulting file you will get the new pages with labels "0001", "0002", "0003" which

appear on the place you specified (e.g., here, on the top center place of the page, and, also,

as bookmark names on the Bookmark pane):

Go to the top
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3. Document Info 

Name

DocInfo

Description

DocInfo represents Document Information and gets information about the PDF document

from the Document Properties. This macro only works with PDF documents. 

Syntax

%[DocInfo:<Parameter>]

Parameters 

Choose a parameter from any field in Main Menu> File> Document Properties>

Description :

Title text from a field Document Title 

Author text from a field Author

Subject text from a field Subject

Keywords text from a field Keywords

Creator text from a field in Creator

Producer text from a field in Keywords

CreationDate date when the document was Created

ModeDate date when the document was Modified

 Note: - As a parameter you may enter any text, but if it is not the name of the standard

field, you will get an empty string as a result.

- You may also use a custom parameter. For example, the macro %[DocInfo:Trapped] displays

an information about trapping, where Trapped is a custom parameter with a value from a

field Trapped in Main Menu> File> Document Properties> Advanced .

- If you have already specified parameters in the JavaScript Console and substituted standard

names for your custom names, you can use these names as a <parameter>. (For example, if

you create the parameter Sample (and, in the JavaScript Console describe info.Sample="My

Choice", with the Macro %[DocInfo:Sample], you will get the result "My Choice").

Go to the top
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4. Page Number

Name

Page

Description

Page represents the Page Number and has the value of a number of page (for example, in the

operation Extracting pages) or the sequence number (for example, in the operation Adding

images). Page Number is "1"-based.

Syntax

%[ Page:<parameter>]

Parameters

r Lower cased roman numbers: i, ii, iii, iv, v, vi, ... (Build 317 and up)

R Upper cased roman numbers: I, II, III, IV, V, VI, ... (Build 317 and up)

L Page labels if they are specified, otherwise page numbers (Build 317 and up)

<integer> Any integer number (e.g., "4") indicates minimum amount of digits in

presenting page number (e.g., here, not less the 4 digits: "0009", "0010", ...). 

Go to the top 56
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5. Number of Pages 

Name

Pages 

Description

Pages automatically returns the number of selected pages:

    - A Number of document pages if you choose All in Pages Range;

    - "1" if you choose Current Page;

    - Number of pages; it is different from Number of pages in a document if you choose

select Pages and/or Page Ranges (e.g. these pages you can see in Preview Window).

Syntax

%[Pages:<parameter>]

Parameters

r  Lower cased roman numbers: i, ii, iii, iv, v, vi, ... (Build 317 and up)

R  Upper cased roman numbers: I, II, III, IV, V, VI, ... (Build 317 and up)

L  Page labels if they are specified, otherwise page numbers (Build 317 and up)

<integer>  Any integer number (e.g., "4") indicates the minimum number of digits used

to display the formatted page number(e.g., here, not less the 4 digits: "0009",

"0010", ...). 

Go to the top 56
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6. File Name

Name

FileName 

Description

FileName returns the file name without the extension (e.g., in the operation Extract Pages) or

with the extension (e.g.. in the operation Add Watermarks).

Syntax

%[FileName]

Example

Go to the top 56
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7. Folder Name 

Name

FolderName 

Description

FolderName returns the path of the folder that contains the PDF file. For local files the folder

name ends with "\".

Syntax

%[FolderName]

Example

1. If you are using this macro with the operation Add Watermarks; you will get a watermark on

each page of document with the file's folder path as a result.

 

2. If you are using Exporting to Images (to a .PNG file) for the current page of the file E:

\_Oksana\PDF Specification\XMPSpecificationPart1.pdf  the resulting file name will be E:

\_Oksana\PDF Specification\.png.

Note: If you only choose this Macro for an operation that outputs a file, you can see that

this file has no name (<path>\.*, where <path> is full path to the file, and <*> is its extension).

 

Go to the top 56
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8. Date

Name

Date 

Description

Date returns the current date. The value includes the information about the day, month, year

or any combination of these parameters.

Syntax

%[Date:<Parameter>]

Parameter

As a parameter you can use the <date formatting string>.

Following the standard Windows date coding, the string <date formatting string> can be

customized and presented as combinations of characters as shown below:

d Day of month as digits with no leading zero for single-digit days ("4", but "24") 

dd Day of month as digits with leading zero for single-digit days ("04") 

ddd Day of week as a three-letter localized abbreviation ("Wed", "Fri")

dddd Day of week as its full localized name ("Wednesday")

M
Month as digits with no leading zero for single-digit months (for September -

number "9")

MM
Month as digits with leading zero for single-digit months (for September - number

"09")

MMM Month as a three-letter localized abbreviation (for September - "Sep")

MMMM Month as its full localized name ("September")

y
Year as last two digits, with a leading zero for years less than 10 (for "2007" - "07";

the same for "1907" - "07")

yy Year as last two digits, with a leading zero for years less than 10 (for "1998" - "98")

yyyy Year represented by full four digits (for "1998" - "1998") 
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Example

- If you don't specify parameters, they will be taken from your OS parameters in the format dd/

MM/yyy.

or

- With the string %[Date:ddd, MMMM dd, yyyy] in the field Text you will get the result Tue,

February 23, 2016.

Go to the top

9. Year

Name

Year 

Description

Year returns the current year as a 4-digit number.

Syntax

%[Year]

Go to the top
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10. Month

Name

Month 

Description

Month returns the current month as a 2-digit integer.

Syntax

%[Month]

Go to the top

11. Day

Name

Day 

Description 

Day returns the current day as a 2-digit number.

Syntax

%[Day]

Go to the top
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12. Time 

Name

Time 

Description

Time returns the current time (day, month, year, AM or PM, or any combination of those

values). 

Syntax

%[Time]                          for standard Windows format;

%[Time:<Parameter>]  for custom format.

Parameter

<Parameter> is a standard Windows <time formatting string>:

h Hours with no leading zero for single-digit hours; 12-hour clock  ("7" for 7 o'clock and 19 o'clock)

hh Hours with leading zero for single-digit hours; 12-hour clock ("07" for 7 o'clock and 19 o'clock)

H Hours with leading zero for single-digit hours; 24-hour clock ("7" for 7 o'clock and "19" for 19

o'clock)

HH Hours with leading zero for single-digit hours; 24-hour clock ("07" for 7 o'clock and "19" for 19

o'clock)

m Minutes with no leading zero for single-digit minutes ("5" for "9 minutes")

mm Minutes with leading zero for single-digit minutes ("05" for "5 minutes")

s Seconds with no leading zero for single-digit seconds ("3" for "3 seconds ")

ss Seconds with leading zero for single-digit seconds ("03" for "3 seconds")

t One character time marker string, such as A or P ("7 A")

tt Two characters time marker string, such as AM or PM ("7 AM") 
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Example

1. Export to Image using the current page of the document and the macro Time as the File

Name. Standard Windows format for Time looks like %[Time:HH:mm:ss tt] and returns the result

"13:32:08  PM" or "13-32-08  PM" as a part of file name.

2. Adding Watermarks to the document using the macro Time.

Note: If the process lasts some time, the Data of Time is taken only on the start of the

process. 

Go to the top

13. Hour

Name

Hour 

Description

Hour returns the value of the current hour at the start of the operation being performed, as a

1 or 2-digit number (with no leading zero for single-digital hour).

Syntax

%[Hour]

Go to the top
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14. Minute

Name

Minute 

Description

The macro Minute returns the value of current minute, at the start of the operation being

performed, as a 1 or 2-digit number (with no leading zero for single-digital number).

Syntax

%[Minute]

Go to the top

15. Seconds

Name

Second 

Description

Second returns the value of the current second, at the start of the operation being performed,

as a 1 or 2-digit number (with no leading zero for single-digital number).

Syntax

%[Second]

Go to the top

56

56



74

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

*Macros

16. Computer Name

Name

Computer 

Description

Computer returns the name of the computer as set as the Windows Computer Name.

Syntax

%[Computer]

Go to the top

17. User Name

Name

User 

Description

User returns the name of the user account currently logged into Windows.

Syntax

%[User]

Go to the top

18. Environment Variable

Name

Env 

Description

Env returns the value of one of the parameters of the available Environment Variables.

56

56
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Syntax

%[Env:<Parameter>]

Parameter

ALLUSERSPROFILE HOMEDRIVE ARCHITECTURE SESSIONNAME USERNAME 

APPDATA HOMEPATH ProgramData SystemDrive USERPROFILE

CommonProgramFiles LOCALAPPDATA ProgramFiles SystemRoot windir

CommonProgramFiles(x86) LOGOMSERVER ProgramFiles(x86) TEMP

CommonProgramFilesW6432 OS ProgramFilesW6432 TMP

COMPUTERNAME PROCESSOR PUBLIC USERDOMAIN

Go to the top

19. Application Version

Name

AppVersion

Description

AppVersion returns value of the user's version and build of the PDF-XChange Editor that is

currently installed.

Syntax

%[AppVersion]

Go to the top
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20. Image Number

Name

ImageNumber

Description

ImageNumber enumerates output images from one page in order.

Syntax

%[ImageNumber:<Parameter>]

Parameters

r  Lower cased roman numbers: i, ii, iii, iv, v, vi, ... (Build 317 and up)

R  Upper cased roman numbers: I, II, III, IV, V, VI, ... (Build 317 and up)

L  Page labels if they are specified, otherwise page numbers (Build 317 and up)

<integer>  Any integer number (e.g., "4") indicates the minimum number of digits used to

display the formatted page number (e.g., here, not less the 4 digits: "0009",

"0010", ...). 

Go to the top 56
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21. Auto Number

Name

AutoNumber

Description

AutoNumber enumerates output files in consecutive order. Each time it adds the next in the

sequence of the number series.

Syntax

%[AutoNumber:<Parameter>]

Parameters

r  Lower cased roman numbers: i, ii, iii, iv, v, vi, ... (Build 317 and up)

R  Upper cased roman numbers: I, II, III, IV, V, VI, ... (Build 317 and up)

L  Page labels if they are specified, otherwise page numbers (Build 317 and up)

<integer>  Any integer number (e.g., "4") indicates the minimum number of digits used to

display the formatted page number (e.g., here, not less the 4 digits: "0009",

"0010", ...). 

Go to the top 56



78

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

*Macros

PDF-XChange Editor Operations that use Macros:

Bates Numbering Main Menu> Document> Bates Numbering> Add to Multiply Files...

Extract Pages Main Menu> Document> Extract Pages

Export to Images Main Menu> File> Export to Images...

From Image File(s)... 1) Main Menu> File> New Document> From Image File(s)... click Options..., 

    and, in the Images to PDF Options window Categories, click Image Labels

2) Main Menu> Document> Insert Pages> Insert Images... click Options..., 

    and, in the Images to PDF Options window Categories, click Image Labels 

From Text Files... 1) Main Menu> File> New Document> From Text Files... click Options..., 

    and, in the Images to PDF Options window Categories , click File Separator

2) Main Menu>  Document> Insert Pages> Insert Text...  click Options..., 

    and, in the Options window,  click File Separator

3) Main Menu> Document> Insert Pages> Insert RTF... click Options..., 

    and, in the Options window, clcik File Separator

Launch Applications Main Menu> Edit> Preferences> Launch Applications click New... and open the

New Launch Application window.

Stamps Palette Main Menu> Tools> Comment And Markup Tools> Stamps Pallet and Add New

Stamp by clicking on the icon .

Summarize Comments Main Menu> Comments> Summarize Comments

Watermarks
Main Menu> Document> Watermarks> Add... (or Manage... then click Add

New...)

Note: PDF-XChange Editor uses the same system of macros for all operations above except Launch

Applications  and Bookmarks.
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Operation 
Bates

Numbering
Extract

Pages

Export

to

Images

From

Image

File(s)...

From

Text

Files...

Stamps

Palette
Summarize

Comments
Watermarks

 Macro Name

 Document Title Yes Yes Yes NO NO Yes Yes Yes 

 Document Index Yes Yes Yes Yes Yes Yes NO NO 

 Document Info Yes Yes Yes NO NO Yes Yes Yes

 Page Number Yes Yes Yes Yes Yes Yes Yes Yes

 Number of Pages Yes Yes Yes Yes Yes Yes Yes Yes

 File Name Yes Yes Yes Yes Yes Yes Yes Yes

 Folder Name Yes Yes Yes Yes Yes Yes Yes Yes

 Date Yes Yes Yes Yes Yes Yes Yes Yes

 Year Yes Yes Yes Yes Yes Yes Yes Yes

 Month Yes Yes Yes Yes Yes Yes Yes Yes

 Day Yes Yes Yes Yes Yes Yes Yes Yes

 Time Yes Yes Yes Yes Yes Yes Yes Yes

 Hour Yes Yes Yes Yes Yes Yes Yes Yes

 Minute Yes Yes Yes Yes Yes Yes Yes Yes

 Seconds Yes Yes Yes Yes Yes Yes Yes Yes

 Computer Name Yes Yes Yes Yes Yes Yes Yes Yes

 User Name Yes Yes Yes Yes Yes Yes Yes Yes

 Environment

Variable
Yes Yes Yes Yes Yes Yes Yes Yes

Application

Version 
Yes Yes Yes Yes Yes Yes Yes Yes

 Image Number Yes Yes NO NO Yes Yes Yes NO

Auto Number Yes  Yes  Yes Yes NO  Yes Yes NO 

348

406

148 129 121
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448
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5 PDF Editor Overview

-Overview-,

When you first open the PDF-XChange Editor, it looks like this: 

Although daunting at first glance, it is really quite simple to use. 

The screen is subdivided into five major bands. From top to bottom they are: 

Menu Bar. The program main menu. See Main menu . 

Tool Bars. Toolbars for easy access to PDF display and modification tools. See Toolbars Area . 

Tab Bar. Shows all open documents. The selected document is displayed brightly; the rest are

grayed out. There is a Close Document button to the right of each document name. 

Thumbnails. List of active document pages presented as miniature pages. See Thumbnails . 

Main Page Display Area. The area in which the PDF files are displayed. This occupies most of the

window. See PDF Display Area .
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5.1 PDF Display Area

-Page Display- ,

PDF Document Tab(s). Permits quickly switching between loaded PDF files. 

Thumbnails & Bookmarks. Allows you to quickly find the necessary page or section. 

Main PDF Page Display Area. A place where the actual PDF content pages are displayed. 
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6 Page Content Editing

The new Full Page content editing feature is now available to users of PDF-XChange Editor. It allows you

to make changes to a PDF page content quickly and easily.

First of all you need to choose the content object for editing:

1. Select the Edit Content   button from the Comment And Markup toolbar.

2. Click the content item you wish to edit. If you need a certain area to be selected, click and drag

the mouse. This will show a bounding box with selection handles around the object. The handles

can be used for resizing or rotating the object.

To move the object, place the pointer to the central circle and drag the object.

To resize the object, pull one of the yellow handles.

To rotate the object, click and drag the green handle above the object.
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3. If you right-click on the selected object, the following menu appears:

4. Properties. To adjust the properties of the selected object, click at the  arrow which appears

when you select one of the properties.

6.1 Editing Text

Except for editing images and annotations, you can edit the text or text blocks within your PDF

document.

1. To edit the text block, select it with the help of the  Edit Content tool. You can move, resize

or rotate the whole text block.

2. To edit the text, double click the selected text block. This will allow you to select the text

fragment for editing. You can type, cut, copy, paste the text, change its color, font, font size

specify the Paragraph settings and apply the Text Style options to the text.
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If you right-click on the selected text, the following context menu will be opened:

 Undo. Reverses the last editing change made to the text.

 Cut. Allows you to remove selected text and copies it to the clipboard.

  Copy. Copies selected text to the clipboard.

 Paste. Pastes clipboard text to the selected location.

Select All. Allows you to select the whole text from the chosen text box for editing.

Paragraph.... Sets the paragraph options for the selected text.

Paragraph Options Window
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Text Style. Opens the following submenu of text formatting options

You may also change these properties through the Properties Toolbar which appears

at the Toolbar area when the text fragment is selected, and the properties toolbar is

activated. For details of each formatting option, please see the Properties Toolbar

section.

You may also use the following hot keys to format the text entry:

Ctrl+B - Bold

Ctrl+I - Italic

Ctrl+U - Underline

Ctrl+Shift+S - Strikethrough

Ctrl+Shift++ - Superscript

Ctrl+Shift+- - Subscript

The Typewriter Toolbar supports additional options for selecting Font and Size

Hyphenate Text will automatically hyphenate text when space in the line runs out.

Note: that PDF files created from solely Image based content (e.g. scanned to PDF) cannot be text

edited - there is no actual text within the PDF file - simply an image, even though the image may represent

text. That is why you will be able only to move, resize or rotate such text.

601

http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=properties_toolbar
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7 Main Menu

-Main Menu-,

File  File level operations including selecting files, document properties, forms data manipulation,

and printing.

Edit  Editing functions on PDF files and forms. Also program preferences can be set, exported and

reset here.

View  Editor information display control. Determines what PDF information is displayed and how.

Document  Controls for Rotating, Deleting, or Cropping pages.

Comments  Organizes the comments operations.

Form  Manages Form Data.

Object  Organizes the object operations.

Tools  Selection of the different PDF tools, including Hand, Snapshot, and Zoom controls.

Advanced  Contains advanced functions such as the bookmarks plugin

SharePoint  Allows the user to Check in or check out a document located on a SharePoint server.

Window  Organizes the layout of the PDF file window(s) currently opened.

Help  Accesses help information about the Editor and its operation. The registration section and

"report a bug" can also be found here.

Tip: By pushing the Alt key, some letters in the menu bar become underlined. If a user presses one of

those keys, that menu will expand. For example Alt, then P will open the SharePoint Menu.
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7.1 File

-- ,

The File menu controls the opening, saving, printing, and closing of PDF files, and the display of

Document Properties. 

 Open...

 Open From

 Save

 Save As...

 Save Copy As...

 Save Optimized Copy

 Save All

 Save To

 New Document

 Send by E-mail...

 Revert

 Close

 Close All

 Export

 Print

 Document Properties...

 Copy Full File Name

 Open Containing Folder...

 Exit
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7.1.1 Open...

-Open from URL-,

Clicking on  Open... calls the Windows Open File dialog box to allow selection of a PDF file to be

viewed.

Select the file to be viewed and click the Open button. Hovering over the Open option in the File

window or clicking on the  will bring up the Recents list. 
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Recent File

Unpinned Recents displays a selection list of recently used files. Clicking the pushpin  to the

right of the document name in the Unpinned Recents will "pin" the document and move it to the

Pinned Recents list so that it won't "fall off" the list if the maximum number of documents in the

Recent Files list is exceeded. To unpin a document, click on the 
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Moving the mouse over a specific file from the list, the first page and other properties of the

document are displayed: 

To adjust the history and recents options click the Manage History and Recents... button from the

bottom of the Recents List. 
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History Options

Max. number of items Sets the maximum number of documents to be displayed in the Recent

documents list. 

Item's life-time Defines how long the unpinned documents will remain in the list.

Clear history on exit Clears the history list completely on exit.

Recents List Options 

Show max. number of items The maximum number of items will be displayed in the Recents

list.

Show thumbnail Displays the thumbnails of the documents listed in the Recents.

Show caption Will show the document Title in the Recents List as indicated in the screenshot

below.

Show file-path Displays the file path of the documents listed in the Recents. 

Cache thumbnails Stores the images for thumbnail previews in cache memory so that the

images can be loaded quickly each time you access the recents list.

Documents can also be opened from the File Toolbar .607
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7.1.2 Open from

Open From Allows you to choose to open from your local machine  (My Computer ), from

 URL , SharePoint  or  Google Drive™.

Open From URL  allows you to open a file saved on the internet. In the resulting dialog, type or

paste the File's URL. 

591
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Open From SharePoint  allows a user to open a document directly from a SharePoint location.

For more details, see the SharePoint  menu section.

Open From Google Drive ™ allows you to open documents directly from your Google Drive.

The first time you try to open from, or save to Google Drive you will be prompted to log in: 

     Google Drive™ authentication window

587
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Once you have entered your Email and Password, you will need to allow the Editor to interact with

Google Drive™ by clicking on Allow. 
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You will then be taken to the Open File from Google Drive™ window.

From here, you will be able to Select and open a folder or file. You can add a new log in to select

from the Drop Down menu by clicking on  New Login...
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7.1.3 Save

The Save options of the File Menu allow you to save changes made to a PDF as well as Save As a

new PDF, and save an optimized copy of the the PDF. Save is only available if the currently displayed

PDF file has been modified. Save immediately saves the modified PDF over the original. Unless

incremental save is activated, the original document will be replaced by the newly saved document.

To preserve the original file you must use the Save As... options to save the modified version to a

new file name.

 

 

 

 Save 

 Save As...

 Save Copy As...  

 Save Optimized Copy...  

 Save All  

 Save To  
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7.1.4 Save As...

-Save As...-,

Save As...  is used to save the changes that have been made without corrupting the original

content. Choosing Save As... will launch a Save File As window. There, type a new file name and

choose the desired save directory.

Save as type allows you to chose from the following file types 

· PDF Document (*.pdf)

· Microsoft PowerPoint (*.pptx) 

· PDF/A Document (*.pdf)

The Options... button becomes active when the Save as type is set to Microsoft PowerPoint or PDF/

A. Please see the respective sections below

98

99
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Microsoft PowerPoint Options

     Export to Microsoft PowerPoint Presentation > Options window

Convert entire page content to image will cause every part of the PDF to be exported to an

image based PowerPoint (.pptx) file. 

Resolution in Dots Per Inch (dpi). Lowering the dpi will reduce the output quality, but increase

speed, and reduce the file size. 

Text Conversion Options:

Mode: 

§ Preserve text editable will allow the text in the resulting PowerPoint to remain

modifiable. 

§ Convert to curves each letter is converted vector based description of itself. 

§ Convert to Images converts the text to images.

Embed all fonts will cause all the fonts in the PDF to be embedded in to the output file. This

will eliminate the need to have the same fonts installed when opening the file on another

system. 
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Allow to use substitution for fonts that cannot be embedded will cause the application to

render the text using the closest font to the original, to render the text. 

Allow to convert text that uses problematic fonts to curves If the fonts, or characters are

detected as causing problems, they will be converted to curves.

Text rasterization quality allows you to select the rasterization quality (convert to raster image)

of text in Dots Per Inch (dpi). Lowering the dpi will reduce the output quality, but increase

speed, and reduce the file size. 

Include Comments will cause any comments or markups present in the PDF to show up in the

PowerPoint presentation file.

PDF/A Document

Clicking on Options... when PDF/A is the selected Save as File Type, the Convert to PDF/A

window opens.

     Convert to PDF/A window

Conformance allows you to define what kind of PDF/A your document will be saved under. For a

description of the various PDF/A conformance specifications, please see the following link: 

https://en.wikipedia.org/wiki/PDF/A#Conformance_levels_and_versions

Color Profile allows you to choose between supported color profiles

https://en.wikipedia.org/wiki/PDF/A#Conformance_levels_and_versions
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7.1.5 Save Copy As
-Save Copy As- ,

Save Copy As... will save a copy of the document with its current changes, and lunch a Save As

window.

7.1.6 Save Optimized Copy

The Save Optimized Copy option launches the PDF Optimizer window which provides many

options available to reduce the size of a PDF.

     Figure 1: PDF Optimizer Window

Images : The images tab contains Image compression, and Downsampling options.

Fonts : The Fonts tab contains Unembedding option which allows the removal of font data from the file.

Discard Objects : The Discard Objects tab contains parameters which will allow the removal of

unnecessary objects from the file.  

Discard User Data : Discard User data will remove the user meta data from the the document properties

of the file.

Clean up : The Clean Up tab contains various other optimization methods.

104
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Settings

The Settings drop-down menu provides options to chose from preexisting optimization settings, as

well as save custom optimization settings.

     Figure 2: Settings Dropdown.

There are two default setting profiles: Standard, and Mobile. The Standard settings are general

defaults that are best suited to optimize PDF that are intended for viewing on Computers. The 

Mobile settings create smaller files, suited best for mobile devices such as tablets and cell phones.

When custom settings are chosen, the  Save Current Settings option becomes active. Allowing

those current custom settings to be saved for future use. These custom settings show up in the

drop-down menu as shown by the highlighted option in Figure2. Selected custom settings can be

deleted by choosing the  Delete option.
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Manage opens the Manage Presets Menu (Figure 3), where the name and description of user

defined custom Presets can be edited, Cloned, and reordered in the Settings dropdown (Figure 2).

     Figure 3: Manage Presets menu

The  and  will change the order of the Preset items in the list accordingly.

Make Compatible With: This drop-down menu allows the selection of the PDF compatibility

method. The higher the number, the more features are compatible. For example, some earlier

versions of PDF did not support commenting. It is recommended that this setting be left alone

unless PDF Compatibility specifications are understood already.
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Audit Space Usage will bring up a dialog that reports what percentages of a file's size are

composed of. See Figure 4 for example.

     Figure 4: PDF Audit Information window
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7.1.6.1 Images

The Sub-sections of the Images Tab in the PDF optimizer Contains the same compression/

optimization options for Color, Grayscale, Indexed, and Monochrome Images.

Downsampling Options

If you plan to use the PDF file on the web, use downsampling to allow for higher compression. If

you plan to print the PDF file at high resolution, do not use downsampling. Select the "No

Downsampling" options from the the drop down menu to disable downsampling options for each

image type listed above. 

     Figure 1: Downsampling Drop-down menu. 

Downsampling Definitions

Downsampling refers to decreasing the number of pixels in an image. To downsample color,

grayscale, or monochrome images, choose an interpolation method from the drop down menu

(Figure 1). Average Downsampling, Bicubic Downsampling, or Subsampling - and enter the

desired resolution (DPI) in the next fields.

Average Downsampling To [specified DPI] Averages the pixels in a sample area and replaces the

entire area with the average pixel color at the specified resolution.

Subsampling To [specified DPI] Chooses a pixel in the center of the sample area and replaces the

entire area with that pixel color. Subsampling significantly reduces the conversion time compared

with downsampling but results in images that are less smooth and continuous.

Bicubic Downsampling To [specified DPI] Uses a weighted average to determine pixel color, which

usually yields better results than the simple averaging method of downsampling. Bicubic is the

slowest but most precise method, resulting in the smoothest gradations.
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Compression Options

Determines the type of compression that is used. 

Figure 2 Figure 3 Figure 4 

Figure 2: Compression Options for Color and Grayscale Images

Figure 3: Compression Options for Indexed images.

Figure 4: Compression Options for Monochrome images.

Retain Existing will not change the compression method.

JPEG2000 Is the new international standard for the compression and packaging of image data. Like

JPEG compression, JPEG2000 compression is suitable for grayscale or color images. It also provides

additional advantages, such as progressive display.

JPEG is suitable for grayscale or color images. JPEG compression is lossy, which means that it

removes image data and may reduce image quality; however, it attempts to reduce file size with a

minimal loss of information. Because JPEG compression eliminates data, it can achieve much smaller

file sizes than ZIP compression.

Zip Works well on images with large areas of single colors or repeating patterns, and for black-and-

white images that contain repeating patterns. 

Run Length Run Length compression produces the best results for images that contain large areas

of solid black or white. 

LZW  is the compression of a file into a smaller file using a table-based lookup algorithm. Works

best for files containing lots of repetitive data. This is often the case with text and monochrome

images. Files that are compressed but that do not contain any repetitive information at all can even

grow bigger!

JBIG2 is an image compression standard for bi-level images, developed by the Joint Bi-level Image

Experts Group. It is suitable for both lossless and lossy compression.

CCITT Group 4 (Consultative Committee on International Telegraphy and Telephony) compression

is appropriate for black-and-white images and any images scanned with an image depth of 1 bit.

Group 4 is a general-purpose method that produces good compression for most monochrome
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images. 

CCITT Group 3 Group 3, used by most fax machines, compresses monochrome bitmaps one row at

a time.

Quality

Determines the amount of compression that is applied For the Compression methods applicable to

Color, and Grayscale image compression options. The options given are as follows: Minimum; Low;

Medium; High; Maximum; and Lossless.

Note: Lossless compression is a class of data compression algorithms that allows the original

data to be perfectly reconstructed from the compressed data. Lossy is the class of data encoding

methods that uses inexact approximations (or partial data discarding) to represent the content. These

techniques are used to reduce data size for storage, handling, and transmitting content.

Note: DPI stands for Dots Per Inch (Pixels Per Inch)
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7.1.6.2 Fonts

In the Fonts section of the PDF Optimizer window, users can see the fonts included in the pages of

a PDF and choose to unembed or retain font information. 

     PDF Optimizer Window > Fonts

When a font is Unembedded, there is a flag in the file, which calls the installed fonts on the

computer the file is being accessed from to render that text. If that font does not exist on that

computer, the Editor uses font substitution to render the text using the closest approximation of

the original font. 

Embedded Fonts cause the file size to increase slightly. However, the file will contain all the

necessary font data for any PDF reader to render the file with that exact same font. 

To Unembed a font, select it in the Left "Embedded Fonts" column, then choose Unembed>> to

move it to the right "Fonts to Unembed" column.
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7.1.6.3 Discard Objects
-Discard Objects- ,

The Discard Objects section of the PDF Optimizer window consists of a checklist for objects to be

removed. Any option selected will remove all related objects when the optimization is finalized. 

     File > Save Optimized Copy > Discard Objects Window     

Discard all Form submissions, import and reset actions These actions include items such as buttons to

reset forms, submit forms. These types of actions will be removed from the PDF.

Discard all JavaScript actions If selected, all JavaScript will be removed from the PDF.

Discard all alternate images In some cases, though rarely used, a PDF may have two of the same image.

This can be useful when a low resolution image is used to allow quick rendering, and a higher quality one is

used when printing. Only the primary image will be kept if this option is selected. 

Discard embedded page thumbnails This option will remove embedded custom page thumbnails. 

Detect and merge image fragments Some images in PDF are created as multiple image sections spliced

together. If this option is selected, those image sections will be merged to combine them to one image. This

can sometimes reduce file sizes dramatically.

Discard embedded print settings This will discard left over encoding from when the document was created

using a virtual printer. 

Discard bookmarks This option will remove all Bookmarks from from the file.
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7.1.6.4 Discard User Data

The Discard User Data tab of the PDF Optimizer allows you to remove certain user specific data.

Access these options by going to File > Save Optimized Copy > Discard User Data.

Discard All Comments, forms and multimedia will remove all form fields, comments, and

annotations.

Discard document information and metadata will remove all document metadata as described in

the Document Properties > Description  section.

Discard file attachments will remove any attached or embedded files.

Discard external cross references Removes links to other documents. Links that jump to other

locations within the PDF are not removed.

Discard private data of other applications Strips information from a PDF document that is useful

only to the application that created the document. This does not affect the functionality of the PDF,

but it does decrease the file size.

Discard hidden layer content and flatten visible layers this will remove any hidden layers. The

optimized document looks like the original PDF but doesn’t contain any layer information.

166
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7.1.6.5 Clean Up

In the Clean Up tab of the PDF Optimizer [File > Save Optimized Copy > Clean Up], there are

miscellaneous options that can sometimes reduce file size.

Discard duplicates of Fonts will remove any redundant fonts.

Discard duplicates of Images Will remove any duplicate images. Some files have two sets of images

that are rendered depending on the screen resolution and zoom level. 

Discard Duplicates of XForms will remove any duplicate XForms data. XForms are graphical groups of

objects. 

Use Flate to encode streams that are not encoded Flate is an encoding method more commonly

referenced to as .zip. In a PDF, there may be information that is set up to be encoded (archived/

compressed), but have not yet been. This option will apply .zip archiving algorithms to reduce the

file size.
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In streams that use LZW encoding use Flate instead will re-encode LZW streams to use Flate (.zip)

encoding. 

Note: LZW encoding was a proprietary encoding method that required a license to use. The

patent has expired, some software will still have issues reading LZW encoded streams. It is

recommended to use Flate instead.

Discard invalid bookmarks bookmarks without actions or working destinations will be removed.

Discard invalid links links that do not work will be removed. This includes bookmarks without

actions.

Discard unreferenced named destinations destinations that are not referenced, such as when the

target page is removed from a file, will be removed.

Find and Remove the content outside of crop box any content outside of the crop box will be

removed. If this option is not selected, the content outside of the crop box will only be hidden.

7.1.7 Save All

-Save All- ,

Saves all modified documents. When there is an asterix (*) next to the file name in that document's

tab, the document has been modified and is in an unsaved state, or the Save button becomes

active in the File Toolbar  .607
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7.1.8 Save To
-SharePoint- ,

The Save To option allows saving a PDF file to  Google Drive™, your computer (  My Computer),

and  SharePoint. 

 My Computer will open a standard Save File As dialog as shown in the Save As section. 

For information regarding the SharePoint plug-in, please see the SharePoint  section. 591
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Google Drive™ will open the Google Drive window.  The Google Drive plug-in allows documents to be

opened directly from Google Drive. The first time a file is opened from, or saved to Google Drive™ the will a

prompt to log in: 

     Google Drive™ authentication window
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Once an Email and Password has been entered, the Editor will need to be allowed to interact with Google

Drive™ by clicking on Allow. 
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The Save File To Google Drive™ window will then open

From here, a folder or file will be able to be selected and opened. A new log in to select from the Drop Down

menu can be added by clicking on  New Login...
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7.1.9 New Document

-New Document- ,

New Document... allows the creation of a new PDF document from a blank page, from a text file, from RTF

file, image file or directly from scanner. 

IMPORTANT! This is a Licensed feature, see IMPORTANT! Evaluation mode vs. Licensed mode  for

more information! 

Selecting this option first opens the New Document... submenu: 

 

 

 

 

 

 

With Blank Pages

Combine Files into a Single PDF...  

From Text Files...  

From Rich Text Format (RTF) Files...

 

From Image Files

From Scanner...  

12

117

118

121

127

129

143



117

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

7.1.9.1 With Blank Pages...

-New Document From Blank Page...- ,

Clicking the With Blank Pages... option opens the New Empty Document dialog box: 

     New Empty Document window

Pages. Specifies the description of the pages in the new document.

Standard. Allows the selection of the page size from a standard set of page sizes. 

Custom. Selecting this option allows setting a custom size of the page. The unit of measurement can

be changed from the drop down menu to the far right.  

Orientation. Sets the orientation of the pages in the document. Choices are: Portrait, or Landscape

orientation. 

· Portrait. The longer side of the page runs vertically. 

· Landscape. The longer side of the page runs horizontally.

Count. Defines the number of empty pages to be created.

Click on OK when satisfied to create the document. 
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7.1.9.2 Combine Files into a Single PDF...

Combine Files into a single PDF... allows the creation of one PDF file from of many other files.

Chose this option to bring up the Combine Files window. 

 Add Files... opens the Open Files window and allows the selection of a file to add to the list. 

Add Folder... opens the Select folder window. Once a folder is selected, the Add Files From

Folder Options window opens. There, the file types can be defined, that will be added to the new

PDF. 

Page Range Options... opens the Setup Pages Range dialog. 

All will select all pages in the currently selected document. 
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Pages type the desired page range here. Multiple page ranges should be separated by a coma. For

example, fo pages 1 to 15, page 17, pages 20 to 46 and pages 88 to 100 of a 100 page document

to be included in the new PDF, type the following: 1-15, 17, 20-46, 88-100. If there is a

disconnected hyphen (dash) in the page ranges, that page range will go to the beginning or end of

the document like so: -15, 17, 20-46, 88-.

Subset allows the choice of a subset of pages of the selected file to be included in the new PDF.

· All pages

· Odd pages Only

· Even pages Only

 To Top will move the selected file to the top of the documents list, as well as to the top of the

resulting PDF. 

 Up will move the selected file up one slot in the documents list, as well as the resulting PDF.

 Down will move the selected file down one slot in the documents list, as well as the resulting

PDF.

 To Bottom will move the selected file to the bottom of the documents list, as well as to the

bottom of the resulting PDF. 

 Remove. Removes the selected file from the list.

Add Files From Folder Options

Ask for Suitable extensions after choosing a source folder If selected, this dialog will be

displayed each time a folder is selected using the Add Folder option. 
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The Add Files From Folder Options dialog can be accessed by clicking on the drop-down menu

button on the Add Folder... button as shown below.

Look in the sub-folders the Editor will collect files within sub-folders of the parent folder.

Choose file types which should be added while searching folders allows the choice of what file

types are and are not added to the new document. 

Add Custom Filter... and Edit Custom Filter... opens a small dialog that allows naming a new

custom filter, and choosing the file extensions that filter will include. To define the file types to be

included, type them beginning with an asterisk (*), then a point (.) followed by the extension as

shown in the screenshot of the Add Custom Filter dialog. Each new file type should be separated

by a comma. 

Remove Custom Filter will remove the selected custom filter.

Custom Filters allows the selection from the Custom Filters list. Multiple can be selected.

Standard Filters Choose All Supported... to include all the supported file types, or select the the

supported file types individually from the list.
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7.1.9.3 From Text Files...

Clicking the  From Text File... option under File> New Document opens the Convert Text

Files to PDF window 

     Convert Text Files to PDF window

Source Text Files. Displays the text files to be used to create a PDF. To modify a properties

pertaining to one of these files, please select it from the list.

 Add files…. Opens the Open Files window to select a text file from.

 Add Folder…. Opens the Browse For Folder window to add/select all text files contained in

the selected folder.

    Up. Moves the selected file up in the list.

    Down. Moves the selected file down in the list.

  Remove. Removes the selected file from the list.

Selected File Options. Allows the setting of file options for the selected file. 
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Text Encoding. Allows the setting of the text file's encoding. Text Encoding is the process of

transforming bytes of data into readable characters for users of a system or program. More

information can be found on text encoding on Microsoft MSDN at the link below: 

https://msdn.microsoft.com/en-us/library/dn271702%28v=nav.90%29.aspx

New Paragraph Mode. Defines the placing of the new paragraphs in the PDF document. 

· Auto Detect.

· Each newline character starts a new paragraph.

· Double newline character starts a new paragraph, singles ignored.

· Double newline character starts a new paragraph, singles converted to space. 

Place File Mode. Allows the choice of the way each file will be placed.

· Start each file from new paragraph. 

· Start each file from new page.

Options…. Allows additional settings to be set for the text files. 

New Page Options 

Allows the page options such as page size, orientation and margins to be set. 

     New Page Options window

Standard. Selecting this option allows the choice of page size from a set of standard page sizes. 

Custom. Selecting this option allows a custom page size to be set. 

https://msdn.microsoft.com/en-us/library/dn271702(v=nav.90).aspx
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Orientation. Sets the orientation of the page.

· Portrait. The longer side of the page runs vertically. 

· Landscape. The longer side of the page runs horizontally. 

Margins. Margins adjust the size of the page by setting non-zero margins using the units. The

adjustments are: 

· Left. The left margin is moved to the right by the amount specified in units. 

· Right. The right margin is moved to the left by the amount specified in units. 

· Top. The top margin is moved down by the amount specified in units. 

· Bottom. The bottom margin is moved up by the amount specified in units.

Text Format

Allows setting the format in which the text within the PDF is rendered.

     Text Format window



124

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Text Style

Font Clicking on Font opens the Select Font window. 

     Select Font window

In the Select Font window, choose from installed fonts, the font style, font size, and color. 

Effects allows the fine-tuning the look of the text within the file. 

Fill defines the main color of the text.

Stroke defines the outline color of the text

Stroke Width defines the width of the stroke or outline

Underline Choose from no underline (None) and Solid underline.
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Paragraph allows setting how paragraphs are rendered in the PDF output.

     Paragraph Options window

General

Alignment allows the setting of the paragraph text alignment.

· Left

· Center

· Right

· Justify

Indentation allows setting the paragraph indent in pt.

Special allows setting an exception to the indentation defined in the other fields. 

· First Line causes the first line in a paragraph to be indented.

Define the level of indentation in pt. in the By field.

· Hanging is the opposite of first line as the first line of the

paragraphs will be indented as per the regular indentation, and

the rest of the lines within a paragraph will be indented as

defined by the Special and By fields.

Spacing allows adjusting the line spacing in between the lines. 
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File Separator

Allows adding a separator for new text files and specify its options. 

     File Separator window

Show title. Shows the title header to separate each file. Enter any valid name. In addition, clicking

the Macros   button opens a submenu of macros that automatically generates file names. For

detailed information go to the *Macros  section.

Back color. Opens the standard color selection dialog to allows setting the background color for

the header.

Font.... opens the Font Select window as described in the Text Style  section above.

Paragraph.... opens the Paragraph Options window as described in the Text Style  section

above.

Draw line. Allows a line to be drawn that would separate files one from another and specify the

line’s appearance.

Place line above header. If this options is selected, the line will be placed above the header.

56
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7.1.9.4 From Rich Text Format (RTF) File...

Clicking the From Rich Text Format (RTF) File... [File> New Document] option opens the

Convert RTF files to PDF dialog box: 

     File> New Document> From RTF

Rich Text Format Files

Selects the text files for the new document to be created from.

 Add files…. Opens the Open Files dialog box to select RTF files from. Use Ctrl+Click to

select multiple files.

 Add Folder…. Opens the Browse For Folder dialog box to select a folder.

 Up Moves the selected file up in the list.

 Down Moves the selected file down in the list.

 Remove Removes the selected file from the list.
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Options…. Defines additional settings for the RTF files. 

Relative path Allows setting the relative path options for links to other files within an RTF file. 

Relative path mode allows defining the behavior of the relative path options.

· Keep existing Does not change the relative paths. 

· Make absolute Makes the relative paths absolute. 

· Make relative Makes the relative paths relative.

Replace relative documents extensions. If ticked, a PDF document will be created from linked RTF

files.
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7.1.9.5 From Image File(s)...

Going to File> New Document>  From Image File(s)... opens the Images To PDF window.

Allowing the addition of multiple image files or folders of images from which to create PDF.

      Images To PDF window

Source image files

Displays the image files to be used to create PDF.

Add files…. Opens the Open window to select an image file from.

 Add Folder…. Opens the Browse For Folder window to add/select all image files contained

in the selected folder.

 Import…. Opens the list of scanners installed on your computer.

       Edit…. Opens the Edit Image window which allows for the modification of the selected image.

    Up. Moves the selected file up in the list.

    Down. Moves the selected file down in the list.

 Remove. Removes the selected file from the list. 
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The Change view mode button opens the list of available view modes that can be selected for viewing

the file list.

 Details  Icons  Thumbnails

Destination

Define the location in the active document for the pages from the source file to be inserted.

Location define the rout location for placement of the selected pages from the source document.

· Before will place the pages before the option defined.

· After will place the pages after the option defined.

First Page the pages inserted from the source file will be located before or after the first page in

the active document depending on the option selected in the Location drop-down menu.

Last Page the pages inserted from the source file will be located before or after the last page in

the active document depending on the option selected in the Location drop-down menu.

Page: the pages inserted from the source file will be located before or after the page number

indicated in the active document depending on the option selected in the Location drop-down

menu.
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Edit Selected Image

Changes can be made to the image before it is inserted to the active document from this screen.

      Edit Images window

 Flip Horizontal button is used to rotate an image through its vertical axis.

 Flip Vertical button is used to rotate an image through its horizontal axis.

 Rotate 90 CCW button rotates the image by 90 degrees counterclockwise.

 Rotate 90 CW button rotates the image by 90 degrees clockwise.

 Apply Filter opens a drop down menu that allows you to apply the following filters:

· Smooth

· Gaussian Blur

· Sharpen

· Mean Removal

· Emboss Laplascian

· Emboss All Directions

· Emboss Lossy

· Edge Detect

· Despeckle
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 Convert To

· 1bpp Indexed

· 8bpp Indexed

· 8bpp Grayscale

· Grayscale with Alpha

· 24bpp

· 32bpp

 Grayscale converts the image to Grayscale.

 Deskew straightens the image.

 Fit Visible button fits the image within the borders of the view pane.

 Zoom In button increases the Zoom percentage of the image. 

 Zoom Out button decreases the Zoom percentage of the image.

 Options…. Defines additional settings for the new document.

New Page Options

Image Layout Options

Image Labels

Image Processing

Image Compression

Image Post-processing
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New Page Options

Allows setting the page options such as size, rotation and margins.

      Images To PDF Options> New Page Options window

Choose Paper Size by Image Size will cause the resulting document size to be the size of the

initial image.

Standard allows selecting the page size from a list of standard page sizes for the document.

Custom  Specify custom document dimensions in the unit listed in the far right drop-down menu.

Orientation Sets the document rotation.

· Portrait The short edge of the page is at the top and bottom.

· Landscape The short edge of the page is at the Left and Right.
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Page Rotation allows setting the rotation of the content on the page.

· Don't Rotate will not rotate the pages.

· Clockwise 90 degrees

· 180 degrees

· Counterclockwise 90 degrees

Margins margins adjust the size of the page by setting non-zero margins using the selected units.

Page margins are the blank space around the edges of the page.

Choose Paper Size by Source. This option specifies the size of the page by the source.

Standard. Selecting this option allows setting the standard size of the page.

Images Layout Options

Allows setting the way images are placed in the PDF.

      Images To PDF Options> Images Layout Options window
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Layout Rules allow setting the layout options.

Columns: Specifies the number of columns for the

vertical layout.

Space between Columns Controls the amount of

horizontal space around an image.

Rows: Specifies the number of rows for the

horizontal layout.

Space between rows Controls the amount of

vertical space around an image.

Align Images allows settting the image alignment.

Fit defines how the images are placed sized to fit into each cell.

· Reduce to cell will reduce the dimension of the image to fit the cell only if the image is

initially larger than the cell.

· Fit to cell will reduce, or increase the dimensions of the image to fit to the cell. 

· Off will not change the size of the image to fit the cell. 

Keep aspect ratio When ticked, the image may be resized to fit the new PDF page (cell), but there will

be no distortion of the image.

Horizontal alignment Sets the horizontal alignment of the images.

· Left

· Center

· Right

Vertical alignment Sets the vertical alignment of the images.

· Top

· Middle

· Bottom 
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Image Labels

Allows for the addition of a text label to the image.

      Images To PDF Options> Image Labels window

Use special text label for each image. Specifies the text label for each file. Enter any valid name.

Macros Clicking the Macros button  opens a list of macros that you can use to automatically

generate file names. More detailed information can be found in the *Macros section.

Back color Opens the standard color selection dialog for setting the background color for the

image label.

http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=*macros
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Paragraph.... Opens the Paragraph Options window to allows adjusting the paragraph settings

for the text label.

      Paragraph Options window

General

Alignment allows setting the paragraph text alignment.

· Left

· Center

· Right

· Justify

Indentation allows setting the paragraph indent in pt.

Special allows defining an exception to the indentation defined in the other fields.

· First Line causes the first line in a paragraph to be indented. Set the level of

indentation in pt. in the By field.

· Hanging is the opposite of first line as the first line of the paragraphs will be

indented as per the regular indentation,

and the rest of the lines within a paragraph will be indented as defined by the 

Special and By fields.

Spacing allows adjusting the line spacing in between the lines.
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Font Clicking on Font opens the Select Font window.

      Select Font window

In the Select Font window, choose from installed fonts, the font Style, font Size, and color.

Effects fine-tune the look of the text within the file.

Fill defines the main color of the text.

Stroke defines the outline color of the text

Stroke Width defines the width of the stroke or outline

Underline Choose from no underline (None) and Solid underline.

Place label above image If ticked, the label will be placed above the image.

Add bookmark for each image with the same text as label. If ticked, a bookmark will be created

for all images with the same text as label specified.
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Image Processing

Allows setting the options of the image’s downsampling and conversion.

      Images To PDF Options> Image Processing window

Downsampling and Conversion.

True Color. Applies image downsampling and conversion options for true color images.

Grayscale. Applies downsampling or conversion options for high color and grayscale images.

Indexed. Applies downsampling or conversion options for indexed images.

Monochrome. Applies downsampling or conversion options for monochrome images.



140

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Downsampling. Downsampling decreases the number of pixels in an image. To downsample images,

choose a downsampling method (linear, bilinear, or bicubic downsampling) and enter the desired

resolution (in pixels per inch). Then enter a resolution in the for images above text box.

No Downsampling. Allows disabling downsampling if the PDF file is to be printed at high

resolution.

Linear Downsampling to. The classical linear downsampling approach is based on the removal

from the original image of those frequencies which are too high to be represented at a lower

resolution level.

Bilinear Downsampling to. Adds pixels by averaging the color values of surrounding pixels. It

produces results of medium quality.

Bicubic Downsampling To. Is a more precise downsampling method based on an examination of

the values of surrounding pixels. Using more complex calculations, Bicubic downsampling

produces smoother tonal gradations than Linear or Bilinear ones.

Conversion. Allows changing the images’ color mode for grayscale, monochrome or black & white.

No Conversion. No images will be converted.

Convert to Grayscale. Images will be converted to grayscale.

Convert to Monochrome. Images will be converted to monochrome.

Convert to Black & White. Images will be converted to black & white.

Dithering. When the Dithering option is selected, Photoshop mixes colors in the destination color

space to simulate a missing color that existed in the source space. Although dithering helps to

reduce the blocky or banded appearance of an image.
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Image Compression

Allows setting the image compression options.

      Images To PDF Options> Image Compression window

True Color. Applies image compression options for true color images.

Grayscale. Applies compression options for high color and grayscale images.

Indexed. Applies compression options for indexed images.

Monochrome. Applies compression options for monochrome images.

Compression enabled. If checked, it will compress image content depending on the image compression

options selected.

· Auto. The best compression settings will be set  by the application whilst retaining reasonable

image quality.

· JPEG. Best used for colored images.

· Flate. Is used for text, graphics and images.

· JPEG/ZIP.
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· JPEG 2000.

· JPEG 2000/ZIP.

JPEG Quality. A percentage value determining image content quality over compression - the higher the

value entered the lower the compression setting applied and image quality is retained to a higher

degree - lower values make smaller files.

Image Post-processing

Allows setting image modification actions, such as Deskew, Despeckle, and/or OCR the images after the

PDF is created.

      Images To PDF Options> Image Post-processing window

Deskew will straighten images if they are skewed or crooked.

Despeckle will detect and remove specks from the document.

Run OCR will run OCR on the pages in the resulting PDF.

OCR Settings See Document> OCR pages ... for more details.430
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7.1.9.6 From Scanner...

To scan directly to PDF, go to File> New document> From Scanner. This launches the Scan Properties

window where the preferences for scanning can be set.

      Scan Properties Window

Scanner Properties allows the selection of custom scan settings. Adjust these settings in the Parameters

section of the Scan Properties dialog.

Parameters

Adjust the settings and behavior when scanning.

Scanner displays the currently selected scanner. Select another scanning device from the drop-

down list.

Data Transfer method:

· Native Mode: Every Source must support this transfer mode as It is the default mode and is

the easiest for an application to implement. However, it is restrictive (i.e. limited to the DIB,

PICT, or TIFF formats and limited by available memory).

· Memory Mode: Offers the greatest flexibility, both in data capture and control. However, it

is more complicated  to implement.
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Color Mode: Choose the color mode for the scanned document from the drop down menu.

· Color

· Grayscale

· Black & White

Resolution:

Paper Size click on  to open the Paper Size setup dialog.

Source: This drop down menu will list the supported options for scanning. The scanner used in

this example supports Flatbed scanning and scanning using the Document feeder. 

Sides: These options facilitate duplex scanning whether the scanning device supports it or not.

· Simple Scan provides a simple, one sided scan.

· Manual duplex scans the front of all the sheets then the backs of the sheets. Back pages

will be automatically interleaved in the order in which they were scanned. Eg. 10 pages (5

double sided originals) would scan pages 1,3,5,7 and 9, then pages 10,8,6,4,2, then collate as

1,2,3,4,5,6,7,8,9,10.

· Manual Duplex Reversed scans the front of all sheets then the backs. Back pages will be

automatically interleaved in the reverse order in which they were scanned. Eg. 10 pages (5

double sided originals) would scan pages 1,3,5,7 and 9, then pages 10,8,6,4,2, then collate as

1,2,3,4,5,6,7,8,9,10.

Scan More Pages: Select the desired option from the drop-down menu.

· Disabled once the scan is complete, the Editor will not ask if there are more pages to be

scanned.

· Ask user once the scan is complete as determined by the scanner itself, the Editor will ask if

there are more pages to scan.

· Automatically after will automatically scan more pages after the set time in the adjacent

field.
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Show images insertion dialog after scanning will launch the image insertion dialog after

scanning has completed. The Image Insertion Dialog allows for modification of Image To PDF

options. 

  Launches the Images To PDF options window. See Image

Insertion Options  section already documented in the New Document>From Image

File(s)... page.

 opens the Paper Size setup dialog to select the desired paper size of the document

to be scanned

      Document> Insert Pages> Insert Scanned Pages> Paper size setup dialog.

Automatic allows for the Editor to automatically detect the size of the page(s) being scanned.

Standard select a standard page size from the drop-down menu.

Custom Defines a custom page size in the units selected.

Orientation choose from Portrait, or Landscape orientation. This option is not available when

scanning pages.

 The image insertion options button opens the Images To PDF Options

window.

See Image Insertion Options  section already documented in the New Document>From Image

File(s)... page

132
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7.1.10 Send by E-mail

Send by E-mail... Sends a copy of the currently displayed PDF file to a recipient by e-mail.

When selecting this Send by Email (File> Send by E-mail...) for the first time, the Send Mail options

dialog is displayed. configuration of these mail settings can be set using Edit> Preferences> Send

Mail.

     File> Send by E-mail... dialog

Send by Mail Client launches the default mail client with the PDF as an attachment. 

Note: A default mail client such as Microsoft Outlook™ or Thunderbird is required be set in

Windows for this option to work 

Send by SMTP send by letter protocol. This must be configured using Edit> Preferences >Send

Mail .

Manual Send opens local folders containing the file to be manually sent. 

Cancel cancels the operation. 

Click on "Remember my Choice" When the send by mail is working correctly, the Editor will

automatically select the option chosen and remember the option for future use.. 

265
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7.1.11 Revert

The Revert feature found under File > Revert becomes active when there are unsaved changes to a

file. Using the Revert feature will undo any unsaved changes and revert to the "original" state of the

document. 

Note: Original state refers to the state of the file when it was opened in the current session.

Previously saved changes will not be undone when the Revert feature is used.

7.1.12 Close

Close closes the currently displayed PDF file. 

7.1.13 Close All

Close All closes all opened PDF files. 

7.1.14 Export

Export exports selected page(s) or selected area of a page as an image file or PowerPoint

presentation. 

Export to Images...  

Export to Microsoft PowerPoint Presentation...  
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7.1.14.1 Export to Images

Exporting a PDF to an image can be accomplished by going to File> Export> Export To Images...

Page Range: Selected <#> of <#> pages

The page range selected defines the pages of of the document that will be exported to images.

All all pages will be exported to image.

Current Page the currently viewed page will be exported.

Current View the converted image will contain only what is currently shown in the PDF display

area.

Pages type the desired page range here. Multiple page ranges should be separated by a coma.

Note: For exporting pages 1 to 15, page 17, pages 20 to 46 and pages 88 to 100 of a 100 page

document, type the following: 1-15, 17, 20-46, 88-100.

If there is a disconnected hyphen (dash) in the page ranges, that page range will go to the beginning

or end of the document like so: -15, 17, 20-46, 88-.

Subset Select a subset of pages. Such as Odd pages or Even Pages. Only pages that fall within

the selected subset will be exported.
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Save As

Defines the file type and save location for exported pages.

Image Type: Select the desired image type from the drop down menu. Clicking the Options...

button opens an Image Saving Options dialog to change the default image format details for the

selected Image Type. See the table below each bullet point for the Options relating to that image

type.

· BMP - Windows Bitmap 

 Options

 Image Type

 Choose the color type from the drop-down list

· 32 (True-Color)

· 1 (Mono)

· 1 Indexed

· 4 Indexed

· 8 Indexed

· 15 (Hi-Color)

· 16 (Hi Color)

· 24 (True-Color)

· 32 (True-Color)

 Alpha
 Yes | No

 If set to Yes, the converted file will contain an alpha channel.  

 Grayscale
 Yes | No

 If set to Yes, the converted image will be created in grayscale.

 X-DPI  Define the dots per inch across.

 Y-DPI  Define the dots per inch from top to bottom.

· PNG - Portable Network Graphic

 Options

 Image Type

 Choose the image color type from the drop down list.

· Black&White

· Indexed (1bpp)

· Indexed (2bpp)

· Indexed (4bpp)

· Indexed (8bpp)

· Gray (8bpp)

· Gray (16bpp)

· Gray with Alpha (8bpp)

· Gray with Alpha (16bpp)

· True Color (24bpp)

· True Color (48bpp)

· True Color with Alpha (32bpp)

· True Color with Alpha (64bpp)
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 Convert To Gray  Yes | No

 Interlaced

 Yes | No

 Once exported if set to Yes, the image loads an early degraded version of the

whole image as soon as possible and then progressively renders the image to

clear state. If set to No, the image will load up in tiles showing clear image in each

tile as it progresses to load in the image.

 Compression Level
 Set to 0 by default for lossless conversion. This can be elevated to compression

level 10 for smaller file size.

 Filter

 Choose filter from drop-down list

· None

· Sub

· Up

· Average

· Paeth

· Auto

 Horizontal DPI  Define the dots per inch across.

 Vertical DPI  Define the dots per inch from top to bottom.

 Title

 Specify the desired document title. This information will be included into the

image Metadata.

Note: Document Title and file name are two different aspects of a file.

Which is displayed in the tabs within the Editor can be set under

Edit> Preferences> Page Display> [Tabs and windows] Setup .

 Author
 Specify an author if desired. This information will be included into the image

Metadata.

 Description
 Enter a description of the resulting file here. This information will be included into

the image Metadata.

 Copyright
 Enter any relevant copywriter data. This information will be included into the

image Metadata.

 Creation Time

 Enter the time at which the file was created. This information will be included into

the image Metadata and functions independently of the actual time the image was

created. 

 Software
 Enter the software desired. This information will be included into the image

Metadata.

 Disclaimer
 Enter any disclaimers related to the file/image. This information will be included

into the image Metadata.

 Warning
 Enter any warnings related to the file/image. This information will be included into

the image Metadata.

 Source
 Enter the source for the file/image. This information will be included into the

image Metadata.

 Comment
 Enter a description of the content. This information will be included into the

image  Metadata.

 Annotation
 Enter a description of annotations. This information will be included into the

image Metadata.

208



151

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

 URL  Enter a URL. This information will be included into the image Metadata.

· GIF - CompuServe Graphics Interchange Format

 Options

 Image Type

 Define the image type from the drop down menu.

· 1 Bpp

· 2 Bpp

· 3 Bpp

· 4 Bpp

· 5 Bpp

· 6 Bpp

· 7 Bpp

· 8 Bpp

 Dither

 Yes | No

 Dithering is the most common means of reducing the color range of images down

to the  256 (or fewer) colors seen in 8-bit GIF images. Dithering is the process of

juxtaposing pixels of two colors to create the illusion that a third color is present.

 Convert to Grayscale
 Yes | No

 If set to Yes, the converted image will be created in grayscale.

 Comment  Add any desired comments to the image metadata.

· PMB - Portable Bitmap

 Options

 Format

 Choose the desired PMB format from the drop down menu.

· Binary

· ASCII

 Use Dithering

 Yes | No

 Dithering is the process of juxtaposing pixels of two colors to create the illusion

that a third color is present.

 Comment  Add any desired comments to the image metadata.

· PGM - Portable Graymap and PPM - Portable Pixelmap

 Options

 Format

 Choose the desired PMB format from the drop down menu.

· Binary

· ASCII

 Comment  Add any desired comments to the image metadata. 
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· JBIG2 - Joint Bi-level Image experts Group

 Options

 Horizontal DPI  Define the dots per inch across.

 Vertical DPI  Define the dots per inch from top to bottom.  

 Compression

 Choose the compression level from the the drop down menu.

· ISO JBIG

· MMR

 Encoding Type

 Choose the encoding type from the drop down menu.

· General

· Symbols 

 File Organization 

 Choose the file organization from the drop down menu.

· Sequential

· Random-Access

· JPEG2000- JPEG 2000

 Options

 Image Type

 Choose the image color type from the drop down menu.

· TrueColor

· Grayscale

 File Format

 Choose the File Format from the drop down menu.

· JP2

· JPC

 LossLess 

Compression

 Yes | No

 With Yes selected, the image compression will be lossless. Lossless compression is

a class  of data compression algorithms that allows the original data to be perfectly

reconstructed from the compressed data.

 Jpeg2000 Quality
 Define the quality level for the exported image. The higher the number (80/100 by

default) the better the image quality, however it will also result in larger file sizes.

 Horizontal DPI  Define the dots per inch across. 

 Vertical DPI  Define the dots per inch from top to bottom.  

· JPEG - Joint Photographic Experts Group

 Options

 Image Type

 Choose the image color type from the drop down menu.

· Gray (8bpp)

· True Color (8bpp)

 JPEG Quality
 Define the quality level for the exported image. The higher the number the better

the image quality, however it will also result in larger file sizes.

 Horizontal DPI  Define the dots per inch across. 

 Vertical DPI  Define the dots per inch from top to bottom.  
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· WBMP - Wireless Mono Bitmap

 Options

 Use Dithering

 Yes | No

 Dithering is the process of juxtaposing pixels of two colors to create the illusion

that a  third color is present.

· PCX - PC Paintbrush File Format and DCX - Multipage PCX

 Options

 Image Type

 Choose the image type from the drop down menu.

· 1 (Mono)

· 4 (Indexed)

· 8 (Indexed)

· 24 (True-Color)

 Dither

 Yes | No

 Dithering is the process of juxtaposing pixels of two colors to create the illusion

that a third color is present.

Note: Dithering for PCX is not available when the Image Type is set to

True-Color

 X-DPI  Define the dots per inch across. 

 Y-DPI  Define the dots per inch from top to bottom.

· TGA - Truevision Targa and TIFF - Tag Image File Format

 Options

 Image Type

 Select the image type from the drop down menu.

· Indexed

· Grayscale

· HiColor

· HiColor with Alpha

· TrueColor

· TrueColor with Alpha

 Dither

 Yes | No

 Dithering is the process of juxtaposing pixels of two colors to create the illusion

that a third color is present.

Note: Dithering for TGA - Truevision Targa and TIFF - Tag Image

File Format is not available when working with any True-Color image

types.  

 Compression

 Choose the compression method from the drop down menu.

· No Compression

· Run-Length
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 Title

 Specify the desired document title. This information will be included into the image

Metadata.

Note: Document Title and file name are two different aspects of a file.

Which is displayed in the tabs within the Editor can be set under 

Edit> Preferences> Page Display> [Tabs and windows] Setup . 

 Author
 Specify an author if desired. This information will be included into the image

Metadata. 

 Software
 Enter the software desired. This information will be included into the image

Metadata. 

 Comment
 Enter a description of the content. This information will be included into the image

Metadata. 

Destination Folder Selects the destination folder to receive the image files. Clicking the 

 Browse button opens the Browse for Folder window to allow for the selection of a target save

location.

File Name. Specifies the name of the export file. Enter any valid file name.

In addition, clicking the  Macros button opens a submenu of file name macros that can be

used to automatically generate file names. This is especially useful for repeat jobs and to set the

file numbering when single-page image files are being generated for multiple document pages.

For more details regarding Macros, please see the *Macros  section.

Export Method Determines how multiple page PDF documents are placed into multi-page

exported image file.

· Save all pages to a single multi page image file

· Save each page range to a separate multi page image file

· Save each page to a separate single page image file

Open the destination folder for the Resulting File(s) if checked, the folder containing the new

image files will be opened.

Graphic

Define the graphics settings for the image.

Page Zoom: Increasing the zoom will increase the dimensions of the image.

Horz. Resolution and Vert. Resolution represent the horizontal and vertical resolution

respectively. Use the link  button to constrain the ratio.

Page Background choose the background color for the resulting image.
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7.1.14.2 Export to Microsoft PowerPoint Presentation

Exports from PDF to PowerPoint by going to File> Export> Export to Microsoft PowerPoint

Presentation. Choosing this feature will bring up a Save File dialog: 

     Save File window

From here, the PDF file can be saved directly to pptx. To adjust the properties and fine-tune the

conversion options, click on Options... to bring up the Options window. 
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     Export to Microsoft PowerPoint Presentation > Options window

Convert entire page content to image will cause every part of the PDF to be exported to an

image based PowerPoint (.pptx) file. 

Resolution in Dots Per Inch (dpi). Lowering the dpi will reduce the output quality, but increase

speed, and reduce the file size. 

Text Conversion Options:

Mode:

· Preserve text editable will allow the text in the resulting PowerPoint to remain

modifiable. 

· Convert to curves each letter is converted vector based description of itself

· Convert to Images converts the text to images.

Embed all fonts will cause all the fonts in the PDF to be embedded to the output file. This

will eliminate the need to have the same fonts installed when opening the file on another

system.

Allow to use substitution for fonts that cannot be embedded will cause the application to

render the text using the closest font to the original to render the text. 
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Allow to convert text that uses problematic fonts to curves If the fonts, or characters are

detected as causing problems, they will be converted to curves.

Text rasterization quality selects the rasterization quality (convert to raster image) of text in

Dots Per Inch (dpi). Lowering the dpi will reduce the output quality, but increase speed, and

reduce the file size. 

Include Comments will cause any comments or markups present in the PDF to show up in the

PowerPoint presentation file.

7.1.15 Print

File> Print or [Ctrl+P] Prints the currently active file. 

Printer

In this section, select from the list of installed printers. 

Properties Opens the printing properties for the selected printer.

Page Setup... Opens the Page Setup window to modify basic page options. 
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     Page Setup window

Paper Size: Pick page size from a list of available page sizes to print to. 

Paper Source: Select the type of paper being printed to.

Orientation Choose between Portrait and Landscape orientation.

Margins Define the size white space around the document

Pages Range: Selected _ of _ pages

Define the page range to be printed. 

All all pages will be printed

Current Page the currently viewed page will be printed

Current View the print job will contain only what is shown in the PDF display area.

Pages type desired page range here. Multiple page ranges should be separated by a coma. 

Note: For printing pages 1 to 15, page 17, pages 20 to 46 and pages 88 to 100 of a 100

page document to be included in the print job, type the following: 1-15, 17, 20-46, 88-

100. If there is a disconnected hyphen (dash) in the page ranges, that page range will go

to the beginning or end of the document like so: -15, 17, 20-46, 88-.
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Selected Pages This option is available when there are pages selected in the Thumbnails Pane

. 

Selected Graphic This option is available when a portion of a PDF is selected using the

Snapshot Tool .

Subset Select a subset of pages. Such as Odd pages or Even Pages.

Pages Placement and Scaling

The page Placement and scaling options change depending on the Type selected from the Type

drop-down menu.

Type:

None

No scaling or placement will be applied. 

Page Zoom shows and allows changing the zoom level of the pages to be printed.

Auto-Rotate Page on Paper will automatically rotate the pages to best fit the printer's

pages.

Auto Center Page on Paper will automatically center the pdf pages to the printed sheets.

Choose Paper Size by Document's Page size The paper size will be selected based on what

the page sizes of the PDF are.

Ignore printer Margins will ignore the edges of the page's printable area. This may cause a

portion of the document not to be printed.

Fit to Printer Margins 

Will reduce, or enlarge the pages to fit to the printer's printable area.

Reduce to Printer Margins

296

508
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Will reduce large pages within a PDF to fit in the printer's printable area. Pages that are smaller or

that already fit within the printer's margins will not be scaled. 

Custom Zoom

Sets a custom zoom level. 

Tile Large Pages 

Allows the printing of pages that are bigger than the available physical sheets.

Show Cut-marks on Sheet shows where to cut the tiled sheets after printing so that all the

pages line up correctly when combined or glued together. 

Show Labels on Sheet shows the page name and sheet number. E.G. Page 1 (title 1 of 15)

at the top of each sheet.

Composite View will show all the pages and

how they will be tiled. Click on Normal View to

switch to it.

Normal View shows how each individual sheet

will be printed. Click on Composite View to

switch to it.

Multiple Pages per Sheet 

Allows printing 2 or more pages on a sheet of paper
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Pages per Sheet from this drop down menu, choose from the preset pages per sheet, or select

custom to define custom number of pages per sheet.

Pages Order Defines the order the pages are to be placed on the sheet.

Horizontal Horizontal Reversed 
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Vertical Vertical reversed 

Show Page border will show a border around each page within the sheet. 

Booklet 

Booklet mode prints documents as books or brochures.

Booklet Type allows selection of the compilation method. 

· Book When collated, folded, and stapled, the double-sided sheets result in a single book

with the correct page order. 

· Brochure Will print the document in the order as shown in the PDF, but will include multiple

pages per sheet and modify the placement so that the front cover is to the correct side of

the binding or fold.

Print Sides will dictate to which sides of the sheet the pages can be printed. 

· Both

· Front 

· Back

Gutter Size Defines the space between adjacent pages to make room for binding or folding. 
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Advanced Print Options

Print:

§ Documents and Markups

§ Document

§ Document and Stamps

§ Form Fields Data Only

§ Markups Only

§ Whole content

Print as Images will send the printer an image rather than regular print data. Note that this

may take longer to print if printing to a network printer.

More... Opens the Advanced Print Options menu.
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Print Content Options Options to fine tune the content that is printed on the sheet(s)

Print Page Content will print the base content of the pages. 

Print Markups (annotations such as rectangle, circle, polygon, etc.)

Print Stamps will print stamp annotations

Print Form-Fields will print form fields with data.

Field Data only (field with no borders and backgrounds)

Print Media-Annotations (movie, Sound, 3D, etc.)

Show Print-Marks Annotations will turn on or turn off the printing of the Print-Marks.

Print Notes will print the note Icon to the sheet, but not the note itself.

Print Note Pop-up(s) will print the sticky note annotation associated with any notes.

Rendering options

Color Override overrides the existing color type when the document is printed.

· Auto

· Grayscale

· Monochrome

· Color

Text Rendering Mode allows the modification of the default text rendering mode that is sent

to the printer.

· Auto

· Outline for embedded fonts

· Outline Always

· Bitmap for embedded fonts

· Bitmap always

Maximum Resolution for images Sets the maximum resolution for images in dpi (dots per

inch)

Resolution for Gradient Fills Sets the maximum resolution for gradient fills in dpi (dots per

inch)

Ignore Accessibility Color Overrides will ignore all color overrides or accessibility settings

when printing. For more information on color overrides and accessibility, please see the 

Accessibility  section.   

Ignore Page Crop-Clip will ignore the dimensions of crop boxes and print the content

outside of cop margins.  

237



165

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

7.1.16 Document Properties

When a PDF document is opened in PDF-Change Editor, the ability is included to Read and Create

information about the PDF file (info, security method, appearance, actions when a document is

viewed, and more) in a window called Document Properties. 

File > Document Properties... (or CTRL + D) opens a window where six Categories of document

properties are accessible. Click on a Category in a left panel and read more about it in a new

window. Closing the window returns to this page.

In a left panel of the window Document Properties offers six tabs with Categories of document properties. 

Right panel exposes the selected tab information (here, Description tab).

Description  tab: Read and Add/Change information, such as Document Title, Keywords, etc (for

more narrow search, for example, through Search  > Include Document Info or using Shell

Extensions ). 

Fonts  tab: Read information about all fonts in the document, their types, and encoding used to

display the original fonts. 

Security  tab: Set Security Method (password, certificate, etc) and Determine what changes are

allowed in that document (content copying, signing, printing, etc.). 

Initial View  tab: Set the initial viewing preferences for that document when it is opened in any

166
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PDF application (what page and layout to display, what magnification level to set, what panels to

open with the document, etc).

Advanced  tab: Set the Base URL for relative links in your document, the prepress options

(trapping), options for printing (duplex mode, number of copies, etc), options for reading from a

screen or other devices), and add Actions such as Execute a Command, Open a Link, Go to a Page,

Run Java Script, Play a Sound, and more.

JavaScript  tab: Allows adding JavaScript scripts to the document. 

7.1.16.1 Description

The Description Tab [File> Document Properties> Description] shows detailed information

about the PDF document and allows setting custom information and properties. Document info can

be used when searching documents within the Editor and Windows Explorer using the Ifilter 

included in the Shell extensions  of the Editor installation. 

    Document Properties> Description window

File Info 

The File Info section shows the file name, location and size as it is shown in File Explorer (also

known as Windows Explorer). These figures change as the document itself changes.

183
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Document Info 

Document Title: A document title can differ from the File name, and is customizable. 

Note: The document Title can be displayed instead of the file name by choosing that option in

the Initial View  section. 

Author: This field is customizable. 

Subject: This field is customizable. 

Keywords: Separate keywords with comas to make searching the for the document quicker. 

PDF Producer: Displays the name of the module or program that created the PDF. 

Application: If known, the name of the application that created the PDF will be listed.

PDF Version: Refers to the version of PDF conformity as specified by the PDF specifications.

Created: Shows the date the file was created.

Modified: Shows the date when the file was most recently modified or changed.

Pages Count: Displays the number of pages in the file.

Page Size: Shows the pages size within the file.

Additional Metadata...

The Document Metadata window allows the ability to enter additional custom data into the fields of

the Description section.

Document Properties> Document Metadata window

180
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Description: The Document Metadata window allows the entering of additional custom data into

the fields of the Description section. 

Description Writer

Copyright Status

§ Unknown

§ Copyrighted 

§ Public Domain

Copyright Notice is a notice of statutorily prescribed form that informs users of the underlying

claim to copyright ownership in a published work.

Copywriting Info URL 

Advanced: Advanced dialog shows raw structure of the XML metadata. It also will allow to export/

import/delete features. 

Note: This feature was not implemented at time of documentation.
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7.1.16.2 Fonts

The Fonts tab [File > Document Properties > Fonts] displays the font information for the PDF

document. This can be quite useful in resolving PDF display issues across platforms, especially in the

case of missing fonts. 

Note: The information displayed here is View Only. Fonts can be embedded, or unembedded

using the Save Optimized Copy  feature.

Document Properties> Fonts Window

100
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7.1.16.3 Document Security

The Security tab [Document> Properties> Security] allows the ability to view, implement, and

manage document permissions, password, and certificate security policies.

Document Properties> Security window

Document Security

PDF documents have the ability to use encryption and passwords to secure a document such that it

cannot be opened without the password. The PDF-XChange Editor supports a range of encryption

strengths, depending on what Adobe version compatibility selected, the strongest security being

compatible with only the latest versions of Adobe Reader.

Security Method selects the security method to apply. When a new security method is selected

the appropriate settings window for that policy will open. Click on one of the links below to

jump to that method's documentation section. 

§ No Security 

§ Password Security

§ Certificate Security

§ File Open

170
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Encryption Method

Changes the settings of the currently active security method by

launching the appropriate settings window for the policy. 

Password Security

Password Security settings window



172

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Options

The options section sets the compatibility and encryption levels for the security policy.

Compatibility: newer compatibility will increase the strength of that security policy,

however,  files using the newer incompatibilities will only be compatible with later

versions of most compliment PDF readers.   

Encrypt all document contents will cause all the content in the document to be

encrypted. 

Encrypt all document contents except metadata allows the metadata to be accessed

and modified. 

Encrypt only file attachments will encrypt only documents that are attached to the

current document. 

Document Passwords

Create passwords for opening and/or modifying a PDF

Require password to open the document With this option selected, users will be

prompted to enter a password when trying to open the document. In the Document

Open Password field, type the password desired, then confirm the password in the field

directly below.

Restrict editing and printing of the document. A password will be required in order

to change these permission settings. This option will allow the document to be opened

and viewed, but will restrict changes to the document depending on the Permissions

selected.

Permissions

Specify the permissions for this security policy.

Printing Allowed: define printing permissions.

§ Not allowed printing will not be allowed. 

§ Low resolution printing will only be available at low

resolution.  

§ High resolution Printing is allowed at full resolution. 

Changing Allowed defines the changes that can be made to the document after the

security policy has been implemented. 

§ Not allowed no changes will be allowed.

§ Inserting, deleting, and rotating pages

§ Filling in form fields and signing existing signature fields

§ Commenting, form field filling, and signing existing

signature fields
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§ Any, except extracting pages

Enable copying of text, images, and other content will allow for text to be copied out and

modified. 

Enable text access for screen reader devices, for the visually impaired.

Certificate Security

Certificate security will be shown only when a document already has a certificate security method

implemented. To certify a document, go to Document> Digital Signing> Certify (invisible).

For more information, see the Digital signing  section.

File Open

File Open security will be shown only when a document already has that security method

implemented. File Open is a third party Digital Rights Management software.

Go to http://www.fileopen.com/ for more details.

430

http://www.fileopen.com/
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 Opens the Managing Security policies window.

Managing Security Policies window

Add New adds a new security policy.

Clone copies the selected security policy

Edit... modifies the selected security policy.

Rename... renames the selected security policy.

Delete deletes the selected security policy.
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To secure a document with encryption and a password do the following:

1. Open the PDF document in  PDF-XChange Editor

2. Click File> Document Properties (CTRL+D)

3. In the Document Properties window select Security [categories] > Document Security >

Security Method > Password Security [drop down menu], or Apply Security Policy...

4. This opens the Password Security Settings dialogue. Choose the encryption strength in

the Compatibility field.  Later versions of Adobe Reader support stronger encryption but

the resultant document will be readable by fewer users.  
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5. Enter passwords where indicated and applicable.

In PDF XChange Editor, there are two separate password fields. These two MUST be

different. The first password is for opening of the document, and that is the one that the

author will send to general users. The second password is to set the permissions, remember

this one to be able to change the document or to remove security from the document. This

would be the "master password" so to speak.

See the bottom of this section for instructions on how to remove security.  
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Managing Security Options:

In PDF-XChange Editor, you can set two passwords. One is required to open the document for

viewing purposes, the other is set to restrict what can be done to the document. These passwords

can be used together or independently.  

Permissions:

The default preferences should be set to not allow users to do anything but read the document. 

Printing Allowed:

-Not allowed

-Low Resolution

-High Resolution

Setting printing permissions to either High Resolution or Low Resolution will set the program to

not prompt for a password while printing. 

Changing allowed:

Functions that are specified to not be allowed will not prompt for a password, they will simply be

greyed out and unusable.  
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Removing Security

Please note that knowledge of all passwords attached to the document is required to remove

security. 

In the first security window: File> Document Properties> Security [sidebar] >Security Method:

[Change to] No Security

File > Document Properties > Security Remove security warning

When opened, a dialog is displayed to type the previously mentioned "master" password, e.g. the

one used to manage permissions for making changes to the document. If permissions editing has

not been restricted there is no need to type a password at all. If a prompt is displayed simply type

in the password used to open the document. 
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Please note that support provided by Tracker Software regarding security issues is very limited.

Make sure to remember your password(s).
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7.1.16.4 Initial View

The Initial View section [File > Document Properties > Initial View] allows specifying viewing

parameters within a file when it is opened, regardless of the application used.

Document Properties > Initial View window

Layout and Magnification

Navigation View: The navigation view option allows which Panes are visible when the file is

opened. 

· Default: The viewing application's default settings will be used. 

· Page Only: Only the File will be displayed.

· Bookmarks pane and page: The Bookmarks Pane  will be displayed with the file.

· Thumbnails pane and page The Thumbnails Pane  will be displayed with the

file.

· Layers pane and page When the file is opened, the Layers Pane  will be

displayed with the file.

284
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· Attachments pane and page When the file is opened, the Attachments Pane

will be displayed with the file.

Page Layout: Defines the default page layout for the document.

· Default 

· Single Page Only one page can be viewed at a time unless otherwise specified. 

· Continuous The pages will be displayed in a single smooth scrolling column. 

· Two Pages - Continuous The pages will be displayed in 2 smooth scrolling columns.

Page 1 on the left, page 2 to the Right, page 3 beneath page 1 and so on.

· Continuous - Cover page The pages will be displayed in 2 smooth scrolling

columns with a cover page. Page 1 on the on to the right of a blank space, page 2

beneath the blank space, page three to the left of page 2. This mode helps show the

pages in a book-like fashion.

· Two Pages Only 2 pages side by side will be shown at a time.

· Cover Page Only 2 pages will be shown at a time side by side, with a blank space at

the beginning of the document like when continuous cover page is set.

Magnification: The option chosen here defines the default zoom level when the file is opened.

· Actual Size The file pages be displayed in its real size, as if it were printed.

Results may vary depending on resolution and dpi. 

· Fit Page the pages will be displayed so that the full page is visible. 

· Fit Width The pages will be displayed so that their left and right sides are at

the edge of the viewing area. 

· Fit Height The pages will be displayed so that the top and bottom of the

page are at the top and bottom of the viewing area. 

· Fit Visible The pages will be displayed so the entire page is visible within the

confines of the viewing area.

· Custom magnification percentage (%)

Open to Page: The number selected in this field indicates which page the document opens to

by default.

Note: These settings can be overridden by the viewing application. The Editor will ignore the

settings above if custom settings are used in the Edit > Preferences > Page Display  section.

309
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Window Options

Show in Title: This section defines what is shown in the document tab while the file is being

viewed. File Name, Or Document Title as described in the Descriptions  section. 

Open in Full Screen Mode: This will cause the document to automatically open in full screen if

allowed by the viewing application.

Resize window to initial page: This option will resize the window frame to the same size as the

first page viewed in the Document. 

Center window on screen: This option centers the window on the monitor. 

Note: The Editor Ignores the parameters "Resize window to initial page" and "Center

Window on screen".

User Interface Options

Hide Menu bar A flag specifying whether to hide the interactive PDF processor’s menu  bar

(File, Edit, View...) when the document is active.

Hide Toolbars A flag specifying whether to hide the interactive PDF processor’s toolbars

 when the document is active. 

Hide Window Controls  A flag specifying whether to hide user interface elements in the

document’s window (such as scroll bars and navigation controls), leaving only the document’s

contents displayed.

Note: Many of these features can be overridden by the viewing application. 
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7.1.16.5 Advanced

The Advanced tab [File > Document Properties > Advanced] allows setting advanced properties

for the document, such as print setting overrides and more. 

Document Properties > Advanced window

PDF Settings

Base URL Specifies a base URL for web links in the PDF document. This makes it easy to

manage web links to other websites. If the URL to the other site changes, simply edit the base

URL and not have to edit each individual web link that refers to that site. The base URL is not

used if a link contains a complete URL address. 

Trapped Trapping is a complex process that depends on the interaction of various color, ink,

and printing factors; the correct settings vary, depending on specific press conditions. Do not

change the default trap settings unless your print service provider has been consulted.

· Yes

· No

· Unknown
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Print Dialog Presets The Print Dialog Presets override the viewing application's default print

settings in favor of the ones customized in within the file.

Page Scaling 

§ Default The default print settings of the viewing application will be kept.

§ None No page scaling will be used. 

Duplex Mode Allows you to specify the default duplex mode for printing the file. 

§ Default

§ None

§ Long Edge

§ Short Edge

Paper Size by Document Page Size If selected, the document's pages will not be scaled, and

the pages size will be determined by the size of the pages in the PDF. 

Print Page Range Individual pages are indicated by their numbers beginning with 1. Sequential

page ranges may appear as hyphenated inclusive ranges, e.g. 2-5 will select pages 2, 3, 4, and 5.

Multiple page ranges may be specified, separated from one another by commas. 

Number of Copies

§ Default

§ Custom number

Reading Options Allows setting the default reading direction and language for the file. This is

useful when delivering files in languages that use right to left reading to other users. If set properly,

users should not need to manually set his or her reading direction or language for the file they have

received.

Binding

§ Left To right (LTR) Set this option for standard languages the read left to right such

as English, French, Latin, German and many many more. 

§ Right To Left (RTL) Set this option for languages the read right to left such as

Hebrew, Arabic, Persian, Urdu, Yiddish and more. 

Language

§ Unknown

§ Specified Language
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Actions Actions can be set to do many tasks, such as go to a webpage, or open another file. The

Link Tool  and Bookmarks  make use of these actions. 

Action Type Actions can be defined at the times defined in the Action Type drop down menu

§ Before Document Closes

§ Before Document Saving

§ After Document Saving

§ Before Document Printing

§ After Document Printing

Edit The Edit button corresponds to the currently selected Action Type from the adjacent drop

down list. Clicking on the Edit button brings up the standard Edit Actions List. Each of these

actions are defined in the Link Creation Tool  section.

566 284
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7.1.16.6 JavaScript

The JavaScript section of the Document Properties lists JavaScripts that may be acting on the

document. New JavaScripts can be created and any existing ones can be modified from here. For

more information for using JavaScript in PDF please see the JavaScript API reference.

Document Properties> JavaScript window

http://http/www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/js_api_reference.pdf
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Add... opens the JavaScript Editor window where a new script can be implemented. 

JavaScript Editor window

Edit... opens the JavaScript Editor for the selected JavaScript for modification. 

Delete removes the selected JavaScript from the list.
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7.1.17 Copy Full File Name

Copies the fully-qualified file name of the active PDF to the Clipboard. 

For example, the copied path name for the demo file used in this documentation is: 

F:\Samples_Editor\PDFVManual.pdf

7.1.18 Open Containing Folder...

Open Containing Folder allows opening the folder containing the active PDF document in

Windows Explorer. When the folder opens, it does so with the active document selected:

7.1.19 Exit

Exits the PDF-XChange Editor program. 

Selecting this option with open PDF files that have been modified, will prompt whether or not to

save the changes. 
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7.2 Edit

The Edit menu items are concerned with modifying PDF information.

 Undo, Redo buttons control the last editing changes

made to the document.

Cut,  Copy and  Paste interact with the windows

clipboard.

 Delete  will delete the selected item.

 Find... Brings up the Find bar.

 Search...  brings up the Search Pane.

 Properties...  brings up the Properties Pane.

 Export Settings...  Will export your settings to a data

file.

 Import Settings...  will bring up a dialogue for the user

to navigate to a saved settings file. 

 Reset Settings...  will reset all settings to their defaults.

 Preferences...  will bring up the Preferences Menu

7.2.1 Find

Find quickly allows searching for specific text within the currently opened PDF document.

In the Main Menu choose Edit > Find or keyboard shortcut [CTRL] + [F].

Find toolbar

The controls on this toolbar are: 

1. Enter Text to Find. Search field to enter the text to be searched.

2. Clear Search. Deletes a word(s) from the Find search field.
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3. Drop-down List of Previous Search Terms. This button allows selection from a drop-down

list of previously searched terms. 

4. Find Options. Sets the Find options that specify how the search term will be searched, what

objects are searched in the current PDF document and how the results will be presented. 

Drop-down list of Find Options

Case Sensitive. Finds the words distinguishing between upper-case and lower-case

letters. For example, if this option is chosen for the word "WHO" (World Health

Organization), in the search results, only the words in all capital letters "WHO"  are

returned but there are no results for"Who" included.

Whole Words. Searches for whole words. For example, with this option your search the

word "theater" will show you all occurrences the word "theater" but will not show any

"the". 

Ignore Diacritics. With this option you can search words with any variation of

characters such as character with accent or tilde etc. For example, if you need to search

a word in French, Polish text etc., you can tape a word without marks that is placed over,

under, or through a letter: you can tape "facon" instead of "façon".

Include Page Text. Searches the text through pages content. 

Include Bookmarks. Searches the text in the Bookmarks panel. 

Include Comments. Searches the text of any comments added to the PDF, as viewed in

the Comments panel. 

Include Form-Field. Searches the text in the Form-Fields. 

Include External Links. Searches the text in hyperlinks (non-visible text in links to web-

sites or to the other documents) but doesn't do it in hypertext. 
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Colored Find-Results. Highlights each word of the searching text in a different color.

For example, if you find the text "Viable thesis statement" with this option, results will

look like 

5. Find Previous/Next Entries. Allows to move to the next (right arrow) or previous (left

arrow) entrance the sought text.

Note: It should be noted that PDF files created from solely Image based content (e.g. scanned

to PDF) cannot be text searched - there is no actual text within the PDF file - simply an image

of the page, even though the image may represent text. Such feature requires using OCR

(optical character recognition) functionality available in Document> OCR Pages... 430
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7.2.2 Search

Search can be used to search documents, folders, portfolios, comments, forms, and more. The

Search pane is activated by going to Edit >Search from the main menu or using keyboard shortcut

[Ctrl]+[Shift]+[F]. 

It differs from Find in that it will search either the active PDF document, or multiple PDF's in

selected Folders. Whereas Find will only search the active document. 

After the search, you may click on any selection in the results list to jump to that page

Search Pane

WHAT would you like to search? In this field, users can type keywords or phrases (query).  Users

who wish to fine tune the search results should use the Advanced Criterion options.
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Advanced Criterion: Choosing this option will expand the search pane and provide the following

fields which can be used to fine tune a search.

Advanced Criterion expanded fields

Custom: Choose from preexisting Advanced Criterion. If no saved advanced criteria exist, the

option will not be active. 

Once an advanced search criteria is entered, the save button becomes active allowing the user

to save that search for future use.

Find Text with: The Advanced search criterion will only include Find text with all these words,

Find text with any of these words and Find text with none of these words. 

· all these words: Results will only include text strings with all the words typed into

this field regardless of their order.

· any of these words: Results will include any of the words typed into this field.

· none of these words: Results containing words typed in this field will be excluded. 

Note: These words can be adjacent or include other words between them. Check

Proximity to set a location for included or excluded words. For example, if searching for

"Conifer tree" but none of "larch", you can choose the option Words from the same

page in Proximity. Result window will not show you entries of "Conifer tree" if  the word

"larch" is on the same page.

WHERE would you like to search? Here, choose in which document(s) or folder the search will be

performed on. 

· In Active Document sets the search to include only the active PDF opened in

the Editor. 

· In all open documents sets the search to include all PDF documents

currently open in the Editor

· Browse to folder will open a file open dialog (also known as windows

explorer), where a local or mapped network location folder can be navigated

to and selected from which to search.
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Search... button, executes the search and starts to look for the results based on specified criteria in

the sections above.

Options... The options button will open a context menu, where further available options to fine

tune the search criteria can be selected.

Search Options menu
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Search Options

Case Sensitive Only results which match the case of the query will be shown. (e.g. "Toolbar"

and "toolbar") 

Whole Words Words containing parts of the query will not be included in the results. E.g. when

searching "Thermal Nuclear Radiation", if Whole Words is not selected, the results may include

"The", or "clear".

Ignore Diacritics Finds the search terms with any variation of the alphabetical characters. For

example, typing école finds both ecole and école. Likewise, typing ecole finds both versions. If

this option isn’t selected, typing ecole doesn’t find école, and vice versa.

Include Page Text Page text will be included in the search results. 

Include Bookmarks Text based bookmarks and bookmarks' text will be included in the search

results. 

Include Comments Text within comments will be included in the search results 

Include Form Fields Text within form fields will be included in the search results

Include External Links Selected text within links will be included in the search results. 

Include attachments Attached documents will be included in the search results. See the

attachment section for more information. This also functions when working with Portfolios. 

Include Document Info Document information as detailed in the document properties section

will be included in the search results. 

Pre-Estimate the search in folder This feature will provide a more accurate search progress for

large searches that take some time to complete.

Look in Sub-Folders When using the Browse to folder search option, all sub-folders of the

folder selected will be included in the search results if this setting is checked.

Proximity This sub-menu defines the search term proximity of the search results. Each

proximity setting defines searches for two or more words that are separated as defined in the

individual option: 

· Only Adjacent Words Only words that are side by side will be included in the results.

· Words from the same Paragraph Only words that appear in the same paragraph will be

included in the results.

· Words from the same page Only words that appear on the same page will be included

in the results.

· Words from the same Document Only words that appear in the same document will be

included in the results.



196

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Colored Search-Results When selected, each word in a query will be displayed as different

color to make the results more clear.

PDF-XChange Editor Window with Search Pane and Colored search results active

Clear results This option will clear all current results.
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7.2.3 Properties

The Properties Pane, becomes active when an object in a PDF document is selected, allowing you

to modify the look, feel and functionality of that tool or object. The options in the Properties Pane

are dynamic and differ depending on what is selected. For example; while typing in somewhere like

a typewriter annotation or text box, the properties pane will look like what is shown below. 

Click Edit >Properties to toggle viewing the Properties Pane on or off from the menu or using

keyboard shortcut [Ctrl¸]+[ ` ]

This instance of the Properties Pane contains all the text dependent settings you will need to make

the text within the annotation exactly how you need it. 

While not typing somewhere, the Properties Pane is dependent of the active tool or object. Please

see the small sample of screenshots below which illustrate this behavior.
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For a description of what each property does for a given tool and its related annotation, please see

the Tools section . 

Note: Most Properties can be modified using the Properties Toolbar .

506
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7.2.4 Export Settings...

Export settings… exports the application’s settings to the data file. When the Export settings

button is selected, the Export Settings Options dialog will come up. 

From there, custom settings can be chosen, or excluded from the export settings function. 

Program Options include all UI, toolbar, and custom comment styles.

History includes the recents list

User Stamps Collections if selected, user's custom stamp collections will be included in the

settings file.

Digital Signature Appearance Templates if selected, digital signatures and templates will be

included in the settings file.

Plug-Ins Additional Data Custom settings for Plug-Ins such as custom dictionaries will be included

in the settings file.

Once satisfied with the options that will and will not be included in the settings file, click Ok to

bring up the save dialog. The settings will then be saved and can be removed using the Import

Settings...  option.200
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7.2.5 Import settings...

Import Settings… imports the previously saved application’s settings from the data file. For

instructions on creating a settings file, see the Export Settings Section.

Note: Importing a settings file will overwrite your current settings. If you wish to retain your

current settings for future use, please export them as described in the Export Settings section 

7.2.6 Reset Settings

The Edit > Reset Settings option resets all settings to the default ones.

199

199
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7.2.7 Preferences

The Preferences Section is where users have access to various application settings:

 Documents  - options to modify document opening, document creating, layout and saving

preferences.

 Page Display  - options to condition how a PDF is initially displayed. The display may be

modified by the user as necessary.

 Page Text  - controls the text options.

 Full Screen  - controls the visual display of PDF pages when in Full Screen mode.

 Performance  - Options affect how well the program utilizes memory and other system

resources to produce the best display.

 Color Management  - Options to adjust color settings for PDF printing and display.

 Languages  - Options to localize the editor to the chosen language.

 Prompts  - Restore the confirmation prompt box of the operation.

 File Associations  - Determines whether PDF-XChange Editor will be used as the default

program for PDF files or whether another previously-installed application should be used. 

 Registration  - Register your copy of the PDF-XChange Editor.

 Accessibility  - Controls color options for displaying PDF pages for people with poor or limited

eyesight.

 Measurement  - Determines the linear units to use for all displays.

 Identity  - Store frequently-used information about yourself that can be added to PDF's that you

are annotating. Note: Such information is never exported without your knowledge and approval.

 Security  - The security options can be set here including interactions with external objects/

applications such as links or attachments.

 JavaScript  - Controls the behavior of JavaScript execution within the PDF-XChange Editor.

 Snapshot Tool  - Controls the behavior of the Snapshot Tool.
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 Forms  - Sets the options of form fields.

 Commenting  - Select between two ways to copy circled text into Comments.

 Signatures - Controls options for signature creation, setting the appearance of signatures, and

how and when signatures are verified.

 Scanner Presets  - Control the options for scanning.

 Plug-ins  - Controls the behavior of the Plug-ins.

 Send Mail  - Allows you to adjust the options for sending an e-mail.

 Search Providers  - Custom search providers can be selected and defined from this screen.

 Launch Applications  - The list of third party PDF viewers can be listed here for use in the

Launch Toolbar .

 Customize UI  - The user interface can be customized through this screen.

 Update - The Tracker Updater can be launched from here to check for updates.

 Speech  - Controls the behavior of the Sound Tool.
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7.2.7.1 Documents

Documents preferences allow you to modify document opening, document creating, layout and

saving preferences. 

Preferences window >Documents
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Tabs and Windows. Determines how PDF documents will be displayed by the PDF-XChange Editor.

The Setup... button will open the following dialog box.

Single document mode. Each frame of the program may display only a single document.

Multiple frames must be opened to display multiple documents. 

Open each new document in new window. Each document is displayed in a new window of

one program instance. 

Hide tab bar when only single document is opened. Hides the tab bar when a single

document is opened. 

Synchronize document's panes layout across opened documents. 

Open new document. 

§ In new tab: Will open new documents in a new tab to the right of all current

tabs.

§ In new Adjacent tab: Will open a new document in a tab adjacent to the

currently active tab.

Open related document. A related document can be an attachment, or items found within a

portfolio. 

§ In new tab: Will open related documents in a new tab to the right of all current

tabs.

§ In new adjacent tab: Will open a related document in a tab adjacent to the

currently active tab.

Minimize to System Tray. When checked, the application will be minimized to system tray. 

Close to System Tray. When checked, the application will be closed to system tray.
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Open Documents. Determines how the PDF-XChange Editor responds to Open commands. 

Restore Last Session when application starts. When checked, the last work session will open

automatically.

Manage History & Recents.... Opens the Manage History and Recents dialog.

History Options. 

Max. number of items. You can set the maximum number of documents to be

displayed in the Recent documents list. 

Item's life-time. Defines how long the unpinned documents will remain in the list.

Clear history on exit. Clears the history list completely on exit.
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Recents List Options. 

Show max. number of items. The maximum number of items will be displayed in

the Recents list.

Show thumbnail. Displays the thumbnails of the documents listed in the Recents.

Show caption. Will show the document Title in the Recents List as indicated in the

screenshot below.

Show file-path. Displays the file path of the documents listed in the Recents. 

Cache thumbnails stores the images for thumbnail previews in cache memory so

that the images can be loaded quickly each time you access the recents list.

Save Documents. Determines how the PDF-XChange Editor responds to Save commands.

Always use Incremental Save. Incremental save mode allows a file to be saved with both

the original and modified data. The file size will be larger but all information will be saved in

both its original and modified forms. 

Users should not have to wait for the entire file - which can contain hundreds of pages or

more - to be rewritten each time modifications to the document are saved. The PDF format

allows modifications to be appended to a file, leaving the original data intact. The addendum

appended when a file is incrementally updated contains only those objects that were actually

added or modified, and includes an update to the cross-reference table. Incremental update

allows an application to save modifications to a PDF document in an amount of time

proportional to the size of the modification rath file. 

In addition, because the original contents of the document are still present in the file, it is

possible to undo saved changes by deleting one or more addenda. The ability to recover the

exact contents of an original document is critical when digital signatures have been applied
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and subsequently need to be verified. 

Choose destination folder for 'Save As' of documents. Selects the destination folder to

receive ‘Save As’ Documents. Clicking the Browse... button opens the Browse for Folder

dialog to select the destination folder.

New Documents. Controls the creation of new documents.

PDF-Specification. Sets the version of PDF-specification used for new document creation.

7.2.7.2 Tools

Tools Preferences allows for the selection of default tools. 

Default Tool: Select from the list of 

· Hand

· Select Text  

507
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Remember last used tool from the list between sessions will remember the previously used tool

when opening a document. The tools this feature function with are those available for selection in

the Default Tool drop down menu.

Keep current tool default for newly opened documents Will keep the current tool selected when

a new document is opened rather than reverting to the default tool.

7.2.7.3 Page Display

Page Display options allow for the configuration of the way that a PDF is initially displayed when it

is opened.

Edit> Preferences> Page Display window

Initial Display 

Determines the settings of the page’s initial display. 

Restore the last used view of document: custom layout and visibility of document's panes

such as bookmarks, thumbnails etc.
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Default View. Determines which parts of the PDF display are visible for the newly-opened

document and this view may be changed after the document is opened. 

Valid values are: 

· Automatic uses the page display information from the PDF to determine how the PDF is

displayed. 

· Page only display only the page. No panels are displayed. 

· Bookmarks panel and page displays Bookmarks and PDF pages. 

· Thumbnails panel and page displays Thumbnails and PDF pages.

Restore last used page layout and zoom settings while opening a document from the Recent

List. When checked, and a file listed on the Recent Files list is opened, uses the page display

settings last used for that document.

Default Page Layout Determines how the pages are arranged and whether to use continuous

scrolling or discrete paging. The view may be changed after document is opened. 

Valid values are: 

· Automatic uses the page display information from the PDF to determine how the PDF is

displayed. 

· Single Page only displays a single page at a time. It is not possible to scroll the pages to see

part of one and part of another. 

· Continuous may display parts of two or more pages simultaneously. 

· Two pages Continuous displays pages side by side and sections from more than two pages

may be viewed simultaneously. 

· Continuous - Cover Page will include a cover page. Most noticeable in two pages, and two

page continuous. 

The first page of the document will display to the right of a blank space so that subsequent

pages display like a book. 

For example, Page one is displayed, then pages 2 and 3; 4 and 5, and so on. The pages will

scroll smoothly, but may display parts of two or more pages simultaneously. 

· Two Pages are displayed side by side in pairs, but only two pages may be viewed at a time. 

· Cover Page display will include a cover page. This is most noticeable in two pages, and two

page continuous. 

The first page of the document will display to the right of a blank space so that subsequent

pages display like a book. 

For example, Page 1 is displayed on the right, then pages 2 and 3; 4 and 5; 6 and 7, and so

on. 
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Default Page Zoom Determines how the pages are initially fitted to the display window. The view

may be changed after opening the document. Valid values are:  

· Automatic Uses the page display information from the PDF to determine how the PDF is

displayed. 

· 100% Page is displayed as Actual Size. 

· 50% Page is displayed half-size. 

· 25% Page is displayed quarter-size. 

· 12.5% Page is displayed one-eighth size. 

· 8.3% Page is displayed one-twelfth size. 

· Actual Size Page is displayed actual size (100%). 

· Fit Width Page is fitted into display area so page width is displayed. This usually results in

some of the page not being visible without scrolling. 

· Fit Page Page is fitted into display area so entire page is displayed. 

· Fit Visible Page is displayed without margins.

Page Display

Determines how the PDF is initially displayed. 

Display art, trim, bleed boxes When ticked, any art, trim, or bleed boxes defined for a document

are displayed. 

Display large images When checked, the large images are displayed. 

Display transparency grid When checked, the grid behind transparent objects is displayed. 

Use logical page numbers Logical page numbers will allow for renaming of thumbnails in the

Thumbnails Pane  and page number prefixes such as roman numerals for the table of contents.

For instructions on how to make the best use of logical page numbering, and how to modify page

number, please see the How to Modify Page Labels  section. 

296
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Use Resolution Page resolution in pixels per inch (DPI). 

· Automatic: 96. Standard display monitors are 96 DPI. 

·   72 DPI

·   96 DPI

· 100 DPI

· 120 DPI

· 132 DPI

· 150 DPI 

· 163 DPI 

· 264 DPI 

· 300 DPI

Forbid the change of the current Zoom factor during execution of ‘Go to Destination’ actions

(these actions can be launched from bookmarks, hyperlinks, java scripts). 

Rendering

Opens the Rendering dialog that controls the smoothing and contrast settings.

Edit> Preferences> Page Display> Rendering window
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Smoothing

Results in a "softer" look but some fine detail may be lost. 

Smooth Text Applies smoothing to the text. 

Smooth line art Applies smoothing to remove abrupt angles in lines. 

Smooth images Applies smoothing to minimize abrupt changes in images. 

Advanced

These are advanced display options for color modes and object rendering. 

Enhance thin lines when lines are defined in a metric measurement such a point (pt), the object

may not line up well with the pixels on screen and result in some blurring. When this options is

turned on, these lines will be rendered so that the edges line up well with the pixels on screen. 

Note: This option has not yet been implemented at the time of documentation (03-04-

2016).

Synchronous page rendering defines the rendering method to be used.

· Auto This option may cause the Editor to wait for the current page to finish rendering

before moving on to the next, but will render multiple pages when scrolling to optimize

smoothness.

· No Pages will be rendered only when the current page has finished rendering. This may

cause some lag when scrolling though long documents. Especially if the document contains

many objects and images.

· Yes All pages will be rendered simultaneously. This may cause the editor to initially render

slowly, but will remain smooth when finished.

Default transparency blending color space

· Auto will use RGB color when there is no transparency between intersecting objects, and will

use CMYK when transparency exists.   

· Working RGB will only use RGB color space.

· Working CMYK will only use CMYK color space, then convert it to RGB for displaying on

screen. 

· Working Grayscale will only use grayscale when rendering. 
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7.2.7.3.1  How to Modify Page Labels

The PDF-XChange Editor permits one to type “xxiv” or the like into the page number field in the

Page Navigation Toolbar  to reach a page (such as one finds in scholarly citations) without

guessing at its absolute page number. It is also possible to to have the special page numbers

displayed in the Thumbnails Pane for each page. 

In this example, I am using a PDF with pages watermarked  1-100, which currently corresponds

with the actual page numbers as shown in figure 1.

Figure 1: Editor Window with Thumbnails Pane

617
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The target is to set Page 1 as the Front Cover (FC), pages 2-10 labeled as roman numerals (I, II, III,

IV, V, VI, VII, and IX,). Then Pages 11-99 labeled 1-88, and finally label the last page as the back

cover (BC). Throughout this section , you will need the Thumbnails Pane  open as shown Figure

1. You can activate it using Ctrl+T, or by going to  View >Thumbnails. You will also need to turn

on "Use Logical page numbers  ". You will find that option under Edit >Preferences >Page

display as shown in Figure 2.

Figure 2: Edit >Preferences >Page Display Window

296
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Page Ranges

First, right click on that page's thumbnail, then go to "Number Pages"

Figure 3: Right click context menu on Thumbnail in Thumbnails Pane

In the following dialogue, please set the the desired page ranges by choosing Add New Range.

Figure 4: Number Pages >Add New Range Window
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Because a page range Starting at page 1 exists, you will need to Enter the start value of the next

page range to indicate the end of the previous. Typing in 2, will result in page ranges 1, and 2-100

as indicated by the yellow range bar:

Figure 5: Page ranges

You will then need to add all the other page ranges (2-11,12-99,and 100). Once that is complete,

you should see the following:

Figure 6: Page Numbering Window

Note: The yellow indicates the currently selected page Range.
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Front Cover (FC)

Select the 0-1 page range, then change the style to "None". You will then be able to add a Prefix

such as "FC":

Figure 7: Page Numbering Window 

Note: In the Preview section of the "Page Numbering" dialogue, the BOLD section is the

currently selected page range. 

You will see that now, the page which is actually the second page in the PDF is now labeled as Page

1 as shown by the close-up screenshot of the Thumbnails Pane  in figure 8.

Figure 8: Thumbnails Pane Close-up 

296
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Book Front Matter

Choose the pages 2-11 page range, and change the Style to roman numerals (or your desired style).

Make sure you set the "Start numbering from:" option to 1. 

Figure 9: Page Numbering Window

Main Pages (12-99)

For the main pages, unless another convention is desired, simply leave the style as 1, 2, 3, ...
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Back Cover (BC)

Select the 100 page range, then change the style to "None". You will then be able to add a Prefix

such as "BC":

Figure 10: Page Numbering Window

Results:

Figure 11: All pages Thumbnails Pane
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Figure 12: Editor Window showing the Front Cover (FC) in the navigation Toolbar.

Notice the page numbers for each thumbnail are now defined correctly to match the theorized

document instead of the actual document's pages. As long as you have logical page numbers

turned on as described at the top of this section, you should see the special page labels in the 

Thumbnails Pane  as well as the Navigation Toolbar .296 617
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7.2.7.4 Page Text

Page Text

The Edit> Preferences> Page Text section contains options which can allow for links and ligature

detection as well as white space adjustments when Copy/Pasting. 

Edit> Preferences> Page Text window

Detect Interactive Text Links

Contains settings for detecting and applying links within text.

Create Links from URLs in page text (i.e. "Http://www.server.com") text recognized as a

link or URL will automatically become active and can be clicked to bring up additional content. 

Handle IP-addresses (i.e. "173.194.33.46") IP- addresses will be shown appropriately. 

Skip IP-addresses without protocol prefix text without the necessary protocol prefix will be

ignored.  
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Copy Text Options

Determines the amount of space(s) put between words while copy/pasting the text. 

Copy white spaces mode: From the drop down list, select the desired method for detecting

white space.

§ Distance words proportionally

§ Only one white space between words

§ Preserve original white space only.

Preserve original ligatures will preserver all original ligatures. Otherwise, a ligature may be

populated with its individual parts.

Note: In writing and typography, a ligature occurs where two or more graphemes or

letters are joined as a single glyph. An example is the character æ as used in English, in

which the letters a and e are joined.
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7.2.7.5 Full Screen

Basic Usage

Enter Fullscreen by pressing F11. Navigating the document is easy; users can make use of the

mouse roller, keyboard, and Left click/Right click. Left click goes one page further into the

document, right click goes back one page. Leave full screen mode by pressing Esc

Changing Preference

When not in full screen mode, Preferences can be adjust by going to Edit> Preferences>

Fullscreen. At all times, using the keyboard shortcut Ctrl+K will access the Edit> Preferences

window 
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General

When document request full screen mode: The option to allow, Deny, or Ask User Before are

provided. These come into effect when a document has a script that automatically wants to

open in full screen.

Which monitor to use: In instances where more than one monitor is being used with a given

computer, you may choose to always have full screen on any particular screen. Current, Tallest,

Widest, biggest and primary are automatically pulled from the system's current information. 

Stay awake:  When this option is ticked, the screensaver will not activate and the computer will

not go to sleep/hibernate

Page Navigation

Exit by pressing 'Esc' Specifies if pressing Esc key leaves full screen mode to return to regular

desktop mode.  

Presentation Mode: Switches the control to Presentation mode:

· Left mouse-click goes to the Next page, Right mouse-click goes to the previous page.

· Press the "B" or "W" key to make the whole screen black or white.

· Press the "P" key to pause the automatic turning of pages and press it again to resume.

· Commenting and form-filling are inaccessible. 

Show pages Navigation Bar: This helps to navigate the document from buttons on the

bottom corner.

 Go to first Page

 Go to Previous Page

 Go to Next Page

 Go to Last Page

 Exit Fullscreen 

Loop After last page: When navigating thought the pages of the document, the editor will

revert to the first page when this option is selected and the last pages is passed.

Automatically go to next page after___: This is for passive presentation. The Editor

automatically goes to the next page after the time specified has elapsed.
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Appearance

Background color: When "use solid background" is specified, you can choose the color that is

used for the background in full screen mode.  

Mouse Cursor: You can set to have the mouse disappear after 5 seconds  (Hide after delay),

never disappear (always visible), or never appear (always hidden) 

Page Transition 

Changing the default transitions defines the way the document shows navigation from one page to

the next. Define the transition type in the Default Transition drop down list. Choose the transition

direction if available in the Direction drop down list.
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7.2.7.6 Performance

Performance options affect how well the program utilizes memory and other system resources to

produce the best display. 

N.B. Unless you know what you are doing, we suggest leaving all options set to 

Automatic. 

Memory. This determines the amount of system memory used by the Editor, in percent of

Physical memory. The minimum used will be 40Mb, the amount specified by Automatic.

Allocating more than this may improve Editor performance, but possibly at the expense of

overall system performance.

· Use system memory in percentage points. 

· Use system memory in megabytes. 

Threads Usage. The values are Automatic, 1, 2, 4, 8. We strongly recommend leaving these set

to Automatic. 

Turn off all textured backgrounds to improve UI performance on terminal session.
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7.2.7.7 Color Management

Color Management allows you to adjust color settings for PDF printing and display. We

recommend that only users with experience in Windows color management make adjustments to

these properties. 

Color Settings. Drop box determines whether Color Management is to be used or not. The valid

options are: 

· Default.

· Save Current Settings. 

· Delete.

· Manage...

· Off. No color management will be used. 

· Custom. The remaining color settings will be used to condition the display of PDF

images.
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Working Spaces. Determine which specific settings apply to images saved with different color

options.

RGB. Conditions display of images using RGB settings. Valid options are: 

· sRGB IEC61966-2.1. Default setting. sRGB is a RGB color space proposed by

HP and Microsoft because it approximates the color gamut of the most

common computer display devices. Since sRGB serves as a "best guess" for

how another person's monitor produces color, it has become the standard

color space for displaying images on the internet. sRGB's color gamut

encompasses just 35% of the visible colors specified by CIE. Although sRGB

results in one of the narrowest gamuts of any working space, sRGB's gamut is

still considered broad enough for most color applications. 

· Adobe RGB (1998).

· Generic Monitor Adobe1998RGB D65 WP 2.2 Gamma.

· Generic Monitor AppleRGB D65 WP 1.8 Gamma.

· Apple RGB.

· CIE RGB.

· ColorMatch RGB.

· DiamondTron Monitor G22 D93.

· Hitachi Monitor G22 D93.

· RICOH RUSSIAN-SC 040402. 

· KODAK DC Series Digital Camera. 

· NEC Multisync Monitor G22 D93.

· NTSC (1953).

· PAL/SECAM.

· ProPhoto RGB.

· SMPTE-C.

· sRGB IEC61966-2.1.

· Trinitron Monitor G22 D93.

· Wide Gamut RGB.
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CMYK. Conditions display of images using CMYK settings. Valid options are: 

· U.S. Web Coated (SWOP) v2. Specifies adaptation to standard coated printing

papers. 

· Coated FOGRA27 (ISO 12647-2:2004).

· Coated FOGRA39 (ISO 12647-2:2004).

· Euroscale Coated v2.

· Euroscale Uncoated v2.

· Japan Color 2001 Coated.

· Japan Color 2001 Uncoated.

· Japan Color 2002 Newspaper.

· Japan Web Coated (Ad).

· Photoshop 4 Default CMYK.

· Photoshop 5 Default CMYK.

· Uncoated FOGRA29 (ISO 12647-2:2004).

· U.S. Sheetfed Coated v2.

· U.S. Sheetfed Uncoated v2.

· U.S. Web Coated (SWOP) v2.

· U.S. Web Uncoated v2.

· Web Coated FOGRA28 (ISO 12647-2:2004).

Grayscale. Conditions display of grayscale images. The only valid option is: 

· Gray Gamma 2.2.

Conversion Options. Allows you to adjust the color space conversion in a document.

Engine. Determines which engine will be used for color space conversion. The only valid

value is: 

· Little CMS. LittleCMS is a CMM, a color management engine; it implements

fast transforms between ICC profiles. 

Use Black Point Compensation.
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7.2.7.8 Languages

Languages allow you to localize your copy of the Editor to the language set you are most

comfortable with. This adjusts all controls and labels to use the selected language. 

Options are: 

1. Select preferred interface language. Allows the user to select which alternate language to

use from a list. Note that there are more languages available than indicated here. 

2. Use Regional Settings. Sets to user's regional settings.

3. English (US), Built-In. This selects the application language which is English. 

4. Set As Default. Sets the specified settings as default.

Please contact Tracker Software Products Ltd for more information.

http://www.tracker-software.com/contact
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7.2.7.9 Prompts

Prompts allow you to restore the confirmation prompt box of the operation. 

While performing some operations in PDF-XChange Editor, the program shows you a dialog box

with a checkbox which allows you to save your choice for future, like in the following example:

If you select the checkbox and click on Yes button, PDF-XChange Editor will remember your choice

and will not show the warning message next time you try to perform the same operation.

To restore the warning message and confirmation prompt you have to click the Restore default

dialog state button.
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7.2.7.10 File Associations

File associations are how Windows identifies a file or file type with a particular program. These can be set

within windows under "Control Panel\Programs\Default Programs\Set Default Programs" and

"Control Panel\Programs\Default Programs\Set Associations". File associations for the PDF-XChange

Editor can also be set by going to Edit> Preferences> File associations from within the Editor itself.

Note: Some file associations cannot be set through the Editor while running in Windows 10.

Windows 10 users may need to manually set the file associations though windows.

Edit> Preferences> File Associations window
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The Current default PDF Application is shown at the top of this window.

Example wherein Microsoft Edge is set as the default.

The options listed for file associations offer 3 choices each:

· Do not change retains the existing associations.

· Restore Restores the previous associations

· Make default/Yes sets the option as default/on.

Note: When clicking on apply, these options will revert back to Do not change.

Set as Default Application for PDF files: Defines the default application for viewing PDF.

View PDF Files in Internet Explorer: When set to Yes PDF can be opened directly in Internet Explorer

using the Editor Plug-in.

Register NP-Plugin for Other Browsers: Registers the NP-Plugin to view PDF in supported browsers.

Preview Handler for PDF Files: Defines the preview handler for previewing PDF in windows explorer.
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Thumbnails Handler for PDF Files: Defines how PDF thumbnails are shown in windows.

File Explorer (Windows Explorer) with Preview and Thumbnail examples

See the thumbnails displayed on the Left, and the Preview to the right.

Apply changes only to current user With this option selected, only the current user's associations will

be modified.
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7.2.7.11 Registration

Registration allows you to register your copy of the PDF-XChange Editor. 

The valid serial key is provided to the registering party when they purchase the PRO version. When

set to Trial, the program runs in the FREE Evaluation Mode. Please see IMPORTANT! FREE vs. PRO

version  for additional information.

When you install the serial key, your Editor's PRO features will be activated. 

To install the serial key, copy your personal key into the Clipboard and then click the Add Key from

Clipboard... button. The key will immediately appear in the list of Installed serial keys on the

Registration tab followed by the message:

12
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The Activate... button will help you in case you need to activate the existing license key. Just enter

the necessary information into the following dialog box: 

Hide all protected features in all toolbars and menus. When checked in 'FREE' mode, items

labeled 'PRO' in the menus and toolbars will not be displayed, thus preventing accidentally

modifying the PDF in a way that would cause the watermarks to appear in the PDF when saved.
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7.2.7.12 Accessibility

Accessibility controls color options for displaying PDF pages for people with poor or limited

eyesight. 

Override Document Colors. When checked, PDF document colors will be overridden and the

other controls on the screen become active. 

Color Scheme. Use Predefined High-Contrast Color Scheme: 

· Windows. Use the color scheme from Windows accessibility options. 

· Green on Black. Green text on Black background. 

· Yellow on Black. Yellow text on Black background. 

· White on Black. White text on Black background. 

· Black on White. Black text on White background. 

· Save Current Settings. Saves all current settings.

· Delete. Deletes the selected color scheme.
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· Manage.... Opens the Manage Presets dialog, which allows you to delete, edit or

clone any of the available color schemes.

Document Color Scheme Options. Allows you to adjust the document color scheme. 

Page Background. This opens the standard Color Selection dialog to assist you in

selecting a page background color. 

Text Color. When checked, this allows you to open the standard Color Selection dialog

to assist you in selecting a text color. 

Line Art. When checked, this activates the following two controls: 

Fill Color. This opens the standard Color Selection dialog to assist you in

selecting a Line Art Fill color. 

Stroke Color. This opens the standard Color Selection dialog to assist you in

selecting a Line Art Stroke color. 

Change the color of black text or line art only. When checked, color changes will only occur

for text and line art that appear as black on white. Other color combinations will not change.
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7.2.7.13 Measurement

Measurement determines the linear units to use for all displays. 

Units and Rulers. Valid unit values are: 

· Point. 1/72 inch. 

· Inch. 

· Centimeter. 

· Millimeter. 

· Pica equal 1/72 of a foot and so to 1/6 inch. There are 12 points in the pica.

Show Rulers. Shows or hides rulers.

Show Fractions. Shows or hides fractions.
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Grid and Guides. Grids provide a visual reference for aligning objects vertically and\or

horizontally to specific page positions according to Ruler increments. 

· Distance between grid lines. Allows you to specify the distance between grid lines.

· Grid lines origin offset. Changes the grid offset.

· Subdivisions for Grid. Specifies the number of lines that appear within a given

distance. 

· Show Guides. Shows or hides guides. 

· Guides Style. Allows you to specify the guide lines’ style. 

· Grid Lines Style. Allows you to specify the grid lines’ style. 

· Use Snapping (to Grid, Guides, Objects). When this option is checked, snapping

will be used. 

Customize.... 

Show Snap location marks. Shows or hides snap location marks. 
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Grid. 

Snap to Grid. Aligns an object with the nearest grid line when you move the

object.

Snap only to Grids Intersections.

Threshold. Allows you to choose the level of sensibility. Valid values are:

Low, Medium, High. 

Guides. 

Snap to Guides. Aligns an object with the guide lines when you move the

object. 

Threshold. Allows you to choose the level of sensibility. Valid values are:

Low, Medium, High.

Objects. 

Snap to Objects. Aligns shapes with other objects. 

Snap to Annotations Only. Allows snapping to annotations only. 

Threshold. Allows you to choose the level of sensibility. Valid values are:

Low, Medium, High.

Snap to: 

End Point. Allows snapping to end point of the object. 

Edge. Allows snapping to the edge of the object. 

Mid Point. Allows snapping to middle point of the object.

Center. Allows snapping to the center of the object. 

Intersection.

Select All. Selects all. 

Deselect All. Deselects all.
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7.2.7.14 Identity

Identity allows you to store frequently-used information about yourself that can be added to PDF's

that you are annotating.

N.B. Such information is never exported without your knowledge and approval.

The fields are self-explanatory.
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7.2.7.15 JavaScript

JavaScript controls the behavior of JavaScript execution within the PDF-XChange Editor. 

N.B. Use of JavaScript capabilities is a programmer-level task! You have been warned. 

JavaScripts may be embedded in PDF documents and activated by either AcroForm controls or by

events generated by manipulating the document in various ways. 

JavaScript. Enables or disables JavaScript actions. 

Enable JavaScript Actions. Checking this checkbox allows JavaScript to execute within

the specified PDF document. If unchecked, the next checkbox becomes active. 

Show warning when JavaScript action executes. When Enable JavaScript Actions is

not checked, checking this box will pop up a warning screen when a JavaScript

attempts to execute. 
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JavaScript Console Enables or disables the JavaScript console. The JavaScript console is a part

of the JavaScript environment that allows you to view an embedded JavaScript and also allows

you to execute JavaScript commands.

Enable JavaScript Interactive Console. Checking this checkbox enables the JavaScript

console integral to the PDF-XChange Editor. 

Show Console on Errors and Messages. When checked, the JavaScript console will be

activated if the JavaScript being executed either encounters an error or if it displays

a message. 

Console Font. Specifies the Font to use when displaying the JavaScript console. 

Font Size. Specifies the size of the Font to use when displaying the JavaScript

console. 

To open the JavaScript Console use shortcut keys [Ctrl]+[J] or go to View menu-> Show

JavaScript Console.
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7.2.7.16 Snapshot Tool

This screen controls the behavior of the Snapshot Tool. 

Image Copy Options. These control the images produced by the Snapshot Tool. 

Used specified resolution for snapshot images. When checked, all snapshot images

will be produced at the resolution specified by the Resolution drop box. 

Valid values are: 72, 96, 100, 150, 300, 400, 600, 1200, and 2400 DPI. 

Force snapshot images to grayscale. Checking this checkbox converts the image from

colored to grayscale. 

This can reduce the image size quite a lot especially at higher resolutions. 

Automatically copy image to clipboard after move or resize.

Select All type. 

Select visible portion of nearest page. Copies a part of the nearest

page.

Select nearest whole page. Copies the whole nearest page.
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Notifications.

Play a sound. When checked, the sounds are made when the snapshot control is clicked

to produce the snapshot. 

Flash the selected region. When checked, the selected region when the snapshot

control is clicked to produce the snapshot. 

Automatically name bookmarks from selected text.
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7.2.7.17 Forms

Forms allow you to control the options of form fields. 

General. Allows you to set the general options for the form fields. 

Automatically calculate form field values. Automatically performs all field calculations

upon user entry. 

Show focus rectangle. Indicates the form field which currently has the focus. 

Show text overflow indicator.

Highlight Form Fields. Allows you to set the highlight options for the form fields. 

Highlight Form Fields When Document Opened. 

Highlight Required Fields Only. Allows you to select a border color of form fields. The

border appears for required form fields only after you attempt to submit the form.  

Fill Color. Opens the standard color selection dialog to assist you in selecting the

color of highlighted form fields. 

Border Color. Opens the standard color selection dialog to assist you in selecting

the border color of highlighted form fields.
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Show Hover Border for Fields. 

Hover Color.

Highlight All Form Fields. Allows you to apply highlight options to all kinds of form

fields. 

Highlight Only Fields of Selected Types. 

Combo Boxes. Allow you either choose an item from a pop-up menu or type in a

value. 

Check Boxes. Present yes-or-no choices for individual items. If the form contains

multiple check boxes, the user can typically select as many or few of these as

wanted. 

List Boxes. Allow you to choose a displayed list of options.

Push Buttons. Initiates a change on the user’s computer, such as opening a file

or others. 

Radio Buttons. Present a group of choices from which the user can select only

one item. 

Signatures. Allow you electronically sign a PDF document with a digital

signature.

Text Boxes. Allow you to type in text. 

Barcodes.



249

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

7.2.7.18 Commenting

Commenting allows you to select two ways to copy text into Comments. 

Comments Viewing Options. 

Display Subject Label in comment pop-ups. The subject label will be displayed in

comment pop-ups. 

Display Author Label in comment pop-ups and tooltips. The author label will be

displayed in comment pop-ups and tooltips. 

Display Modification Date in comment pop-ups. The modification date will be

displayed in comment pop-ups. 
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Comments Creation Options. 

Copy encircled text into Drawing comment pop-ups. For drawing-type comments,

encircled text will be copied into the pop-up comment, where it can be edited or

further commented on. 

Copy selected text into Highlight, Cross-Out, and Underline comment pop-ups.

When using the Select Tool , selected text will be copied into the pop-up comment,

where it can be edited or further commented on. 

Paste comments into mouse position. Copied comments will be pasted into mouse

position.

508
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7.2.7.19 Signatures

Digital signatures can be used for many types of documents where traditional pen-and-ink

signatures were used in the past. However, the mere existence of a digital signature is not adequate

assurance that a document is what it appears to be. Moreover, government and enterprise settings

often need to impose additional constraints on their signature workflows, such as restricting user

choices and document behavior during and after signing. 

Place a digital signature to any unsecured document by going to Document> Digital Signing. See

the Digital Signing  section for more details. See bellow for help with configuring Creation and

Appearance, and Verification of digital signatures. These preferences are located under Edit>

Preferences> Signatures.

Edit> Preferences> Signatures window

432
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Creation and Appearance

Control options for signature creation and set the appearance of signatures. Click on More... to

launch the Creation and Appearance Preferences window. 

Creation and Appearance Preferences window

Creation define how the signatures are created in this section. 

Default Signing Method define the default method for signing such as a signature pad or

other hardware. 

§ Default DigiSig Handler is the default plug in library used to apply digital signatures

and certificates to PDF documents. If no other signing method is detected, only the

DigiSig will be available. 

Default Signature Format

§ PKCS#7 - Detached Ensures that certificates are encoded in Abstract Syntax Notation

One (ASN.1) format, where ASN.1 is an ISO/IEC standard for encoding rules used in

ANSI X.509 certificates and PKCS documents.

§ CAdES An electronic signature that has been created in compliance with eIDAS has the

same legal value as a handwritten signature.

Include signature's revocation status Signature revocation can be used with a remotely

controlled signature or certificate. Such a certificate can be revoked by the issuer. This option

will simply display whether or not the certificate/signature has or has not bee revoked. 

Flush PIN cache before applying signature Some certificates require a personal

identification number to be used. In some cases the PIN is cached in memory for a short time

so that the PIN is not requested. Flushing the PIN cache will force the prompt to enter the PIN

if the certificate requires it. 
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Appearances click on More... to access the Digital Signature Appearance Templates window.

Note: Click on one of the default templates and click Edit to edit its appearance.

Otherwise, click on Clone to copy the template, then edit the copy to preserve the original.

Show Graphics will specify an image, or Icon to use with the digital signature. To display any

Icon/log, insure that the Display Logo option is selected.

No Icon will cause the signature not to use any image, only the parameters set in the

Show Text section will be displayed. 

Name as Icon will use the signer's name instead of an Icon

Custom Icon define a path to a desired image to be used as an Icon. Most commonly

used with digital copies of handwritten signatures. Click on the  Browse button to

select the desired file.
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Show Text: Select the text information to be populated in the signature. 

Name displays the signers name.

Distinguished Name combines a key to each value the prefaces the name. E.g.

"Digitally signed by Jack Jones" with the option active, and "Jack Jones" with it inactive. 

Reason will display the reason defined at time of signing. 

Subject the subject is taken from the digital certificate's subject. 

Location lists the country the document was signed in. For example, CA for Canada.

Date displays the date at the time of placement. 

Labels will add labels before the data displayed in the signature. such as C= CA for

Country = Canada instead of listing only the values without the labels.

Editor Version displays the version of the Editor used to place the signature.
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7.2.7.20 Scanner Presets

Scanner Presets control the options for scanning.

Parameters. Sets the parameters for scanning.

Scanner. Selects the scanner on which to scan the document. 

Data Transfer Method.

Native Mode transfers in the default mode for your scanner. Memory Mode is automatically

selected for scanning in resolutions over 600 dots per inch (dpi).

Show Native UI. 

Color Mode. Allows you to choose the color mode.

Resolution. Sets the desired 'DPI' (Dots per inch) for the file pages. This can be any value from

50 to 2400 DPI - though this is also MS Windows OS dependant; some earlier Versions of

Windows do not support DPI settings of such high values.

Paper Size. Allows you to choose an appropriate paper size.

Setup.... 
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Sides. Sets the scanning side. The options are: 

· Both Sides. Scans both sides of pages.

· Front Sides. Scans only front sides of pages.

Scan More Pages. Lets you select one of the following options:

· Disabled. Disables the scanning of more pages.

· Ask user. When scanning is finished, you will be asked if you want to scan more pages.

· Automatically after. When the scanning session is finished, the next one will start

automatically.

Show Presets Dialog.

Show Images Insertion Dialog. 

Images Insertion Options.... Defines additional image insertion options for the new document. 

New Page Options. Allows you to set the page options.

Choose Paper Size by Source. This option specifies the size of the page by the

source.

Standard. Selecting this option allows you to choose the standard size of the page.

Custom. Selecting this option allows you to specify the size of the page.
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Orientation. Sets the orientation of the page. 

§ Portrait. The longer side of the page runs vertically.

§ Landscape. The longer side of the page runs horizontally.

Page Rotation. Allows you to rotate the page. The fields are self-explanatory.

§ Don't rotate.

§ Clockwise 90 degrees.

§ 180 degrees.

§ Counterclockwise 90 degrees.

Margins. Margins adjust the size of the page by setting non-zero margins using the

selected "user units." The adjustments are:

§ Left. The left margin is moved to the right by the amount specified in Units.

§ Right. The right margin is moved to the left by the amount specified in Units.

§ Top. The top margin is moved down by the amount specified in Units.

§ Bottom. The bottom margin is moved up by the amount specified in Units.

Images Layout Options. Allows you to set the image layout options.
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Layout Rules. Sets the layout rules options.

Horizontal count. Specifies the number of columns for the horizontal layout.

Vertical count. Specifies the number of columns for the horizontal layout.

Horizontal space. Controls the amount of horizontal space around an image.

Vertical space. Controls the amount of vertical space around an image.

Align Images. Sets the image alignment.

Fit. When checked, the image will be sized to fit the new PDF page.

Keep aspect ratio. Depends on Fit. When checked, the image will be resized to fit the

new PDF page, but there will be no distortion of the page. 

Horizontal alignment. Sets the horizontal alignment of the images. 

· Left.

· Center.

· Right.

Vertical alignment. Sets the vertical alignment of the images.

· Top.

· Middle.

· Bottom.

Image Labels. Allows you to set the image label options.
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Image Label. Allows you to add a text label for the image.

Use special text label for each image. Specifies the text label for each file. You

may enter any valid name you like.

Macros. Clicking the Macros button opens a submenu of file name macros that

you can use to automatically generate file names. 

The fields are self-explanatory.

Back color. Opens the standard color selection dialog for you to customize the

background color for the image label.

Paragraph.... Specifies the paragraph settings for the text label.

Font.... Specifies the font settings for the text label.

Place label above image. If checked, the label will be placed above the image.

Add bookmark for each image with the same text as label. If checked, a

bookmark will be created for all images with the same text as label.

Image Processing. Allows you to set the options of image’s downsampling and

conversion.
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Downsampling and Conversion.

· True Color. Applies image downsampling and conversion options for

true color images.

· Grayscale. Applies downsampling or conversion options for high color

and grayscale images.

· Indexed. Applies downsampling or conversion options for indexed

images.

· Monochrome. Applies downsampling or conversion options for

monochrome images.

Downsampling. Downsampling decreases the number of pixels in an image. To

downsample images, choose a downsampling method (linear, bilinear, or bicubic

downsampling) and enter the desired resolution (in pixels per inch). Then enter a

resolution in the for images above text box.

· No Downsampling. Allows you to disable downsampling if the PDF

file is to be printed at high resolution.

· Linear Downsampling to. The classical linear downsampling approach

is based on the removal from the original image of those frequencies

which are too high to be represented at a lower resolution level.

· Bilinear Downsampling to. Adds pixels by averaging the color values

of surrounding pixels. It produces results of medium quality.

· Bicubic Downsampling To. Is a more precise downsampling method

based on an examination of the values of surrounding pixels. 

Using more complex calculations, Bicubic downsampling produces

smoother tonal gradations than Linear or Bilinear ones.

Conversion. Allows you to change the images’ color mode for grayscale,

monochrome or black & white.

· No Conversion. No images will be converted.

· Convert to Grayscale. Images will be converted to grayscale.

· Convert to Monochrome. Images will be converted to monochrome.

· Convert to Black & White. Images will be converted to black & white.

· Dithering. When the Dithering option is selected, Photoshop mixes

colors in the destination color space to simulate a missing color that

existed in the source space. Although dithering helps to reduce the

blocky or banded appearance of an image.
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Deskew. If checked, it will straighten a skew scanned image.

Image Compression. Allows you to set the image compression options.

· True Color. Applies image compression options for true color images.

· Grayscale. Applies compression options for high color and grayscale images.

· Indexed. Applies compression options for indexed images.

· Monochrome. Applies compression options for monochrome images.

Compression enabled. If checked, it will compress image content depending on

the image compression options selected.

· Auto. The best compression settings will be chosen on your behalf whilst

retaining reasonable image quality.

· JPEG. Best used for colored images.

· Flate. Is used for text, graphics and images.

· JPEG/ZIP.

· JPEG 2000.

· JPEG 2000/ZIP.
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JPEG Quality. A percentage value determining image content quality over

compression - the higher the value entered the lower the compression setting

applied and image quality is retained to a higher degree - lower values make

smaller files.

Image Post-processing.

· Deskew.

· Despeckle.

· Run OCR.
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·

7.2.7.21 Plug-ins

This sections displays a list of the installed Plug-ins, provides options to enable/disable specific

Plug-ins, and access to additional settings for the selected plug-in if available. 

Edit> Preferences> Plug-ins window

Available Plugins Shows the list of all available installed plugins.

· Bookmarks plugin options can be accessed and adjusted from the Main Menu >

Advanced > Bookmarks  

· PDF Converter is the plugin used when saving a file as a MSPowerPoint file. Please see File

> Save As  or File >Export  for more information.

· File Open client this plugin functions silently in the background. It allows the Editor to open

file protected by File Open Digital Rights Management software. 

Find more information at http://www.fileopen.com/

86

574 287

87 97 87 155

http://www.fileopen.com/
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· Google Drive access Google Drive™ functions can be accessed under File > Open From

 , and File > Save to  

· OCR the OCR feature and settings can be accessed through Document > OCR pages...

· PDF/A Converter allows the conversion of PDF files to PDF/A archival specifications. These

functions can be found under File > Save As  

· PDF Optimizer allows the optimization of PDF file sizes under File > Save Optimized

Copy  

· Read out loud The functions of the Read out loud plugin are available through the context

menu when interacting with selected text. The settings can be found under Edit >

Preferences > Speech

· Share Point The functions, and setup instructions for the SharePoint plugin are documented

under Main Menu > SharePoint

· Spell Checker The spell checker can be used when interacting with text within a document. 

Please see View> Other Panes >  Spell Checker  for configuration settings.

These settings can also be accessed by clicking on Setup from the Plug-ins window. 

Enable/Disable Enables or disables the selected plugin. 

Setup.... Opens the dialog which allows the adjustment of additional settings for the selected

plugin. Some plug-ins are not modifiable from this section. Please see below setup options for each

plug in.

Plugin information displays additional information for a selected plugin.

88

92 111 112

327

430

87 97
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100

189

201 275

587 591

282 302 302 443
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7.2.7.22 Send Mail

Send Mail preferences allow adjusting the options for sending a PDF file by e-mail, using the PDF-

XChange Editor. 

Edit> Preferences> Send Mail Options window

Method: There are several methods used to send PDF documents and other attachments by e-

mail. 
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· Ask before sending will cause the Send Mail dialog to open each time using the send by E-

mail feature. 

Send Mail dialog

· Mail Client Sends e-mail message through the default e-mail client application currently

setup as the default Windows e-mail client, with the properties filled as specified on this

preference page. Same as option 1 - but no opportunity to edit the message or add

additional attachments - other than the active PDF document. 

· SMTP Sends e-mail message, bypassing the e-mail client application using the default

values stored in the SMTP options within the PDF-XChange Editor. Setup and use multiple

SMTP servers using this option. For information on setting up the SMTP server information,

knowledge of the SMTP server settings are required - please consult a system administrator

for advice as necessary. 

· Local Launches the default e-mail client application and creates a new email text with the

properties set here. This saves the e-mail to the e-mail client`s local folder, allowing editing

the e-mail, adding additional attachments and send or cancel your message. 
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SMTP Server

Sets the SMTP Server properties.

From. Enter an e-mail address. 

Server Name. Enter the server name. 

Port. Specifies the port of the SMTP server. 

Server Requires Authentication. This check box specifies the login information for the SMTP

server if required. If no authentication required please uncheck this box.

User Name. Enter e-mail user name here. 

Password. Enter password.  

Connection Security. Specify connection security level.

Desktop Client Options 

Modifies the behavior of the default mail client application. 

Show Clients Dialog Window will cause the mail client to launch the email in its own

window. 

Local Store Options. 

Define setting where to store email files for sending locally. 

Destination Folder where the file will be saved

Open the Folder In Explorer on data ready causes File Explorer (also known as Windows

Explorer) to launch and open to the destination folder.

Pack File Attachments the Editor will compress files into a .zip folder before sending.
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7.2.7.23 Launch Applications

The Launch applications section of the Preferences menu allows the addition of custom third party

applications to the Launch Toolbar . 

     Preferences> Launch Applications window

To add an application to the Launch Toolbar. Click on New... This will open the New Launch

Application window. 

619
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New Launch Application window

Name: In the Name field, specify the name to be displayed in the Launch Toolbar for that

application. 

Path: If the path to the file executable is known, type or paste it into this field. Otherwise, browse

for the file by clicking the  button.

Parameters: Parameters are variables which inherit real values of the current document which are

then passed to the command that launches the third party application. These Parameters are

Macros , type or paste them into this field. Otherwise, click on the button to expand the

parameters dropdown menu:

 Parameter Name Variable  Definition

 File Name  %1  Required - Inherits the file name and path

 Zoom  %z  Inherits the zoom level

 Page Number  %p  Inherits the currently viewed page number

 Page (0-base

numeration)

 %p0  inherits the page number beginning in 01, 02...

 Position X (in pixels)  %vx  Inherits the position viewed along the x axis

 Position Y (in pixels)  %vy  Inherits the position viewed along the y axis

 Position X (in pt)  %px  Inherits the position viewed along the x axis in pt

 Position Y (in pt)  %py  Inherits the position viewed along the y axis in pt

 View Rotation  %vr  Inherits the rotated view  of documents.

Parameters drop list

56

610
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How to use Parameters: To use these parameters and their variables, users must know the launch

commands used to for the launch application that they are setting up. In this example, we will use

the PDF-XChange Viewer as a launch application. The Viewer's command line options can be

found in the Viewer manual. The command line options there state, that to open a file with the

Viewer, to a certain page, the /A "page=<page_number>" command must be used. In the

Parameters field, type /A "page=%p" "%1"

The variable %p is substituted by the current page number when the application is launched. Each

parameter muse be separated by an & and contained in "double quotations". The File name (%1)

variable must be contained in its own double quotations. To open a file in using the Viewer as a

launch application, where the page number, and zoom levels are inherited, enter /A "page=%

p&zoom=%z" "%1"

Note: Some applications may not support opening files with some, or any of these variables.
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7.2.7.24 Customize UI

To customize the UI, you must go to Edit> Preferences> Customize UI:

Note: You can customize and create custom toolbars as well. For more information, please see

the How to customize toolbars  section. 

Edit> Preferences> Customize UI Window

There, you will find three major groups: Fonts, Colors, and Backgrounds. As you can see in the

screenshot above, I am currently using the Default UI settings.

620
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Fonts

Here you will see two sections: One for the font in the Toolbars, and the other for fonts within

windows and dialogs as well as their respective font size.

Toolbar and menu bar Fonts:

General UI font for windows and dialogs
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Colors

In Colors, you will see a few sections where you can change the default color. For Face, I choose a

darker color which you can see in the screenshot below. Selection Color refers to the currently

active button such as the Ok Button showed below.. Changing the Highlight Color will effect

Selected Items in the UI such as Tabs and tools as shown by the Apply button bellow. 

We find the darker face color to be easier on the eyes and does not conflict with the color of text.

Of course the text color can be changed to accommodate a darker UI.        
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Backgrounds

In the backgrounds section, users can choose from different background types, and colors.

Type: The Type drop down menu allows the user to select which background area is currently being

modified by the other options in the Backgrounds section of the Customize UI Window. 

· Main Background secondary UI items such as scroll bars and borders. 

· Pages Background Refers to the background in the PDF display area.

· Dialog Background is the background for all dialogues. 

Style/Pattern can be used to specify a special texture for each of the Type options from the Drop

Down menu. The color overlay for these background options can be chosen from the drop down

menu to right of the Style/pattern drop down menu as shown by the screenshot below: 

Backgrounds

To apply the changes, go to Apply, or Click on OK.
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7.2.7.25 Speech

Speech controls the behavior of the Sound Tool.

Read Out Loud Options. Set the options of reading the text in a PDF document.

Volume. Controls the volume.

Use default voice. The default voice will be used.

Voice. Opens the list of possible voices for you to choose.

Use default speech attributes. If checked, the pitch and rate will be set by default. If

this option is not checked, you can change the pitch and rate of the voice manually.

Read Comments. If checked, the text including comments will be read.

Read Form Fields. If checked, the text including form fields will be read.

Test. Allows you to test the voice settings. 
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7.2.7.26 Security

Find global security options under Edit> Preferences> Security. The settings found here are

specific to the PDF-XChange Editor File Open and Program Launch options and do not apply to any

particular document. 

When Document is Trying to Open a File define the behavior when a document tries to open a

file. 

· Use Trusted/Untrusted list will refer to the trusted/untrusted list. If undefined in the list,

the Editor will prompt to open the file. 

· Prevent it the file will not be opened, and there will be no prompt.

· Allow it opens the file without user input or warning. 

· Allow PDF(s) and use Trusted/Untrusted list for other PDF files will be allowed to open,

however other files will refer to the Trusted/Untrusted list. If undefined in the list, the Editor

will prompt to open the file. 
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When Document is Trying to Open an Attachment defines the behavior when documents

attached to the current document try to open. 

· Use Trusted/Untrusted list will refer to the trusted/untrusted list. If undefined in the list,

the Editor will prompt to open the file. 

· Prevent it the file will not be opened, and there will be no prompt. Open attachments from

the Attachment Pane  . 

· Allow it opens the file without user input or warning.

· Allow PDF(s) and use Trusted/Untrusted list for other PDF files will be allowed to open,

however other files will refer to the Trusted/Untrusted list. If undefined in the list, the Editor

prompt to open the file. 

When Document is Trying to Open a Site

· Use Trusted/Untrusted list will refer to the trusted/untrusted list. If undefined in the list,

the Editor prompt to open the link.

· Prevent it will prevent links from opening. 

· Allow it will allow links to open 

· Allow PDF(s) and use Trusted/Untrusted list for other if the link points to a web-based

PDF, it will open. Will refer to the Trusted/List for all other links. If undefined in the list, the

Editor prompt to open the link.

Trusted/Untrusted Locations and Names: This contains a list of trusted and untrusted items. Click

on Add to add a new Trusted or Untrusted Item. Click on Edit... to modify an Item selected in the

Trusted/Untrusted list. 

Clicking on Add opens a drop-down menu that allows for the addition of a File, Folder, Host or File/

Host Pattern. 

Add File launches a standard File Open window to select a file to mark as trusted or untrusted.

Add Folder launches a standard Folder Select window to select a folder to mark as trusted or

untrusted.

309
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Add Host opens the Add New Trusted/Untrusted Item dialog to add a host address such a link to

mark as trusted or untrusted. 

Add File/Host Name Pattern opens the Add New Trusted/Untrusted Item. Specify a pattern to

be recognized as trusted or untrusted. Patterns can include virtually any text, but are typically used

for file extensions. 

 Edit opens the appropriate Add New Trusted/Untrusted Item window for the

selected item.
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7.2.7.27 Search Providers

PDF-XChange Editor has the ability to search the internet for selected words or phrases. Simply

select a word or phrase, then right click; in the right click context menu, select the search option. 

Right Click click context menu with text highlighted example 1

To configure, or add new search options, go to Edit> Preferences> Search Providers.

Edit> Preferences> Search Providers window
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   Up Moves the selected search provider up in the list.

   Down Moves the selected search provider down in the list.

 Remove Delete the selected search provider.

Turn off all search providers makes all search providers unavailable. 

Allow obtaining  icons for search providers from the Internet will fetch the icon for a search

provider from the URL provided. 

 To add a new search provider click on the New... button. Doing so opens the New

Search Provider dialog.

New search provider window

As described in the dialog, first go to the web page of the "search provider" and search "TEST"

without the quotation marks. Then, copy the URL from the search results into the URL field. For

example going to http://www.tracker-software.com/support and searching TEST in the search

field results in the following URL: http://www.tracker-software.com/support_search?

query=TEST&go_btn=Go

http://www.tracker-software.com/support
http://www.tracker-software.com/support_search?query=TEST&go_btn=Go
http://www.tracker-software.com/support_search?query=TEST&go_btn=Go
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Once set up, the option to search Tracker Software Support from a selected word or phrase will be

available. 

Right Click click context menu with text highlighted example 2

Name: Type the name for the search option. 

Description: Provide an optional description of the search provider. 

Encoding:  UTF-8 is a character encoding method capable of encoding all possible characters, or

code points, defined by Unicode. The encoding is variable-length and uses 8-bit code units. 

To edit an existing search provider, click on the Edit button. Doing so opens the Edit Search

Provider dialog. From here, the settings can be adjusted. See the New section above for a

description of the fields and values. Default search providers cannot be modified.

To set a search provider as the current one, select the search provider and click on Make Current.

This causes the selected search provider to populate in the right click context menu as shown

above. The most recently used search provider is automatically set as current. 
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7.3 View

The View menu offers features for what additional PDF information is displayed in panes alongside

the PDF document.

As well, access to options for how the document is displayed,  hiding or showing rulers, guides and

snapping preferences for use when creating and editing PDF files.

 Toolbars

 Rotate View

 Bookmarks

 Thumbnails

 Other Panes

 Page Layout

 Zoom

 Show

 Snap

 Go To

 Portfolio

 

Note: Bookmarks, Thumbnails, and Comments may be docked either as "Panes" (along the

top of the PDF Display area), "Bars" (along the left or right sides of the PDF Display area) or left as

floating dialog boxes. 
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7.3.1 Toolbars

The Toolbars submenu selects or deselects the following toolbars to be displayed. 

 

Menu Bar 

File Toolbar 

Standard Toolbar 

Rotate View Toolbar

 

Zoom Toolbar  

Content Editing

Toolbar  

Form Toolbar 

Commenting Toolbar 

Measurement

Toolbar 

Document Options

Toolbar  

Document Navigation

Toolbar  

Page Layout Toolbar 

Launch Application

Toolbar 

Properties Toolbar 

Customize Toolbars... 

Please see the Toolbars Area  for additional information. See the How to Customize Toolbars

section for instructions on customizing and creating toolbars.
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7.3.2 Bookmarks

Clicking the Bookmarks item shows the Bookmarks pane. If the Thumbnails pane is displayed, this

hides it. 

The Bookmarks pane has a Bookmark Editor Toolbar at the top of the page that will allow you to

add, change, or remove Bookmarks from the active document. 

See Bookmark Editor  for more information.

The Bookmarks Tree below the Editor Toolbar contains the list of Bookmarks for the active

document.

287
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Clicking the Options button or right-clicking any bookmark brings up the Bookmark pop-up menu:

The menu options are: 

Go to Bookmark. Changes the current displayed page to the one the bookmark points to. 

New Bookmark.... Create a new bookmark. See Bookmark Editor . 

Cut. Cuts the selected bookmark. 

Copy. Copies the selected bookmark. 

Paste. Pastes the copied bookmark. 

Delete. Deletes the selected bookmark. 

Rename. Allows you to rename the current bookmark. 

Set Destination. Sets the bookmark to point to the currently selected page area. 

287
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Make Current Properties Default. Sets the default properties of all bookmarks to match the

currently-selected bookmark. 

Apply Default Properties. Applies the default properties to the selected bookmark(s). 

Text Size. Sets bookmark font size. Valid values are: Small, Medium, Large.

Wrap Long Bookmark. Toggling this on allows long bookmark text to wrap to multiple lines. If

this is unchecked, then long bookmarks will take up only one line but will appear truncated in

the bookmarks pane. 

Show/Hide Icons. Shows or hides bookmark icons. 

Import Bookmarks.... Imports currently selected bookmarks.

Export Selected Bookmarks.... Exports currently selected bookmarks.

Export All Bookmarks.... Exports all bookmarks. 

Properties.... See Bookmark Properties and Actions .288
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7.3.2.1 Bookmark Editor

The Bookmark Editor feature allows you to Add, Change, or Delete bookmarks in the active

document's Bookmark tree.

IMPORTANT! This is a Licensed feature, see IMPORTANT! Evaluation mode vs. Licensed

mode  for more information!

The Editor is controlled by the Bookmark Editor Toolbar:

Each button on the toolbar has a tooltip that appears when you hover the mouse over the button,

so if you cannot remember which button does what, the tooltip will help to remind you.

In addition, each button also has a keyboard shortcut associated with it:

OPERATION KEYBOARD

SHORTCUT

ACTION 

Expand All Bookmarks  <none> Expands all of the bookmarks in Bookmarks View.

Collapse All Bookmarks  <none> Collapse all of the bookmarks in Bookmarks View.

New Bookmark...  Insert

Inserts a new bookmark after the selected bookmark

Other New Bookmark options are:

Alt+Insert - add bookmark before currently selected 

Ctrl+New - add a bookmark as a last child of

currently selected (if current bookmark has no

children, a new one will be added) 

Ctrl+Alt+Insert - add a bookmark as a first child of

currently selected bookmark. 

Properties...  Ctrl+' 
Opens Bookmark Properties screen. See Bookmark

Properties .

Delete  Delete
Deletes selected bookmark(s). More than one

bookmark may be selected for deletion.

Ensure visibility of

corresponding

bookmark

 <none>

Ensures that all of the parent bookmark items of the

selected bookmark will be visible when the document

is opened.

12
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7.3.2.2 Bookmark Properties & Actions

The Bookmark Properties pane may be opened either by selecting a Bookmark in the Bookmark list and

clicking the Bookmark Edit button, or simply right-clicking the selected Bookmark.

IMPORTANT! This is a Licensed feature, see IMPORTANT! Evaluation mode vs. Licensed mode for

more information!

General. Specifies the text of the title to be displayed in the Bookmarks pane.

Style. Sets the font style.

Actions. Defines the action(s) to be performed when the Bookmark is selected.

The Actions list lists the action(s) to be performed when the Bookmark is selected. At the top of

the list is an editor toolbar for the Actions list:

http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=important_free_pro
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1. Add.... Adds a new Action to the list.

Run a JavaScript. Runs the previously specified JavaScript.
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Go To a Page in the Document. Goes to the specified destination in the current document.
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Go To a Page in Another Document. Goes to the specified destination in another document.

Open a Web Link. Opens the previously specified link on the Internet.
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Open a File. Opens the specified file.

Execute a Command. Executed the specified command from the menu.
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Reset a Form. Resets the previously entered data in a form.

Submit a Form. Sends the form data to the specified URL.
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Play a Sound. Plays the previously specified sound file.

Show/Hide a Field. Shows or hides a field in a document. This action may be used for form fields.



295

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Read an Article. Allows you to follow an article in a PDF document.

2. Edit.... Edits the selected Action.

3. Up. Moves the selected action up in the list.

4. Down. Moves the selected action down in the list.

5. Remove.... Deletes the selected Action.
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7.3.3 Thumbnails

The thumbnails pane can be toggled using [Ctrl]+[T] or by going to View> Thumbnails from the

main menu. The Thumbnails Pane displays a smaller representation of each page in the active

document. Pages can be inserted, Reordered, deleted and more using the Thumbnails Pane. By

default, the Thumbnails Pane is snapped to the left of the PDF Display Area, but like most panes can

be moved to another location, or floated.

   

Multiple Thumbnails can be selected at a time by holding Ctrl and left clicking on the thumbnails to

be selected. A group of Thumbnails can also be selected by selecting the first thumbnail, and while

holding Shift, select the last thumbnail in to be selected. All thumbnails in between the first and last

selected will also be selected.

To insert pages from another document to the Thumbnails Pane, simply select the thumbnails from

one document, and drag/drop them to the location in the target document's Thumbnail Pane.
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To Delete pages from the Thumbnails Pane, use the Delete key or click on  to delete the selected

pages.

 Note: The Thumbnail highlighted in yellow is the currently viewed page.

Zoom In increases the magnification of the thumbnails, but not the pages viewed in the PDF

Display area.

Zoom out decreases the magnification of the thumbnails, but not the pages viewed in the PDF

Display area.

Rotate Clockwise 90° degrees rotates the selected pages 90° degrees to the right.

Rotate Counterclockwise 90° degrees rotates the selected pages 90° degrees to the left.

Print opens the Print dialog. If thumbnails are selected, the settings will be automatically updated

to print only those selected pages.
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Properties opens the Properties Pane for the active selected page.

Page Properties

(Single Page/Thumbnail selected)

General

Number Shows the actual page number within the PDF.

Label Shows the page label. For instructions on how to modify page labels,

please see the How to Modify Page Labels  section.

Width Shows the width of the page.

Height Shows the height of the page.

Rotation Shows the rotation of the page. 0° represents no rotation. 

· 0° returns to original rotation.

· 90° rotates 90° degrees to the right.

· 180° flips the page upside down.

· 270° flips the page 90° to the left.

Tab Order Specifies the order of tabulation for moving focus trough objects, fields

and annotations using the Tab key. Select the available options from the

drop down menu.

· Unspecified

· Use Row order tabs through objects from Left to right.

· Use Column order tabs through objects from top to bottom.

· Use Document order use the order defined in the document.

· Use Annotation Array Order use the order in which comments were

placed.

· Use Widget Order use the order of object widgets. 

213
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Actions

Note: See the Common Actions  section for more information about available actions. 

Page Open Initiate listed action focus is switched to this page. Click on the ... button

to set up an action.

Page Close Initiate action when page is no longer in focus. Click on the ... button to

set up an action.

Delete removes the selected pages from the document.

Options opens the options menu, which is identical to the right click context menu when used

on selected thumbnails.

34
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Cut Cuts the selected pages to the clipboard.

Copy Copies the selected pages to the clipboard.

Paste Pastes copied pages

 Delete Deletes the selected pages.

Insert Pages 
Launches the Insert Pages window.

See the Document> Insert Pages  sections for more details.

Extract Pages 
Launches the Extract Pages window. 

See the Document> Extract Pages section for more details.

Replace Pages 
Launches the Replace Pages window.

See the Document> Replace Pages  section for more details.

Delete Pages 
Launches the Delete Pages window.

See the Document> Delete Pages  section for more details.

Crop Pages 
Launches the Crop Pages window.

See the Document> Crop Pages  section for more details.

Resize Pages 
Launches the Resize Pages window.

See the Document> Resize Pages section for more details.

Rotate Pages Launches the Rotate Pages window.

See the Document> Rotate Pages  section for more details.

Split Pages Launches the Split Pages window.

See the Document> Split Pages  section for more details.

Number Pages... Launches the Number Pages window.

See the Document> Number Pages  or the

How to Modify Page Labels  Section for more details.

Print 
Launches the Print dialog. See the File> Print section for more

details.

Export Export to Images

Launches the Export to Images window.

See the File> Export> Export to Images  section for more

details.

Zoom In Thumbnails 
 Zooms in so that the thumbnails in the Thumbnails Pane

appear bigger with more detail.

Zoom Out Thumbnails 
 Zooms out so that the thumbnails in the Thumbnails Pane

appear smaller allowing for more to fit within the pane.
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Highlight Visible Area  With this option selected, the currently viewed portion of a

page is highlighted in the thumbnails.

Highlight Visible Area: On Highlight Visible Area: Off 

  

Interactive Highlighted

Area

 With Highlight Visible Area active, the viewed area can be

moved by moving the highlighted section when clicking on and

moving the .

Properties  opens the Properties Pane for the active selected page.
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7.3.4 Other Panes

In addition to Bookmarks and Thumbnails, there are other panes that may be shown or hidden.

Destinations  Opens a pane with a list of destinations. 

Content  Selecting this option opens a pane within the PDF display area that displays the

content. 

Articles  Selecting this option opens a pane within the PDF display area that displays the articles. 

Signatures  Selecting this option opens a pane within the PDF display area that displays the list

of digital signatures added to the PDF document. 

Layers  Correspond to what Adobe® calls "Optional content." Selecting this option opens a pane

within the PDF display area that displays the optional content layers. 

Comments  Display a list of comments, annotations and markups. 

Attachments  Open a pane within the PDF display area that displays the attached files and allows

you to attach PDFs and other types of files to a PDF document. 
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Fields  Fields are found within Adobe® Acrobat® Forms. Selecting this option opens a pane

within the PDF display area that displays the Form fields. 

Pan and Zoom  The Pan and Zoom window shows a representation of the current page(s) with a

Blue rectangle that shows the area being displayed in the main window in a reduced form. 

Stamps Palette  Opens a selection list of available stamps organized by Palette type. 

Comment Styles Palette  Opens the palette with the list of comments’ styles. 

Spell Check  utilizes the Spell Checker Plugin to actively spell check a document 

Properties Pane  Opens the properties pane 

7.3.4.1 Destinations

The Destinations pane displays the list of named destinations.

Options. Displays the list of options for controlling named destinations.

Go To Destination. Moves to the selected destination.

310

310

546

457

443

315



304

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

New Destination.... Creates the destination at the currently displayed page.

Delete. Deletes the selected destination.

Rename. Allows you to rename the selected destination.

Set. Sets the target of the destination to the currently displayed page.

7.3.4.2 Content

The Content pane displays the list of pages with a set of objects for each page. The objects are

shown due to their order on the page. 

If you click any object from the content pane list, it will be selected on a page with a blue bounding

box. If you wish to move, resize or rotate the object, choose the Edit Content button from the

Comment And Markup toolbar. The bounding box with selection handles will appear.
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7.3.4.3 Articles

Selecting this option opens a pane within the PDF display area that displays the articles. 

Note: This function was not available at the time of writing of this documentation

revision. 

7.3.4.4 Signatures

The Signatures Pane provides information regarding any signatures within a PDF. Going to View> Other

Panes> Signatures opens the Signatures pane.



306

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Options

Lists some options for placing and validating digital signatures and certificates. See the Document>

Digital Signing section for more details regarding each option and for instructions for creating and

placing digital signatures and certificates.

Sign Document

Place signature

Certify (Visible)

Certify (Invisible)

Timestamp

Validate all signatures

Clear all signatures

7.3.4.5 Layers

Layers correspond to what Adobe
®

calls "Optional content." Selecting this option [View > Other

Panes > Layers] opens a pane within the PDF display area that displays the optional content layers.

It is possible to show or hide content using layers. Content with a lit bulb  is visible, where as

content with the light bulb off  is currently hidden. 

Options. Allows you to set the layer options.

432
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List Layers for All Pages. Shows each layer across every page of the document.

List Layers for Visible Pages. Shows layers only on the currently visible pages.

Reset to Initial Visibility. Allows you to reset layers to their default state.

Apply Layers Overrides. Displays all layers, even those which that are not listed in the Layers

panel. 

Expand All. Expands the layers tree if they are structured that way.

Collapse All. Collapses the layers tree if they are structured that way. 

Rename. Allows you to rename the current layer. 

Properties.... Opens the layer Properties pane.
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7.3.4.6 Comments

Comments displays a list of Comments, Annotations and Markups:

This displays a list of all Annotations by page. Note that you can go to the page and Annotation by

clicking on the comment in this list. Clicking on an Annotation also opens the appropriate toolbar

for the comment.
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7.3.4.7 Attachments

Attachments opens the Attachments pane which allows you to attach PDFs and other types of files

to a PDF.

The Attachments pane has the Attachments Editor Toolbar that will allow you to open, save, add

new or delete the existing files from the active document.

Options.... Displays the list of options for controlling the attachments.

Open Attachment. Opens the selected attached file. 

Save Attachment. Saves the selected attachment into an external file.

New Attachment…. Opens the standard Open Files dialog for choosing a necessary file. 

Besides, it is possible to add a new attachment file using the Drag&Drop option. When

you drag the file to the Attachment List field and drop it, the following question appears:
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Delete. Deletes the selected attachment.

Edit Description.... Allows you to add a description to the attached file in the opened New

Attachment Description dialog box.

7.3.4.8 Fields

Fields are found within Adobe
®

Acrobat
®

 Forms. Selecting this option opens a pane within the PDF

display area that displays the Form fields. Note that the fields are listed alphabetically, not in the

order they may appear to be in on the page.

Each field is identified by its name and type. You may click on a field to highlight its entry in the

pane, or double click a field in the pane to highlight the form field.

N.B. This function was not available at the time of writing of this documentation revision.

7.3.4.9 Pan and Zoom

When the Pan and Zoom tool is selected, the Pan and Zoom window appears:
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The Pan and Zoom window shows a representation of the current page(s) with a Blue rectangle that

shows the area being displayed in the main window. You may use the Hand control to move the

blue rectangle and the main display window will automatically follow that movement.

The control bar at the top of the window shows the current display area's zoom factor. The  and

 buttons may be used to change the zoom factor, or you may click the down arrow to open a

list of standard zoom factors:

To go to the First Page, click on  or use the Home key. Clicking on  or using the End key

will take you to the Last Page in the document.

Clicking on  takes you to the Previous Page in the document, and  takes you to the Next

Page.

The Camera button  allows you to make a Snapshot  of the highlighted area of the page.

507

508
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7.3.4.10 Stamps Palette

Stamps Palette opens the Stamps Palette dialog with a selection list of available stamps organized

by Palette type. 

Zoom In. Enlarges the size of the thumbnail images in the Stamps area.

Zoom Out. Reduces the size of the thumbnail images in the Stamps area. 

New from File.... Creates a stamp from a selected image file or PDF document page.

You could also scan your signature into a file to allow you to then 'Stamp' a document with your

physical signature

- however, should you do this we strongly recommend you use the Flatten Comments

 option to ensure your signature is not easily interfered with in the final PDF once distributed.

New from Clipboard.... Creates a stamp from an image contained in the clipboard. 

Rename. Allows you to change an existing stamp's name.

Delete. Deletes the selected stamp from the collection.

446
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7.3.4.11 Comment Styles Palette

Comments Styles Palette opens the palette with the list of comments’ styles. 

The toolbar at the top allows you to do the following things: 
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Reset. Resets the style of the selected comment to default. All custom styles except for the

default ones will be removed. 

Clone. Creates the style of the comment, identical to the selected one. 

Rename. Allows you to rename the selected style. 

Reset. Resets the style of the selected comment to default. All custom styles except for the

default ones will be removed. 

Delete. Deletes the selected comment style.

Properties. If you select the Properties item, the pane appears with the tabs which allow you to

adjust the appearance and other properties of the selected tool.

Set Current. Sets the selected custom style to the current tool's style.
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7.3.4.12 Properties Pane

The Properties Pane appears when you select the Properties... item from the View> Other

panes> Properties pane. To change any property you must click it. In the end of a box with

property's name there appears an arrow. After you click the arrow, you will see available options for

changing each of the properties. The options in the Properties Pane are dynamic and differ

depending on what is selected allowing you to modify the look, feel and functionality of that tool or

object. For a simplified and more user-friendly properties device, please see the Properties Toolbar

. 

Descriptions for each property of each tool and function can be found on that tool or function's

help section. 

Note: If you are viewing this help in a PDF, you can use the Search function to find the

section you are looking for.

7.3.5 Zoom

Zoom opens a dialog box to allow you to select or enter the zoom percentage to use to display the

PDF pages.

Actual Size. Sets the Zoom percentage to 100%, forcing the PDF page to display at actual size. 

Fit Page. Fits the entire PDF page within the borders of the view pane. 

Fit Width. Fits the PDF to the width of the view pane. Scroll bars are provided to enable you to

scroll the PDF page as desired. 

Fit Height. Fits the PDF to the height of the view pane.

Fit Visible. Page is displayed without margins.

601

192
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Zoom To.... Opens a dialog box to allow you to select or enter the zoom percentage to use to

display the PDF pages. 

Loupe Tool. 

The Loupe Tool opens a special dialog window that is linked to a scrollable, resizable

rectangular that acts as a cursor and permits the selection of a portion of the PDF page/file. 

The selected area can be resized and its contents view size zoomed larger or smaller to suit.

Further - like the main 'snapshot' tool - the defined Loupe content area can also be copied

to the clip board and used as required.

The toolbar at the bottom of the page allows you to change the zoom percentage, and

clicking the Snap shot (camera) icon copies the displayed area to the clipboard as a bitmap.
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Pan and Zoom. 

When this is selected, the Pan and Zoom window appears:

The Pan and Zoom window shows a representation of the current page(s) with a Blue

rectangle that shows the area being displayed in the main window in a reduced form. You

may use the Hand control to move the blue rectangle and the main display window will

automatically follow that movement.

The control bar at the bottom of the window shows the current display area's zoom factor.

The blue + and - buttons may be used to change the zoom factor, or you may click the

down arrow to open a list of standard zoom factors:

The white arrow buttons navigate to the various pages of the currently displayed PDF

document.

The Camera button allows you to make a snapshot of the highlighted area of the page.
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7.3.6 Show

Show opens a dialog to allow you to select the displaying of rulers, grid, guides or JavaScript

Console.

Show Rulers shows horizontal and vertical rulers, which let you check the size of objects in your

documents.

Show Grid displays the grid behind transparent objects. Grid is used to accurately line up text

and objects in a document.

Show Guides shows the guides for lining up objects, such as form fields. 

To create a guide, drag down from the horizontal ruler, or drag to the right of the vertical ruler.

Show JavaScript Console. To perform a JavaScript action on a PDF, launch the JavaScript

Console with the keyboard shortcut CTRL+J or go to View Menu | Show JavaScript Console.

When the JavaScript Console opens, paste or write your JavaScript code into the top of the two

windows and click the Run... button. The code will run and if there are any errors the message

will be displayed in the window below your code.

The Clear button removes the error message from the window below. The Options... button

opens the JavaScript tab from the Preferences....243



319

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

7.3.7 Snap

Snapping is used to help with precise measurements and placement of annotations or comments.  When

snapping is enabled, the pointer will automatically move to a snapping point when within the threshold. 

Snapping can be toggled under View> Snap> Enable Snapping or [Ctrl]+[Shift]+[;]

Specify which items to snap to by selecting or deselecting the options. See the View> Show  section

for more details on Grid and Guides. Enabling snap to objects will allow an object to be used as a

snapping point. To configure detailed settings for the snapping function go to Edit> Preferences>

Measurement> Customize Snapping (to Grid, Guides, Objects).

Snapping Indicators

Snap can sometimes snap to different portions of the same object such as the  End point,  Edge, 

Mid Point, Center, or Intersection. Each snap point type has its own Icon to indicate which is

currently used.

318
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Snap to Grid

Show the grid under View> Show> Grid. This allows the snapping function to snap to grid lines as

shown in the screenshot below:

Notice that the cross hairs are not where the annotation ends. This is because the Snapping function has

detected a snapping point on the grid. The snap location is Identified by a small red square  to indicate

the location.

Snap to Guides

Guides can be placed when working with rulers. When Snap to Guides is activated, the guides will be

detected as snapping points.

Snap to Objects

Snap to objects allows for annotations, comments and base content alike to be detected as snapping

points.
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7.3.8 Go To

Selecting Go To opens the Page Selection submenu:

The Go To options are: 

First Page. Moves the view to the top of the first page of the document. This option is disabled

if the first page is the active page. 

Previous Page. Moves the view to the top of the previous page of the document. This option is

disabled if the first page is the active page. 

Next Page. Moves the view to the top of the next page of the document. This option is

disabled if the last page is the active page. 

Last Page. Moves the view to the top of the last page of the document. This option is disabled

if the last page is the active page. 

Go to Page.... Opens a dialog box to allow you to enter a page number. 

Back. Moves to the previous view. If you are on the first view, this option is disabled. Reopens

closed documents that have been viewed during the session.

Forward. Moves to the next view. If you are on the last view, this option is disabled.
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7.3.9 Portfolio

A PDF Portfolio is a PDF container that may include a wide range of files created in different

applications (e.g. text files from Microsoft Word, AutoCAD drawings, Excel, PowerPoint

presentations, images, e-mail messages etc). 

The documents are wrapped in the PDF file and can be opened by applications which support PDF

format and specifically PDF Portfolio files.

The PDF-XChange Editor can Open, View, and Edit PDF Portfolio files. 

To Open a PDF Portfolio file, from the Main Menu choose File > Open (or Ctrl+O) or Open

From... , select the PDF Portfolio file, and click the button Open.

To View a PDF Portfolio, from the Main Menu choose View > Portfolio:

Viewing a Portfolio in Navigator Layout View mode.



323

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Portfolio Sub-menu

The Portfolio sub-menu shows Portfolio viewing options that change the way the files embedded in

the Portfolio are presented.

Check Show Navigator to see the Content of Portfolio (all embedded documents like *.pdf, *.docx,

*.html, *.jpg etc). 

Navigator Layout View mode shows thumbnails of the embedded documents (tiles with image

previews, names of files and icons).

Navigator Layout View mode. The example PDF portfolio includes JPG file, PDF file, and DOCX file.

Right-click on the thumbnail to open the context menu for quick access to:
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· Preview File to open the selected file in its native application (set by default for that type of

document). 

· Extract from Portfolio to extract and save the selected file to a destination folder.

Extracting does not delete the file from the PDF Portfolio.

· Select All to select all embedded components of the portfolio.

· Deselect All to annul selection of all files.

Navigator Details View shows the list of included documents with details and properties (creation

or modification date, size, description, etc). 

Sort the list by clicking on the column title of the property field.

Viewing a PDF Portfolio in the Navigator Detail View mode.
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Check Show Cover Sheet to display the Portfolio standard Cover Sheet or any page(s) that can be

set as the Cover page(s).

Custom Cover Sheet. Thumbnails pane exposes this Cover Sheet and allows to manage it.

A PDF Portfolio is, essentially, a PDF cover-sheet document that contains embedded files and

information about each of those files. The Cover Sheet is the page(s) that distinguishes a PDF

Portfolio file from a regular PDF file.

Usually Cover Sheet serves for providing the information about the portfolio creator.

To Edit PDF Portfolio, in Main Menu choose View > Portfolio, and then check Show Cover Sheet.

Next, open pane with Attachments  and/or Thumbnails  by View > Other Panes >

Attachments (or Ctrl+Shift+A) and/or View > Thumbnails (or Ctrl+T) and Edit PDF Portfolio like

PDF file with attached documents. 

The editing PDF Portfolio through the Attachments and Thumbnails panes is the same as editing

any PDF document.

309 296
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  The PDF Portfolio with marked Show Cover Sheet and Show Navigator options, with opened Thumbnails and

Attachments panes.

   To get the view of all possible panes, choose:

   1 - View > Portfolio > Show Navigator;

   2 - View > Portfolio > Show Cover Sheet;

   3 - View > Thumbnails;

   4 - View > Other Panes > Attachments.

Through the Attachments pane you can add new document(s) to the PDF Portfolio, delete,

extract file(s), open them in their native application, etc. 

Through the Thumbnails  pane you can manage the Cover Sheet (add, rotate page(s), etc.).

309
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7.4 Document

The Document menu allows you to manipulate pages in a document. For example, you can Insert,

Extract, Delete, Rotate, or Crop pages, Sign or Redact the document. 

For a detailed descriptions of each feature, click the links to the right of the menu:

Header and Footer  

Watermarks  

Background  

Bates Numbering  

Add Barcode...  

Add Image...  

Insert Pages  

Extract Pages...  

Split Document by Bookmarks...

 

Replace Pages...  

Delete Pages...  

Crop Pages...  

Crop Pages Tools  

Resize Pages...  

Rotate Pages...  

Split Pages...  

Number Pages...  

OCR Pages...  

Digital Signing  

Signatures and Initials  

Redaction  

Spell Check  

Launch:  
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Note: In FREE mode you can use:

Add Barcode, 

Add Image, 

Split Documents by Bookmarks, 

Replace Pages, 

Rotate Pages, 

OCR, 

create Signatures and Initials (but cannot Apply), 

Mark for Redaction (but cannot Apply All Redaction). 

You can also try the other features in EVALUATION mode, but it will cause the saved PDF to have watermarks.

IMPORTANT! Most of these functions are Licensed features, see IMPORTANT! Evaluation

mode vs. Licensed  mode for more information!

7.4.1 Header and Footer

Header and Footer are areas at the top and the bottom margins of the PDF document where

the additional information can be inserted.

Additional information can include both static text and dynamic variables, such as a page number, a

file name, a current date, a document title, or document properties.

To add, remove, or edit the header and footer, go to Main Menu> Documents> Headers and

Footers> Add, Remove All, or Manage.

Documents> Headers and Footers Sub-menu

12
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 Add Header and Footer

To insert information in the header and/or footer, click Add.... The Preview pane shows the header

and footer of the PDF document before applying to. 

Add Header and Footer Window

Text settings section allows text or variables to be inserted into specific header and footer regions

of the page.

· Left Header Text: inserts text to be displayed in the left header of the page.

· Central Header Text: inserts text to be displayed in the center header of the page.

· Right Header Text: inserts text to be displayed in the right header of the page.

· Left Footer Text: inserts text to be displayed in the left footer of the page.

· Central Footer Text: inserts text to be displayed in the central footer of the page.

· Right Footer Text: inserts text to be displayed in the right footer of the page.
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Margins setting adjusts the distance of the header and footer from the edge of the page by setting

non-zero margins using the selected "Units". 

· Top: moves the margin down from the top edge of the page by the specified amount of

Units selected.

· Bottom: moves margin up from the bottom edge of the page by the specified amount of

Units selected.

· Left: moves margin to the right from the left edge of the page by the specified amount of

Units selected.

· Right: moves margin to the left from the right edge of the page by the specified amount of

Units selected.

· Units drop-down box sets the units of measurement used for the margin movements.

Options are: point, inch, centimeter, millimeter and pica.

Font... button provides options for the font settings, such as Font name, Font Style, Font Size,

Color applied to the header and footer text. 
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Insert Date inserts the formatted current date into the chosen header or footer region. 

Insert Page Number inserts the formatted page number into the chosen header or footer region. 

Page Number And Date Format...opens a window for formatting the date, the number of the page

and for adjusting the start page number.

Preview Page settings set a range of pages with a preview of the header and footer before

applying them to the document.

· Preview Page option selects the number of a page for previewing it in the Preview pane.

· Pages Range Options... specifies the page range that the header and footer preview will be

shown on.

· All button adds the header and footer to all pages of the document.

· Selected Page button adds the header and footer to the selected page only.

· Current Page button adds the header and footer to the current page only.
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· Pages field adds the header and footer to the individual page or a range of pages. Individual

pages are indicated by their numbers beginning with 1. 

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select pages

2, 3, 4, and 5. 

Multiple page ranges may be specified, separated from one another by commas.

The Subset drop-down list provides options for selecting the group(s) of pages based on an order

within a document.

· All Pages adds the header and footer to all of the specified pages.

· Odd Pages Only adds the header and footer to odd-numbered pages only: 1, 3, 5, etc.

· Even Pages Only adds the header and footer to even-numbered pages only: 2, 4, 6, etc.

The Settings drop-down menu allows the selection and application of pre-existing Header and

Footer settings or to save the current Header and Footer settings to a new Custom Settings

Template.

When custom settings are chosen, the  Save Current Settings option becomes active, allowing

current custom settings to be saved for future use. These custom settings show up in the drop-

down menu as shown by the highlighted option. Selected custom settings can be deleted by

clicking Delete .
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 Manage opens the Manage Presets menu, where the name and description of user defined

custom header and footer presets can be edited, cloned, or reordered in the Settings: drop-down

list. By clicking on an existing Preset, additional actions will be activated for working with the

template.

· The and will change the order of the Preset items in the list accordingly.

· Edit... button opens the Edit Settings window for entering a unique name and short

description of the edited settings.
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· Clone button opens the New Settings window for entering a unique name and short

description of the cloned settings preset.

· OK button saves the cloned Header and Footer template to a new preset using the name

and description provided.

· Cancel button cancels the New Settings action and closes the dialog window.

 Remove Header and Footer option removes all existing headers and/or footers from the

active PDF document.

 Manage Header and Footer option allows managing and editing Header and Footer presets

(See  Add...  option), edit, remove the existing settings, or remove all header and footer presets. 329
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7.4.2 Watermarks

Watermarks are text or images displayed over top or underneath content in a PDF file. For

example, to indicate the document's status or to place a logo on the document.

To add, remove, or edit the Watermarks go to Main Menu> Documents> Watermarks> Add...,

Remove All..., or Manage...

      Document>Watermarks Sub-menu

 Add...

To insert watermarks in the PDF document, click  Add.... The Preview pane shows the

watermarks on the PDF page before applying the watermark to the document..

       Add Watermark Window
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Source settings specify the type of watermark and the content to be applied.

Type sets the type of watermark to be applied

· Text applies a text based watermark of the contents typed into the Text field below the drop

down when this Type is selected.

· File applies an image based watermark of the contents of the file selected

Text Watermarks

To insert a text watermark, select Text in the Type drop-down list and enter text in the Text field

provided.

      Source options for Text Watermark

The Macros  button  opens a drop-list of macros that can be used to automatically generate

watermarks content such as filename, date or time.

Font button opens the Select Font window for setting font options for the Text Watermark, such as

Font Name, Font Style, Font Size, Color and different Effects for the watermark text.

      Select Font Options

56
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Align drop-list selects the text alignment for the Watermark and can be set to: Left, Center, Right.

File Watermarks

To insert an image file or another PDF file as a watermark, select the File option in the Type drop-

down list and click the  button to browse to the file to be used for the watermark.

      Source options for File Watermarks

Once a file is selected through the file browser, the filename will appear in the Name field.

Note: File types that can be selected for watermarks include all supported raster image files (ie,

PNG, GIF, JPG, etc) as well as TIFF and PDF files which can contain a single page or multiple

pages.

If a multi-page TIFF or PDF file is chosen as the Watermark Source, use Page to set which

page of the file to use for the Watermark

Page sets the page of a multi-page File to use as the Watermark.

Appearance settings customize the appearance of the watermark in the PDF Document.

Rotation: adjusts the orientation of a watermark on the page (Zero degree is a horizontal line).

Opacity: adjusts the transparency of a watermark on the page.

Scale: increases or decreases the size of the watermark on the page.

Scale relative to target page: When selected, this option overrides Font Size setting for Text

Watermarks and scales the text to the meet the limits of the page margins; for File Watermarks it

automatically scales the image of the file to meet the limits of the page margins.

Placement settings adjust the specific position of a watermark on the page.

Horizontal Offset: applies a horizontal alignment offset of a watermark, from a choice of position

on a page in the Units selected.
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Vertical Offset: applies a vertical alignment offset of a watermark, from a choice of position on a

page in the Units selected.

From: allows specify the watermark position from the Center, Left or Right edge of the document

page.

Units: values are points, inches, centimeters, millimeters, or picas.

As Background inserts a watermark underneath existing content of the PDF document.

Note: If the PDF that the watermark is being applied to was created from an image file or

scanned document, the content of the PDF page is an image (a picture of a page in the case of

scans)

If the page is an image without a transparent background, the As Background option will hide

the Watermark completely under the existing content of the this kind of PDF, and will not be

seen..

Pages Range settings specify the page range for applying the watermark to the PDF document.

All button adds a watermark to all pages of the document.

Selected Page button adds a watermark to the selected page(s) only.

Current Page button adds watermark to the active page only.

Pages button adds a watermark to an individual page or a range of pages. Individual pages are

indicated by their numbers beginning with 1.

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select pages 2, 3, 4,

and 5.

Multiple page ranges may be specified, separated from one another by commas.

Subset drop-down list is used in conjunction with the other Pages Range to select groups of pages

based on an order within a document.

· All Pages adds a watermark to all of the specified pages.

· Odd Pages Only adds a watermark only to odd-numbered pages only: 1, 3, 5, etc.
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· Even Pages Only adds a watermark,within the specified Pages Range, to even-numbered pages

only: 2, 4, 6, et

Settings <Custom> button allows saving the current Watermark settings as a Custom Preset

template for future use or selecting and loading an already saved Watermark Preset to be applied

to the document.

Watermark Presets (white background) Existing Watermark presets are listed at the top, click

the Preset settings that you would like to load for the Watermark. 

Save Current Settings button allows saving the current Watermark settings as a Preset for

future use. Clicking this will open the New Settings Window and prompt to enter a Unique Preset

name and short description.

Delete with a Preset selected, in blue, use the Delete button to delete the preset and remove it

from the list. A prompt will be displayed asking for confirmation that the Preset is to be deleted.
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Manage... opens the Manage Presets Window where Watermark Presets can be Deleted,

Edited, Reordered or Cloned.

      Manage Presets Window

· Delete will delete the selected Preset and remove it from the Presets List

· Edit... will allow editing the Preset's name and short description

· Up and Down arrows move the selected Preset up or down in the list.

· Clone Copies an existing Preset as a New Preset and prompts for a new name and short

description for the Cloned preset.

· Close closes the Manage Presets window

 

 Remove All...

Removes all watermarks from the document.
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 Manage...

Clicking Manage... opens the Manage Watermarks Window where Watermark Presets can be

Added, Edited or Cloned and saved as a new Watermark Settings Preset

Manage Watermarks Window

· List displays the list of all watermarks that have been applied to the PDF document.

· Add New button opens the Add Watermark dialog box for adding new watermarks.

· Edit....button opens the Edit Watermark dialog box for editing the selected watermark.

· Remove. Removes the selected watermark.

· Remove All button removes all watermarks.

· Close button closes the dialog.
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7.4.3 Background

 Background option allows you to add a background to your PDF document. It may be created of an

image file or just a color and it may be applied to the whole document or the selected pages only.

Main Menu > Documents > Background > Add, Remove All or Update.

   Add... Opens the Add Background Window and displays the options for adding a background to

the PDF document.

Add Background Window
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Source settings specify whether a background is created using a Color, or choosing an Image or PDF file

to use as the background for the PDF file.

From Color: drop-down list contains the standard color selection or click More Colors for

customizing the background color for PDF document.

By default, using From Color as the source of the background adds a rectangle of the selected

color the size of the PDF page to the bottom page layer of the PDF document.

Name: This option allows selecting any supported raster image or PDF file to set as the

background of the PDF document.

To insert an image file or another PDF file as a background, select the Name option in the Source

settings and click the  button to browse to the file to be used for the background.

Once a file is selected through the file browser, the filename will appear in the Name field.

Note: File types that can be selected for backgrounds include all supported raster image files

(ie, PNG, GIF, JPG, etc) as well as TIFF and PDF files which can contain a single page or multiple

pages.

If a multi-page TIFF or PDF file is chosen as the Background Source, use Page to set which

page of the file to use for the background.

Page: sets the page of a multi-page File to use as the Watermark.
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Appearance settings customize the appearance of the background in the PDF document.

Rotation: adjusts the orientation of a watermark on the page (Zero degree is a horizontal line).

Opacity: adjusts the transparency of a watermark on the page.

Scale: increases or decreases the size of the watermark on the page.

Scale relative to target page: When selected for Backgrounds applied using an image of PDF

file, this option automatically scales the image of the file to meet the limits of the page margins.

This option is not available for From Color backgrounds.

Note: Appearance settings applied to a From Color background, manipulate the page sized

rectangle of selected color which can be rotated, scaled and have its opacity adjusted to the

desired amount.

Placement settings adjust the specific position of the background object on the page.

Horizontal Offset: applies a horizontal alignment offset of the background object, from a choice

of position on a page in the Units selected.

Vertical Offset: applies a vertical alignment offset of background object, from a choice of position

on a page in the Units selected.

From: allows specify the background object's position from the Center, Left or Right edge of the

document page.

Units: values are points, inches, centimeters, millimeters, or picas.

Pages Range settings specify the page range for applying the background to the PDF document.

All: adds a background to all pages of the document.

Selected Page: adds a background to the selected page(s) only.

Current Page: adds a background to the active page only.

Pages: adds a background to an individual page or a range of pages. Individual pages are

indicated by their numbers beginning with 1.

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select pages 2, 3,

4, and 5.

Multiple page ranges may be specified, separated from one another by commas.
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Subset drop-down list is used in conjunction with the other Pages Range to select groups of pages

based on an order within a document.

· All Pages adds a background to all of the specified pages.

· Odd Pages Only adds a background only to odd-numbered pages only: 1, 3, 5, etc.

· Even Pages Only adds a background,within the specified Pages Range, to even-numbered pages

only: 2, 4, 6, etc.

Setting <Custom> Allows creating, loading, editing & deleting Background preset templates.

Background Presets (white background) Existing Background  presets are listed at the top,

click the desired Preset settings to load for the Background.
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Save Current Settings button allows saving the current Background settings as a Preset for

future use. Clicking this will open the New Settings Window and prompt to enter a Unique Preset

name and short description.

Delete with a Preset selected, in blue, use the Delete button to delete the preset and remove

it from the list. A prompt will be displayed asking for confirmation that the Preset is to be deleted.

Manage... opens the Manage Presets Window where Background Presets can be Deleted,

Edited, Reordered or Cloned.

Manage Presets Window



347

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

· Delete will delete the selected Preset and remove it from the Presets List

· Edit... will allow editing the Preset's name and short description

· Up and Down arrows move the selected Preset up or down in the list.

· Clone Copies an existing Preset as a New Preset and prompts for a new name and short

description for the Cloned preset.

· Close closes the Manage Presets window

 Remove... removes the current background from the document.

 Update.... button opens the Edit Background dialog box for editing the active background. The

Edit Background window is identical to the Add Background window shown at the top of this page,

but displays all the settings of the currently active  Background that has been applied to the PDF

document.
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7.4.4 Bates Numbering

 Bates Numbering is a useful method of indexing legal documents for easy identification and

retrieval by adding an electronic number and date to each page of the PDF document.This option allows

you to add Bates identification numbers to one or more PDF documents

Clicking the Main Menu>  Documents> Bates Numbering> will display the Bates Numbering Sub-

menu.

 Add... opens the Add Bates Numbering window with options to add bates numbering to PDF

documents.

The top half of the window contains settings and options, while the bottom half includes a Preview area

that shows how the applied Bates Numbering will look once added to the PDF.

Under the Page Preview area is the Custom Settings drop down, which allows to save Bates Numbering

settings as a Preset templates and includes option for managing these Presets.

Add Bates Numbering window
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Like the Header and Footer feature, Bates Numbers can be placed in one of 6 header or footer regions.

Text settings section allows text or variables to be inserted into specific header and footer regions of the

page.

· Left Header Text: inserts text to be displayed in the left header of the page.

· Central Header Text: inserts text to be displayed in the center header of the page.

· Right Header Text: inserts text to be displayed in the right header of the page.

· Left Footer Text: inserts text to be displayed in the left footer of the page.

· Central Footer Text: inserts text to be displayed in the central footer of the page.

· Right Footer Text: inserts text to be displayed in the right footer of the page.

Margins setting adjusts the distance of the header and footer from the edge of the page by setting non-

zero margins using the selected "Units".

· Top: moves the margin down from the top edge of the page by the specified amount of Units selected.

· Bottom: moves margin up from the bottom edge of the page by the specified amount of Units selected.

· Left: moves margin to the right from the left edge of the page by the specified amount of Units selected.

· Right: moves margin to the left from the right edge of the page by the specified amount of Units selected.

· Units drop-down box sets the units of measurement used for the margin movements. Options are: point,

inch, centimeter, millimeter and pica.

Font... button provides options for the font settings, such as Font name, Font Style, Font Size, Color

applied to the header and footer text.
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Insert Date inserts the formatted current date into the chosen header or footer region.

Insert Page Number inserts the formatted page number into the chosen header or footer region.

Page Number and Date Format... opens a window for formatting the date, the number of the page and

for adjusting the start page number.

Preview Page settings set a range of pages with a preview of the Bates Numbering before applying

them to the document.

· Preview Page option selects the number of a page for previewing it in the Preview pane.

· Pages Range Options... specifies the page range that the header and footer preview will be

shown on.

· All button adds the Bates Number to all pages of the document.

· Selected Page button adds the Bates Number to the selected page only.

· Current Page button adds the Bates Number to the current page only.
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· Pages field adds the Bates Number to the individual page or a range of pages. Individual pages

are indicated by their numbers beginning with 1.

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select pages 2, 3,

4, and 5.

Multiple page ranges may be specified, separated from one another by commas.

The Subset drop-down list provides options for selecting the group(s) of pages based on an order within

a document.

· All Pages adds the header and footer to all of the specified pages.

· Odd Pages Only adds the header and footer to odd-numbered pages only: 1, 3, 5, etc.

· Even Pages Only adds the header and footer to even-numbered pages only: 2, 4, 6, etc.

 Add to Multiple Files... menu item opens the Add Bates Numbering to Files Windows with option

for applying Bates Numbering across a group of selected
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Source Files dialog box, you can select the files for adding the Bates numbering.

Add Files... button opens the Open Files dialog box to select PDF files to add Bates Numbering to.

Add Folder... button opens the Browse For Folder dialog box to add all the PDF files which are

contained in the selected folder.

Page Range Options... button opens the Setup Pages Range  window as described earlier in

the chapter.

Up button  moves the selected file up in the list of files.

Down button  moves the selected file down in the list of files.

To Bottom  moves the selected file to the bottom of the list of files.

Remove button  allows to remove selected file(s) from the list.

The Output Options section, includes options for naming and saving the file(s) that the Bates

Numbering is applied to.

Replace file names starting and ending Bates numbers (e.g.000100-000115.pdf) option

specifies that the selected files in the list will be renamed using the Bates Number format selected.

File Name option allows setting the name of the output file. You may enter any valid file name or use

the Macros button to use available variable name when naming output files.

The Macros  button  opens a submenu of file name macro variables that can be used to

automatically generate the file names.

(For detailed information please the manual chapter on Macros ).

350
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Destination Folder sets the folder where this operation will save the processed files.

Browse folders button  opens the select folder window, which allows navigation to the folder

where the processed files are to be saved.

Overwrite Existing Files check box  overwrites existing files of the same name which are

located in the Destination Folder.

Open folder with results after the numeration check box  when checked opens the

Destination Folder in Windows Explorer after numbering the files.

Create Log File check box  creates a text file in the Destination Folder with information on the

files that have been processed.

 Options button opens the Add Bates Numbering  window to setup the template of how the

Bates Number will be formatted and applied to the selected files.

 Remove All... button removes all existing bates numbering from the active document.

348
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 Manage... button opens the Manage Bates Numbers Window, allowing the addition, deletion, and

editing of Bates Numbers that have been applied to the document.

Manage Bates Number window

List section displays a list of all Bates numbers that were added to the document.

Add New... button opens the Add Bates Numbering  window for adding new Bates Numbers

to the document.

Edit... button opens the Add Bates Numbering  window for editing the selected Bates

Numbering applied to the document.

Remove button removes the selected Bates Numbers from the document.

Remove All button removes all Bates Numbering from the active document.

Close closes the window and returns to the active PDF document open.

348
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7.4.5 Add Barcode

A Barcode  can be added to a PDF document for providing information accessible to barcode

readers and mobile devices such as smartphones and tablets. The created barcode can be scanned,

interpreted, and incorporated into a database. Using the barcode saves time from manually reading and

recording data and bypasses data-entry errors that may otherwise occur.

To place a new barcode, go to Document> Add Barcode. This opens the Select Barcode Place Tool

window. Select the area for the barcode placement by clicking on Drag Barcode Rectangle...

      Select Barcode Place Tool window

Create the rectangle using the mouse to click and drag.

 

Once the placement is selected, the Add Barcode window is opened.
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      Document> Add barcode window

Select barcode type: select the type of barcode desired

· QR Code consists of black modules (square dots) arranged in a square grid on a white

background, which can be read by an imaging device (such as a camera, scanner, etc.). The

required data is then extracted from patterns that are present in both horizontal and vertical

components of the image.

Options

Fill these fields with the required data to be scanned from the barcode.

Data Type: Select the data type from this drop-down menu. The options fields available differ

depending on the Data Type selected. 

· Contact (vCard) all contact details entered will be scanned. See Add barcode window

above for an example of the options available using this Data Type.
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· URL Only the web address will be scanned.

· Free text any text can be entered in the field here:

· EMail choose an Email address, Subject and Message in the respective fields. When

scanned, the barcode will start writing the email. Results may vary depending on the

scanner used.

· Telephone number type the desired phone number into this field.

Clear will remove all the data entered in the fields above.
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Image Preview

Provides a live preview of the barcode. Changes made to any of the fields will change the preview as well.

As Stamp annotation places the barcode as a Stamp. Visit the Stamp section  for more details on

using, and resizing stamps annotations.

As Part of the page's content places the barcode as part of the base content of the PDF.

As Vector will create a vector object of the barcode. Vector images do not lose quality when zoomed at

any level.

As image will place the barcode as an image.

Note: Select the image quality in dpi (dots per inch) in the adjacent field. 

Add Margin select this option to add a blank area around the barcode.

Fill color select the fill color (background) for the barcode. Default is no color.

Barcode Color select the color of the barcode. Default is black.

Once satisfied with all the settings and parameters, click on  to place the barcode

on the page.

541

http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=stamp_tool
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7.4.6 Add Image

Add Image... menu item allows adding an image to the PDF document. 

Click Main Menu> Document> Add Image... to open the Open Files window and navigate to and

select the desired image file to add to the PDF document.

Once the image file is chosen, it will be opened up in the Add Image Window.

            Add Image Window

Source Settings

Name: displays the full path and file name of the image file selected to add to the page.
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 Open File button opens the Open File window in Windows explorer and allows navigating to and

selecting a different image to add to the document.

Image preview displays the image that is currently selected to add to a document; 

Options settings provides 2 methods of adding the selected image to the document

· As Stamp annotation option imports the selected image as a Stamp Annotation  and allows

placement, resizing and editing the properties of the image "stamp" prior to adding it to the

document.

Once an image has been placed as a Stamp annotation it can be edited by clicking the Edit

Comments  tool on the toolbar (move, resize, change properties) or Tools> Comments and

Markup Tool> Edit Multiple Comments.

Note: This option that is available in the Free or Licensed version of the Editor and is set as

the default method for adding an image.

· As part of page's content option allows adding an image as a part of the PDF page's base

content content . To edit image click on the  Edit Content  (move, resize, change properties)

or through Tools > Content Editing Tools > Edit Content Tool .

Note: Editing content like images is a Licensed feature. This feature can used in Evaluation mode,

but it will add demo stamps to the PDF page after saving the PDF document.

The Place button applies the chosen image to the PDF document.

The Cancel button cancels all operations.
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7.4.7 Insert Pages

The Insert Pages options facilitate the addition of pages from other documents, without the need to

move each page manually using the Thumbnails Pane  . With Insert pages, simply define the required

preferences with the desired output, then click OK to finalize the insertion of pages from another file.

 Insert Empty Pages...

 Insert Images...

 Insert Scanned Pages...

 Insert Text...

 Insert RTF...
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To  Insert Pages from other files to the currently active file, go to Document> Insert Pages or use

Ctrl+I to open the Insert Pages dialog.

      Insert pages dialog

Within the insert pages dialog, find the necessary functions and settings for desired result when the

page insertion is executed. To finally insert the pages from the source file to the active file, click on the 

OK button.
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Source

Define the file from which to insert pages.

From File click on the  browse button to open a standard Windows File select window.

From Already Opened Document select an already open document from the drop-down list.

Actions for Objects 

Define the behavior of objects on the inserted pages.

Comments: Interacts with comments on the document to be inserted.

· Copy copies all comments.

· Flatten will flatten comments on the source file. Visually, the comments will exist on the

inserted pages, but as base content objects.

· Do not copy will not copy any comments from the source file to the current file.

Form Fields: Interacts with fillable form fields. 

· Copy will copy the form fields themselves as well as the filled content to the current file.

· Flatten will flatten form data and remove the interactive elements of the form field. 

· Do not copy will simply ignore any forms or form data.

Bookmarks: Interacts with bookmarks from the source file.

· Do not copy will not copy bookmarks from the source file.

· Copy All will copy all bookmarks from the source file.

· Copy related will only copy valid bookmarks from the source file. A bookmark is invalid

when it refers to an action that can no longer be performed do to changes to the

document.

Add root bookmark with file name adds a bookmark to the active document that points to the

inserted pages.  
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Page Range: Selected <#> of <#> pages

Select the page(s) to be inserted from the source file. The <#> represent a variable where the number of

pages and the number of pages selected is displayed. In the Insert Pages dialog image above, notice

that 423 of 423 pages have been selected for insertion from the source file.

When changing the page range, the Page Range selected value in the title of this portion of the Insert

Pages dialog changes as shown in the image below.

      Insert Pages> Page Range: Selected 14 of 423

All will include all documents from the source file.

Pages: type desired page range here. Multiple page ranges should be separated by a coma.

Note: For printing pages 1 to 15, page 17, pages 20 to 46 and pages 88 to 100 of a 100 page

document to be included in the print job, type the following: 1-15, 17, 20-46, 88-100. If there is a

disconnected hyphen (dash) in the page ranges, that page range will go to the beginning or end of

the document like so: -15, 17, 20-46, 88-.

Subset Select a subset of pages. Such as All Pages, Odd pages or Even Pages.

Destination

Define the location in the active document for the pages from the source file to be inserted.

      Insert Pages> Destination

Location define the rout location for placement of the selected pages from the source document.

· Before will place the pages before the option defined.

· After will place the pages after the option defined.
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First Page the pages inserted from the source file will be located before or after the first page in

the active document depending on the option selected in the Location drop-down menu.

Last Page the pages inserted from the source file will be located before or after the last page in

the active document depending on the option selected in the Location drop-down menu.

Page: the pages inserted from the source file will be located before or after the page number

indicated in the active document depending on the option selected in the Location drop-down

menu.
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7.4.7.1 Insert Empty Pages...

To insert blank pages to the currently active document, select the  Insert Empty pages option

found under Document> Insert Pages> Insert Empty pages. Selecting this option opens the

Insert Empty Pages dialog. 

Insert Empty Pages dialog

Pages

Select the page size, and orientation of the blank pages to be inserted. 

Document will insert pages that match the active document's page size.

Standard select a standard page size from the drop-down menu. 

Custom defines a custom page size in the units selected. 

Orientation choose from Portrait, or Landscape orientation. 

Count defines the number of empty pages to be inserted to the active file.

Destination

Define the location in the active document for the pages from the source file to be inserted. 

Location define the rout location for placement of the selected pages from the source

document. 

· Before will place the pages before the option defined.

· After will place the pages after the option defined.
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First Page the pages inserted from the source file will be located before or after the first page

in the active document depending on the option selected in the Location drop-down menu. 

Last Page the pages inserted from the source file will be located before or after the last page

in the active document depending on the option selected in the Location drop-down menu. 

Page: the pages inserted from the source file will be located before or after the page number

indicated in the active document depending on the option selected in the Location drop-

down menu. 

Once the parameters have been set to the required location and dimensions, click on OK to insert

the pages to the active document.
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7.4.7.2 Insert Images...

To insert images to the active document, use the  Insert Images feature located in Document>

Insert Pages> Insert Images.

     
      Images To PDF window

Source image files

Displays the image files to be used to create PDF.

 Add files…. Opens the Open window to select an image file from.

 Add Folder…. Opens the Browse For Folder window to add/select all image files contained

in the selected folder.

 Import…. Opens the list of scanners installed on your computer.

       Edit…. Opens the Edit Image window which allows for the modification of the selected image.

    Up. Moves the selected file up in the list.

    Down. Moves the selected file down in the list.

 Remove. Removes the selected file from the list. 
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The Change view mode button opens the list of available view modes that can be selected for viewing

the file list.

 Details  Icons  Thumbnails

Destination

Define the location in the active document for the pages from the source file to be inserted.

Location define the rout location for placement of the selected pages from the source document.

· Before will place the pages before the option defined.

· After will place the pages after the option defined.

First Page the pages inserted from the source file will be located before or after the first page in

the active document depending on the option selected in the Location drop-down menu.

Last Page the pages inserted from the source file will be located before or after the last page in

the active document depending on the option selected in the Location drop-down menu.

Page: the pages inserted from the source file will be located before or after the page number

indicated in the active document depending on the option selected in the Location drop-down

menu.
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Edit Selected Image

Changes can be made to the image before it is inserted to the active document from this screen.

      Edit Images window

 Flip Horizontal button is used to rotate an image through its vertical axis.

 Flip Vertical button is used to rotate an image through its horizontal axis.

 Rotate 90 CCW button rotates the image by 90 degrees counterclockwise.

 Rotate 90 CW button rotates the image by 90 degrees clockwise.

 Apply Filter opens a drop down menu that allows you to apply the following filters:

· Smooth

· Gaussian Blur

· Sharpen

· Mean Removal

· Emboss Laplascian

· Emboss All Directions

· Emboss Lossy

· Edge Detect

· Despeckle

 Convert To
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· 1bpp Indexed

· 8bpp Indexed

· 8bpp Grayscale

· Grayscale with Alpha

· 24bpp

· 32bpp

 Grayscale converts the image to Grayscale.

 Deskew straightens the image.

 Fit Visible button fits the image within the borders of the view pane.

 Zoom In button increases the Zoom percentage of the image. 

 Zoom Out button decreases the Zoom percentage of the image.

 Options…. Defines additional settings for the new document.

New Page Options

Image Layout Options

Image Labels

Image Processing

Image Compression

Image Post-processing
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New Page Options

Allows setting the page options such as size, rotation and margins.

      Images To PDF Options> New Page Options window

Choose Paper Size by Image Size will cause the resulting document size to be the size of the

initial image.

Standard allows selecting the page size from a list of standard page sizes for the document.

Custom  Specify custom document dimensions in the unit listed in the far right drop-down menu.

Orientation Sets the document rotation.

· Portrait The short edge of the page is at the top and bottom.

· Landscape The short edge of the page is at the Left and Right.

Page Rotation allows setting the rotation of the content on the page.

· Don't Rotate will not rotate the pages.

· Clockwise 90 degrees

· 180 degrees
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· Counterclockwise 90 degrees

Margins margins adjust the size of the page by setting non-zero margins using the selected units.

Page margins are the blank space around the edges of the page.

Choose Paper Size by Source. This option specifies the size of the page by the source.

Standard. Selecting this option allows setting the standard size of the page.
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Images Layout Options

Allows setting the way images are placed in the PDF.

      Images To PDF Options> Images Layout Options window

Layout Rules allow setting the layout options.

Columns: Specifies the number of columns for the

vertical layout.

Space between Columns Controls the amount of

horizontal space around an image.

Rows: Specifies the number of rows for the

horizontal layout.

Space between rows Controls the amount of

vertical space around an image.
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Align Images allows settting the image alignment.

Fit defines how the images are placed sized to fit into each cell.

· Reduce to cell will reduce the dimension of the image to fit the cell only if the image is

initially larger than the cell.

· Fit to cell will reduce, or increase the dimensions of the image to fit to the cell. 

· Off will not change the size of the image to fit the cell. 

Keep aspect ratio When ticked, the image may be resized to fit the new PDF page (cell), but there will

be no distortion of the image.

Horizontal alignment Sets the horizontal alignment of the images.

· Left

· Center

· Right

Vertical alignment Sets the vertical alignment of the images.

· Top

· Middle

· Bottom 
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Image Labels

Allows for the addition of a text label to the image.

      Images To PDF Options> Image Labels window

Use special text label for each image. Specifies the text label for each file. Enter any valid name.

Macros Clicking the Macros button  opens a list of macros that you can use to automatically

generate file names. More detailed information can be found in the *Macros  section.

Back color Opens the standard color selection dialog for setting the background color for the

image label.

56
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Paragraph.... Opens the Paragraph Options window to allows adjusting the paragraph settings

for the text label.

      Paragraph Options window

General

Alignment allows setting the paragraph text alignment.

· Left

· Center

· Right

· Justify

Indentation allows setting the paragraph indent in pt.

Special allows defining an exception to the indentation defined in the other fields.

· First Line causes the first line in a paragraph to be indented. Set the level of indentation in

pt. in the By field.

· Hanging is the opposite of first line as the first line of the paragraphs will be indented as per

the regular indentation,

and the rest of the lines within a paragraph will be indented as defined by the Special and

By fields.

Spacing allows adjusting the line spacing in between the lines.
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Font Clicking on Font opens the Select Font window.

      Select Font window

In the Select Font window, choose from installed fonts, the font Style, font Size, and color.

Effects fine-tune the look of the text within the file.

Fill defines the main color of the text.

Stroke defines the outline color of the text

Stroke Width defines the width of the stroke or outline

Underline Choose from no underline (None) and Solid underline.

Place label above image If ticked, the label will be placed above the image.

Add bookmark for each image with the same text as label. If ticked, a bookmark will be created

for all images with the same text as label specified.
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Image Processing

Allows setting the options of the image’s downsampling and conversion.

      Images To PDF Options> Image Processing window

Downsampling and Conversion.

True Color. Applies image downsampling and conversion options for true color images.

Grayscale. Applies downsampling or conversion options for high color and grayscale images.

Indexed. Applies downsampling or conversion options for indexed images.

Monochrome. Applies downsampling or conversion options for monochrome images.

Downsampling. Downsampling decreases the number of pixels in an image. To downsample images,

choose a downsampling method (linear, bilinear, or bicubic downsampling) and enter the desired

resolution (in pixels per inch). Then enter a resolution in the for images above text box.

No Downsampling. Allows disabling downsampling if the PDF file is to be printed at high

resolution.
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Linear Downsampling to. The classical linear downsampling approach is based on the removal

from the original image of those frequencies which are too high to be represented at a lower

resolution level.

Bilinear Downsampling to. Adds pixels by averaging the color values of surrounding pixels. It

produces results of medium quality.

Bicubic Downsampling To. Is a more precise downsampling method based on an examination of

the values of surrounding pixels. Using more complex calculations, Bicubic downsampling

produces smoother tonal gradations than Linear or Bilinear ones.

Conversion. Allows changing the images’ color mode for grayscale, monochrome or black & white.

No Conversion. No images will be converted.

Convert to Grayscale. Images will be converted to grayscale.

Convert to Monochrome. Images will be converted to monochrome.

Convert to Black & White. Images will be converted to black & white.

Dithering. When the Dithering option is selected, Photoshop mixes colors in the destination color

space to simulate a missing color that existed in the source space. Although dithering helps to

reduce the blocky or banded appearance of an image.
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Image Compression

Allows setting the image compression options.

      Images To PDF Options> Image Compression window

True Color. Applies image compression options for true color images.

Grayscale. Applies compression options for high color and grayscale images.

Indexed. Applies compression options for indexed images.

Monochrome. Applies compression options for monochrome images.

Compression enabled. If checked, it will compress image content depending on the image compression

options selected.

· Auto. The best compression settings will be set  by the application whilst retaining reasonable

image quality.

· JPEG. Best used for colored images.

· Flate. Is used for text, graphics and images.

· JPEG/ZIP.
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· JPEG 2000.

· JPEG 2000/ZIP.

JPEG Quality. A percentage value determining image content quality over compression - the higher the

value entered the lower the compression setting applied and image quality is retained to a higher

degree - lower values make smaller files.
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Image Post-processing

Allows setting image modification actions, such as Deskew, Despeckle, and/or OCR the images after the

PDF is created.

      Images To PDF Options> Image Post-processing window

Deskew will straighten images if they are skewed or crooked.

Despeckle will detect and remove specks from the document.

Run OCR will run OCR on the pages in the resulting PDF.

OCR Settings See Document> OCR pages ... for more details.430
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7.4.7.3 Insert Scanned Pages...

Insert Pages from a scanned document by selecting the  Insert Scanned Pages feature found under

Document> Insert Pages> Insert Scanned pages. This opens the Scan Properties dialog.

      Scan Properties Window

Scanner Properties allows the selection of custom scan settings. Adjust these settings in the Parameters

section of the Scan Properties dialog.

Parameters

Adjust the settings and behavior when scanning.

Scanner displays the currently selected scanner. Select another scanning device from the drop-

down list.
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Data Transfer method:

· Native Mode: Every Source must support this transfer mode as It is the default mode and is

the easiest for an application to implement. However, it is restrictive (i.e. limited to the DIB,

PICT, or TIFF formats and limited by available memory).

· Memory Mode: Offers the greatest flexibility, both in data capture and control. However, it

is more complicated  to implement.

Color Mode: Choose the color mode for the scanned document from the drop down menu.

· Color

· Grayscale

· Black & White

Resolution:

Paper Size click on  to open the Paper Size setup dialog.

Source: This drop down menu will list the supported options for scanning. The scanner used in

this example supports Flatbed scanning and scanning using the Document feeder. 

Sides: These options facilitate duplex scanning whether the scanning device supports it or not.

· Simple Scan provides a simple, one sided scan.

· Manual duplex scans the front of all the sheets then the backs of the sheets. Back pages

will be automatically interleaved in the order in which they were scanned. Eg. 10 pages (5

double sided originals) would scan pages 1,3,5,7 and 9, then pages 10,8,6,4,2, then collate as

1,2,3,4,5,6,7,8,9,10.

· Manual Duplex Reversed scans the front of all sheets then the backs. Back pages will be

automatically interleaved in the reverse order in which they were scanned. Eg. 10 pages (5

double sided originals) would scan pages 1,3,5,7 and 9, then pages 10,8,6,4,2, then collate as

1,2,3,4,5,6,7,8,9,10.

Scan More Pages: Select the desired option from the drop-down menu.

· Disabled once the scan is complete, the Editor will not ask if there are more pages to be

scanned.
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· Ask user once the scan is complete as determined by the scanner itself, the Editor will ask if

there are more pages to scan.

· Automatically after will automatically scan more pages after the set time in the adjacent

field.

Show images insertion dialog after scanning will launch the image insertion dialog after

scanning has completed. The Image Insertion Dialog allows for modification of Image To PDF

options. See Image Insertion Option  section below.

  Launches the Images To PDF options window. See Image

Insertion Option  section below.

Destination

Define the location in the active document for the pages from the source file to be inserted.

Location define the rout location for placement of the selected pages from the source document.

· Before will place the pages before the option defined.

· After will place the pages after the option defined.

First Page the pages inserted from the source file will be located before or after the first page in

the active document depending on the option selected in the Location drop-down menu.

Last Page the pages inserted from the source file will be located before or after the last page in

the active document depending on the option selected in the Location drop-down menu.

Page: the pages inserted from the source file will be located before or after the page number

indicated in the active document depending on the option selected in the Location drop-down

menu.
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 opens the Paper Size setup dialog to select the desired paper size of the document

to be scanned

      Document> Insert Pages> Insert Scanned Pages> Paper size setup dialog.

Automatic allows for the Editor to automatically detect the size of the page(s) being scanned.

Standard select a standard page size from the drop-down menu.

Custom Defines a custom page size in the units selected.

Orientation choose from Portrait, or Landscape orientation. This option is not available when

scanning pages.

The image insertion options button opens the Images To PDF Options window.
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New Page Options

Allows setting the page options such as size, rotation and margins.

      Images To PDF Options> New Page Options window

Choose Paper Size by Image Size will cause the resulting document size to be the size of the

initial image.

Standard allows selecting the page size from a list of standard page sizes for the document.

Custom  Specify custom document dimensions in the unit listed in the far right drop-down menu.

Orientation Sets the document rotation.

· Portrait The short edge of the page is at the top and bottom.

· Landscape The short edge of the page is at the Left and Right.
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Page Rotation allows setting the rotation of the content on the page.

· Don't Rotate will not rotate the pages.

· Clockwise 90 degrees

· 180 degrees

· Counterclockwise 90 degrees

Margins margins adjust the size of the page by setting non-zero margins using the selected units.

Page margins are the blank space around the edges of the page.

Choose Paper Size by Source. This option specifies the size of the page by the source.

Standard. Selecting this option allows setting the standard size of the page.
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Images Layout Options

Allows setting the way images are placed in the PDF.

      Images To PDF Options> Images Layout Options window

Layout Rules allow setting the layout options.

Columns: Specifies the number of columns for the

vertical layout.

Space between Columns Controls the amount of

horizontal space around an image.

Rows: Specifies the number of rows for the

horizontal layout.

Space between rows Controls the amount of

vertical space around an image.

Align Images allows settting the image alignment.

Fit defines how the images are placed sized to fit into each cell.

· Reduce to cell will reduce the dimension of the image to fit the cell only if the image is

initially larger than the cell.

· Fit to cell will reduce, or increase the dimensions of the image to fit to the cell. 
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· Off will not change the size of the image to fit the cell. 

Keep aspect ratio When ticked, the image may be resized to fit the new PDF page (cell), but there will

be no distortion of the image.

Horizontal alignment Sets the horizontal alignment of the images.

· Left

· Center

· Right

Vertical alignment Sets the vertical alignment of the images.

· Top

· Middle

· Bottom 

Image Labels

Allows for the addition of a text label to the image.

      Images To PDF Options> Image Labels window



392

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Use special text label for each image. Specifies the text label for each file. Enter any valid name.

Macros Clicking the Macros button  opens a list of macros that you can use to automatically

generate file names. More detailed information can be found in the *Macros  section.

Back color Opens the standard color selection dialog for setting the background color for the

image label.

Paragraph.... Opens the Paragraph Options window to allows adjusting the paragraph settings

for the text label.

      Paragraph Options window

General

Alignment allows setting the paragraph text alignment.

· Left

· Center

· Right

· Justify

Indentation allows setting the paragraph indent in pt.

Special allows defining an exception to the indentation defined in the other fields.

· First Line causes the first line in a paragraph to be indented. Set the level of

indentation in pt. in the By field.

56
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· Hanging is the opposite of first line as the first line of the paragraphs will be indented

as per the regular indentation,

and the rest of the lines within a paragraph will be indented as defined by the Special

and By fields.

Spacing allows adjusting the line spacing in between the lines.

Font Clicking on Font opens the Select Font window.

      Select Font window

In the Select Font window, choose from installed fonts, the font Style, font Size, and color.

Effects fine-tune the look of the text within the file.

Fill defines the main color of the text.

Stroke defines the outline color of the text

Stroke Width defines the width of the stroke or outline

Underline Choose from no underline (None) and Solid underline.

Place label above image If ticked, the label will be placed above the image.

Add bookmark for each image with the same text as label. If ticked, a bookmark will be created

for all images with the same text as label specified.
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Image Processing

Allows setting the options of the image’s downsampling and conversion.

      Images To PDF Options> Image Processing window

Downsampling and Conversion.

True Color. Applies image downsampling and conversion options for true color images.

Grayscale. Applies downsampling or conversion options for high color and grayscale images.

Indexed. Applies downsampling or conversion options for indexed images.

Monochrome. Applies downsampling or conversion options for monochrome images.

Downsampling. Downsampling decreases the number of pixels in an image. To downsample images,

choose a downsampling method (linear, bilinear, or bicubic downsampling) and enter the desired

resolution (in pixels per inch). Then enter a resolution in the for images above text box.

No Downsampling. Allows disabling downsampling if the PDF file is to be printed at high

resolution.
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Linear Downsampling to. The classical linear downsampling approach is based on the removal

from the original image of those frequencies which are too high to be represented at a lower

resolution level.

Bilinear Downsampling to. Adds pixels by averaging the color values of surrounding pixels. It

produces results of medium quality.

Bicubic Downsampling To. Is a more precise downsampling method based on an examination of

the values of surrounding pixels. Using more complex calculations, Bicubic downsampling

produces smoother tonal gradations than Linear or Bilinear ones.

Conversion. Allows changing the images’ color mode for grayscale, monochrome or black & white.

No Conversion. No images will be converted.

Convert to Grayscale. Images will be converted to grayscale.

Convert to Monochrome. Images will be converted to monochrome.

Convert to Black & White. Images will be converted to black & white.

Dithering. When the Dithering option is selected, Photoshop mixes colors in the destination color

space to simulate a missing color that existed in the source space. Although dithering helps to

reduce the blocky or banded appearance of an image.



396

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

Image Compression

Allows setting the image compression options.

      Images To PDF Options> Image Compression window

True Color. Applies image compression options for true color images.

Grayscale. Applies compression options for high color and grayscale images.

Indexed. Applies compression options for indexed images.

Monochrome. Applies compression options for monochrome images.

Compression enabled. If checked, it will compress image content depending on the image compression

options selected.

· Auto. The best compression settings will be set  by the application whilst retaining reasonable

image quality.

· JPEG. Best used for colored images.

· Flate. Is used for text, graphics and images.

· JPEG/ZIP.

· JPEG 2000.

· JPEG 2000/ZIP.
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JPEG Quality. A percentage value determining image content quality over compression - the higher the

value entered the lower the compression setting applied and image quality is retained to a higher

degree - lower values make smaller files.

Image Post-processing

Allows setting image modification actions, such as Deskew, Despeckle, and/or OCR the images after the

PDF is created.

      Images To PDF Options> Image Post-processing window

Deskew will straighten images if they are skewed or crooked.

Despeckle will detect and remove specks from the document.

Run OCR will run OCR on the pages in the resulting PDF.

OCR Settings See Document> OCR pages ... for more details.430
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7.4.7.4 Insert Text...

To insert text files to an existing file, select the Insert Text option found under Document> Insert

Pages> Insert Text to open the Convert Text Files To PDF window. 

      Convert Text Files To PDF window

First, choose the source file(s) or folder(s) using the  Add Files... and  Add Folder buttons

respectively. Selecting a folder will include all text files contained within that folder, and sub-folders.

Select one of the files to change file-specific behavior at the time of insertion.

Once the destination and options are correctly defined, select OK to insert the pages to active file. See

below for more details.
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Source Files

This section allows for the selection of text files to be added to the currently active PDF file.

Add files…. Opens the Open window to select an text file from.

 Add Folder…. Opens the Browse For Folder window to add/select all text files contained in

the selected folder.

    Up. Moves the selected file up in the list.

    Down. Moves the selected file down in the list.

 Remove. Removes the selected file from the list. 

Options for Selected File(s)

Text Encoding defines the language of the text in the file. 

New Paragraph Detection define how the Editor recognizes paragraph structure for the selected

text file.

· Auto Detect

· Each newline character starts a new paragraph

· Two newline characters starts a new paragraph, single is ignored

· Double newline character starts a new paragraph, single is converted to space

File Placement define the location and placement behavior for the selected text file.

· Start each file from new paragraph

· Start each file from new page

Destination

Define the location in the active document for the pages from the source file to be inserted.

Location define the rout location for placement of the selected pages from the source document.

· Before will place the pages before the option defined.

· After will place the pages after the option defined.

First Page the pages inserted from the source file will be located before or after the first page in

the active document depending on the option selected in the Location drop-down menu.

Last Page the pages inserted from the source file will be located before or after the last page in

the active document depending on the option selected in the Location drop-down menu.
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Page: the pages inserted from the source file will be located before or after the page number

indicated in the active document depending on the option selected in the Location drop-down

menu.

The Options button lunches the options window. There, options such as text formatting, Page sizes and

more can be defined.

New Page Options

      Options> New Page Options window

Document the page size of the currently active PDF will be used for the inserted pages.

Standard choose from a list of standard page sizes.

Custom Define a custom page size in the adjacent fields using the units selected.

Margins Define the margin in the unit selected.

Left: Defines the white space between the left edge of the page, and the content.

Right: Defines the white space between the right edge of the page, and the content.

Top: Defines the white space between the top edge of the page, and the content.

Bottom: Defines the white space between the bottom edge of the page, and the content.
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Text Format

Allows setting the format in which the text within the PDF is rendered. 

      Options> Text Format window

Text Style

 opens the Select Font window.

      Select Font window
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In the Select Font window, choose from installed fonts, the font style, font size, and color.

Effects allows for fine-tuning the look of the text within the file.

Fill defines the main color of the text.

Stroke defines the outline color of the text

Stroke Width defines the width of the stroke or outline

Underline Choose from no underline (None) and Solid underline.

 allows setting how paragraphs are rendered in the PDF output.

      Paragraph Options window

General

Alignment allows the setting of the paragraph text alignment.

· Left

· Center

· Right

· Justify

Indentation allows setting the paragraph indent in pt.

Special allows setting an exception to the indentation defined in the other fields.

· First Line causes the first line in a paragraph to be indented. Define the level of indentation

in pt. in the By field.
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· Hanging is the opposite of first line as the first line of the paragraphs will be indented as per

the regular indentation, and the rest of the lines within a paragraph will be indented as

defined by the Special and By fields.

Spacing allows adjusting the line spacing in between the lines.

Before defines the line spacing above each line in Points (pt)

After defines the line spacing below each line in Points (pt)

Line Spacing select the line spacing method.

File Separator

Allows for the addition of a file separator for new text files and to specify its options.

      Options File Separator window

Show title. Shows the title header to separate each file. Enter any valid name. In addition, clicking

the Macros  button opens a submenu of macros that automatically generates file names.

For detailed information go to the *Macros  section.

Back color: Opens the standard color selection dialog to allows setting the background color for

the header. 

Font.... opens the Font Select window as described in the Text Style  section above. 

Paragraph.... opens the Paragraph Options window as described in the Text Style  section

above.

Draw line. Allows a line to be drawn that would separate files one from another and specify the

line’s appearance.

Place line above header. If this option is selected, the line will be placed above the header.

56
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7.4.7.5 Insert RTF...

To insert RTF (Rich Text Format) files to an existing file, select the Insert RTF option found under 

Document> Insert Pages> Insert RTF to open the Convert RTF Files To PDF window. 

      Convert RTF Files to PDF Window

First, choose the source file(s) or folder(s) using the  Add Files... and  Add Folder buttons

respectively. Selecting a folder will include all RTF files contained within that folder, and sub-folders.

Select one of the files to change file specific behavior at the time of insertion.

Once the destination and options are correctly defined, click OK to insert the pages to active file. See

below for more details.

Source Files

This section allows for the selection of RTF files to be added to the currently active PDF file.

Add files…. Opens the Open window to select an RTF file from.

 Add Folder…. Opens the Browse For Folder window to add/select all RTF files contained in

the selected folder.

 Up. Moves the selected file up in the list.

 Down. Moves the selected file down in the list.

 Remove. Removes the selected file from the list. 
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Destination

Define the location in the active document for the pages from the source file to be inserted.

Location define the page insertion location for placement of the selected pages from the source

document.

· Before will place the pages before the destination page defined.

· After will place the pages after the destination page defined.

First Page the pages inserted from the source file will be located before or after the first page in

the active document depending on the option selected in the Location drop-down menu.

Last Page the pages inserted from the source file will be located before or after the last page in

the active document depending on the option selected in the Location drop-down menu.

Page: the pages inserted from the source file will be located before or after the page number

indicated in the active document depending on the option selected in the Location drop-down

menu.

Options opens the Options window.

Relative Path Options define the path from which to call the selected RTF file. .

Keep existing keeps the current file path.

Make absolute Creates an absolute file path pointing directly to the RTF.

Make Relative Creates a path relative to the active PDF file pointing to the RTF file.
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7.4.8 Extract Pages

To Extract Pages from a document to a new document or documents, go to Document> Extract

Pages. This opens the Extract Pages window. 

Page Range: Selected <#> of <#> pages

Define the page range to be extracted. 

All all pages will be extracted.

Current Page the currently viewed page will be extracted.

Pages type the desired page range here. Multiple page ranges should be separated by a

coma. 

Note: For printing pages 1 to 15, page 17, pages 20 to 46 and pages 88 to 100 of a 100 page

document to be included in the print job, type the following: 1-15, 17, 20-46, 88-100. If there is

a disconnected hyphen (dash) in the page ranges, that page range will go to the beginning or

end of the document like so: -15, 17, 20-46, 88-.
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Selected Pages This option is available when there are pages selected in the Thumbnails

Pane . 

Subset Select a subset of pages. Such as Odd pages or Even Pages.

Actions for Objects

Define the actions to perform on each of the objects. 

Comments: Define the behavior for comments and annotations. 

· Copy: Copies the object to the new document.

· Flatten flattens the objects so they appear to be copied, but are in fact base

content objects instead of comments. 

· Do not copy: Will not copy comments to the new document. 

Form Fields: Define the behavior for form fields.

· Copy copy form fields and entered data to the new document. 

· Flatten flattens form fields and their content to the new document. 

· Do not copy does not extract form data or fields to the new document. 

Bookmarks: Define the actions for bookmarks.

· Copy All Copy all the bookmarks from the original document to the new

document. 

· Do not copy does not copy bookmarks to the new document. 

· Copy related copies only bookmarks related to the pages included in the

extraction.  

Delete Pages after extraction: Will remove the pages from the original document after

extraction. 

Output Options define the preferences for the resulting document. 

Type:  defines the output for each page extracted. 

· Extract all pages to a new document all extracted pages will be extracted to a

new, unsaved document. 

· Save all extracted pages to one file all extracted pages will be in a single

resulting document. 

296
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· Save each page to a separate file each extracted page will be extracted to its

own document. 

· Save each page range to a separate file Pages within a single page range will be

extracted to a single document. For example, if the page range is defined as 3-4, 9-

26, 43-49 the result will be 3 documents. 

File Name: Macros can be used in this field to define the file name programmatically. For a

guide to using Macros, please see the *Macros  page. A custom name can be manually

typed into this field as well. 

Destination Folder Define the folder to which the new document(s) will be saved.  

Open Destination folder for the resulting files will open the folder that the extracted pages

have been saved to. 

56
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7.4.9 Split Document By Bookmarks

Split Document by Bookmarks  allows splitting of the current PDF document into multiple

smaller-size PDF documents from Top Level Bookmarks (Root Bookmarks). 

This feature can split a big PDF document (e.g., a book) into individual chapters.

From the Main Menu choose Document> Split Document by Bookmarks to launch the Split

Document By Bookmarks window and split the PDF document. Each new file will inherit the name

of the related root bookmark.

     Split Document By Bookmarks window

Actions with Objects

Actions related to objects that are included in the original PDF document, such as Comments,

Form Fields, and child Bookmarks, can be included to the new documents; can be converted to the

part of the new content or ignored in the resulting documents.

Comments: 

· Copy adds the related comments as Comments  to the new documents. 

· Flatten adds the related comments as part of the documents content - Flatten

Comments . 

· Do Not Copy discards all comments and creates the resulting documents without

comments.

446
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Form Fields: 

· Flatten adds the content of the form fields to the content of the resulting documents. 

· Do Not Copy discards all form field content.

Bookmarks: 

· Do Not Copy discards all bookmarks and creates the resulting documents without

bookmarks.

· Copy All adds all bookmarks to the new documents. Bookmarks related to the current

root bookmark will not perform the same action in the new file. Bookmarks that do not

relate to the resulting document will only be listed in the Bookmarks  Pane. 

· Copy Related adds only the related bookmarks to the new documents. 

Output Options 

These options define the results of the new documents. 

Destination Folder, which may already exist, or can be created for the resulting documents

to be saved to. The documents will get the names of the root bookmarks. 

Further to this options include:

Open the Destination Folder with Result Files and see the new files once saved, named as

related root bookmarks.

Overwrite Existing Files and save the new documents over existing files in the folder with

the same names. Use this option when you attempt to split the original PDF document more

than one time.

Press OK to split the PDF document by bookmarks into new PDF documents or Cancel to cancel

the operation.

284
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7.4.10 Replace Pages...

Replace Pages replaces existing pages of an open PDF document with pages from another already

opened PDF document or a Supported file type located in an available folder.

Main Menu> Document> Replace Pages... opens the Replace Pages Window.

Replace pages can also be accessed using the Thumbnails  pane: Select the pages to be

replaced and then open the context menu by right-clicking the mouse and selecting Replace

pages... 

     Replace Pages window

296
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Pages to Replace

Sets the range of pages of the active PDF document to replace, using the Pages From: and To: fields

New Pages From 

Sets the document that contains the new pages to replace the existing ones.

From File selects a file using the standard Windows Open File  dialog to navigate to a

folder on your computer or network to select a file.

Note: The types of files containing replacement page(s) must be supported by PDF-

XChange Editor.

From Already Opened Document selects a file that is already opened in the Editor using the

drop-down list provided.

Page Range sets the page(s) to be inserted into the original document.

All inserts all pages from the document.

Pages: selects individual pages from the document. The pages will be indicated by their numbers

beginning with 1. 

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select pages

2, 3, 4, and 5. 

Multiple page ranges may be specified, separated from one an other by commas.

Subset drop-list provides the option to select groups based on an order within the document.  

· All Pages option inserts all of the specified pages.

· Even Pages Only option inserts, within the specified Pages Range, only even-

numbered pages: 2, 4, 6, etc.

· Odd Pages Only option inserts, within the specified Pages Range, only odd-numbered

pages: 1, 3, 5, etc.

88
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Replace Pages Options

With the new pages you may want to place not only their content, but also the objects from these

pages, such as Comments, Form Fields, and Bookmarks.

Only content if you want to replace only content (text, images, which are the part of content)

of selected pages from an active document with content of new pages.

Note: All links, comments, bookmarks from the original pages will remain their

places. 

Actions and bookmarks, associated with replaceable pages, will be unavailable. 

With this option you can replace only the same number of pages (for example, if

you attempt to replace pages 5,6 with pages 5-8, you are able to replace only

pages 5 and 6.)

Or

Content of comments, form fields, and bookmarks. delete all content and annotations

(comments, links) from the original pages and bring new pages their content, related links,

and objects such as:

Comments: 

· Copy comments to add related comments to the new

documents as Comments ; 

· Flatten comments to add these comments as part of the

documents content - Flatten Comments ; 

· Do Not Copy comments to discard all comment and get the

result documents without comments.

Form Fields: 

· Flatten form fields to add the content of form fields (but not

fields themselves) to the resulting documents' content; 

· Do Not Copy to discard all form fields.

Bookmarks:

· Do Not Copy bookmarks to discard all bookmark and get the

result document without bookmarks;

· Copy All bookmarks to all bookmarks to the new document.

Bookmarks, that are not related to the current root bookmark,

in a new document will not perform any action; they will be

only listed in the Bookmark  Pane.

· Copy Related to add only related bookmarks to the new

document.
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7.4.11 Delete Pages

Delete Pages allows you to select pages to be deleted from the active PDF.

IMPORTANT! This is a Licensed feature, see IMPORTANT! Evaluation mode vs. Licensed mode

for more information! 

Pages Range. There are three ways that page(s) may be selected for deletion: 

Selected Pages. If you select one or more pages in the Thumbnails display, this option

will be available. Clicking OK will cause those selected pages to be removed. 

Current Page. Selecting this option will cause the current page of the active document

to be deleted. 

Pages. This option allows you to enter Pages Range. Individual pages are indicated by

their numbers beginning with 1. 

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select

pages 2, 3, 4, and 5. 

Multiple page ranges may be specified, separated from one another by commas. 

Subset. When Pages is selected, this drop box becomes active. The valid values

are: 

All Pages. All pages in the specified range will be removed. 

Odd Pages Only. Only ODD numbered pages will be removed. 

If you specify a range of "1-5", only pages 1, 3, and 5 will be removed. 

Even Pages Only. Only EVEN numbered pages will be removed. 

If you specify a range of "1-5", only pages 2 and 4 will be removed.
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7.4.12 Crop Pages

IMPORTANT! This is a Licensed feature, see IMPORTANT! Evaluation mode vs. Licensed mode

 for more information! 

The Portable Document Format (PDF) file encapsulates a complete description (the content and

appearance) of a document. Among the other parameters, it stores the sizes of the document page.

It includes the 5 various descriptions of page sizes (page boxes): Media Box, Crop Box, Bleed Box,

Trim Box, Art Box. Media Box defines the size of sheet of paper for print (the width and height). If

the PDF file has not been prepared to the printing office, the size of the Media Box equals the actual

page size. 

A finished (physical) page appears as a sheet of paper (for example, as in a book); its size is shown in

the Measurement Info  (in the left bottom corner) or in the Preview in the Print  window.

The intermediate page is distinguished from the finished page. It includes additional information for

the printing office, such as bleeds, printer marks outside of the boundaries of the finished page.

Fig.1 Fig.2

Fig.1. The example of a PDF page (Media Box) with the visual borders of all boxes, printing marks and data outside of the

Bleed Box. It looks ready to the printing establishment.

Fig.2. The example of a PDF page as a physical page (as a book page after trimming).

Crop Pages can define all sizes of boxes for a PDF page (Crop Box, Trim Box, Bleed Box, Art Box) and

crop the selected pages to the prescribed boundaries. This feature allows to adjust the visible area

and helps to prepare the PDF document for the prepress process.

12
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In a Main Menu choose Document > Crop Pages (or press Ctrl+Shif+T):

First, set the Page Range to which you want to describe the box.

Second, choose the Box and set the value of its Margins. For Crop Box decide what to do

with the content outside of the box.

At the end, click OK to approve the changes or Cancel to discard them.

Crop Margins dialog allows to set and change margins for Crop, Trim, Bleed, and Art Boxes. 

Choose the Crop Method to work with all boxes or just to cut the white edges from the

page.

· Manual Control of Margins on Crop Box, Bleed Box, Trim Box, and Art Box to

set the parameters of margins by typing their values or by dragging the

edges of the box with a mouse.

· Remove White Spaces to crop all vertical and horizontal white spaces on the

page(s) without additional settings. It is the easiest way to remove all white

margins from the displaying and printing area of document pages.

· Remove Vertical White Spaces to crop white spaces on the top and the

bottom of the page(s) without additional settings.
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· Remove Horizontal White Spaces to crop left and right white spaces on the

page(s) without additional settings.

In the field Apply to box choose a box for further setting.

· Crop Box defines the region for screen display or printing (visual page). The

page content outside of Crop Box will be clipped. Usually identical to the

Media Box, Trim Box, or both. For prepress use Crop Box is irrelevant.

· Trim Box defines the actual, final page size (after trimming when

professionally printed). The Trim Box is taken from the document setup.

· Bleed Box is wider and taller than the Trim Box. Images or other elements

touching an outer edge of a printed page need to extend beyond the edge of

the paper to compensate for inaccuracies in trimming the page. Information

is sourced from the margin section of the print dialog box or is in a

requirement list from a printing office.

· Art Box defines a rectangular within a page for special interest. As example of

using the Art Box is to handle ads: the Art Box can define the size of that ad

on a with an advertisement. This allows you to place that PDF on another

page but only use the ad from that PDF.

Show All Boxes. Check this option to see all boxes in the Preview window. They are

displayed as the rectangles in assigned colors. 

Note: To make the boxes visible on the page(s), choose the option Display art, trim,

bleed boxes in the Main Menu > Edit > Preferences > Page Display .

Manual Control of Margins allows to set the value of margins for the selected box. Also,

using the arrows up/down, increase and decrease the value of the margins in the Left, Right,

Top, and Bottom fields. 

In the Units field choose the desired unit of measurement: millimeter, centimeter, inch, pica

(1/6 inch or 12 pt), point (1/72 inch).

Constrain to Proportions allows to set all margins with the same value. Choose this option

to set all margins automatically after changing one of them.

Note: Also, in the Preview window, you can move the borders of the rectangular

with the mouse to adjust them approximately.

For annul manual changes press the button:

Set to Zero to set all margins for the selected box back to "0". It means the box will not

have margins. 

208
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Revert To Original to reset the original margins - the margins approved before

changes. 

Set To White Margins to adjust the boundaries of the current box to the white

margins on the selected pages.

Remove the content outside of the crop box area for permanent delete the content outside of

the Crop Box. This option may reduce the size of image based PDF document. To return the outside

content to previous, click Undo (Edit > Undo) or Ctrl+Z. 

Page Range

The options in that dialog allow to define which pages to be effected by the Crop, Trim, Bleed, or

Art Box settings. 

In the Page Range dialog, click the radio button to choose the range of pages for the selected box:

All Pages to select all pages within the file the box settings will be the same. 

Selected Pages to apply the following box settings for only pages selected in the Thumbnails

Pane .

Current page to apply the following box settings for the currently viewed page. 

Pages to type numbers and/or page ranges separated by commas for further apply the box settings

(for example, 2-5,7,10-12)

Click: 

· OK to apply changes.

· Cancel to annul changes.

189
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7.4.13 Crop Page Tool

The Crop Pages Tool  allows users to crop the active document's pages based on setting

Margins for the individual boxes.

This is most often necessary if the PDF is being used to transmit information for printing or faxing

and user control over the information display must be maintained.

IMPORTANT! This is a Licensed feature, see IMPORTANT! Evaluation mode vs. Licensed mode

 for more information!   

The crop Pages tool is used to select an area of a page for which to crop. When the Tool is

activated, a dialog will pop up with instructions to use Crop Tool.

To start, click on Drag Crop Rectangle... then select the desired area to be cropped: 

      Area selected for cropping

Once the Area is selected, the Crop Pages  dialog will launch, allowing the user to fine-tune the

area to be cropped. For Further information regarding the Crop Pages dialog, please see the Crop

Pages section.
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7.4.14 Resize Pages...

The Resize Pages utility found under Document> Resize Pages can redefine the size of a page or

pages. 

Paper Size 

Dictates the size of the page(s) after resizing. 

Standard Choose from the standard page size list. Choose either Portrait or Landscape

orientation of the page from the second drop down menu. 

Custom Selecting this option allows for the specification of the page size using the Units

selected in the adjacent drop down menu.
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Placement Options

The placement fields allow the definition of the position of a resized area on a PDF page.

Vertical Offset. Once the area is resized to one of the 9 starting positions, "Fine tune" the

position by applying vertical offset values to the resized area. 

Horizontal Offset. Once the area is resized to one of the 9 starting positions, "Fine tune" the

position by applying horizontal offset values to the resized area. 

From Positions. Selecting one option from each of these buttons will position the resized area

to one of 9 starting positions on the page by choosing a horizontal, and vertical value from

the drop down menu.

· Left

· Center

· Right

Pages Range: Selected _ of _ pages

Define the page range to be resized.

All all pages will be resized.

Current Page the currently viewed page will be resized

Pages type desired page range here. Multiple page ranges should be separated by a coma. 

Note: For resizing pages 1 to 15, page 17, pages 20 to 46 and pages 88 to 100 of a 100

page document to be resized, type the following: 1-15, 17, 20-46, 88-100. If there is a

disconnected hyphen (dash) in the page ranges, that page range will go to the beginning

or end of the document like so: -15, 17, 20-46, 88-.

Selected Pages This option is available when there are pages selected in the Thumbnails

Pane . 

Subset Select a subset of pages. Such as Odd pages or Even Pages.

§ Odd Pages Only. Only ODD numbered pages will be resized. If you specify a range

of "1-5", only pages 1, 3, and 5 will be resized.

§ Even Pages Only. Only EVEN numbered pages will be resized. If you specify a range

of "1-5", only pages 2 and 4 will be resized. 

Content Transform Options 

Allows for the content of the page to be resized relative to the page resizing.

Transform Content with selected pages turning on this option will cause content to be

resized with the pages. 

Constrain the aspect ratio of the content content will not be distorted, stretched or

squished.
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7.4.15 Rotate Pages

There are a few ways to rotate pages in the PDF-XChange Editor. Pages selected within the 

Thumbnails Pane  can be rotated by clicking on one of the rotate options at the top of the

Thumbnails Pane, or by Right Click> Rotate Pages.

     Thumbnails Pane floating window

Rotate Clockwise will rotate the pages 90° degrees to the right. 

Rotate Counterclockwise will rotate the pages 90° degrees to the left. 

296
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Otherwise, Pages can be rotated using the options found under Document> Rotate Pages.

     Rotate Pages window

Direction Select one of the available rotation directions from the drop down menu. 

· Clockwise 90 degrees will rotate the pages 90° degrees to the right. 

· 180 Degrees will flip the document so that the top and bottom of the page(s) are now

inverted. 

· Counterclockwise 90 degrees will rotate the pages 90° degrees to the left.

Pages Range: Selected _ of _ pages

Define the page range to be resized. 

All all pages will be rotated.

Current Page the currently viewed page will be rotated.

Pages type desired page range here. Multiple page ranges should be separated by a coma. 

Note: For rotating pages 1 to 15, page 17, pages 20 to 46 and pages 88 to 100 of a 100

page document, type the following: 1-15, 17, 20-46, 88-100. If there is a disconnected

hyphen (dash) in the page ranges, that page range will go to the beginning or end of the

document like so: -15, 17, 20-46, 88-.
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Selected Pages This option is available when there are pages selected in the Thumbnails

Pane . 

Subset Select a subset of pages. Such as Odd pages or Even Pages.

· Odd Pages Only. Only ODD numbered pages will be resized. If you specify a

range of "1-5", only pages 1, 3, and 5 will be rotated.

· Even Pages Only. Only EVEN numbered pages will be resized. If you specify a

range of "1-5", only pages 2 and 4 will be rotated.
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7.4.16 Split Pages

The Split Pages feature allows users to split pages into multiple pages. Please take a look at the

video below on how you can split pages with the PDF-XChange Editor, or read on to the written

instructions bellow.

To split pages, go to Document> Split pages. This will bring up the Split pages dialog. 

      Figure 1: Split pages Dialog

To add a new vertical split, click on , to add a new horizontal split, click on the . Use the

 to remove a selected split. 

The  and  buttons allow the user to zoom in and out respectively on the preview.
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A split can be Edited by mousing over, and adjusting the dotted line as shown in figure 2. You will

also notice the values of that split boundary in the left section.

      Figure 2: Split pages Dialog

Note: The currently selected split boundary will show as a red dotted line red in the Preview

section. 

Users can Edit the selected boundary using the  Edit Split... option. This will allow the user to

enter a custom value.

Settings

Remove source pages after splitting them will remove the original pages from the PDF instead of

adding the split pages to the PDF.

Choose splitting method: 
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· Change the physical size of the resulting pages This option will remove any data outside

of each split area, so that the page info contains only what is visible.

· Change the Crop box of resulting pages This option will cause the Crop Pages function to

work on behalf of the Split pages. The visual results will be the same, however all the original

page's underlying data exists on each of the resulting pages.

Preserve Original content: This option is only available while using the Change the Crop box of

resulting pages option. It will cause the page's original content to be preserved.

Pages Range

Pages. Individual pages are indicated by their numbers beginning with 1. Sequential page ranges

may appear as hyphenated inclusive ranges For example: 2-5 will select pages 2, 3, 4, and 5.

Multiple page ranges may be specified, separated from one another by commas. Page ranges

beginning or ending with a "-" will indicate the beginning or end of the document. For example if 2-

is indicated as the page range, all pages after page 2 will be effected.
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7.4.17 Number Pages

For better visual organizing PDF document with a Cover Page, Table of Contents, and complex

Content the Free feature Number Pages can be very effective.

It allows you to put labels on the document for easiest navigation.

Note: For physical adding page-numbering ranges to a PDF document use the Licensed

feature Header and Footer .

The result of applying the Number Pages:

1 - a label for the current page (the first page from the range pages 1-6) includes prefix "Part 1" and number "I"; 

2 - using the page numbering affects the page thumbnails (Thumbnails pane);

3 - the labels can be included in the Table of Content.

To apply labels to different ranges of pages in Main Menu choose Document > Number Pages...

To add a new page-numbering range click on the bar Add new range..., or drag the corresponding

slider to the beginning position of the new range, or type the number of the first page 

of the new range in the field Start page.
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Remove... will allow you to cancel the operation.

Reset ranges.. will delete all ranges

Style: of numbers inside the chosen range can be "integer" (1, 2, 3, ...), "Roman numeral" (I, II, III,

IV, ...), "Letter" (A, B, C, ...), etc.

Prefix: can be applied before the number for customize the range.

Start numbering from: allows you to put the first label for the range on the any desire page inside

the diapason.

Window Page Numbering:

1 - first range (pages 1-6) is highlighted; 2 - next range starts from page 7; 3 - Undo/Redo allows you cancel or

repeat previous changing the range; 4 - adding new range by using a slider; 5 - adding a new range by taping a

number of the page from what this range will start; 6 - style of numbering can differ in each range; 7 - type a prefix

to each range; 8 - numbering in a new range can start on any page inside the range; 9 - preview the results.

Note: To add the labels to content, use the Licensed feature Build Table of Contents

(Advanced > Bookmarks > Build Table of Content, section Page Numbering)
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7.4.18 OCR Pages...

When there is no current page selection, the "Selected Pages" option will be unavailable. 

If the current output type is set to "Create New Searchable PDF" a new document containing only

the pages from the selection will be created. OCR Pages… recognizes the text of the previously

scanned PDF document to make the scanned text searchable and selectable.

Selecting this menu option opens the OCR Pages dialog:

In addition to selecting pages for OCR, this dialog allows you to temporarily change the OCR

settings for the current task, if you wish, without saving them for next time. The options available

under Recognition and Output are the same as those found in the preferences. Please see the

documentation for Edit | Preferences | Scanner Presets  for details. You must use the

preferences page if you want to save your settings for the future.
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Pages Range. This group allows pages or page ranges to be selected for OCR. 

All. Selects all document pages for OCR.

Current Page. OCR only the current page.  

Selected Pages. Select pages with the "Thumbnails" view: see View | Thumbnails  for

details.

Pages. Allows a range to be typed into the range box. The format for page range

specification should be familiar, with commas separating ranges, and ranges

specified with hyphens. For example, 1-3,5,9 selects pages 1 to 3, then page 5, and

finally page 9. A hyphen at the start or end of the selection indicates the minimum or

maximum. For example, you could write 7- to select all pages from 7 to the end of

the document.

Subset. Specifies a filter to apply to the main selection. Choices are Odd, Even and All.

When there is no current page selection, the "Selected Pages" option will be unavailable. 

If the current output type is set to "Create New Searchable PDF" a new document

containing only the pages from the selection will be created. 

Recognition. Specifies the settings for recognizing the text.

Primary Language. Specifies the language which will be used for identifying the

characters.

More Languages.... Allows you to select other languages.

Accuracy.

Auto Deskew.

Output. Specifies the output settings.

Output Type. Allows you to select one of the following output types for a PDF

document.

Create New Searchable PDF.

Preserve Original Content and Add Text Layer. 

Quality. Determines the resolution of the new PDF document.
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7.4.19 Digital Signing

Digital signatures can be used for many types of documents where traditional pen-and-ink

signatures were used in the past. However, the mere existence of a digital signature is not adequate

assurance that a document is what it appears to be. Moreover, government and enterprise settings

often need to impose additional constraints on their signature workflows, such as restricting user

choices and document behavior during and after signing. 

Place a digital signature to any unsecured document by going to Document> Digital Signing. See

the Edit> Preferences> Signatures  section for help with configuring Creation and Appearance,

and Verification of digital signatures. 

 Sign Document

When Sign Document is activated, choose an area to place the signature by clicking and dragging

using the left mouse button. 

Once the area is defined, the Sign Document window is automatically opened. There, select the

certificate and signature template. 
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     Sign Document window

Select Certificate (Digital ID):

Use Certificate from System Store: uses a certificate from the windows certificate store. 

Use Certificate from File: uses a digital certificate from a file. Click on Browse to select a

certificate file.
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Setup Details and Appearance for Signature:

Reason for Signing: Select from the list of predefined reasons, or type the reason manually. 

Location: Manually type the desired value(s) for this field. 

Contact Info: Manually type the desired value(s) for this field. 

Permissions: Define the permissions to be governed by the signature from the drop-down

list

· No changes allowed

· Allow Form Fill-in, Signing and Creation of Template Pages

· Allow Form Fill-in, Signing, Commenting and Creation of Template pages.

Sign Template: Choose from existing signature templates in the drop-down menu, or select

Manage to open the Digital Signature Appearance Templates window. From there,

templates can be cloned, deleted, and modified.

Note: Click on one of the default templates and click Edit to edit its appearance.

Otherwise, click on Clone to copy the template, then edit the copy to preserve the

original. 

        See the Edit> Preferences> Signatures  section for more details.

Use Timestamp Server: If selected, a 3 party Timestamp server will provide official information on

when the document was signed. 

 Place Signature

Place Signature works in much the same way as Sign Document. Place Signature will create and

place a Digital signature/Certificate on the document. Sign Document will usually work the same

way as Place 

Signature unless there exists already, in the document, an unsigned signature field. If there is only

one of these in the document then Sign Document will go straight to the Sign Document window

(above) and add the signature to the existing signature field.  If there is more than one unsigned

signature field Sign Document will prompt a message to the effect that there is more than one to

choose from, and to please select the one you want to sign, then the sign document window will

again open.

 Certify (Visible) 

Creating a visible signature will place a visible signature on the PDF page when the document is

printed.
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 Certify (Invisible)

Will digitally sign the document, but will not place a visible signature. 

 Timestamp

Time stamping is an important mechanism for the long-term preservation of digital signatures, time

sealing of data objects to prove when they were received, protecting copyright and intellectual

property and for the provision of notarization services. Find more information at https://

www.signfiles.com/timestamping/

Server URL: Selects the Timestamp server to use. 

Server Requires Authentication some Timestamp servers require a username and password to

validate the signature/document. If so, select the option and fill in the fields below for Username

and Password.

Once satisfied, click on Ok to apply the time stamp certificate and save the document. 

 Validate All Signatures

When a signed document is received, some may want to validate its signature(s) to verify the signer

and the signed content. Validation may occur automatically. Signature validity is determined by

checking the authenticity of the signature’s digital ID certificate status and document integrity

 Clear All Signatures

Clears all digital signatures and certificates. 

Note: Some digital certificates/signatures cannot be removed without a password.

https://www.signfiles.com/timestamping/
https://www.signfiles.com/timestamping/
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7.4.20 Signatures and Initials

You can add visual picture with your own Signature or Initials to your PDF document from an image

or directly draw in a special window. 

In Main Menu choose Document > Signatures and Initials > Manage. 

 Window for managing your Signatures and Initials:

   1 - with this option you can Add New signature from a file or draw it in a special window; 2 - you can Edit selected

picture (give a name and password); 3 - name of your Signature;  4 - Remove selected; 5 - Remove all existing

Signatures and Initials.

Add New.. You can add or create pictures with signatures and apply to every PDF document you

want.

Import from File  With this option you will get a signature from an image file. 
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Draw Signature will open a window where you can draw your own signature or initials by the

mouse or stylus. Choose color from a giving palette or add custom color.

Edit... 1. After adding a signature press OK and open a window where you can name your signature

and protect it with a password. 

          2. You can choose any existing Signature from your list Signature and Initials and change its

name and protection.

Note: Adding a Signature is similar to adding Stamp . Any manipulation with Signature

(rotations, changing its size, pop-up notes etc) is valid too, but, as additional, you can protect

you Signature with password.

Remove... will delete selected Signature.

Remove All... will delete all Signatures.

After adding Signature (-s) to your document you will be prompted to Apply All Signatures or

Cancel All Signatures.

Note: If you have Licensed PDF-XChange Editor, you can press Apply All Signature. In another

case you will get DEMO signs on your document.
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7.4.21 Redaction

To completely remove content from a PDF, so that it can not be recovered, the  Redaction tool

must be used. No other tool will remove content so that it can never be recovered. Find the

Redaction tools located under Document> Redaction.
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The first step in redacting a document is to select  Mark for Redaction, and mark the area on

the PDF to be redacted. To mark some text, simply use the Mark for Redaction tool to highlight the

text. For larger areas, a block can be redacted simply by click and dragging from one corner of the

area to be redacted to the opposite corner.

Areas marked for redaction will be shown as a red rectangle by default over the marked area. The

red border in the Redaction Preview example screenshot below can be modified using the Stroke

Color property. Hovering the mouse over the marked area displays a preview of the result after

redaction is applied. 

Choose  Apply All Redactions to apply the redaction. The redaction can be undone until the

document is saved; at which point the data will have been fully removed from the document and

can not be recovered.

      Redaction Preview example
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Use the Redaction Properties toolbar to to change the output result and preview of the redaction.

The Redaction Properties toolbar is activated in the standard Properties Toolbar  when the

Mark for Redaction tool is active, or when an area marked for redaction is selected.

  Fill color defines the color used for the body of the preview. (Black as default)

  Stroke color defines the color of the border that represents the area marked for

redaction. 

  Opacity defines the translucency of the redaction. Regardless of the Opacity selected, all

content within the bounds of the marked area will be removed. 

 Keep Selected will keep the Redaction tool selected unless another tool is explicitly

activated.  

 Exclusive Mode (on) sets the active tool so it will ignore existing comments or

annotations that are already placed on the PDF page.

This allows for overlapping the placement of new comments, annotations or shapes

without activating the existing object already occupying the same area. 

As well this mode allows access to objects or base content beneath an existing

annotation. 

For an example to illustrate this functionality, create a new PDF by going to File >New

Document >With blank pages. 

Once the document is created, use the Add Text tool to add some base content text.

Now use the Rectangle tool and cover the text. With exclusive mode turned off you

will notice that no tool can interact with the text without moving the rectangle

annotation first. Now turn on Exclusive mode, and try to select the text using the text

select tool. You should find that the rectangle annotation in ignored, and you are now

able to select the underlying text.

 Redact Fill color defines the color of the area once redaction has been applied. 

 Text Color defines the color of overlay text. 

Note: The Properties Pane must be used to create a text overlay for the selected

redaction area.

Font selects the font to be used in the overlay text. 

Font Size defines the size of the font for the overlay text.
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Align Text Left aligns the text from the left margin of the redaction area. 

Center Text centers the text in the redaction area. 

Align Test Right aligns the text from the right margin of the redaction area. 

Repeat Overlay Text use this flag to repeat the overlay text so that it fills the redaction area. 

Properties opens the Properties Pane.

Properties Pane

The Properties Pane is another location where the behavior and display of an object can be

modified.

      Redaction Properties (specific for currently selected area marked for redaction)
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General Properties 

Subject Sets the subject for the redaction. This property should not be modified. 

 Author Displays the user's name that placed the redaction.  

 Name Shows the programmatic name of the selected area marked for redaction.  

 Created Shows the creation date and time of the selected area marked for redaction. 

 Modified Shows the most recent modification date and time of the selected area marked

for redaction.

 Read Only Yes | No

If set to Yes, the area marked for redaction cannot be modified. The redaction

will be applied when the Apply Redaction command is used. 

 Printable Yes | No

If set to Yes, the redaction preview will be printed. After the redaction is

applied, the redaction will always be printed as the underlying data no longer

exists. 

 Locked Yes | No

If set to Yes, the area marked for redaction cannot be moved or resized. 

 Style Properties

 Fill Color  Defines the color used for the body of the preview. (Black as default) 

 Stroke Color  Defines the color of the border that represents the area marked for

redaction. 

 Opacity  Opacity defines the translucency of the redaction. Regardless of the Opacity

selected, all content within the bounds of the marked area will be removed. 

Overlay 

 Fill Color Defines the color of the area once redaction has been applied. 

 Text Color Defines the color of overlay text. 

 Text Type in this property to define the overlay text. Blank by default.  

 Font Define the font for the overlay text. 

 Font Size Define the size of the font for the overlay text. 

 Text alignment Define the desired text alignment for the overlay text. 

 Repeat Yes | No

If set to Yes, repeats the overlay text so that it fills the redaction area. 
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7.4.22 Spell Check

To Check the spelling of contents in a document go to Document> Spell Check. Doing so will

show the  Spell Check pane.

     Spell Check pane

As shown by the screenshot above, the Spell Check is trying to correct the word "FO". Select the

correct spelling from the list below, then click Replace. In this case "FO" is an incorrect spacing for

the word "for", so it will need to be modified manually to remove the space. Clicking on Ignore or

Ignore all will move to the next incorrectly spelled word or unrecognized string. Click on Add to

add the word or string to the custom word list. Words listed in the Custom Word list will not be

recognized as incorrect. 

Note: The word currently being spell checked is highlighted in the PDF display area. 
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Include Page Text The text on the page will be spell checked. 

Include Comments Text within comments and annotations will be spell checked.

Include Form-Fields Text within form fields will be spell checked. 

Spell Check Settings... 

Spell checker settings can be accessed by clicking on the Spell Check Settings option, or by going

to Edit> Preferences> Plug-ins> Spell Checker> Setup.

Enable Spell Checker allows the Spell Checker to perform its duties. 

Ignore word in UPPERCASE will cause the Spell Checker to skip words written in all capitol

letters. 

Ignore words that contain numbers will cause the Spell Checker to skip words that contain

numeric characters.
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Enable Hyphenation Allows the Spell Checker to place a hyphen (dash "-") to words that do not fit

on the same line.

Enable dictionary hyphenation will allow the Spell Checker to add hyphen to words that

should have hyphens in them as defined by the dictionary. 

Hyphenate unknown words will allow the insertion of a hyphen to words even if they do not

exist in the dictionary. 

Select the desired language(s) and dialect(s) in the list. 

Add Dictionary 

Allows for the addition of a spell check dictionary from file. Go to http://fmg-www.cs.ucla.edu/

geoff/ispell-dictionaries.html to download more dictionaries. 

Custom Word List 

Allows for the addition of non-standard words to the dictionary. Words in the Custom Word List will

not be recognized as incorrect. 

7.4.23 Launch

When a PDF document is open in the PDF-XChange Editor, it can be launched to open in a third

party application that also supports PDF files directly from the Editor.

In Main Menu, choose Document> Launch:

The list of third party applications shows all applications set to launch with their file location.

In the Launch Application Toolbar  click  located in the right bottom corner of the

PDF-XChange Editor window.

Note: To create and manage the list of the possible applications to launch in Launch

Application  open Main Menu> Edit> Preferences> Launch Applications.
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7.5 Comments

The Comments menu allows you to Flatten, Summarize, Import, Export Comments to Data File

and view Comments List and Styles Palette.

Flatten Comments

Summarize Comments

Import Comments

Export Comments to Data

File

Show Comments List

Comment Styles Palette

7.5.1 Flatten Comments

Flatten Comments... flattens the annotations in case you want to make it impossible to change

them.

This is a one way operation and cannot be reversed, so save a copy prior to doing this if you still

wish to have your annotations editable yourself.

Flattening comments as well removes clickable hyperlinks, and flattens fillable PDF form fields to

selectable text.
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Pages Range. Allows you to select the page(s) with the comments for flattening. 

All. All pages with the comments will be flattened. 

Selected Pages. Only selected pages will be flattened. 

Current Page. Only the current page with the comments will be flattened. 

Pages. Individual pages are indicated by their numbers beginning with 1. 

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select

pages 2, 3, 4, and 5. 

Multiple page ranges may be specified, separated from one another by commas. 

Subset. This works in conjunction with the other Pages Range to select groups based on

order within the document. 

Valid values are: 

All Pages. All of the specified pages with the comments will be flattened. 

Odd Pages Only. Within the specified Pages Range only odd-numbered pages

will be flattened: 1, 3, 5, etc. 

Even Pages Only. Within the specified Pages Range only even-numbered pages

will be flattened: 2, 4, 6, etc.

Options. Valid options are: 

Non-Printable. Defines a certain action for non-printable comments. 

Flatten. Non-Printable comments will be flattened. 

Left As Is. Non-Printable comments will be left as they are. 

Remove. Non-Printable comments will be removed. 

Form Fields. Defines a certain action for form fields. 

Flatten. Form fields will be flattened. 

Left As Is. Form fields will be left as they are. 

Remove. Form fields will be removed. 
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7.5.2 Summarize Comments

Summarize Comments... allows you to get a summary of all the comments associated with a PDF

to view them as a new PDF Document, Rich Text Format, Plain Text or HTML Page.
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General. Allows you to set the general options for summarizing comments. 

Group by. Defines the parameters by which the comments can be grouped. Valid values

are: 

Page. The comments are grouped by page. 

Type. The comments are grouped by type. 

Author. The comments are grouped by author. 

Date. The comments are grouped by date. 

Subject. The comments are grouped by subject. 

Sort by. Defines the parameters by which the comments can be sorted within a group.

Valid values are: 

Page. The comments are sorted by page. 

Type. The comments are sorted by type. 

Author. The comments are sorted by author. 

Date. The comments are sorted by date. 

Subject. The comments are sorted by subject. 

Exclude replies. When specified, the replies to the comments are not included into the

summary. 

Include invisible comments. When specified, the invisible comments are included into

the summary.

Pages Range. Allows you to select the page(s) with the comments to be summarized. 

All. All pages with the comments will be summarized. 

Selected Pages. Only selected pages with the comments will be summarized. 

Current Page. Only the current page with the comments will be summarized. 

Pages. Individual pages are indicated by their numbers beginning with 1. 

Sequential page ranges may appear as hyphenated inclusive ranges, viz. 2-5 will select

pages 2, 3, 4, and 5. 

Multiple page ranges may be specified, separated from one another by commas. 

Subset. This works in conjunction with the other Page Ranges to select groups based on

order within the document. Valid values are: 

All pages. All of the specified pages with the comments will be summarized. 

Odd pages. Within the specified Page Range(s) only odd-numbered pages with the

comments will be summarized: 1, 3, 5, etc. 

Even pages. Within the specified Page Range(s) only even-numbered pages with the

comments will be summarized: 2, 4, 6, etc.
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Output. Depending on the type of the comment summary output, the paper and layout options

are changed correspondingly. 

Type. PDF Document (*.pdf)

Options. Valid options are: 

Paper. Selecting this option allows you to choose the standard size of the

page. 

Layout. Determines how pages are arranged in the PDF document pane. 

Place each group on separate page. Allows you to place each group of

summarized comments on separate pages. 

Destination Folder. Selects the destination folder to receive the comments. 

Note that you may not simply type in the destination folder. 

Clicking the Browse button opens the Browse for Folder dialog to select the

destination folder.

File Name. Specifies the name of the export file. You may enter any valid file

name you like. 

In addition, clicking the Macros button opens a submenu of file name macros

that you can use to automatically generate file names. 

This is especially useful for repeat jobs and to set the file numbering when

single-page image files are being generated for multiple document pages.
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Type. Rich Text Format (*.rtf)

Options. Valid options are: 

Paper. Selecting this option allows you to choose the standard size of the

page. 

Place each group on separate page. Allows you to place each group of

summarized comments on separate pages. 

Destination Folder. Selects the destination folder to receive the comments. 

Note that you may not simply type in the destination folder. 

Clicking the Browse button opens the Browse for Folder dialog to select the

destination folder.

File Name. Specifies the name of the export file. You may enter any valid file

name you like. 

In addition, clicking the Macros button opens a submenu of file name macros

that you can use to automatically generate file names. 

This is especially useful for repeat jobs and to set the file numbering when

single-page image files are being generated for multiple document pages.
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Type. Plain Text (*.txt)

Options. Valid options are: 

Text Encoding. Allows you to choose the appropriate text encoding. 

Destination Folder. Selects the destination folder to receive the comments. 

Note that you may not simply type in the destination folder. 

Clicking the Browse button opens the Browse for Folder dialog to select the

destination folder. 

File Name. Specifies the name of the export file. You may enter any valid file

name you like. 

In addition, clicking the Macros button opens a submenu of file name macros

that you can use to automatically generate file names. 

This is especially useful for repeat jobs and to set the file numbering when

single-page image files are being generated for multiple document pages.
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Type. HTML Files (*.html)

Options. Valid options are: 

Destination Folder. Selects the destination folder to receive the comments. 

Note that you may not simply type in the destination folder. 

Clicking the Browse button opens the Browse for Folder dialog to select the

destination folder. 

File Name. Specifies the name of the export file. You may enter any valid file

name you like. 

In addition, clicking the Macros button opens a submenu of file name macros

that you can use to automatically generate file names. 

This is especially useful for repeat jobs and to set the file numbering when

single-page image files are being generated for multiple document pages. 

View New Document after Creation. Allows you to view the document after summarizing

comments.
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7.5.3 Import Comments

Comments can be imported from a PDF document by going to Comment > Import Comments.

Comments can also be imported from a Form Data Format (FDF) file or an XFDF file, which is an

XML-based FDF file. 

From PDF Reference 1.7:

8.6.6    Forms Data Format

Forms Data Format (FDF) is the file format used for interactive form data (PDF 1.2). FDF is used

when submitting form data to a server, receiving the response, and incorporating it into the

interactive form. It can also be used to export form data to stand-alone files that can be stored,

transmitted electronically, and imported back into the corresponding PDF interactive form.

Please refer to PDF Reference 1.7, available as a free download from http://www.adobe.com/.

The comment positioning matches that of the file from which they were imported. If comments

appear out of place, the source and recipient PDF documents are likely different. For example, if you

import comments from a ten-page document to a two-page document, only comments from the

first two pages appear.

http://www.adobe.com/
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7.5.4 Export Comments to Data File

Export Comments to Data File... allows you to export comments in order to publish or send them

to someone.

7.5.5 Show Comments List

Show Comments List opens a scrollable list of all comments above the PDF Display Area, in the

"Other Panes" area:

As you select different comments, the PDF Display will reposition to the correct place in the

document. 
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Options. Determines the options of the comments.

Expand All. Allows you to expand all groups of comments in the list.

Collapse All. Allows you to contract all groups of comments in the list.

Group By Page. Groups comments by page.

Group By Type. Groups comments by type.

Group By Modification Date. Groups comments by modification date.

Group By Creation Date. Groups comments by creation date.

Group By Author. Groups comments by author.

Group By Color. Groups comments by color.

Group By Subject. Groups comments by subject.

Show Subjects. Shows subjects of all comments.

Show Authors. Shows authors of all comments.

Show Dates. Shows dates of all comments.

Show Text. Shows text of all comments.

Show Statuses. Shows statuses of all comments.

Show Colors. Shows colors of all comments. 

The toolbar at the top allows you to do several things: 

Next Comment and Previous Comment allow you to scroll up and down the list of comments. 

Add Reply allows you to generate a reply to the selected comment. 

Summarize Comments... allows you to summarize comments. 

Delete deletes the selected comment, or the selected comments Group.

Properties opens comment properties pane.
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7.5.6 Comment Styles Palette

Comments Styles Palette opens the palette with the list of comments’ styles. 

The toolbar at the top allows you to do the following things: 

Reset. Resets the style of the selected comment to default. All custom styles except for the

default ones will be removed. 

Clone. Creates the style of the comment, identical to the selected one. 

Rename. Allows you to rename the selected style. 

Reset. Resets the style of the selected comment to default. All custom styles except for the

default ones will be removed. 
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Delete. Deletes the selected comment style.

Properties. If you select the Properties item, the pane appears with the tabs which allow you to

adjust the appearance and other properties of the selected tool.

Set Current. Sets the selected custom style to the current tool's style.
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7.6 Form

Main Menu> Forms allows you to access features to fill, clear, edit, manipulate, create and

highlight form fields. 

 

Manage Form Data  

Highlight Form Fields 

Reset Form 

Edit Form 

7.6.1 Manage Form Data

You can manage form Data from the Form> Manage form Data menu. 

 Import Data… allows you to import data from an Adobe
©

 Acrobat
©

 FDF file to an AcroForm.

Note: A PDF AcroForm with matching field names as the form data FDF file must be the Active

document for this to work.

Select the saved form data file that matches the fields in the open form document, by default %

Docname-data.fdf, where %Docname is the name of the active AcroForm
©

 document.

Click Open, and the fields in the active document will then contain the data from the FDF form data

file.

459
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 Export Data… allows you to export data from an AcroForm to an Adobe
©

 Acrobat
©

 FDF file. 

Note: A PDF AcroForm with matching field names as the form data FDF file must be the Active

document for this to work.

The default name of the saved form data file is defined as %Docname-data.fdf, where %Docname

is the name of the Active document. Simply accept or specify the name you wish to use for the form

data, and an Adobe
®

 Acrobat
®

 FDF format file will be created.

7.6.2 Highlight Fields

Highlight Fields. Allows you to set the highlight options for the form fields. 

All Fields. Allows you to apply highlight options to all form fields. 

Push Buttons. Highlights buttons which initiate a change on the user’s computer, such as opening

a file or others. 

Check Boxes. Highlights boxes which present yes-or-no choices for individual items. If the form

contains multiple check boxes, the user can typically select as many or few of these as wanted. 

Radio Buttons. Highlights buttons which present a group of choices from which the user can select

only one item. 

Combo Boxes. Highlights boxes which allow you either choose an item from a pop-up menu or

type in a value. 
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List Boxes. Highlights boxes which allow you to choose from a displayed list of options. 

Text Boxes. Highlights boxes which allow you to type in text. 

Barcodes. Highlights barcode fields. 

Signatures. Allow you to electronically sign a PDF document with a digital signature. 

Only Required Fields. Allows you to select a border color of form fields. The border appears for

required form fields only after you attempt to submit the form.

7.6.3 Reset Form

Reset Form resets all of the form fields, removing all changes to the initial state of the form.

7.6.4 Edit Form

Edit and create fillable forms using the  Edit Form option under the Forms menu.

 

PDF-XChange Editor Plus supports most Adobe™ JavaScript actions for advanced interaction with

forms and actions. 

To use the functions of the  Edit Form feature, the Properties Toolbar  [View> Toolbars>

Properties] and the Properties Pane  [View> Other Panes> Properties] should be activated.

All the variations and form field types can be accessed from the Properties Toolbar, and the

properties such as actions, display, and other parameters can be accessed through the Properties

Pane.

The same operations can be accessed using the right click context menu.

Note: Though not necessary, the Fields Pane found under View> Other Panes> Fields Pane

 can be very useful when organizing the various form fields within a PDF form. 

601
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http://help.adobe.com/en_US/acrobat/acrobat_dc_sdk/2015/HTMLHelp/index.html#t=Acro12_MasterBook%2FJS_Dev_AcrobatForms%2FUsing_JavaScript_in_Forms.htm
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      Edit Form Properties Toolbar

To skip ahead to the pages that define each form field

type and how to use them, please click on the

appropriate link below: 

 Text Field

 Check Box

 Radio Button

 List Box

 Dropdown

 Button

 Digital Signature

 Barcode
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http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=check_box
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=radio_button
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=list_box
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=drop_box
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=button
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=digital_signature
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=barcode
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Edit Form object Right-Click context menu

When a form field item is selected the right click context menu contains the following options:

Rename Field renames the selected field and opens the Rename Field window.

      Rename Field window

Set as Required Field sets the field as required.
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Add new Field allows for the creation of a new form field.

Cut cuts the selection and places it in the clipboard.

Copy copies the selection to the clipboard.

Delete deletes the selection

Select All selects all form fields.

Align allows for the alignment of the selected fields. This option is only available when multiple

fields are selected, and interacts only with those fields.  

 Align Left Edges

 Align Right Edges

 Align Top Edges

 Align Bottom Edges

 Align Horizontal Centers

 Align Vertical Centers

 Distribute Horizontally

 Distribute Vertically

 Make Same Width

 Make Same Height

 Make Same Size
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Create multiple Copies... opens the Create Multiple Copies of Fields window to allow for

duplication of the selected form fields to be placed on the form.

Number of Fields defines how many copies of the selected field will be made.

Copy Selected fields down: In this field, enter the number of copies desired to be placed

vertically below the parent field.

Copy Selected fields across: In this field, enter the number of desired copies to be placed

horizontally from the parent field.
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Distance/Overall Size modifies the distance and size of form fields.

Specify distance between fields using the units defined in the Units field.

Horizontal Space defines the horizontal space between fields.

Vertical Space defines the vertical space between fields.

Units selects the units used in the Horizontal and Vertical space fields. 

Specify overall size of all fields defines the of the area the fields will be multiplied within.

Setting a larger with width than the fields require causes the resulting fields to be spaced

further apart.

Overall width defines the overall width of the area the field will be multiplied within.

Overall height defines the overall height of the area the field will be multiplied within.

Units selects the units used in the Overall Height and Width space fields.

Overall Position

Allows modification of the overall position by modifying the X: and Y: axis fields. Select the

square within the grid to determine the starting point for all measurements and positions

when creating multiple copies.
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Preview places a preview on the document before applying the duplication.

      Preview example

Use the Same Names causes all duplicated fields to have the same name as the original. This

can be useful for fields that require the same user data input such as their name, or today's

date, allowing the data to populate in each instance of that field.

 Note: Actions for each instance of fields with the same name interact only with the

current instance of the field rather than all of them. For more information regarding

actions, see the Common  Actions section.

Show Tab Numbers shows a small number in the left of each form field that represents the tab

order when using Tab to move through and fill the form. The Tab order can be modified by drag

and dropping the items to the desired order within the Fields Pane  .

Duplicate Annotations... opens the Duplicate Annotations window to allow simple duplication of

the selected object.

Duplicates Count defines how many times the selected object will be duplicated.

Horizontal Offset defines the horizontal offset from the original object. 

Vertical Offset defines the vertical offset from the original object.

Page Offset defines the page offset from the original object. 

34

310
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Show Grid overlay a grid on the PDF to help with object alignment.

Make Current Properties Default applies the properties of the selected object as default.

Apply Default Properties applies the default properties to the selected object.

Properties opens the Properties Pane .

Form Fields

Find a list of the form field options and a brief description of what each mean below. For more

detail, please see that form field type's sub section.

 Select Fields

The Select Fields allows the selection, and Edit existing form fields. Please see one of the sections

below for information pertaining to each form field type.

 Text Field

The Text Field allows for the placement a fillable text field on the form. See the Text Field section

 for more details.

 Check Box

The Check Box option can place a check box on the form. See the Check Box section  for more

details.

470
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http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=properties_pane
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 Radio Button

The Radio Button option places a radio button on the form. See the Radio Button section  for

more details.

 List Box

The List Box options places a list box on the form containing items that can be selected. See the List

Box section  for more details.

 Dropdown (drop-down menu)

The drop-down menu option places a drop-down menu on the form containing items that can be

selected. See the Dropdown section  for more details.

 Button

The button option places a button on the form. You can edit the action(s) from the properties pane.

See the Button section  for more details.

 Digital signature

The digital signature option places a signature field on the form. These can be used in conjunction

with the Sign document feature. See the Digital Signature section for more details. 

 Barcode

The Barcode option allows you to place a barcode on the form. See the Barcode section  for

more details.

482
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7.6.4.1 Text Field

While using the  Edit Form feature under Form> Edit Form, select the field to be interacted

with and modify. 

The Properties Pane  will reflect the parameters and properties of the selected field. A Text

Field can be filled with text data, numeric values and more. See the options and modifiable

properties below.

General

Read Only Yes | No

If set to Yes, the field will not be editable.

Locked Yes | No

If set to Yes, the field cannot be moved, and the properties cannot be modified.

Field name
Type the name desired for the field. This name will be displayed in the field

before it is filled

Tooltip Type a tooltip, or hint into this field.

Mapping

name
For mapping purposes, give this field a technical or programmatic name.

Orientation Set the orientation of the form field.

Visibility Sets the visibility of the form field:

· Visible

· Hidden

· Visible but does not print

· Hidden but printable

Required Yes | No

If set to Yes, marks the selected field as required.

Exportable
Yes | No

If set to Yes, the selected field's data can be exported from the form.

315
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Style Properties

 Fill Color Select the fill color for the text field

 Stroke

Color
 Set the color for the border of the text field

 Border

Style

Choose the border style for the selected field:

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border

Width
Sets the border width.

Default Text Format

Font Defines the font of the text when the field is filled.

Font Size Allows for the selection the required font size.

Note: If specified , the text within the field will not be shrunk to fit when it

becomes to large.

 Text Color Specify the color of the text within the selected form field.
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Options

Alignment Sets the alignment for the text within the field when filled. 

Default Value Specify a default value in this field. The field will revert to its default value when

the form is reset under Form> Reset Form .

File Select Yes | No

If set to Yes, the text entered in the field represents the path name of a file

whose contents shall be submitted as the value of the field.

JavaScript Example:

field.browseForFileToSubmit

If invoked on a text field for which the fileSelect flag is set to Yes, opens a

standard file-selection dialog box. The path entered through the dialog box is

automatically assigned as the value of the text field.

If invoked on a text field in which the fileSelect flag is set to No, an exception is

thrown.

Password Yes | No

Sets the field as a password field that can not be copied.

Check Spelling Yes | No

If set to Yes, the words entered to the form field will be spellchecked.

Multi Line Yes | No

If set to Yes, the text field will allow multiple lines of text.

Scroll Yes | No

If set to Yest, allows a scroll bar to the right of the Text Field when there is not

enough space for all the contents.

Allow Rich Text Yes | No

If set to Yes, the text field will allow Rich text.

Comb Yes | No

Adds line separators between each character space in the text field. The amount

of comb lines corresponds directly with the Character Limit.

Character Limit Set a character limit for the selected form field.

461
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Actions

 Note: See the Common Actions  section for more information about available

actions. 

 Mouse

Down

Initiate action when pressing on the left mouse button Click on the ... button to

set up an action.

 Mouse Up initiate action when depressing the left mouse button. Click on the ... button to

set up an action.

 Mouse

Enter

Initiate action when the mouse pointer hovers over. Click on the ... button to set

up an action.

 Mouse

Leave

Initiate action when the mouse pointer leaves the area. Click on the ... button to

set up an action.

 On Focus Initiate action when focus is switched to the selected text field. Click on the ...

button to set up an action.

 On Blur Initiate action when focus leaves the selected text field. Click on the ... button to

set up an action.

Format Value

Category Select a category for more options

None No specific format is required in the field. 

Number
Restricts the field input to numbers only.

Decimal places Specify the amount of decimal places available

Separator Style Select from available separator types.

· 1,234.56

· 1234.56

· 1.234,56

· 1234,56

· 1'234.56

Currency Symbol Choose from available currency symbols.

Symbol Location Dictates where the currency symbol will show

· Before the number

· After the number

Add Space if set to Yes, adds a space between the currency symbol and the

numbers themselves.    

Negative Number Style Select the way negative numbers are shown.

· Regular -$100

34
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· Red Text $100.00

· In parentheses ($100.00)

· Red text in parentheses ($100.00)

Percentage Restricts the field input to a percentage only.

Decimal Places Specify the amount of decimal places available

Separator Style Select from available separator types.

· 1,234.56

· 1234.56

· 1.234,56

· 1234,56

· 1'234.56

Date Restricts the field input to date only.

Date Format Specifies the date display format.

· m/d

· m/d/yy

· mm/dd/yy

· mm/yy

· d-mmm

· d-mmm-yy

· yy-mm-dd

· mmm-yy

· mmmm-yy

· mmm d, yyy

· m/d/yy h:MM tt

· m/d/yy HH:MM

Time Restricts the field input to time only.

Time Format

· HH:MM

· h:MM tt

· HH:MM:ss

· h:MM:ss tt
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Special Restricts the field input to the special format specified only.

Special Format

· ZIP Code

· ZIP Code + 4

· Phone Number

· Social Security

Custom Action Allows the addition of a custom action using JavaScript.

Format Action | Run a JavaScript. Click on the ... icon to launch the JavaScript

Console and write a script.

Keystroke Action | Run a JavaScript. Click on the ... icon to launch the

JavaScript Console and write a script.

Value Validation

 Validation Select the validation type from the drop-down menu.

 None No value validation.

Value in range Sets a range for the value within the selected text field.

From specify the minimum value for the selected form field.

To specify the maximum value for the selected form field.

Custom Action
Validation action | Run JavaScript Click on the ... button to launch the

JavaScript console and write a script.

Value calculation

Note: All examples used below are calculating the Sub Total and Tax fields created in an

example document. To follow these examples, please create 2 text fields with the following

properties:

Sub Total Field and Tax Field: Format Value = Number no other properties are necessary,

though naming the fields appropriately will simplify selecting them from the Field Selection

window.

Total Field: Format Value = Number the Value Calculation will depend on the type of

calculation required.

 Calculation Choose a calculation type from the drop-down menu.

 None No calculation.

http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=javascript
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=javascript
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 Sum (+) Will calculate the sum. To add a field that will be used in the calculation click on

the ... icon to the left of the Fields property. Doing so will launch the Field

Selection window. There, select the name of the fields to be calculated.

      Field Selection window

The result from the example above in the "Total" Field will be the sum of the

"Sub Total" and "Tax" fields.
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 Product (*) Will calculate the Product of the chosen fields.

 

To add a field that will be used in the calculation click on the ... icon to the left

of the Fields property. Doing so will launch the Field Selection window. There,

select the name of the fields to be calculated.

 Average  Will calculate the Average of the chosen fields.

 

To add a field that will be used in the calculation click on the ... icon to the left

of the Fields property. Doing so will launch the Field Selection window. There,

select the name of the fields to be calculated.

 Minimum Will show the minimum or smallest number of all the fields included in the 

Fields property.

 

To add a field that will be used in the calculation click on the ... icon to the left

of the Fields property. Doing so will launch the Field Selection window. There,

select the name of the fields to be calculated.
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 Maximum  Will show the minimum or smallest number of all the fields included in the 

Fields property.

 

To add a field that will be used in the calculation click on the ... icon to the left

of the Fields property. Doing so will launch the Field Selection window. There,

select the name of the fields to be calculated.

 Simplified

Notation

Write a calculation in the Simple Notation  property using the field names and

standard mathematical notation.

 Custom Action Set up a custom JS action for the calculation

Run a JavaScript click on the ... to launch the JavaScript console and write a

script. A moderate understanding and working knowledge of JavaScript is

required to use this action. 
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7.6.4.2 Check Box

While using the  Edit Form feature under Form> Edit Form, select the field to be interacted

with and modify. 

The Properties Pane  will reflect the parameters and properties of the selected field.

The Check Box option places a check box into the custom form.

General 

Read Only Yes | No

If set to Yes, the field will not be editable.

Locked Yes | No

If set to Yes, the field cannot be moved, and the properties cannot be

modified. 

Field name 
Type the name desired for the field. This name will be displayed in the field

before it is filled

Tooltip Type a tooltip, or hint into this field.

Mapping name For mapping purposes, this field can given a technical or programmatic name. 

Orientation Set the orientation of the form field. 

Visibility set the visibility of the form field:

· Visible

· Hidden

· Visible but does not print

· Hidden but printable 

Required Marks the selected field as required. 

Exportable 
Yes | No

If set to Yes, the selected field's data can be exported from the form.
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Style 

 Fill Color  Select the fill color for the check box. 

 Stroke Color  Set the color for the border of the check box

 Border Style Choose the border style for the selected field: 

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border Width Sets the border width and thickness.

Default Text Format

Font Size Allows for the selection the required font size.

Note: If specified , the text within the field will not be shrunk to fit when it

becomes to large.

 Text Color Specify the color of the text within the selected form field.

Options 

Check Box  Style Style Example

 Check

 Circle

 Cross

 Diamond

 Square

 Star
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 Export Value Define a custom value when the field is exported. 

Note: For a working example, create a Check box on a new document and

specify a value in the Export Value property, then open the JavaScript console.

In the JavaScript console, enter the script below: 

getField("Check Box1").value

The result will list the export value. 

 Checked By

default

Yes | No 

If set to Yes, the field will be checked by default.

Actions 

Note: See the Common Actions  section for more information about available actions.

 Mouse Down Initiate action when pressing on the left mouse button Click on the ... button to

set up an action. 

 Mouse Up initiate action when depressing the left mouse button. Click on the ... button to

set up an action. 

 Mouse Enter Initiate action when the mouse pointer hovers over. Click on the ... button to

set up an action. 

 Mouse Leave Initiate action when the mouse pointer leaves the area. Click on the ... button to

set up an action. 

 On Focus Initiate action when focus is switched to the selected field. Click on the ...

button to set up an action. 

 On Blur Initiate action when focus leaves the selected field. Click on the ... button to set

up an action. 
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7.6.4.3 Radio Button

Radio Buttons are similar to Check Boxes but their intent is for multiple choice. A Radio

Button should be used where only one option can be selected; such as when two options are

mutually exclusive.

General Properties

Read Only  If set to Yes, the field will not be editable.

Locked  if set to Yes, the field cannot be moved

Field name 
 Type the name desired for the field. Add the same name for radio buttons in

the same group. 

Tooltip  Type a tooltip, or hint into this field.

Mapping name  For mapping purposes, give this field a technical or programmatic name. 

Orientation  Set the orientation of the form field. 

Visibility Sets the visibility of the selected form field:

· Visible

· Hidden

· Visible but does not print

· Hidden but printable 

Required Marks the selected field as required. 

Exportable 
Yes | No

If set to Yes, the selected field's data can be exported from the form.

Style Properties  

 Fill Color  Select the fill color for the radio button. 

 Stroke Color  Set the color for the border of the radio button.

 Border Style Choose the border style for the selected field: 

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border Width Set the border width.
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Default Text Format 

Font Size Select the desired font size

Note: If specified , the text within the field will not be shrunk to fit when it

becomes to large.

 Text Color Specify the color of the text within the selected form field.

Options 

Radio Button

Style 

Style Example

 Check

 Circle

 Cross

 Diamond

 Square

 Star

Export Value Define a custom value when the field is exported. 

Note: For a working example, create a Check box on a new document and

specify a value in the Export Value property, then open the JavaScript

console. In the JavaScript console, enter the script below: 

getField("Check Box1").value

The result will list the export value. 

 Checked By

Default

Yes | No

If set to Yes, the field will be checked by default.
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Actions 

Note: See the Common Actions  section for more information about available actions.

 Mouse Down Initiate action when pressing on the left mouse button Click on the ... button to

set up an action. 

 Mouse Up initiate action when depressing the left mouse button. Click on the ... button to

set up an action. 

 Mouse Enter Initiate action when the mouse pointer hovers over. Click on the ... button to

set up an action. 

 Mouse Leave Initiate action when the mouse pointer leaves the area. Click on the ... button to

set up an action. 

 On Focus Initiate action when focus is switched to the selected field. Click on the ...

button to set up an action. 

 On Blur Initiate action when focus leaves the selected field. Click on the ... button to set

up an action. 
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7.6.4.4 List Box

Items in a  List Box can be selected. See below for manipulation and creation properties. 

     List Box example

General Properties

Read Only Yes | No

If set to Yes, the field will not be editable.

Locked Yes | No

if set to Yes, the field cannot be moved

Field name Type the desired name for the field. 

Tooltip Type a tooltip, or hint into this property.

Mapping name 
For mapping purposes, give this property a technical or programmatic name for

the field. 

Orientation Set the orientation of the form field. 

Visibility Sets the visibility of the form field:

· Visible

· Hidden

· Visible but does not print

· Hidden but printable 

Required Yes | No

If set to Yes, marks the selected field as required. 

Exportable 
Yes | No

If set to Yes, the selected field's data can be exported from the form.
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Style Properties 

 Fill Color  Select the fill color for the text field 

 Stroke Color  Set the color for the border of the text field

 Border Style Choose the border style for the selected field: 

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border Width Sets the border width in pt (point). 

Default Text Format 

 Font Specify the desired font.

 Font Size Define the font size. 

Text Color Define the Text Color. 

Options 

List box Items Click on this property to open the List Box Items dialog and add, sort and name

list items.

     List Box Items dialog
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Add New Adds a new item to the list. 

Delete Item Deletes the selected item from the list.

Move Up Moves the item up in the list. 

Move Down Moves the selected item down in the list. List items ticked in the

List Box Items dialog reflect the selected items in the List Box.

Sort Items Yes | No

Sorts the items in the list. 

 Multiple

Selections

Yes | No

If set to Yes, will allow multiple list items to be selected.

 Imminently

commit 

Yes | No

If set to Yes, fields that depend on the selection will immediately change when

a List Item is selected. If set to No, the dependent fields will only populate with

the required data once focus changes from the List Box.  

Actions 

Note: See the Common Actions  section for more information about available actions.  

 Mouse Down Initiate action when pressing on the left mouse button Click on the ... button to

set up an action. 

 Mouse Up Initiate action when depressing the left mouse button. Click on the ... button to

set up an action. 

 Mouse Enter Initiate action when the mouse pointer hovers over. Click on the ... button to

set up an action. 

 Mouse Leave Initiate action when the mouse pointer leaves the area. Click on the ... button to

set up an action. 

 On Focus Initiate action when focus is switched to the selected text field. Click on the ...

button to set up an action. 

 On Blur Initiate action when focus leaves the selected text field. Click on the ... button to

set up an action. 

Selection Change

Action  Click on the ... button to set up an action that initiates when the selection is

changed. 

34
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7.6.4.5 Dropdown

The Dropdown option is used to create drop down menus otherwise known as combo boxes. 

     Dropdown form field example 

General Properties

Read Only Yes | No

If set to Yes, the field will not be editable.

Locked Yes | No

if set to Yes, the field cannot be moved

Field name Type the desired name for the field. 

Tooltip Type a tooltip, or hint into this property.

Mapping name 
For mapping purposes, give this property a technical or programmatic name for

the field. 

Orientation Set the orientation of the form field. 

Visibility Sets the visibility of the form field:

· Visible

· Hidden

· Visible but does not print

· Hidden but printable 

Required Yes | No

If set to Yes, marks the selected field as required. 

Exportable 
Yes | No

If set to Yes, the selected field's data can be exported from the form.
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Style Properties 

 Fill Color  Select the fill color for the drop down menu 

 Stroke Color  Set the color for the border of the drop down menu

 Border Style Choose the border style for the selected field: : 

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border Width Sets the border width in pt (point). 

Default Text Format 

 Font Specify the desired font.

 Font Size Define the font size. 

Text Color Define the Text Color. 

Options 

List box Items Click on this property to open the Drop Box Items dialog and add, sort and

name list items.

     Drop Box Items dialog
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Add New Adds a new item to the list. 

Delete Item Deletes the selected item from the list.

Move Up Moves the item up in the list. 

Move Down Moves the selected item down in the list. List items ticked in the

List Box Items dialog reflect the selected items in the List Box.

Sort Items Yes | No

Sorts the items in the list. 

 Multiple

Selections

Yes | No

If set to Yes, will allow multiple list items to be selected.

 Imminently

commit 

Yes | No

If set to Yes, fields that depend on the selection will immediately change when

a List Item is selected. If set to No, the dependent fields will only populate with

the required data once focus changes from the List Box.  

Actions 

Note: See the Common Actions  section for more information about available actions.  

 Mouse Down  Initiate action when pressing on the left mouse button Click on the ... button to

set up an action. 

 Mouse Up  initiate action when depressing the left mouse button. Click on the ... button to

set up an action. 

 Mouse Enter  Initiate action when the mouse pointer hovers over. Click on the ... button to

set up an action. 

 Mouse Leave  Initiate action when the mouse pointer leaves the area. Click on the ... button

to set up an action. 

 On Focus  Initiate action when focus is switched to the selected text field. Click on the ...

button to set up an action. 

 On Blur  Initiate action when focus leaves the selected text field. Click on the ... button

to set up an action. 
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Format Value 

Category   Select a category for more options

None  No specific format is required in the field.  

Number Restricts the field input to numbers only.

Decimal places Specify the amount of decimal places available

Separator Style Select from available separator types.

· 1,234.56

· 1234.56

· 1.234,56

· 1234,56

· 1'234.56

Currency Symbol Choose from available currency symbols.

Symbol Location Dictates where the currency symbol will show

· Before the number

· After the number

Add Space if set to Yes, adds a space between the currency symbol and the

numbers 

Negative Number Style Select the way negative numbers are shown.

· Regular -$100

· Red Text $100.00

· In parentheses ($100.00)

· Red text in parentheses ($100.00)

Percentage  Restricts the field input to a percentage only.

Decimal Places Specify the amount of decimal places available

Separator Style Select from available separator types.

· 1,234.56

· 1234.56

· 1.234,56

· 1234,56

· 1'234.56 
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Date Restricts the field input to date only.

Date Format Specifies the date display format. 

· m/d

· m/d/yy

· mm/dd/yy

· mm/yy

· d-mmm

· d-mmm-yy

· yy-mm-dd

· mmm-yy

· mmmm-yy

· mmm d, yyy

· m/d/yy h:MM tt

· m/d/yy HH:MM

Time Restricts the field input to time only.

Time Format

· HH:MM

· h:MM tt

· HH:MM:ss

· h:MM:ss tt

Special  Restricts the field input to the special format specified only.

Special Format

· ZIP Code

· ZIP Code + 4

· Phone Number

· Social Security

 Custom Action Allows for the addition of a custom action using JavaScript.

Format Action | Run a JavaScript. Click on the ... icon to launch the JavaScript

Console and write a script.

Keystroke Action | Run a JavaScript. Click on the ... icon to launch the

JavaScript Console  and write a script.

Value Validation 

 Validation Select the validation type from the drop-down menu. 

 None No value validation.

Value in range Set a range for the value within the selected text field. 

From specify the minimum value for the selected form field.

To specify the maximum value for the selected form field.

Custom Action Validation action | Run JavaScript Click on the ... button to launch the

JavaScript console  and write a script. 

243
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7.6.4.6 Button

A Button can be set to perform virtually any action through the use of JavaScript or preset actions.

Please see the Common Actions  page for details regarding preset actions. 

See below for the standard properties of the  Button field. 

     Button example

General Properties

Read Only  Yes | No

 If set to Yes, the button will not be editable.

Locked  Yes | No

 if set to Yes, the button cannot be moved

Field name  Type the desired name for the button. 

Tooltip  Type a tooltip, or hint into this property.

Mapping name 
 For mapping purposes, this property can be given a technical or programmatic

name for the field. 

Orientation  Set the orientation of the button. 

Visibility  The visibility of the button can be set: 

· Visible

· Hidden

· Visible but does not print

· Hidden but printable 

Required  Yes | No

 If set to Yes, marks the selected field as required. 

Exportable 

 Yes | No

 If set to Yes, the selected field's data can be exported from the form, and later

imported if need be.

34
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Style Properties 

 Fill Color  Select the fill color for the drop down menu 

 Stroke Color  Set the color for the border of the drop down menu

 Border Style  Allows for the selection of the border style: 

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border Width Sets the border width in pt (point). 

Options

Layout  Defines the layout options for the button label, and Icon. See "Up Icon"

property to add an icon.

· Label only

· Icon only

· Icon top, label bottom

· Label top, icon bottom

· Icon left, label right

· Label Left, icon right

· Label over icon 

 Behavior  Defines the visual behavior of the button when it is pressed, or clicked on.

·  None

·  Invert

·  Outline

·  Push

 Up Label  Defines the button label. In the example used above , the label is defined as

"Button".
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 Up Icon  Click on the ... button to open the Select Icon window and select the desired

icon. 

     Select Icon window

Name The name field shows the chosen icon's file name. click on to select the

icon from an existing file.

Icon Placement Properties 

When to Scale  Defines in what situation the Icon will be scaled. 

· Always

· Never

· Icon is too big

· Icon is too small 

Scale  Proportionally will retain the aspect ratio of the icon. 

     Proportional scaling example

 Non-Proportionally will not retain aspect ratio. 

      Non proportional scaling example
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 Fit to Bounds  Yes | No

 If set to Yes, the icon will be be made to fit in the bounds of the button.

 Horizontal

Position

 Sets the horizontal position of the icon within the button. 50% positions the

icon in the middle, 100%

 positions it to the far right, and 0% to the far left within the confines of the

button.  See examples below:

50% 

100% 

0% 

 Vertical Position  Sets the vertical position of the icon within the button. 50% positions the icon

in the middle, 100% positions it at the very top, and 0% to the bottom within

the confines of the button.

Actions 

Note: See the Common Actions  section for more information about available actions.  

 Mouse Down  Initiate action when pressing on the left mouse button Click on the ... button to

set up an action. 

 Mouse Up  initiate action when depressing the left mouse button. Click on the ... button to

set up an action. 

 Mouse Enter  Initiate action when the mouse pointer hovers over. Click on the ... button to

set up an action. 

 Mouse Leave  Initiate action when the mouse pointer leaves the area. Click on the ... button

to set up an action. 

 On Focus  Initiate action when focus is switched to the selected field. Click on the ...

button to set up an action. 

 On Blur  Initiate action when focus leaves the selected field. Click on the ... button to set

up an action. 

34



497

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

7.6.4.7 Digital Signature

The  Digital Signature field places a "sign here" form field that can be filled by going to

Document> Digital Signing> Sign Document  .

     Example Signature field

When clicked on, the signature field will open the Sign Document window. 

General Properties

Read Only Yes | No

If set to Yes, the field will not be editable.

Locked Yes | No

if set to Yes, the field cannot be moved

Field name Type the desired name for the field. 

Tooltip Type a tooltip, or hint into this property.

Mapping name 
For mapping purposes, this property can be given a technical or programmatic

name for the field. 

Orientation Set the orientation of the field. 

Visibility The visibility of the field can be set: 

· Visible

· Hidden

· Visible but does not print

· Hidden but printable 

Required Yes | No

If set to Yes, marks the selected field as required. 

Exportable 

Yes | No

If set to Yes, the selected field's data can be exported from the form, and later

imported if need be.

432
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Style Properties 

 Fill Color  Select the fill color for the field. 

 Stroke Color  Set the color for the border of the field

 Border Style Choose the border style for the selected field: 

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border Width  Sets the border width in pt (points). 

Default Text Format 

 Font Specify the desired font.

 Font Size Define the font size. 

Text Color Define the Text Color. 

Actions 

Note: See the Common Actions  section for more information about available actions.  

 Mouse Down  Initiate action when pressing on the left mouse button Click on the ... button to

set up an action. 

 Mouse Up  initiate action when depressing the left mouse button. Click on the ... button to

set up an action. 

 Mouse Enter  Initiate action when the mouse pointer hovers over. Click on the ... button to

set up an action. 

 Mouse Leave  Initiate action when the mouse pointer leaves the area. Click on the ... button

to set up an action. 

 On Focus  Initiate action when focus is switched to the selected field. Click on the ...

button to set up an action. 

 On Blur  Initiate action when focus leaves the selected field. Click on the ... button to set

up an action. 
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Signed

When Signed Select the the behavior of the form when the signature field is signed. 

Do Nothing Does not change the behavior of the fields in the form. 

Mark as Read-

only 

Will mark fields as read-only as described in the Fields Range property.

Fields Range

· All Fields

· Just Specified Fields

· All fields except specified

Fields opens the Field Selection window. To add a field click on the ... icon to

the left of the Fields  property. Doing so will launch the Field Selection

window. There, select the name of the fields to be include. 

      Field Selection window

Custom action Action | Run JavaScript Click on the ... button to launch the JavaScript

console  and write a script. 243
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7.6.4.8 Barcode

Barcode fields translate a user's form entries into a visual pattern that can be scanned, interpreted,

and incorporated into a database.

General 

Read Only Yes | No

If set to Yes, the field will not be editable. 

Locked Yes | No

if set to Yes, the field cannot be moved or modified. 

Field Name Type the desired name for the field. 

Tooltip Type a tooltip, or hint into this property. 

Mapping Name For mapping purposes, this property can be given a technical or programmatic

name for the field. 

Style Properties 

 Fill Color  Select the fill color for the field. 

 Stroke Color  Set the color for the border of the field

 Border Style Choose the border style for the selected field: 

·  Solid

·  Dashed (2 white, 2 black)

·  Dashed (3 white, 3 black)

·  Dashed (4 white, 4 black)

·  Dashed (4-3-2-3)

·  Dashed (4-3-16-3)

·  Dashed (8-4-4-4)

·  Beveled

·  Insert

·  Underline

 Border Width  Sets the border width in pt (points). 
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Options 

Symbology Selects the symbology of the barcode. 

· PDF417 is a stacked linear barcode symbol format used in a variety of

applications, primarily transport, identification cards, and inventory

management. The 417 signifies that each pattern in the code consists

of 4 bars and spaces, and that each pattern is 17 units long.

· QR Code consists of black modules (square dots) arranged in a square

grid on a white background, which can be read by an imaging device

(such as a camera, scanner, etc.). The required data is then extracted

from patterns that are present in both horizontal and vertical

components of the image.

· Data Matrix is a two-dimensional matrix barcode, which encodes text

or raw data in a pattern of black and white square modules. Usual data

size is from a few bytes up to 2 KB. By adding error correction codes

(according to the ECC200 standard) the symbols can be read even if they

are partially damaged.

Compress Data Yes | No

Will cause the data scanned to be compressed in a .zip archive. This is not

recommended for mobile scanners as they typically are not able to open .zip

files. 
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Ecc Level ECC (Error Correction Capability) level compensates for dirt, damage or

fuzziness of a barcode. A high ECC level adds more redundancy at the cost of

using more space.Ecc Level properties change depending on the symbology

used.

PDF417

· 0

· 1

· 2

· 3

· 4

· 5

· 6

· 7

· 8

QR Code

· L low ECC

· M medium ECC

· Q medium-high ECC

· H high ECC

X Dimensions  Changes the size of the Barcode data. 

X/Y Ratio Available only with with PDF417 symbology. 

Actions 

Note: See the Common Actions  section for more information about available actions.  

 Mouse Down  Initiate action when pressing on the left mouse button Click on the ... button to

set up an action. 

 Mouse Up  initiate action when depressing the left mouse button. Click on the ... button to

set up an action. 

 Mouse Enter  Initiate action when the mouse pointer hovers over. Click on the ... button to

set up an action. 

 Mouse Leave  Initiate action when the mouse pointer leaves the area. Click on the ... button

to set up an action. 

 On Focus  Initiate action when focus is switched to the selected field. Click on the ...

button to set up an action. 

 On Blur  Initiate action when focus leaves the selected field. Click on the ... button to set

up an action. 
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Value Calculation

Calculation

Type 
Select the required calculation type 

Encode Using

Tab Delimited

format

Fields | To add a field that will be included in the barcode data click on the ...

icon to the left of the Fields property. Doing so will launch the Field Selection

window. There, select the name of the fields to be included.

     Field Selection window

Include Field names | If set to Yes, Field names will be included in the scanned

data.

Reference | This property has no programmatic bearing on behavior. It is

typically used to specify the file from which the scanned data was extracted. A

Reference Line is added to the text data so that anybody looking at the data will

know from which file the data was extracted. 

 Encode Using

XML Format

Fields | To add a field that will be included in the barcode data click on the ...

icon to the left of the Fields property. Doing so will launch the Field Selection

window. There, select the name of the fields to be included.

Reference | This property has no programmatic bearing on behavior. It is

typically used to specify the file from which the scanned data was extracted. A

Reference Line is added to the XML data so that anybody looking at the data will

know from which file the data was extracted. 

Custom Script  Calculation Script | Run a JavaScript Click on the ... button to launch the

JavaScript console and write a script.
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7.7 Object

The Object menu allows you to Transform the selected objects in the document. 

Transform Selection

Duplicate Annotations...

7.7.1 Transform Selection

Transform Selection allows you to control the position, size and rotation of the selected object

(comments, content objects).

To select a content object, you may use the Edit Content button from the Comment And Markup

Toolbar .

X and Y. Allow you to position an object wherever you need to on the PDF page by applying X

(horizontal) and Y (vertical) offset values to the object. You may  alter  the  location  by 

changing  the  spin  boxes  directly  by  entering  position  values  or  by clicking the spin box

up and down arrows. The PDF page coordinate system measures vertical position upwards from

the lower left corner. 

∆X; ∆Y. If checked, will allow you to set the offset values relative to the current position of the

object.
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Unit. The Units may be points, inches, centimeters, millimeters or picas. 

Width. Horizontal size of object on page, in Units or percentage points.

Height. Vertical size of object on page, in Units or percentage points.

Rotation. This box allows you to rotate the object clockwise or counterclockwise. 

Shear. Slants an object along a horizontal axis. To shear the object, enter a desired shear angle

into the spin box. 

7.7.2 Duplicate Annotations...

Duplicate Annotations... Duplicates selected annotations from the current page to the next one

using specified parameters.

To duplicate the annotations open the Duplicate Annotations dialog box and set the options:

Duplicates Count. Sets the number of copies.

Horizontal Offset. Sets the horizontal offset.

Vertical Offset. Sets the vertical offset.

Page Offset. Sets the number of pages, which will be left without annotations.
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7.8 Tools

Through the Tools menu users can access features to manipulate the PDF document.

Basic Tools  

Zoom Tools  

Content Editing tools  

Comment And Markup Tools  

Measuring Tools  

Link Tools  

In the Basic Tools submenu there are three options:

Hand Tool  

Snapshot Tool  

Select Text tool  

In the Zoom Tools submenu there are three options:

Zoom Tool  

Loupe Tool  

Pan and Zoom  

The Content Editing Tools  submenu allows selection of the following two options:

Edit Content Tool

Add Text Tool

The Comment & Markup Tools  submenu hosts 22 tools. See the Comment & Markup Tools

 section for the complete list.
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The Measuring Tools  submenu contains of three options:

Distance Tool

Perimeter Tool

Area Tool

Calibrate Measurement Tool

The Link Tools submenu contains the Link Creation tool: 

Link creation tool  

7.8.1 Basic Tools

Selecting Basic Tools submenu allows selection of one of three options:

See the subtopics for a description of each tool.

Hand Tool

activates the  Hand Tool and changes the cursor to a hand.

Hand Tool mode permits you to "grab" the PDF page and move it within the pane by clicking and

dragging the page you can also select another page as it comes into view as you scroll through a

file and reselect an alternate page and effectively scroll through the entire file in this way by

changing the 'grabbed' page area or indeed the page selected.
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Snapshot Tool

 Permits copying a rectangular area of a PDF page or the entire visible page area to the

clipboard as a Bitmap, which can be pasted into a bitmap editor such as Microsoft
®

 Paint
®

 or

indeed any other Windows application that allows the copy/pasting of content from the Windows

clipboard. When selected, the cursor is changed to a  Camera icon. Clicking on a page will

copy the entire page, or you may click-and-drag to outline a rectangular area of the page. When

you release the left mouse button, the outlined area will be copied to the clipboard as a bitmap.

Clicking on the Hand  or Select  tools will clear the selection.

 

Select Tool

The  Select Tool allows you to select text on the screen for editing using the Edit menu items.

You can use the Copy and Paste commands to copy the selected text into another application. If

you hold the pointer over the text selection, a menu appears that lets you copy, highlight, or

underline the text, among other options.

Basic Tools Properties The Hand Tool, and Select Text Tool properties include only Exclusive

mode. Activate exclusive mode by clicking on the  button. To Deactivate exclusive mode, click

on the  button. For more information regarding Exclusive mode, please see the Properties

Toolbar section . The snapshot tool has no properties.

7.8.2 Zoom Tools

Selecting the Zoom Tools submenu allows selection of one of four options:

507 508
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Zoom Tool

The  Zoom Tool increases or decreases the Zoom percentage, enlarging or shrinking the PDF

page within the pane.

Loupe Tool

The  Loupe Tool opens a special dialog window that is linked to a scrollable, resizable rectangle

that acts as a cursor and permits the selection of a portion of the page.

The selected area can be resized and its contents view size zoomed larger or smaller to suit. Further

- like the main Snapshot Tool - the defined Loupe content area can also be copied to the clip

board using the  and used as required.

The toolbar at the top of the page allows you to change the zoom percentage with the  and

 buttons, and clicking the Snap shot  icon copies the displayed area to the clipboard as a

bitmap.
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Pan and Zoom

When the  Pan and Zoom tool is selected, the Pan and Zoom window appears:

The Pan and Zoom window shows a representation of the current page(s) with a Blue rectangle that

shows the area being displayed in the main window. You may use the Hand control to move the

blue rectangle and the main display window will automatically follow that movement.

1. The control bar at the top of the window shows the current display area's zoom factor. The 

and  buttons may be used to change the zoom factor, or you may click the down arrow to

open a list of standard zoom factors:

2. To go to the First Page, click on  or use the Home key. Clicking on  or using the End key

will take you to the Last Page in the document.

Clicking on  takes you to the Previous Page in the document, and  takes you to the Next

Page.

3. The Camera button  allows you to make a Snapshot  of the highlighted area of the page.
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7.8.3 Content Editing Tools

Edit Content Tool 

The Edit Content tool allows for editing base content within PDF. 

1. Select the Edit Content  button from the Comment And Markup toolbar.

2. Click the content item you wish to edit. If you need a certain area to be selected, click and

drag the mouse. This will show a bounding box with selection handles around the object.

The handles can be used for resizing, moving or rotating the object.

To move the object, place the pointer to the central circle and drag the object.

To resize the object, pull one of the yellow handles.

To rotate the object, click and drag the green handle above the object.
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3. If you right-click on the selected object, the following context menu appears:

Cut 

Copy

Paste 

Delete 

Properties

Note: Copy/paste of base content is not yet fully supported. When Editing base

content such as text, other text can be pasted as base content, and the text can be

selected, then copied from the base content. Copy and Paste of base content such as

images are not yet supported. When an image is pasted into a PDF, that image

becomes a stamp annotation. The stamp can later be Flattened by going to

Comments> Flatten  Comments  

Properties. To adjust the properties of the selected object, click on the arrow which appears

when you select one of the properties. 

Add Text tool

The Add Text Tool  will add base content text to a PDF. Click anywhere on the page to start

typing. This tool makes use of the Text properties state of the Properties Toolbar.
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7.8.4 Comment And Markup Tools

The Comment and markup submenu contains the tools necessary to mark up, comment on or

annotate PDF pages. Please see each tool's section for information regarding that tool.

 Edit Multiple Comments  

 Sticky Note Tool  

 Typewriter Tool 

 Text Box Tool  

 Callout Tool  

 Highlighting Text Tool  

 Strikeout Text Tool  

 Underline Text Tool  

 Line Tool  

 Arrow Tool  

 Rectangle Tool  

 Oval Tool  

 Polygon Line tool  

 Polygon Tool  

 Cloud Tool  

 Stamp Tool  

 Pencil Tool  

 Eraser Tool  

 File Attachment Tool  

 Sound Tool  

 Comment Styles Palette  

 Stamps Pallet  
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7.8.4.1 Important! Please read!

All of the Comment And Markup Tools have one thing in common: they each support TWO

different Properties screens; one for the "contents" and a common one for the "container". 

1. If you right-click on a container, you will get the common container pop-up menu: 

See Container Properties  for additional information on this common menu and its

items. 

2. To access the Contents Properties pop-up, you must first double click on the contents

inside the container. Each tool has its own contents properties, and will be discussed with

the tool. 

3. Some Comment And Markup Tools also support Property Toolbars for both the container

and contents. See the individual tools for examples of these. 
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7.8.4.1.1  Container Properties

The Container Properties menu allows you to: 

1. Open Pop-Up Note. Opens a new or existing note for the item. Your user name and the

date and time of the note are automatically entered. 

You may now enter any text you wish in the lighter portion of the note. 

2. Hide Pop-Up Note. Hides the note. 

3. Reset Pop-Up Note Location. Selecting this allows you to position the cursor in the pop-up

heading and then click-and-drag the pop-up to a more convenient location. 

4. Cut. Cuts the selected container. 

5. Copy. Copies the selected container. 

6. Paste. Pastes the copied container. 

7. Delete. Deletes the annotation’s container (and contents). 

8. Flatten. Flattens the container in case you want to make it impossible to change it later.

9. Add Reply. Adds a reply area to the note. 
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10. Status. Defines the status of the container.

11. Order. Allows you to set the order of the containers. 

12. Flip Line. Allows you to turn the line around. 

13. Make Current Properties Default. Sets the current properties as the default ones for all

future containers of this type.

14. Apply Default Properties. Allows you to change the properties of the markup for the one,

saved as default. 

15. Properties.... If you select the Properties... item, the pane appears with the tabs which allow

you to adjust the appearance and other properties of the container: 

The General tab allows you to enter additional information about the notation. 

The Style 

The Appearance tab allows you to adjust the container's visual appearance. 

The Advanced button allows you to either set the current container's Appearance

properties to the default values, or to set the default values for future containers of this

markup. 
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7.8.4.1.2  Comment And Markup Example

This is an example of creating a Comment or Markup using the Annotation feature by adding a

pop-up to an Oval markup. The steps apply to ALL comment and markup tools. 

Select the Oval Tool from the toolbar or menu. This displays a thin crosshair cursor. 

Position the cursor at the upper left corner of the area you want to mark, and then left-click and

drag the cursor to the lower right position. 

When you release the mouse button a "bounding rectangle" will appear. If you move the cursor

to the corners or edges of the rectangle, the cursor will change to standard resizing arrow,

enabling you to adjust the boundaries of the oval to more closely match the area of interest. If

you move the cursor inside the rectangle then it will change to a four-way arrow cursor,

allowing you to click-and-drag the entire oval to a new location without changing its size. The

blue rectangle will disappear when the document is saved. 

In addition, if you right-click with the four-way arrow cursor visible, the following pop-up menu

becomes visible.
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The menu items are: 

Open Pop-up Note. Opens a new or existing note for the item. Your user name and the

date and time of the note are automatically entered. You may now enter any text you

wish in the lighter portion of the note. 

Reset Pop-up Note Location. Selecting this allows you to position the cursor in the

pop-up heading and then click-and-drag the pop-up to a more convenient location. 

Cut. Cuts the Markup and note. 

Copy. Copies the selected Markup and note.

Paste. Pastes the copied Markup and note.

Delete. Deletes the Markup and note. 

Flatten. Flattens the Markup in case you want to make it impossible to change it later.

Add Reply. Adds a reply area to the note. 
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Status. Defines the status of the note.

Order.Allows you to set the order of the notes. 

Make Current Properties Default. Sets the current properties of the markup as the

default ones for new markups of the same type. 

Apply Default Properties. Allows you to change the properties of the markup to the

ones, saved as default. 

Properties.... Opens a pane that allows you to change the properties of the markup

shape and note. 
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General. Allows you to change the heading fields of the markup. 

Style. Allows you to change the markup area to something more useful. 

Fill Color. Allows you to select the fill color. 

Stroke Color. Allows you to select the stroke color.

Border Style. Allows you to select the style of the border.

Border Width. Allows you to select the width of the border. 

Opacity. Allows you to select the opacity percentage. 

Blend Mode. Controls the image editing in a way that two layers of the

image are blended into each other. There is a standard set of blend

modes. Separable blend modes are the following: Normal, Multiply,

Screen, Overlay, Darken, Lighten, Color Dodge, Color Burn, Hard Light,

Soft Light, Difference and Exclusion. Nonseparable blend modes are Hue,

Saturation, Color, and Luminosity. 

Normal. This is the default mode. It does not change an image by

mixing its two layers and uses only the top layer.
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Multiply. This mode is used for darkening the images. It overlays

the color of the bottom layer on the top one. If the top layer is

white, nothing will be changed. 

Screen. This mode is opposite to Multiply and is used for

lightening the images. It overlays the inverted top layer on the

bottom one what makes the picture brighter.

Overlay. This is the combination of Multiply and Screen modes. It

mixes the top and bottom layers. As a result, the light parts of the

top layer become lighter and the dark ones become darker. 

Darken. It combines the colors of the top and bottom layers and

mixes the pixels in those parts where the top layer is darker than

the bottom one. It replaces the lighter top layer pixels with the

darker ones from the bottom layer. If the color of the top layer is

darker than the bottom layer color, the pixels remain unchanged.

Lighten. This mode is opposite to Darken. It replaces the darker

top layer pixels with the lighter ones from the bottom layer. If the

color of the top layer is lighter than the bottom layer color, the

pixels remain unchanged.

Color Dodge. The brighter parts of the top layer enhance the

brightness of the bottom layer. If the top layer is black, the image

will remain unchanged.

Color Burn. The darker parts of the top layer enhance the

darkness of the bottom layer. If the top layer is white, the image

will remain unchanged.

Hard Light. It uses the same method as the Overlay mode, but the

result is more intense. The top layer is changed in the same way as

in the Multiply or Screen blend modes, depending on the layer's

color. If the top layer is lighter than 50% gray, the picture is

lightened. If the top layer is darker than 50% gray, the picture is

darkened. If the top layer is exactly 50% gray, there will be no

effect.

Soft Light. This mode also uses the same method as the Overlay

mode, but the result is softer. The top layer is changed in the same

way as in the Color Dodge or Color Burn blend modes, depending

on the layer's color. If the top layer is lighter than 50% gray, the

picture is lightened. If the top layer is darker than 50% gray, the

picture is darkened. If the top layer is exactly 50% gray, there will

be no effect.

Difference. Subtracts the top layer from the bottom one or the

bottom layer from the top one, depending on which of those is
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brighter. Blending with black does not give the result. Blending

with white inverts the image.

Exclusion. This mode is similar to Difference but this one is lower

in contrast. 

Hue. Combines Hue of the top layer with Saturation and

Luminance of the bottom layer.

Saturation. Combines the Saturation of the top layer with Hue

and Luminance of the bottom layer.

Color. Combines the Hue and Saturation of the top layer with the

Luminance of the bottom layer.

Luminosity. Combines the Luminance of the top layer with the

Hue and Saturation of the bottom layer.
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7.8.4.2 Edit multiple Comments

Clicking the Edit Multiple Comments button you can select a group of comments with the help of

the mouse cursor. 

To move the group of comments, drag the selected area with your mouse. To resize the group of

comments, drag one of the resize (yellow) handles. To rotate the group of comments, drag the

rotate (green) handle. 

To edit the text, double click the text area and select the necessary text fragment.

If you right-click on the selected area the following menu appears:

Open Pop-Up Note. Opens the new or existing notes for all of the items. Your user name and

the date and time of the notes are automatically entered. 

You may now enter any text you wish in the lighter portion of the notes.

Hide Pop-Up Note. Hides all of the notes. 

Reset Pop-Up Note Location. Selecting this allows you to position the cursor in the pop-up

heading and then click-and-drag the pop-up to a more convenient location. 
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Cut. Cuts the selected group of containers.

Copy. Copies the selected group of containers. 

Paste. Pastes the copied group of containers. 

Delete. Deletes the group of annotation’s containers (and contents). 

Flatten. Flattens the group of containers in case you want to make it impossible to change them

later.

Status. Defines the status of the containers.

Order. Allows you to set the order of the containers. 
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Align. Allows you to control the alignment distribution and size of the whole group of

comments.

Apply Default Properties. Allows you to change the properties of the comments for the ones,

saved as default.

Properties.... Opens the Properties pane for the selected group of comments.

Besides, you may change the properties of the comments with the help of the Properties

Toolbar which appears at the Toolbar area when the group of comments is selected:

See the Comment And Markup Tools  menu section for more information on the Markup tools.

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created.
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7.8.4.3 Sticky Note Tool

The Sticky Note Tool adds a Sticky Note wherever you need one for commenting. 

Simply select the tool and a "sticky note cursor" appears. Place the cursor where you want the note

and click it and a pop-up note appears: 

1. You may move the note by clicking on the frame and dragging the note where you

like. 

2. You may edit the pop-up note by clicking inside the light colored area and typing

whatever text you like. 

3. You may click Ctrl-E to display the Sticky Note toolbar.

4. You may also change the properties of the note by right-clicking inside the frame

(yellow area in the example) and the following menu appears: 
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Open Pop-up Note. Opens a new or existing note for the item. Your user name

and the date and time of the note are automatically entered. 

You may now enter any text you wish in the lighter portion of the note. 

Reset Pop-up Note Location. Selecting this allows you to position the cursor in

the pop-up heading and then click-and-drag the pop-up to a more convenient

location. 

Cut. Cuts the selected note.

Copy. Copies the selected note.

Paste. Pastes the copied note. 

Delete. Deletes the note (and contents). 

Flatten. Flattens the note in case you want to make it impossible to change it later.

Add Reply. Opens a reply area under the main text area of the note so others can

add additional text or comments. 

Status. Defines the status of the note.

Order. Allows you to set the order of the notes. 

Make Current Properties Default. Sets the current properties of the Sticky Note

as the default ones for new markups of the same type. 

Apply Default Properties. Allows you to change the properties of the markup for

the ones, saved as default. 
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Properties.... Opens the Properties dialog for the Sticky Note. 

See Comment and Markup Example  for additional information on

manipulating the Sticky Note properties.

7.8.4.4 Typewriter Tool

The Typewriter Tool allows you to enter text comments into a PDF page: 

1. Click the Typewriter Tool button and then click the starting position for the text entry. Then

just type. 

2. Press Enter to start a new line.

3. If you right-click on the typed text you open the following menu: 

Undo. Reverses the last editing change made to the typed text. 
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Cut. Allows you to remove selected typed text and copies it to the clipboard.

Copy. Copies selected typed text to the clipboard.

Paste. Pastes clipboard text to the chosen location.

Select All. Allows you to select the whole typed text for editing.

Paragraph.... Sets the paragraph options for the Typewriter text.

Text Style. Opens the following submenu of formatting options:

Besides, you may change the properties of the text with the help of the Properties

Toolbar which appears at the Toolbar area when the Typewriter Text is selected:
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You may also use the following hot keys to format the text entry: 

· Ctrl+B - Bold

· Ctrl+I - Italic

· Ctrl+U - Underline 

· Ctrl+Shift+S - Strikethrough

· Ctrl+Shift++ - Superscript 

· Ctrl+Shift+- - Subscript 

· The Typewriter Toolbar supports additional options for selecting Font and

Size.

4. If you right-click on the container you open the following menu: 

Cut. Cuts the selected container.

Copy. Copies the selected container.

Paste. Pastes the copied container. 

Delete. Deletes the annotation’s container (and contents).

Flatten. Flattens the container in case you want to make it impossible to change it later.
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Status. Defines the status of the container.

Order. Allows you to set the order of the containers. 

Make Current Properties Default. This allows you to set the currently selected Font,

Font size etc as the default font/size etc - whenever you select the Typewriter tool. 

Apply Default Properties. Allows you to change the appearance of the Typewriter tool

for the one, saved as default.
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Properties.... Opens the Properties dialog for the Typewriter Tool. 
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7.8.4.5 Textbox Tool

The Textbox Tool allows you to add text on a page in a text box. 

1. To use the tool, click the tool in either the menu or the toolbar, and a cross cursor will

appear at the upper left corner Drag the resulting text box away from the click point and the

arrow will appear. 

2. Click inside the box to begin typing text. 

In addition,clicking the edge of the box restores the small resizing boxes, permitting you to

change the size of the text box. 

3. The Textbox Toolbar supports additional options for selecting Font and Size. 

You may change the properties of the text with the help of the Toolbar which appears at

the Toolbar area when the Typewriter Text is selected:

TIP - Whilst editing existing page content is for the most part - not currently possible -

replacing existing content is... 

For example - if you want to cover up some existing text or content on a PDF page - use the text

box tool to apply replacement content (or no content if required) set the background color to

match the existing page and also set the box borders to match - and then Flatten  the box and

content so it cannot be moved or erased to reveal the original content. 
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7.8.4.6 Callout Tool

The Callout Tool allows you to add a text box with an arrow pointing to a selected location on the

page. 

1. To use the tool, click the tool in either the menu or the toolbar, and a cross cursor will

appear. 

2. Move the cursor to where you want the point of the arrow to appear. 

3. Click and then drag the resulting text box away from the click point and the arrow will

appear. 

4. Click inside the box to begin typing text. 

5. In addition, clicking the edge of the box restores the small boxes, permitting you to change

the look and size of the arrow and text box. 

6. The Callout Toolbar supports additional options for selecting Font and Size. 

You may change the properties of the text with the help of the Toolbar which appears at

the Toolbar area when the Typewriter Text is selected:

7.8.4.7 Highlight Text Tool

The Highlight Text Tool permits you to highlight text within the PDF document, and works like

the Select Tool .

Note: You cannot Highlight image based text!

For example if you scan a page to PDF - there is no text in that file can be modified - only image

based content!
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To use the Highlight Text Tool, click on the menu item, and a selection cursor will appear. 

Click and drag the selection cursor over the text to be highlighted. When you release the mouse

button, the selected text will then appear to be highlighted with color, like a highlighter pen.

Right-clicking inside the highlighted area will open the pop-up menu. See Sticky Note Tool  for

more information on the pop-up menu.

N.B. If you select the Delete option from the pop-up menu, only the highlighting will be

deleted. The underlying text is not changed in any way!

7.8.4.8 StrikeoutText Tool

The Strikeout Text Tool permits you to cross out the selected text. 

Note: You cannot Strikeout image based text!

For example if you scan a page to PDF - there is no text in that file can be modified - only image

based content! 

To use the Strikeout Text Tool, click on the menu item, and a selection cursor will appear. 

Click and drag the selection cursor over the text to be crossed out. When you release the mouse

button, the selected text will then appear to be crossed out.

Right-clicking inside the crossed out area will open the pop-up menu. See Sticky Note Tool  for

more information on the pop-up menu.

N.B. If you select the Delete option from the pop-up menu, only the crossouts will be deleted.

The underlying text is not changed in any way!

7.8.4.9 Underline Text Tool

The Underline Text Tool permits you to underline the selected text.

Note: however that you cannot Underline image based text!

For example if you scan a page to PDF - there is no text in that file can be modified - only image

based content!
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To use the Underline Text Tool, click on the menu item, and a selection cursor will appear. 

Click and drag the selection cursor over the text to be underlined. When you release the mouse

button, the selected text will then appear to be underlined.

Right-clicking inside the underlined area will open the pop-up menu. See Sticky Note Tool  for

more information on the pop-up menu.

N.B. If you select the Delete option from the pop-up menu, only the underlining will be

deleted. The underlying text is not changed in any way!

7.8.4.10 Line and Arrow Tools

The Line and Arrow Tools are two forms of the same markup control. By default, the Line tool is a

solid line, and the Arrow tool has an arrow at the leading end. For both tools, click the appropriate

button and a small cross-hair cursor appears. Select the starting point and then click-and-drag the

cursor to the ending point. For the Arrow tool, an arrow head appears at the end of the arrow when

drawn. 

After drawing the line or arrow, you can add a pop-up note. See Comment And Markup Example

 for more information.

      Properties Toolbar for Line and Arrow Tools

The options listed below are in order from left to right as they are shown in the Properties Toolbar

for the Line and Arrow tools

Fill Color is not an available property for the Line and Arrow tools unless there is a closed Starting

Type, or Ending Type such as a Closed Arrow as shown below. 

Stroke Color defines the color of the line and border of any line Ending Type or Line Starting

Type.
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Border Style controls the type of line that is displayed. 

Border Width dictates the thickness of the Line and Arrow. 

Note: Using Ctrl+5 will toggle between the actual width of the line, and 1pt view to make

documents with numerous lines more clear. If the document is printed, the actual Border

Width will be 

Line Staring Type dictates the object if any at the beginning of the Line or Arrow.   

Line Ending Type dictates the object if any at the end of the Line or Arrow.
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Opacity allows you to set the transparency of the annotation. 

Blend Mode Controls the image editing in a way that two layers of the image are blended into each

other. There is a standard set of blend modes. Separable blend modes are the following: Normal,

Multiply, Screen, Overlay, Darken, Lighten, Color Dodge, Color Burn, HardLight, Soft Light, Difference

and Exclusion. Nonseparable blend modes are Hue, Saturation, Color, and Luminosity.

Keep Selected Keeps that selected tool active across all opened document unless otherwise

specified. 

Exclusive Mode Excludes annotations that might be overlapping the target text so that the text can

be selected. 

Note: You will not be able to Edit comments or annotations when this option is turned on.

Properties opens the Properties Pane  .

7.8.4.11 Rectangle Tool

The Rectangle Tool allows you to draw a rectangle on the currently displayed PDF document page. 

To draw the Rectangle, click the Rectangle button and a small cross-hair cursor appears. Position

the cursor at the upper left corner of the area you want to mark, and then left-click and drag the

cursor to the lower right position. 

After drawing the rectangle, you may add a pop-up note. See Comment And Markup Example

 for more information.

7.8.4.12 Oval (Circle) Tool

The Oval (Circle) Tool allows you to draw ovals and circles on the currently displayed PDF

document page.

See Comment And Markup Example  for an example of using the Oval (Circle) Tool. 
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7.8.4.13 Polygon Line Tool

The Polygon Line Tool is an extension of the basic Line Tool that allows you to draw multiple

connected line segments:

To draw the Polygon Line, click the Polygon Line Tool button and a small cross-hair cursor

appears. Select a starting point and click-and-drag the cursor to the next point. When you get there,

click again to start a new segment that is automatically connected to the first. Repeat until you

reach your stopping point and then double click to end the line.

After you complete the Polygon Line, you may add a pop-up note. See Comment And Markup

Example  for more information. 

You may adjust the ends of the line or arrow by selecting Properties... from the pop-up menu, and

setting the Line Starting and Line Ending Styles for the Start or End of the line.

7.8.4.14 Polygon Tool

The Polygon Tool draws a polygon outline around selected parts of the PDF page to highlight

them: 

To draw the polygon, click the Polygon markup button and a small cross-hair cursor appears. Click

a series of points around the area of interest to draw the outline. At the starting point of the

polygon there appears a small blue circle. To end the polygon, you have to click at that circle. 
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After you complete the Polygon, you may add a pop-up note. See Comment And Markup

Example  for more information.

You may also adjust the Properties of the Polygon by selecting Properties....

7.8.4.15 Cloud Tool

The Cloud Tool draws a "cloud" outline around selected parts of the PDF page to highlight them: 

To draw the cloud, click the Cloud markup button and a small cross-hair cursor appears. Click a

series of points around the area of interest to draw the cloud outline. At the starting point of the

cloud there appears a small blue circle. To end the cloud outline, you have to click at that circle. 

Note that for best results you should click the area in a clockwise motion. You are not restricted to

using a rectangle and you are not restricted to four sides at right angles. 

After you complete the Cloud markup, you may add a pop-up note. See Comment And Markup

Example  for more information.

You may also adjust the Properties of the Cloud by selecting Properties....

7.8.4.16 Pencil Tool

The Pencil Tool allows you to draw a freehand shape on the document. 

After you complete the Pencil shape, you may add a pop-up note. See Comment And Markup

Example  for more information.

You may also adjust the Properties of the Pencil shape by selecting Properties....
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7.8.4.17 Eraser Tool

In conjunction with the Pencil tool, an Eraser tool has been added that permits you to erase any

part of a Pencil-drawn annotation.

7.8.4.18 Stamp Tool

The Stamps submenu allows you to apply standard stamps to the currently displayed PDF

document page. 

You may select the stamp type by selecting the Stamp Tool option from the Comment And

Markup Tools menu or selecting the Stamps Palette option from the Other Panes menu. A

selection list of available stamps organized by Palette type will be opened: 
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1. Simply click on the desired stamp type you want to use, which will set the cursor to a

"stamp" cursor. 

2. After selecting the stamp type, position the cursor at the upper left corner of the position

where you want to place the stamp, and click: 

3. After placing, you may click-and-drag the stamp to a better position. You may also resize

the stamp by click-and-dragging any of the 4 small boxes at the corners of the stamp. 
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Stamps Palette opens the Stamps Palette dialog with a selection list of available stamps organized

by Palette type. 

1. Zoom In. Enlarges the size of the thumbnail images in the Stamps area.

2. Zoom Out. Reduces the size of the thumbnail images in the Stamps area. 

3. New from File.... Creates a stamp from a selected image file or PDF document page.

You could also scan your signature into a file to allow you to then 'Stamp' a document with

your physical signature - however - should you do this - we strongly recommend you use

the Flatten Comments option to ensure your signature is not easily interfered with in the

final PDF once distributed.

4. New from Clipboard.... Creates a stamp from an image contained in the clipboard. 

5. Rename. Allows you to change an existing stamp's name.

6. Delete. Deletes the selected stamp from the collection.
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7.8.4.18.1  How to create dynamic stamps

Dynamic stamps are special stamps that contain a variable field(s) that change depending on any

number of factors (ie today's date, the current user logged in the computer using the Editor, etc). A

basic to moderate working knowledge of JavaScript is required to create dynamic stamps, but many

dynamic stamps JavaScript examples are available on the internet, that can easily be incorporated

into created stamps. 

For full description of actions supported under JavaScript, please see the JavaScript API reference. 

Creating a dynamic stamp from an existing image or PDF file

1. Go to the Stamps pallet found under Tools> Comment And Markup Tools> Stamp

Tool> Stamps Pallet.

2. Click on  New From File... and browse to, and select the desired file from which to

create a stamp. 

      Stamps Pallet

3. Close the PDF-XChange Editor, and navigate to the stamps directory to locate the newly

created stamp. 

Custom stamps are typically stored under C:\Users\<User>\AppData\Roaming\Tracker

Software\PDFXEditor\3.0\Stamps

http://www.adobe.com/content/dam/Adobe/en/devnet/acrobat/pdfs/js_api_reference.pdf
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4. Move the newly created stamp out of the stamps directory, then open it with the PDF-

XChange Editor Plus.

Note: If the file is opened from the Stamps directory, changes made cannot be saved. 

5. Add a Text Form Field  using the Edit Form  feature found under Form> Edit Form

with the Value calculation property set to Custom Action. 

Custom actions can be created by pressing the [...] button to bring up the Edit Action: "Run

a JavaScript" window and enter a new JavaScript. 

      Edit Action: "Run a JavaScript" window

Inherit today's date JavaScript Example:

var d = new Date;
event.value = util.printd("yyyy/mm/dd", d);

470 461
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Inherit Username JavaScript Example:

if((identity.name != null) && !/^\s*$/.test(identity.name))
event.value = identity.name;
else
event.value = identity.loginName.replace(/\./g," ").replace(/\./g,"
").replace(/\b(\w)/g,function(Word,cFst){return
cFst.toUpperCase()});

6. Once the fields have been positioned on the stamp, and the data has been entered correctly,

save the file, then close the PDF-XChange Editor. 

7. Move the stamp file back into the stamps directory (C:\Users\<User>\AppData\Roaming

\Tracker Software\PDFXEditor\3.0\Stamps). 

The dynamic stamp will then be available in the stamps collection specified.  

7.8.4.18.2  Stamp Palette

Use the Stamps Palette to add a custom stamp to the Stamp Tool  PDF-XChange Editor has a

feature called the Stamp Tool.   The Stamp Tool can place an image on the page as though

you were using a rubber stamp. It comes with a number of default stamps, and you can also create

your own custom stamps. This is a very convenient way to repeatedly add the same content to

documents. 

Stamps can be created from image files or PDF documents.  To create your own stamp to use with

the Stamp Tool you need to open the Stamps Palette and add a new item.  Click the small arrow

beneath the Stamp Tool to display all currently available stamps in a pop up window. 
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At the bottom of this window you can select "Show Stamps Palette" to open up the Stamps

Palette dialogue box where you can add, rename and delete stamps from your palette.
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This picture shows palette of Standard stamps, Dynamic Dates stamps, and Customer stamp (here it's named

Signature)

New stamps can be made from most image file formats or PDF documents; either from a file or the

Windows "Clipboard".

Create a Stamp from a PDF

The first thing that needs to be done here is to locate or create a PDF with the content you want. 

You can use PDF-XChange Viewer/Editor to create a new PDF file or PDF-XChange 4 Printer to

convert something from another program to PDF and use that.  For this example I used Microsoft

Word to create a cloud with an appropriately sized page, then used the PDF-XChange Office Addin

to convert it to PDF.
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To use this as the basis for a new Stamp, click the "new from file" icon in the Stamps Palette, browse

for the desired file you wish to use as a stamp, then name it. 

Next to target collection, click Add New...

note: If you already have a custom stamp pallet you will not need to create a new one, however if you

only have the standard stamps pallet, a new one must be added
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Click OK to add the new stamp collection then click ok to add your new stamp. 

You should now have a new stamp available to put on documents.

Creating a stamp from an image is done in a very similar way.  Some detail is available here: KB#62

Next, close the Stamps Palette and your new stamp should now be available, from within the Stamp

tool, to use on your documents:

https://www.tracker-software.com/knowledgebase/62-How-do-I-create-stamps-for-use-in-the-Stamp-Tool
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Click the small arrow bellow the stamp tool Icon to open the stamp collections 

Click on the stamp you wish to use and you are ready to stamp up your document. 

Things to consider when creating a stamp:

· Most Image files are in a Raster format, and will pixelate when zoomed to a high degree, so

make your stamp from an image pre-sized to what you need.

· PDF documents can be either raster or vector based so be sure you understand what type

you have.

· If you want to have a transparent background to your stamp, you will need to use a suitable

image format (.gif or .png being two common ones, but not jpg) or pdf.

· For more detail on creating stamps from images, see this article: KB#62

7.8.4.19 File Attachment Tool

File Attachment Tool allows you to pin the attachment to any place on a page. After choosing the

File Attachment Tool you should click on the page. It opens the standard Open Files dialog box

which allows you to attach PDFs and other types of files to a PDF document.

See Attachments for more information.

7.8.4.20 Sound Tool

The Sound Tool allows you to add a sound comment to the selected location on the PDF page. 

1. To create a sound comment, select the Sound Tool from the Tools|Comment And Markup

Tools and click to a necessary area on the page. The following dialog box will appear:

309
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This will allow you to browse for a previously saved file or record a new sound file. 

2. To listen to the sound comment, you should double click the Sound Tool icon on the PDF

page.

3. The appearance of the Sound Tool icon may be changed with the help of the Properties

Toolbar:

Here you can choose one of the three available icons and change their color.

See Comment And Markup Example  for more information.517
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7.8.5 Measuring Tools

Selecting Measuring Tools submenu allows selection of one of three options: 

Distance Tool

Perimeter Tool

Area Tool

Calibrate Measurement

See the subtopics for a description of each tool.

7.8.5.1 Distance Tool

Distance Tool permits measuring the distance between two points. 

To measure the distance between two points, click the Distance tool markup button and a small

cross-hair cursor appears. Select the starting point and then click-and-drag the cursor to the ending

point. The measurements appear in the process of dragging the cursor. 

After you click the last point, drag the dimension line to figure out the leader line and then click

again.  

After you complete the Line, you may add a pop-up note. See Comment And Markup Example

 for more information.
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If you right-click on the dimension line you open the following menu:

Open Pop-Up Note. Opens a new or existing note for the item. Your user name and the date

and time of the note are automatically entered. You may now enter any text you wish in the

lighter portion of the note. 

Hide Pop-Up Note. Hides the note. 

Reset Pop-Up Note Location. Selecting this allows you to position the cursor in the pop-up

heading and then click-and-drag the pop-up to a more convenient location. 

Cut. Cuts the selected dimension line. 

Copy. Copies the selected dimension line. 

Paste. Pastes the copied dimension line. 

Delete. Deletes the following dimension line and the note. 
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Flatten. Flattens the dimension line in case you want to make it impossible to change the note

later.

Add Reply. Adds a reply area to the note. 

Status. Defines the status of the dimension line.

Order. Allows you to set the dimension line’s order. 

Flip Line. Allows you to turn the dimension line around.

Restore Caption Placement. Allows you to return caption to its former placement. 

Edit Label.... Allows you to add a text label to the dimension line.

Delete Label.... Deletes a text label from the dimension line. 

Make Current Properties Default. Sets the currently selected properties as a default ones for

all new Distance tools of the same type. 

Apply Default Properties. Allows you to change the properties of the Distance tool for the

ones, saved as default. 

Properties.... Opens the Properties dialog for Distance tool. 
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7.8.5.2 Perimeter Tool

Perimeter tool allows you to measure a set of distances between multiple points. 

To measure the distance between multiple points, click the Perimeter tool markup button and a

small cross-hair cursor appears. Select a starting point and click-and-drag the cursor to the next

point. When you get there, click again to start a new segment that is automatically connected to the

first. Repeat until you reach your stopping point and then double click to end the measurement. 

After you complete the line, you may add a pop-up note. See Comment And Markup Example

 for more information.

If you right-click on the Dimension Polyline you open the following menu:

Open Pop-Up Note. Opens a new or existing note for the item. Your user name and the date

and time of the note are automatically entered. You may now enter any text you wish in the

lighter portion of the note. 

Hide Pop-Up Note. Hides the note. 
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Reset Pop-Up Note Location. Selecting this allows you to position the cursor in the pop-up

heading and then click-and-drag the pop-up to a more convenient location. 

Cut. Cuts the selected dimension polyline. 

Copy. Copies the selected dimension polyline. 

Paste. Pastes the copied dimension polyline. 

Delete. Deletes the following dimension polyline and the note. 

Flatten. Flattens the dimension polyline in case you want to make it impossible to change the

note later.

Add Reply. Adds a reply area to the note.

Status. Defines the status of the dimension polyline.

Order. Allows you to set the dimension polyline’s order. 

Control Points. 

· Add Point. Creates new point.

· Delete Point. Deletes new point.

Edit Label.... Allows you to add text label to the dimension polyline. 

Delete Label.... Deletes text label from the dimension polyline. 

Make Current Properties Default. Sets the currently selected properties as a default ones for

all new Distance tools of the same type.

Apply Default Properties. Allows you to change the properties of the Distance tool for the

ones, saved as default. 

Properties.... Opens the Properties dialog for Distance tool.
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7.8.5.3 Area Tool

Area tool allows you to measure the area within the line segments that you draw. 

To measure the area within the line segments that you draw, click the Distance tool markup button

and a small cross-hair cursor appears. Click a series of points around the area of interest to draw the

outline. At the starting point of the line there appears a small blue circle. To end the outline, you

have to click at that circle. 

After you complete the line, you may add a pop-up note. See Comment And Markup Example

 for more information.

If you right-click on the dimension line you open the following menu:

517
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Open Pop-Up Note. Opens a new or existing note for the item. Your user name and the date

and time of the note are automatically entered. You may now enter any text you wish in the

lighter portion of the note. 

Hide Pop-Up Note. Hides the note. 

Reset Pop-Up Note Location. Selecting this allows you to position the cursor in the pop-up

heading and then click-and-drag the pop-up to a more convenient location. 

Cut. Cuts the selected dimension polygon. 

Copy. Copies the selected dimension polygon. 

Paste. Pastes the copied dimension polygon. 

Delete. Deletes the following dimension polygon and the note. 

Flatten. Flattens the dimension polygon in case you want to make it impossible to change the

note later.

Add Reply. Adds a reply area to the note.

Status. Defines the status of the dimension polygon.

Order. Allows you to set the dimension polygon’s order. 

Control Points.

· Add Point.

· Delete Point. 

Edit Label.... Allows you to add text label to the dimension polygon.

Delete Label.... Deletes text label from the dimension polygon.
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Make Current Properties Default. Sets the currently selected properties as a default ones for

all new Distance tools of the same type. 

Apply Default Properties. Allows you to change the properties of the Distance tool for the

ones, saved as default. 

Properties.... Opens the Properties dialog for Dimension Polygon Tool. 

7.8.5.4 Calibrate Measurement

To set a scale for an entire drawing, you must use the calibration tool.To use the calibration tool you

must first find a known distance, once you have, you can set all future measurements based upon

that one.  

Go to tools> Measuring tools> Calibrate measurement [Ctrl+Shift+C] and choose two points

with a known distance between them. In the example, I have chosen to calibrate the measurements

using a doorway of three feet (3').

Holding shift while placing the calibration will keep the tool horizontal, 45 degrees or vertical.   

Note: With snapping turned on, I have reliable consistency in placing my measurements along

lines, or in this case, inside the middle of the door jam (indicated by the red triangle) see the 
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Measurement Section  for more details and how to use/ implement the snapping

functions. 

When the calibration is placed, the following window will show up:

In the highlighted field, place the desired measurement. Notice that I have placed 3' to indicate

three feet for a scale of 0.29"=3' then press OK.

Note: The formatting you use in this field, will be the formatting displayed. For example if I

want the following format 5' 6 1/2" I would place 3' 0/12" 

237
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Note: All units available in the Editor are available to use in the calibration, up to as many

decimal points, or any fraction accuracy specified in the highlighted field above. For example

1.0000000000000m (meters).

If no decimal places are specified (e.g. 3 ft or 3'), Measurement Tools will round to the nearest

whole number when measuring.

Now you will be able to place all future measurements using this scale. 
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You can manage the format or scale later by right clicking on a measurement> set scale:
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In the screenshot below, we have encased the measurement of the initial calibration. All

measurements placed after calibration are blue.
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Notice the different format in the screenshot below. The scale is the same, only the format in which

it is displayed is different.
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7.8.6 Link Tools

Selecting Link Tools submenu allows selection of the following option: 

Link Creation Tool

7.8.6.1 Link Creation Tool

Link Tool allows you to create a link in order to jump to other locations in the same document or

to websites. 

To create a Link, click the Link Tool markup button and a small cross-hair cursor appears. Position

the cursor at the upper left corner of the area you want to mark, and then left-click and drag the

cursor to the lower right position.

A link can be edited at any time. You can change its position or associated link action, delete or

resize the link rectangle, or change the destination of the link. 

Changing the properties of an existing link affects only the currently selected link. If a link isn’t

selected, the properties will apply to the next link you create. 

To change the properties or position of multiple link objects you should drag a rectangle to select

them using the Link tool while holding the CTRL key. 

To move the link rectangle, drag it. To resize the link rectangle, drag any corner point. 
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If you right-click on the link you open the following menu:

Cut. Cuts the selected link. 

Copy. Copies the selected link. 

Paste. Pastes the copied link. 

Delete. Deletes the following link. 

Status. Defines the status of the link.

Order. Allows you to set the link’s order. 

Valid values are: 
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Transform to Quadrilateral. Allows you to transform the Rectangle link tool to Quadrilateral

and vice versa.

Make Current Properties Default. This allows you to set the currently selected properties as

default for Link Tools of the same type. 

Apply Default Properties. Applies the default properties to the selected link(s). 

Properties.... Opens the Properties pane for the Link Tool. 

General. Specifies the general properties of the link. 

Style. Sets the font style of the link. 

Actions. Defines the action(s) to be performed when the link is selected.

The Actions list lists the action(s) to be performed when the Bookmark is selected. At

the top of the Edit Actions List dialog is an editor toolbar for the Actions list: 
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Add.... Adds a new Action to the list.

Run a JavaScript. Runs the previously specified JavaScript.
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Go To a Page in the Document. Goes to the specified destination in the current

document.

Go To a Page in Another Document. Goes to the specified destination in another

document. Choose the necessary document with the help of the Browse button in

the Target Document section.
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Open a Web Link. Opens the previously specified link on the Internet.

Open a File. Opens the specified file.

Execute a Command. Executed the specified command from the menu.
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Reset a Form. Resets the previously entered data in a form

Submit a Form. Sends the form data to the specified URL.

Play a Sound. Plays the previously specified sound file.
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Show/Hide a Field. Shows or hides a field in a document. This action may be used

for form fields.

Read an Article. Allows you to follow an article in a PDF document.

Edit. Edits the selected Action.

Up. Moves the selected action up in the list.

Down. Moves the selected action down in the list.

Remove.... Deletes the selected Action.



574

PDF-XChange Editor/Editor Plus V6                                                                                                                                                                       © 2001-2016 Tracker Software Products Ltd

Main Menu

7.9 Advanced

The Advanced Menu allows for advanced manipulation of the document. 

Bookmarks  

7.9.1 Bookmarks

 

 Bookmark Table Of Contents...

 Generate Bookmarks From Page Text...

 Generate Bookmarks From Text File...

 Bookmark Every Nth Page...

 Add Text to Bookmarks Tile...

 Change Bookmark Case...

 Convert To Named Destinations...

 Convert Named Destinations To 

regular Destinations...

 Find And Replace Bookmark Text...

 Build Table of Contents...

 Sort Bookmarks...

 Validate Bookmarks...

 Export Bookmarks To HTML File...

 Export Bookmarks To Text File...

 Bookmark Table Of Contents...

Creates bookmarks from an existing Table of contents. 

 Generate Bookmarks From Page Text...

This feature allows you to create bookmarks from the text within a document. The text can be

specified by font style, size, color, and/ or phrase. Please see the Generate Bookmarks From Page

Text  section.
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 Generate Bookmarks From Text File...

This feature creates bookmarks from an existing text file containing programmatic instructions on

creating bookmarks. Please see the Generate Bookmarks From Text File  section.

 Bookmark Every Nth Page...

This feature has not yet been documented

 Add Text to Bookmarks Tile...

This feature has not yet been documented

 Change Bookmark Case...

This feature has not yet been documented

 Convert To Named Destinations...

This feature has not yet been documented

 Convert Named Destinations To regular Destinations...

This feature has not yet been documented

 Find And Replace Bookmark Text...

This feature has not yet been documented

 Build Table of Contents...

This feature has not yet been documented

 Sort Bookmarks...

This feature has not yet been documented

 Validate Bookmarks...

This feature has not yet been documented
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 Export Bookmarks To HTML File...

This feature has not yet been documented 

  Export Bookmarks to Text File...

This feature creates a simple text file containing instructions for recreating the same bookmarks in a

text (.txt) file. Please see the Export Bookmarks to Text File  section

7.9.1.1 Bookmark Table Of Contents

The  Bookmark Table of contents feature interacts with selected text within a PDF document,

to help easily create a clickable table of contents.  

Going to Advanced> Bookmarks> Bookmark table of contents will open the Bookmark Table

of Contents window. 

     Bookmark Table of Contents window

Add bookmarks to pages using table of contents adds bookmarks to the bookmarks tree,

pointing to the corresponding location in the file based on the existing TOC entries.

Add links to the table of contents entries adds click-able links to the TOC entries to navigate to

the correct page for each link. 
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Use existing links as new bookmarks destinations This feature allows for the addition of

bookmarks and link annotations with GoTo actions assigned to the corresponding pages. Links will

be placed on top of the TOC entries. 

Note that if the TOC entry already has a link pointing somewhere, the new link will not be

created. These existing link annotations can be used as a GoTo action source for newly created

bookmarks, (the action will be copied from them into the corresponding bookmarks).

Try to improve bookmarks destinations based on text Normally the bookmark will point to the

top left corner of the page specified in the TOC entry. This checkbox allows searching for the

topmost text that will match the entry text. This could somewhat slow bookmarks/links generation.

Remove consecutive spaces from bookmark titles will remove any extra spaces in the titles of

bookmarks.

Use TOC indents to create bookmarks hierarchy will use the Table of Contents indents to create

bookmarks with the same parent-child relationship as the Table of Contents.

Choose Separator type select the separator type corresponding to the existing separator in the

table of contents. 

· Include all

· Chapter....................1

· Chapter                    1

· Chapter                    1 

Page Offset specifies the difference between the actual page number and the marked page

number.

Change Offsets

The text inside the specified offsets parameters from the top and bottom of the page will be

ignored. This is used to ignore text in headers and footers. 

     Change Offsets window

Top Offset: Specify the offset from the top of each page. 

Bottom Offset: Specify the offset from the bottom of each page. 

Units: Select the units for measurement.
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7.9.1.2 Generate Bookmarks From Page Text

The  Generate Bookmarks from Page Text feature allows for the creation of bookmarks,

using the location and style of existing text within a file. By going to Advanced > Bookmarks >

Generate Bookmarks from Page text, the Generating Bookmarks From page Text window will

appear. 

     Advanced> Bookmarks> Generating Bookmarks From Page Text window

Page Range Selected <#> of <#> pages 

The Page Range options elect the pages that will be included in the bookmark generation. The total

number of pages will be listed in bold as shown in the screenshot of the Generating Bookmarks

From Page Text window.
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Ignore text that contains stop words allows setting of specific words that stop the generation of

bookmarks. Click on the [...] button to add new, or manage existing stop words and bring up the

Edit Stop Words window. If one of these words will be inside the text that matches the generation

criteria then this text will be ignored and the bookmark won't be created from it.

     Edit Stop words window

 Add... adds a new Stop Word

 Edit... edits the selected Stop Word

 Remove removes the selected Stop Word

Match text case Stop words that do not match the the case exactly will be not function as a

Stop Word.

Match whole words Portions of words will not be accepted as a Stop Word.

Use regular expressions The expressions are using the http://www.cplusplus.com/

reference/regex/ECMAScript/ 

Ignore consecutive duplicate bookmarks will stop identical bookmarks from being generated

side-by-side.

http://http/www.cplusplus.com/reference/regex/ECMAScript/
http://http/www.cplusplus.com/reference/regex/ECMAScript/
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Click on  Add... to add a new bookmarking rule. This will launch the Bookmark Generation

Properties window where the Text Matching Options, Resulting Appearance, and Title

Formatting can be manipulated. 

Text Matching Options 

Specifies the details of the text from which to generate a bookmark.

      Bookmark Generation Properties> Text Matching Options

Text Style

Select the text style of the text to be used in the bookmark generation.
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Font Names choose font name(s) that will be used to search and generate the bookmarks.

Click on  Add... to choose fonts from a list of fonts currently used in the document. 

      Bookmark Generation Properties> Text Matching Options> Add

To add a custom font from which to create bookmarks, click on  Add Custom... then

type the name of the font in the field provided.

     Add New Custom Font window
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Fine-tune the results by specifying a Font Size and Text Color.

Font Size can be specified in the first field. 

Tolerance Specify how many units that the font size can differ from what is specified in

the Font Size field. For example; if 12pt is the specified size, with a tolerance of 2pt,

fonts at the size of 10pt, 11pt, 12pt, 13pt, 14pt and anything in between will be

included.

Units drop down defines the way the Font Size is measured.  

· Point (pt)

· Inch (in)

· Centimeter (cm)

· Millimeter (mm)

· Pica (pc) 

Font Color specifies the color of the font to be used to generate the bookmark(s)

Get Style From Selected Text will automatically populate all the fields in the Text Style

section of the  Bookmark Generation Properties> Text Matching Options window with the

properties from the selected text in a file using the Text Select  tool.

Text Content Rules Specify the details of the text to be used in generating the bookmark(s). 

Match Text Case Specify the restrictions to be used when generating the bookmarks. 

· No restrictions the rules for bookmark generation will not be case sensitive. 

· All Characters are Capital All Characters must be upper case (capital) for it to be

used in generating bookmarks.

· First Character is Capital The first letter of the text string must be upper case

(capital) for it to be used in generating bookmarks.

· First Character is Digit The first character must be a number for it to be used in

generating bookmarks.
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Allow multiline Bookmark titles Titles can be have take up more than one line of text such

as is shown in the screenshot below

     Bookmarks Pane

Match Text Pattern requires the pattern of text to match. A pattern typically would include a

word or phrase, but could be based off of any combination of text patterns. This feature

makes use of regular expression. 

Match Text Case will ensure that the case used in the text pattern matches exactly before a

bookmark can be created. 

Limit Bookmark titles to matching patterns only will only allow bookmarks the are of same

text pattern to be created.
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Resulting Appearance

Customizes the resulting appearance of the bookmarks within the Bookmarks Pane .

     Bookmarks Generation Properties> Resulting Appearance window.

Text Color the color shown here will be the resulting color of the bookmarks' text.

Text Style defines the style of the text within the bookmark.

· Normal

· Italics

· Bold

· Bold and Italics

Zoom specifies the zoom level of the page when clicking on the bookmark. 

· Inherit will use the existing zoom level.

· Actual Size sets the PDF page to its actual size within the view pane. This is the same

as selecting 100% in the Zoom drop down list. This may result in the page exceeding

the limits of the viewable space; however, scroll bars are provided to enable scrolling

through the PDF page as desired.  

· Fit Page fits the entire PDF page within the borders of the view pane.  

284
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· Fit Width fits the PDF to the width of the view pane. Scroll bars are provided to

enable scrolling through the PDF page as desired.  

· Fit Height fits the full height of the page to the top and bottoms of the viewing

area. 

· Fit Visible fits visible content to the viewing area with a small boarder. Results may

vary depending on the PDF.

· Fit visible Width fits visible content to the left and right of the viewing area with a

small boarder. 

· Fit visible Height fits visible content to the top and bottom of the viewing area with

a small boarder. 

Show Expanded will cause the resulting bookmarks and children to be shown expanded. 

Title Formatting

Modify text properties that will be applied to the new bookmark title(s). 

     Bookmark Generation Properties> Title Formatting window
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Text Case these settings are used to define the case of the bookmarks. The examples are shown by

the way each option is named.

Do not change 

UPPERCASE will cause all the resulting bookmark titles to be in all caps (capitalized)

Title Case will generate bookmarks that follow English title conventions. (E.G: The Chronicles

of Narnia; Jurassic Park; The Emperor's New Groove)*

Sentence case Will capitalize only the first letter. 

lowercase all characters will be lower case.

*All titles used in this example are owned and trademarked. Tracker Software Products does

not claim to own these titles, or any rights to them. 

Advanced Formatting

Search and replace bookmarks title with text patterns

Search Pattern type the text pattern or regular expression to find text. 

Replace Pattern specify the text desired in place of the text found using the above field. 

Insert this text before each title The text entered in this field will be prepend to the

bookmark's title. 

Add this text after each title The text entered in this field will be appended to the bookmark's

title.

Leading numbers are numbers that prefix the title of the bookmark.

· No change

· Add

· Remove

Use

· Numbers 1, 2, 3, 4, 5, 6...

· Letters A, B, C, D....

· Roman numerals I, II, III, IV, V, VI, VII, VIII, IX, X

Maximum title length dictates how many character spaces can be used in the bookmark title. 

Remove duplicate spaces removes any instances where two blank characters spaces are placed

together. 
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7.9.1.3 Generate Bookmarks From Text File

Generate Bookmarks From Text File creates bookmarks from an existing text file containing

programmatic instructions on creating bookmarks. If the desired bookmarks exist in another PDF

file, simply use the Export Bookmarks To Text file option  with that file to create the required

text file. 

Otherwise, the conventions must be known to manually create a text file that will generate the

appropriate bookmarks. 

7.9.1.4 Export Bookmarks To Text File

Export Bookmarks To Text File creates a simple text file containing instructions for recreating

the same bookmarks in a text (.txt) file. This feature is best used when the intent is to later import

the same bookmarks to another PDF file using the Generate Bookmarks From Text File  option.

Selecting the Export Bookmarks To Text File option opens the Export Bookmarks to Text File

window.

General

Allows specification of the bookmarks to be Exported and how those bookmarks will be exported. 

     Export Bookmarks to Text File> General window

587
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Select Bookmarks to Export

Export All will export all bookmarks in the currently active file. 

Export Selected Bookmarks will export only the bookmarks selected in the Bookmarks

Pane .

Include all sub-bookmarks will include all child bookmarks in the bookmarks tree of the

selected bookmark.

Export bookmarks that perform hyperlink actions select the desired hyperlink action for

the bookmarks to be exported. For a complete list and description of available actions, please

see the Common Actions section .

· Bookmarks with all types of hyperlink actions bookmarks containing any

actions will be exported.

· Bookmarks with Go-To Page actions bookmarks containing Go-To Page

actions will be exported.

· Bookmarks with Open File actions bookmarks containing Open File actions will

be exported.

· Bookmarks with Open Web Link actions bookmarks containing Open Web link

actions will be exported.

· Bookmarks with Go-To Remote actions bookmarks that contain an action to

go to a page in another document will be exported. 

· Bookmarks with JavaScript actions bookmarks containing JavaScript actions

will be exported.

Output Parameters

Use PDF-document filename to save results the name of the PDF will be used as the name

for the bookmarks' text file. 

File Name: Specify the desired file name in this field. 

Folder: Specify the folder to save the text file to. Select the  button to open a Select

Folder window and browse to the desired save location. 

Overwrite existing files will overwrite files of the same name.

Open containing folder causes file explorer (also known as windows explorer) to open the

folder containing the new text file after exportation. 

284
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Bookmark Properties

Allows for the modification of the bookmark properties to be included in the resulting text file. 

      Export Bookmark to Text File> Bookmark Properties window

Export Bookmark actions will export the action set for the bookmark and that action's properties. 

Export Page that bookmark points to adds the page number to the bookmarks properties. 

Resolve names destination to page numbers Check "Resolve named destinations" option to

resolve named destination references to a page number. If bookmark action uses a named

reference to a

specific location within a document and this option is off, then a named destination title will be

exported instead of a page number.

Export detailed destination description exports a more detailed description of the destination for

the bookmark.

Export Web Links will export the web links to the text file. 

Export Open File actions description will export the description of the "Open File" action. This is

necessary to later recreate the same action.  

Export Remote Go-To actions description a GoTo remote action typically points to an external

PDF. Select this option if you wish the bookmark description to include a path to the external file. 

Export JavaScript actions code will export any JavaScript action's code to the text file. 

Export bookmark text style and color properties will export the the bookmark's text style and

color properties. 

Export bookmark "closed" state if the state of the bookmark will be exported. Bookmark will
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appear in the “closed” state (not showing its children).

Properties delimiter specifies the delimiter that separates each property of a bookmark in the text

file.  

Do not escape service symbols such as @ # { } \ : etc. all of the service symbols (\ { } @ # :),  line

breaks and delimiter symbol should be escaped inside of the bookmarks attributes (title and action

settings)
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7.10 SharePoint

PDF-XChange Editor has a plugin (installed by default) to allow users to open, modify and save PDF

documents from and to a SharePoint server directly.

Note:The way SharePoint works with a web browser one cannot simply expect to click a file in

your SharePoint shares from your web browser have it open in your browser PDF plugin then save

directly to your SharePoint server.  The credentials to do so are not available to the plugin, it will

save a local copy you must then upload to SharePoint.

PDF-XChange Editor does however have SharePoint integration available directly from the Editor

itself.  The process to work directly on SharePoint PDF files in the PDF-XChange Editor is to open

the file using the Editor’s File >Open From >SharePoint feature.  This will then allow your

SharePoint credentials to be saved in the Editor itself.

Opening a SharePoint file in PDF-XChange Editor

Start PDF-XChange Editor and select File >Open From >SharePoint
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Enter the URL for the SharePoint share and click “Navigate”.

You will be prompted to enter your SharePoint credentials:
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Once authenticated browse to the PDF file you want to open:

You can either open the PDF or open and check out the file:

Now you can save the PDF directly to your SharePoint server directly using the Editor’s regular Save

features:
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Depending on whether you opened or checked out the file you may be prompted to choose again

whether to Save and Check Out:

See here for details on the use of Open and Check Out files in SharePoint: https://

support.office.com/en-us/article/Open-or-check-out-Office-files-from-a-SharePoint-library-

b4221e42-d47c-49fc-92a6-04ed88befc0c

https://support.office.com/en-us/article/Open-or-check-out-Office-files-from-a-SharePoint-library-b4221e42-d47c-49fc-92a6-04ed88befc0c
https://support.office.com/en-us/article/Open-or-check-out-Office-files-from-a-SharePoint-library-b4221e42-d47c-49fc-92a6-04ed88befc0c
https://support.office.com/en-us/article/Open-or-check-out-Office-files-from-a-SharePoint-library-b4221e42-d47c-49fc-92a6-04ed88befc0c
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7.11 Window

Window activates a pull down of window options. These control how the various windows are

arranged on your screen. PDF Document display control is on the View menu. 

Window menu is activated when Tabbed Documents from the Edit | Preferences | General and

Navigation Tabs from the View menu are unchecked. 

New Window. Note: This function was not available at the time of writing of this

documentation revision.

Reset Main Panes Layout. Resets the current position and size of main panes to default,

removing all changes. Main panes are those which cannot be closed simultaneously with the

document (e.g. Search, Properties, etc.).
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Reset Document Panes Layout. Resets the current position and size of document panes to

default, removing all changes. Document panes are those which are closed simultaneously with

the document (e.g. Bookmarks, Thumbnails, etc.).

Active Document to New Horizontal Tab Group. Places the active document to the right side

of a horizontal tab group.

Active Document to New Vertical Tab Group. Places the active document at the bottom of a

vertical tab group.

All Documents to One Tab Group. Arranges all open documents to one tab group.

Split. Allows you to arrange the Minitab windows.

Horizontal Split. Arranges all open Minitab windows horizontally so they fit next to each

other on the desktop and do not overlap.

Vertical Split. Arranges all open Minitab windows vertically so they fit next to each other

on the desktop and do not overlap.

Remove Split. Removes the window split.

Close All. Closes all the open PDF files.
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7.12 Help

Help opens the Help menu.

 

 Contents 

 Home Page

 Check for updates

 Enter License Key...

 Support Forum

 Report a Problem

 About

Contents Opens the online help manual

Home Page Links to the Tracker Software Products website.

Check for updates calls the Tracker Updater to checks for updates. 

Enter License Key... Brings up the Edit > Preferences > Registration window. 

Support Forum Opens a link to the Tracker Software Products, Ltd. support forums. 

Note:You must register (free) to login and View the Forums - otherwise you will not see the full

forums list of previously reported issues and answers etc - or be able to post problems of your

own and receive support. If you require support, but do not wish to register on the Forums,

please send an email to support@tracker-software.com.
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Report a Problem Opens the Report a Problem window to permit clients to report any problems

directly to Tracker Software Products, Ltd. by email:

Please ensure you include all relevant info in your message and whenever possible leave all

the options above checked.

A sample PDF file is usually an essential item in any problem report! 
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About Opens a dialog box that displays version and license information for the PDF-XChange

Editor.
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8 Toolbars Area

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.

Note: The Document options, Page Measurement info, Page navigation, page display, and

launch applications toolbars cannot be floated or customized.

Properties Toolbar  

Menu Toolbar  

Main Toolbar Area  

· Commenting Toolbar  

· Content Editing Toolbar  

· File Toolbar  

· Rotate View Toolbar  

· Zoom Toolbar  

Document Options Toolbar  

Page Measurement info  

Page Navigation  

Page Layout  

Launch Applications  

See also How to Customize Toolbars  and How to Customize Commands  section.
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8.1 Properties Toolbar

The Properties Toolbar [Ctrl+E or View > Toolbars > Properties to toggle] becomes active when

an object in a PDF is selected, which allows the modification of the look, feel and functionality of

that tool or object. 

The options in the Properties Toolbar are dynamic and differ depending on what is selected. For

example, while typing text into a typewriter annotation or text box, the Properties Toolbar will look

like what is shown below.  

This instance of the Properties Toolbar contains all the text dependent settings and properties

needed to make the text within the annotation exactly as desired.

From Left to right, the first Item on the toolbar is the Fill Color option, which allows modification of

the text color. Next is the Font selection Drop down menu, followed by the Font Size field.

From here, many default or installed fonts can be selected from the drop-down list, and any font

size desired can be set by typing the numbers in the Text Size field or again selecting standard font

sizes from the drop-down list.

Increases the font size by 1 pt

Decreases the font size by 1 pt

Activates Bold text style

Activates Italic text style

Activates Underlined text.

Activates Strikethrough text.

Changes the text to the subscript level.

Changes the text to the superscript level.

Align text using the Left Justify  , Center  , Right Justify  and Justify 

buttons.

Clear Style remove all text formatting

Make Default Style saves the current text properties as default.
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Apply Default Style applies the current default text style.

While not typing anywhere, the Properties Toolbar is dependent of the active tool or object. Please

see the small sample of screenshots below which illustrate this behavior. 

Note: Notice the labels at the top left of each properties toolbar that show which tool or

object is being used and/or affected by the properties displayed. 

 Exclusive Mode sets the active tool so it will ignore existing comments or annotations that

are already placed on the PDF page.

This allows for overlapping the placement of new comments, annotations or shapes without

activating the existing object already occupying the same area. 

As well this mode allows access to objects or base content beneath an existing annotation. 

For an example to illustrate this functionality, create a new PDF by going to File >New Document

>With blank pages. 
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Once the document is created, use the Add Text tool to add some base content text. Now use the

Rectangle tool  and cover the text. With exclusive mode turned off  you will notice that no

tool can interact with the text without moving the rectangle annotation first. Now turn on Exclusive

mode, and try to select the text using the text select tool. You should find that the rectangle

annotation in ignored, and you are now able to select the underlying text.

Keep Selected when activated, the current tool will not revert to the hand tool after an

annotation is placed. 

For a description of what each property does for a given tool and its related annotation, please see

the Tools section .

8.2 Menu Toolbar

File  File level operations including selecting files, document properties, forms data manipulation,

and printing.

Edit Editing functions on PDF files and forms. Also program preferences can be set, exported and

reset here.

View Editor information display control. Determines what PDF information is displayed and how.

Document  Controls for Rotating, Deleting, or Cropping pages.

Comments  Organizes the comments operations.

Form  Manages Form Data.

Object Organizes the object operations.

Tools Selection of the different PDF tools, including Hand, Snapshot, and Zoom controls.

Advanced Contains advanced functions such as the bookmarks plugin

SharePoint Allows the user to Check in or check out a document located on a SharePoint server.

Window Organizes the layout of the PDF file window(s) currently opened.

Help Accesses help information about the Editor and its operation. The registration section and

"report a bug" can also be found here.

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.

Note: By pushing the Alt key, some letters in the menu bar become underlined. If a user

presses one of those keys, that menu will expand. For example Alt, then P will open the SharePoint

Menu.
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8.3 Main Toolbar Area

You Can move a toolbar to a new location in our out of the toolbar area. To move a toolbar, you

can grab it at the left edge and move it to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.

     Main Toolbar Area [Top]

Commenting Toolbar  

Content Editing Toolbar  

File Toolbar  

Measuring Toolbar  

Rotate View Toolbar  

Standard Toolbar  

Zoom Toolbar  

8.3.1 Commenting Toolbar

The default Commenting Toolbar contains some of the commenting tools, this toolbar is highly

customizable. For more details on customizing toolbars, please see the How to Customize

Toolbars  section.

For details of each tool found within the default Commenting Toolbar, please see the Comments

and Markup Tools  section, or the corresponding links below.
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Edit Comments Tool   is used to Edit existing comments. Clicking the Edit Comments

button you can select a group of comments with the help of the mouse cursor. To move the group

of comments, drag the selected area with your mouse. To resize the group of comments, drag one

of the resize (yellow) handles. To rotate the group of comments, drag the rotate (green) handle. To

edit the text, double click the text area and select the necessary text fragment.

Typewriter Tool   To type on a page like a typewriter. The typewriter is not constricted by

bounding boxes.

Callout Tool   used to place a Callout annotation.

Highlight Tool  used to place a highlight annotation to text on a page

Strikeout Tool   used to cross out text on a page

Underline Tool   Underlines text on a page

Sticky Note Tool   used to apply a sticky note annotation

Attach File Tool   used to attach document, file, images, portfolios and more.

Sound Tool    used to add a sound to a page.

Line Tool   used to place a line annotation

Oval Tool   used to place oval annotation. Use the Alt key to constrain the annotation to a

circle.

Polygon Line Tool   Used to create an open multi side line annotation. Single click to start a

new segment, double click to finish.

Cloud Tool  Used to create a closed cloud. Single click to add new segments, double click

or return to starting point to finish.

Arrow Tool   used to create an arrow annotation.

Rectangle Tool   used to place a rectangle annotation.

Polygon Tool    used to create a polygon, multi side closed annotation. Single click to add a

segment, double click or return to the starting point to finish.

Stamp Tool   used to place stamps. Stamps can be selected from the Stamps Palette .

Pencil Tool   Used to draw on a page.
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http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=highlight_tool
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=file_attachment_tool_
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=cloud_tool
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http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=pencil_tool
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Eraser Tool   used to remove pencil tool markups.

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.

8.3.2 Content Editing Toolbar

The Content Editing Toolbar contains the Edit Content tool and the Add text tool. 

For details of the content Editing options, please see the Content Editing Tools  Section or the

corresponding links below.

Edit Content Tool  to edit existing base content.

Add Text Tool  to add base content text.

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.
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8.3.3 File Toolbar

The File Toolbar contains navigation, creation, saving and opening options.

Clicking the Open  button opens the Open...  dialog box. Clicking the down arrow  opens

the Recent Files drop list.

Clicking the Save  button saves the modified file, as per the Save  menu item.

Clicking the Print...  button (Printer icon) opens the Print  dialog.

Clicking the From Scanner...  button (Scanner icon) opens the Scan Properties dialog.

Clicking the Send by E-mail  button (mail icon) opens the Send by E-mail dialog. 

Clicking the Previous View or Next View  button moves to the previous or next view.

Clicking the Undo  , Redo  buttons control the last editing changes made to the document.

Recent Files

Unpinned Recents displays a selection list of recently used files. Clicking the pushpin  to the

right of the document name in the Unpinned Recents will "pin" the document and move it to the

Pinned Recents list so that it won't "fall off" the list if the maximum number of documents in the

recent files list is exceeded. To unpin a document, click on the 

88

96

157

http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=file_toolbar&nocache=16396#Recent%20Files
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=from_scanner
http://help.tracker-software.com/PDFXEdit6/page.aspx?pageid=send_by_e-mail
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When you mouse over a specific file from the list, the first page and other properties of the

document are displayed: 

To adjust the history and recents options open the Manage History and Recents... dialog from the

bottom of the Recents List. 
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History Options. 

Max. number of items. You can set the maximum number of documents to be

displayed in the Recent documents list. 

Item's life-time. Defines how long the unpinned documents will remain in the list.

Clear history on exit. Clears the history list completely on exit.

Recents List Options. 

Show max. number of items. The maximum number of items will be displayed in

the Recents list.

Show thumbnail. Displays the thumbnails of the documents listed in the Recents.

Show caption. Will show the document Title in the Recents List as indicated in the

screenshot below.

Show file-path. Displays the file path of the documents listed in the Recents. 

Cache thumbnails stores the images for thumbnail previews in cache memory so

that the images can be loaded quickly each time you access the recents list.

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section. 

8.3.4 Measuring Toolbar

620
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Clicking the  button switches to the Distance Tool . 

Clicking the  button switches to the Perimeter Tool . 

Clicking the  button switches to the Area Tool . 

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created.Toolbars are highly customizable. For instructions and

information regarding customizing toolbars, please see the How to Customize Toolbars

section.

8.3.5 Rotate View Toolbar

The Rotate View Toolbar can be used to change the viewing orientation of a document.

Note: Rotate View is not a permanent change! It is more akin to rotating your monitor. When

reopened, the document will revert rotation. To permanently rotate pages, please use the Rotate

Pages function found under Document > Rotate Pages .

Clicking the Rotation buttons rotates the PDF view clockwise  or counterclockwise  90

degrees. You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar

you should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.

8.3.6 Standard Toolbar

The Standard toolbar contains the basic tools necessary for viewing PDF.
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Clicking the  button switches to the Hand Tool . 

Clicking the  button switches to the Snapshot Tool . 

Clicking the  button switches to the Text Select Tool . 

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.

8.3.7 Zoom Toolbar

The tools included in the default Zoom Toolbar can be used to manipulate the Zoom level of a PDF

Clicking the Actual Size  button sets the PDF page to its actual size within the view pane. This

is the same as selecting 100% in the Zoom drop list. This may result in the page exceeding the

limits of the viewable space; however, scroll bars are provided to enable you to scroll the PDF page

as desired.  

Clicking the Fit Page  button fits the entire PDF page within the borders of the view pane.  

Clicking the Fit Width  button fits the PDF to the width of the view pane. Scroll bars are

provided to enable you to scroll the PDF page as desired.

The Zoom drop box may be uased to select standard zoom settings or to enter any zoom

percentage you need. 

Clicking the Zoom In Tool  button increases the Zoom percentage of the selected area. 

Clicking the Zoom In  button increases the Zoom percentage. Clicking the Zoom Out 

button decreases the Zoom percentage. 

You can move a toolbar to a new location in or out of the toolbar area. To move a toolbar you

should grab it at the left edge and move to the necessary place. If you drag a toolbar out of the

toolbar area, a floating toolbar will be created. Toolbars are highly customizable. For instructions

and information regarding customizing toolbars, please see the How to Customize Toolbars

section.
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8.4 Document Options Toolbar

Found in the bottom left, Clicking on the  Options Toolbar brings up the following menu

Bookmarks   toggles the Bookmarks Pane

Thumbnails  toggles the Thumbnails Pane

Destinations toggles the Destinations Pane

Content toggles the Content Pane

Signatures  toggles the signatures Pane 

Layers toggles the Layers Pane

Comments toggles the comments Pane

Attachments  toggles the attachments Pane

Spell Check  allows you to spell check the whole

document

Properties Pane Toggles the Properties Pane

Show Rulers  shows document rulers

Show Grid shows a gird overlay on the PDF

Show Page Measurement Info  toggles the

Measurement info

Find  toggles the Find bar

Document Properties...  Opens the document

properties dialog

Note: This feature has not yet been implemented at the time of documentation.
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8.4.1 Show Rulers

The Show Rulers  options will activate the rulers around the PDF Display area as shown below. 

Note: There are small red lines on the rulers that show the position of the cursor relative to that

ruler.

Guides can be added by clicking and dragging from the rulers. Guides can be used as snapping

points.  318
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From Horizontal Ruler:

From Vertical Ruler: 
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You can add a cross section by clicking and dragging from the point where the rulers meet : 
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8.4.2 Show Grid

The Show Grid  option will overlay pages with a grid which can be used as snapping points.

8.4.3 Show Page Measurement Info

The Show Page Measurement Info  will show the size of the currently active page next to the

 as well as the mouse pointer's current coordinates next to the  in whatever unit is set in the

Measurement sections of the Preferences menu. 

319

239
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8.5 Page Navigation

The Document Navigation toolbar contains the necessary tools to navigate within a PDF

document.

     Document Navigation toolbar

To go to the First Page, click on  or use the Home key. Clicking on  or using the End

key will take you to the Last Page in the document.

Clicking on  takes you to the Previous Page in the document, and  takes you to the

Next Page.

Clicking on  takes you to the Previous View, and clicking on  takes you to the Next

View.

Note: Next View is only active after going to Previous View.

The Field will display the current and total page number and total pages. The screenshot above

[Document Navigation Toolbar] is an example of a document viewed on page 2 out of 54 (2/54).
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8.6 Page Layout

In the page layout toolbar, you van set how the pages are viewed in the document display area. By

default, the page Layout Toolbar is found in the lower right corner of the Editor window.

     PDF-XChange Editor main Window.

Single Page: Will show only one page pf the PDF at a time.

Continuous: Will scroll continuously and smoothly. The document display area can show parts

of two adjacent pages. (For example, the bottom  of page 2, and the top of page 3 with a small gap

between the pages.)

 Two pages: Similar to single page. Only two pages will be shown adjacently at a time.

Two pages continuous: Display area will scroll continuously and smoothly. Document display

area will contain two columns of pages.

More detailed settings for page display can be found in the Page Display  section of the

Preferences dialog.    

208
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8.7 Launch Applications Toolbar

The Launch Application Toolbar allows the user to select any third party application to launch the

currently active PDF. For instructions on how to add a new launch application, please see the 

Launch Application  section of the Preferences Menu.268 201
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8.8 How to customize toolbars

Making the Editor's toolbars and tool buttons smaller in one easy step:

Mousing over this line (see screenshot) you will see the arrow allowing you  to compress the

toolbar.

By clicking and dragging, you will have the following result: 

Note: The toolbar is thinner, and the buttons for each tool has shrunk and their positions

changes accordingly.

Show/Hide specific toolbars

On occasion, even the above might prove to take up too much space.

Right click on a blank piece of toolbar >Customize toolbars or go to View >Toolbars>

Customize. There, users can choose which toolbars are, and are not displayed. 

     Customize Toolbars Window
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Add Remove and Reset Toolbars

To add custom toolbars, click on the New... button. A window will pop up asking you to name the

new toolbar.

Once named, click Ok. The newly created toolbar will populate as an empty floating toolbar.

Add tools to this Toolbar by dragging and dropping various commands as described in the next

section of this article.

The new toolbar will show up under the User Toolbars list in the Customize window. When

selected, the Rename button becomes active to allow you to rename the toolbar.

Note: Only custom toolbars can be renamed or deleted.

The Reset button will reset the currently selected toolbar to its default settings, whereas the Reset

All button will reset all toolbars to default settings.

Changing and Moving the Tools Within Toolbars

With the Customize toolbar window open (View> toolbars >Customize toolbars) users can add/

remove and move tools within the toolbar.  The tools can also be floated in their own independent

toolbar.

Moving tools: By clicking and dragging an existing tool in the toolbar, you can move it to your

desired location. To remove it, simply drag the icon into the Customize... window.
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Add Tools

To add tools to the toolbars Navigate to the Commands tab. From there, you can type the name of

the tool/command you would like to add. For example, I like to use "save as" frequently, so I wish to

add it to my toolbar: 

I can drag the tool to my desired location within the toolbar.
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8.9 How to customize commands

By searching for a tool in the commands section of the Customize toolbars  window, you can

add or change keyboard shortcuts associated with certain tools. For example, I use the Highlight

text tool often and mousing over to it can be tiresome. I will create a keyboard shortcut by

searching for the tool, selecting it from the search results then click on to properties.

I have chosen Alt+H as my shortcut, then I click on the green check mark to assign it. 

Note: that you must use the desired action when assigning (e.g. pushing the two keys instead of

typing a,l,t,+,H) 

If there is a conflict, the Editor will provide a warning and the shortcut will not work. 

620
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9 Shell Extensions
-Shell Extensions- ,

The latest version of PDF-XChange Editor now includes a Windows shell extension to display

thumbnails of PDF files in Windows Explorer. When using thumbnail mode view in Windows

Explorer, thumbnails of the first page in a document are shown instead of standard PDF document

icons when the folder is set to view medium, large, or extra-large icons.
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9.1 iFilter

Additionally, the Shell Extensions include a very powerful search tool – the PDF iFilter, designed for

end users or administrators who wish to index PDF documents using Microsoft iFilter indexing. 

This allows the user to easily search for text within PDF documents, including all text in content,

annotations, bookmarks, document XMP information (title, author, keywords, etc.), and even files

attached/embedded within a PDF.

Key Benefits:

· Integrates with existing Windows operating systems on your home computer or computers

within your company.

· Provides an easy solution to search text within PDF documents located on your computer,

company network, and company intranet.

· Greatly increases your ability to accurately locate many forms of information contained

within a PDF document. 
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