Get Flash Player

IMPORTANT

PDF-XChange Editor Flash Support requires the specific Flash Player for Internet Explorer as it contains ActiveX components, where the Flash Player for other browsers does not.

If you are not viewing this page using IE please copy the address from this page run Internet Explorer return to this page in Internet Explorer and click the link below.

Or right-click the link below and select Copy Link Location and run Internet Explorer and paste the link into the address bar and hit Enter.

To get latest version of Adobe Flash player for use with PDF-XChange Editor please click here.