PDF-XChange Lite Printer - System Requirements

PDF-XChange LIte Printer V9 supports all Windows (32/64 bit) operating systems from Windows 7 and later:

 

 

V4 thru V9: Microsoft/Citrix Terminal Server compatible.
Version 4, 5, 6, 7: Microsoft/Citrix Terminal Server compatible; WIndows XP*, WIndows Vista compaible
Version 3: Still available for Windows 95/98

 

Need more information? Get in touch.

You can contact us by phone, email or our social media accounts — we are here to assist you.